拨号和接入 : 综合业务数字网络 (ISDN),随路信令 (CAS)

配置使用Dialer Profile的 BRI备份接口

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

此配置演示使用ISDN基本速率接口(BRI)电路备份专线、WAN或者串行连接。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

背景理论

backup interface 命令将接口置于备用模式,直到主接口关闭。欲知备用接口功能的更多信息,参见评估备份接口、浮动静态路由和DDR备份的拨号程序监视。

此示例对备份接口功能使用 Dialer Profiles。使用 backup interface 命令强制将已配置的物理或逻辑接口置于备用模式。使用拨号程序配置文件,只有逻辑接口(拨号程序接口)采用备用模式,而物理接口(BRI)仍然可以用于其他连接,作为其他连接池的成员。有关 Dialer Profiles 的详细信息,请参阅使用 Dialer Profiles 配置 ISDN DDR

配置

本部分提供有关如何配置本文档所述功能的信息。

配置按需拨号路由 (DDR) 备份包括以下这些不同步骤:

  1. 配置 DDR。您可以使用传统 DDR (Dialer Maps) 或 Dialer Profiles。此配置使用 Dialer Profiles。在实施备份配置前验证您的DDR连接正常工作。这允许您在配置备份之前验证所使用的拨号方法、点到点协议(PPP)协商和认证是否成功。欲知基于拨号映射的备份配置,使用BRI和backup interface命令,参见“DDR备份”文件。

  2. 配置其中一个路由器以在主链路出现故障时启动 DDR 连接。此配置使用 backup interface 命令来触发拨出。

  3. 定义在主链路出现故障时将触发备份连接的相关流量。

欲知更多信息,建议您参见“配置和故障排除DDR备份文件”文件。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/5721/bri-to-bri-backup.gif

配置

此配置使用一个BRI电路备份串行链路。它还在两个路由器之间使用 Open Shortest Path First (OSPF) 路由协议。一旦激活备用连接,您必须保证更新路由表,使用新的备份链路。只有一端 (maui-soho-01) 配置为拨出。另一端 (maui-nas-05) 配置为只接受呼叫。

在此配置中,我们使用串行连接,有一个连接到Cisco 3640路由器的Cisco 1604路由器。两个路由器也通过BRI接口安装,此接口用于备份链路。Cisco 1604运行Cisco IOSï ¿  ½软件版本12.1(5)T,并且Cisco 3640使用Cisco IOS 12.1(2)。

注意: 在您配置备份接口和backup delay命令之前,配置和检验DDR连接(拨号程序1和BRI0)适当运行。这将允许在您配置备份之前,有效管理排除拨号配置文件故障、ISDN、PPP和认证问题。

maui-soho-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1687 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- Basic AAA configuration for ppp calls.

enable secret 5 <deleted>
!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret(used for
!--- CHAP authentication).
!--- Shared secret must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0

!--- The loopback address will be used by OSPF for the router ID.

!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary Interface

 backup delay 10 30

!--- Backup link will be activated 10 seconds after primary link goes down.
!--- Backup link will be deactivated 30 seconds after primary link is restored.

 backup interface Dialer1

!--- Interface Dialer 1 will provide backup. Dialer 1 will be placed in Standby
!--- until the primary link goes down.

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 no fair-queue
 clockrate 64000
 ppp authentication chap
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 10

!--- Assign BRI0 as member of dialer pool 10.
!--- Dialer pool 10 is specified in interface Dialer 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112
 ppp authentication chap

!--- Use PPP CHAP authentication.

 ppp multilink
!
interface Dialer1

!--- Dialer 1 provides backup for the serial link.
!--- This interface will be in standby until the primary link is down.

 ip address 172.20.10.2 255.255.255.0

!--- Address for the dialer interface. 
!--- The remote side dialer interface is in the same subnet.

 encapsulation ppp
 dialer pool 10

!--- Defines Dialer pool 10.
!--- BRI 0 is a member of this pool.

 dialer remote-name maui-nas-05

!--- Specifies remote router name. 
!--- This name must match that used by the remote router to authenticate itself.

 dialer idle-timeout 900

!--- Idle timeout is set to 900 seconds (15 minutes).
!--- The link will be disconnected if there is no interesting traffic for 900 secs.
!--- Since OSPF hellos are interesting traffic, this will reset the idle timeout
!--- and cause the link to stay up until the primary link is restored and the dialer
!--- returns to standby mode.

 dialer string 5552222

!--- Defines the destination routers phone number.

 dialer load-threshold 80 outbound

!--- This sets the outbound load level for traffic at which 
!--- additional connections will be added to the MP bundle load level.
!--- Values range from 1 (unloaded) to 255 (fully loaded). The threshold
!--- in this case is 80/255=32%.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 ppp authentication chap

!--- Use PPP CHAP authentication.

 ppp multilink
!
router ospf 5

!--- OSPF configuration. You can use any routing protocol here without any other
!--- changes to the configuration.

 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit

!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.
!--- OSPF hello packets will trigger the dial.

!
line con 0
 exec-timeout 0 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!
end

在 maui-soho-01 的配置中,请注意以下几点:

  • 备份链路使用 Dialer Profiles。不使用物理接口(BRI 0)时,允许备份接口(拨号程序1)采用备用模式。当主链路处于活动状态时,允许您使用物理接口(通过把它用作不同拨号池的成员)。有关 Dialer Profiles 的详细信息,请参阅 Dialer Profiles 的配置与故障排除文档。

  • 路由器使用 OSPF 作为路由协议。您也可以使用任何其他路由协议(例如 RIP、EIGRP)。请参阅相应的路由协议配置指南 IPC:第 2 部分:IP 路由协议。确保路由协议配置中包括主要接口网络和备份接口网络,以便信息可以使用路由协议传播。如果您希望使用静态路由而不是路由协议,则使用远程BRI接口的下一跳创建静态路由(根据实际情况,您可以把它创建为浮动静态路由)。

  • 任何 IP 流量都将触发拨号(基于 dialer-list 1 和 dialer-group 1)。由于主链路正常运行时备份链路处于备用模式而无法拨号,因此备份链路在备份接口DDR备份环境中运行良好。因为备份链路要求触发数据流拨通备份链路,以验证您有生成触发数据流的数据流源。在本示例中,OSPF hello 数据包将触发拨号。如果您没有使用路由协议,您可以使用ICMP Ping来拨打备份链路。根据需要来调节相关流量。

maui-nas-05 (3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- Basic AAA configuration for ppp calls.

enable secret 5 <deleted>
!
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret
!---(used for CHAP authentication).
!--- Shared secret must be the same on both sides.

ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0

!--- The loopback address will be used by OSPF for the router ID.

!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0
 ip unnumbered Loopback0

!--- Unnumbered to the Loopback 0 address.

 encapsulation ppp
 dialer pool-member 20

!--- Assign BRI0 as member of dialer pool 20.
!--- Dialer pool 20 is specified in interface Dialer 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223
 ppp authentication chap

!--- Use ppp chap authentication.

 ppp multilink
!

! <<-- Unused interface configurations have been removed.

!
interface Serial2/0

!--- Primary interface.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 no fair-queue
 ppp authentication chap
!

! <<--Unused interface configurations have been removed.

!
interface Dialer1

!--- Dialer 1 provides backup for the serial link.
!--- Notice that there is no dialer string on this router. This prevents the NAS
!--- from attempting to dialout using the backup circuit when the primary is up.

 ip address 172.20.10.1 255.255.255.0

!--- Address for the dialer interface. 
!--- The remote side dialer interface is in the same subnet.

 encapsulation ppp
 dialer remote-name maui-soho-01

!--- Specifies remote router name. 
!--- This name must match that used by the remote router to authenticate itself.

 dialer pool 20

!--- Defines dialer pool 20.

 dialer idle-timeout 900

!--- Idle timeout is set to 900 seconds (15 minutes).
!--- This is equal to the idle timeout set on maui-soho-01.

 dialer max-call 4096
 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 ppp authentication chap

!--- Use ppp chap authentication.

 ppp multilink
!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate

!--- Transmit ospf default information. 
!--- This may be required for remote router to use the BRI DDR link.

!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

在服务器 maui-nas-05 (3640) 的配置中,验证以下几点:

  • 该配置与任何拨入配置都类似。就 NAS 而言,备份链路只是另一个传入呼叫。

  • 拨号程序接口没有拨号程序字符串,因此无法拨出。

  • 所有流量都是相关流量。由于备份链路无法以任何方式拨出(请参阅上一个项目符号列表项),因此这是可接受的。如果您增加触发数据流的限制(例如,路由协议不是触发协议),如果没有触发数据流通过链路,NAS则有可能断开呼叫。在备份情况下,最好是让某一终端(拨出或拨入端)控制备份链路,避免链路不稳定性。

测试备份链路

备份接口要求,甚至在将备份接口考虑为备用模式之前,就应该关闭主接口协议。因此,要在不物理上切断主链路的情况下测试备份链路是不可能的。选项有:

  • 使用 shutdown 命令关闭主接口。但不要对配置了 backup interface 命令的路由器使用 shutdown 命令。这不会使 Cisco IOS 软件对备份链路拨号。通过关闭不带有backup interface命令的路由器上的主要接口,您可以激活备份。在这种方案中,在 maui-soho-01 (1600) 上配置了 backup interface 命令。因此在 maui-nas-05 (3640) 的主要接口执行 shutdown 命令,可以激活备份链路。

  • 物理上通过拔去电缆或某些等效的方法切断主要连接,从而打开备份接口。

显示命令

输出解释器工具支持某些 show 命令(只限于注册用户),通过它可以查看 show 命令输出的分析。

  • show isdn status - 确保路由器与 ISDN 交换机正常通信。在输出中,验证第1层状态是否为活跃状态,是否第2层状态=MULTIPLE_FRAME_ESTABLISHED出现。此指令也显示活动的呼叫的数量。

  • show ip interface brief - 这将在备用模式下显示拨号程序 1(在 maui-soho-01 上)。将拨号1用作备份接口意味着物理接口(BRI0)并不专用于备份。因此,在主链路接通时,不能将 BRI 0 用于普通 DDR。

show 输出示例

下面的输出显示了客户端的路由表。下面的输出显示了主链路处于活动状态时的路由表。

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
O       172.20.10.0 [110/1849] via 192.168.10.1, 00:00:10, Serial0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 00:00:11, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 00:00:11, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 00:00:11, Serial0

show ip route的输出(显示如上)显示使用主链路(serial0)从对等体获取的OSPF路由。现在,让我们关闭主链路并激活备份链路。

备份链路被激活之后,OSPF表将被交换,使用备份链路的新路由将被安装。此时,流量将流过备份链路。

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, Dialer1
C       172.20.10.1/32 is directly connected, Dialer1
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:00:01, Dialer1
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:00:02, Dialer1
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:00:02, Dialer1

故障排除

本部分提供的信息可用于对配置进行故障排除。

debug 命令

在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug dialer -这用于显示关于在拨号程序接口上收到的信息包的 DDR 信息。

  • debug isdn events - 用于查看发生在ISDN接口用户端上的ISDN活动。

  • debug isdn q931 - 显示(第3层)路由器和ISDN交换机之间的ISDN网络连接的呼叫建立和拆卸。

  • debug ppp negotiation - 在协商 PPP 组件(包括链路控制协议 (LCP)、认证和 NCP)时显示有关 PPP 流量和交换的信息。成功的PPP协商将首先开放LCP状态,然后进行验证,最后进行NCP协商。

  • debug ppp authentication -显示PPP认证协议消息,包括质询验证协议(CHAP)信息包交换和密码认证协议(PAP)交换。如果您发现故障,则请验证是否正确配置了 CHAP 用户名和口令。

  • debug ppp error - 用来显示与PPP连接协商和操作相关的协议错误和错误统计数据。

排除 DDR 备份故障

在您配置备份接口和备份延迟命令之前,配置和检验DDR连接(拨号程序1和BRI0)适当运行。这允许您在配置备份之前,验证拨号程序配置文件、ISDN、PPP和鉴权是否正常运行。若要对 DDR 链路进行故障排除,请参阅拨号技术:故障排除技术

即然您已经验证了DDR连接正在适当运行,您便可以执行以下所述的备用故障排除步骤:

  • 关闭主链路。请勿对配置了 backup interface 命令的路由器使用 shutdown 命令。这不会使 Cisco IOS 软件对备份链路进行拨号。通过关闭不带有backup interface命令的路由器上的主要接口,您可以激活备份。在这种方案中,在 maui-soho-01 (1600) 上配置了 backup interface 命令。因此,对 maui-nas-05 (3640) 的主接口执行 shutdown 命令会激活备份链路。并且,您可以通过拔去电缆或使用等效方法从物理上切断主要连接,从而打开备份接口。

  • 您应该看到一条控制台消息,指明备份接口(接口拨号程序 1)已接通。只有在 backup delay 命令所指定的时间间隔过后,才会出现此消息。在此配置中,备份激活延迟为 10 秒。如果未看到此控制台消息,请检查 backup delay 计时器。

    *Mar  1 03:37:31.788: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    *Mar  1 03:37:42.719: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
    
  • 使用 show ip route 命令来查看主链路关闭时的路由表。您应该观察到拨号程序 1 的直接连接路由。对远程路由器的拨号程序接口(与接口拨号程序 1 位于同一子网中)的 IP 地址执行 ping 操作。您应看到链路拨号和连接。

    • 如果链路未拨号,请验证相关流量定义是否允许 ICMP (ping)。

    • 如果链路启用,我们可以推断问题发生是由于没有指定到该子网的数据流。然而,依据到特定主机的ping,强制执行到拨号的备份链路并不现实。若要避免出现此问题,可以为默认流量配置浮动静态路由。

      maui-soho-01(config)#ip route 0.0.0.0 0.0.0.0 172.20.10.1 200 
      

      上述默认路由具有远程路由器拨号程序接口的下一跳地址和200的管理距离。如果没有更好的默认路由(配有更短的管理距离),此浮动路由允许路由器将信息包路由到拨号程序接口。记住我们以前验证路由到拨号程序接口的信息包导致链路拨号。

  • 如果路由器拨打链路,但不能接通,便不再是DDR备份问题,您应该考虑拨号技术:故障排除技术以获取进一步的帮助。

欲知故障排除的更多信息,参见“配置和故障排除DDR备份”文件中的“排除备份接口故障”部分。

调试输出示例

以下debug输出(从客户端)显示主链路发生故障,备份链路激活:

注意: 出于打印目的,某些调试输出行分为多个行。

maui-soho-01#show debug

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#debug isdn q931
ISDN Q931 packets debugging is on
maui-soho-01#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-soho-01#debug ppp authentication 
PPP authentication debugging is on
maui-soho-01#
*Mar  1 01:09:24.872: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary link is unplugged.
!--- Refer to the section Testing the Backup Link for the appropriate procedure.

*Mar  1 01:09:24.880: Se0 IPCP: State is Closed
*Mar  1 01:09:24.884: Se0 CDPCP: State is Closed
*Mar  1 01:09:24.888: Se0 PPP: Phase is TERMINATING [0 sess, 0 load]
*Mar  1 01:09:24.892: Se0 LCP: State is Closed
*Mar  1 01:09:24.892: Se0 PPP: Phase is DOWN [0 sess, 0 load]
*Mar  1 01:09:24.908: Se0 IPCP: Remove route to 192.168.10.1
*Mar  1 01:09:24.916: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on Serial0
 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 01:09:25.864: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
 changed state to down

!--- Primary interface line protocol is down. This must happen before the backup
!--- interface is brought out of standby.

*Mar  1 01:09:34.824: Di1 DDR is shutdown, could not clear interface.
*Mar  1 01:09:34.840: BR0 DDR: rotor dialout [priority]

!--- Note: The backup interface was activated 10 seconds after the primary
!--- link went down. This interval was defined with the backup delay command
!--- in maui-soho-01 (1600).

*Mar  1 01:09:34.848: BR0 DDR: Dialing cause ip (s=172.20.10.2, d=224.0.0.5)

!--- OSPF hellos cause the router to dial.

*Mar  1 01:09:34.852: BR0 DDR: Attempting to dial 5552222

!--- Phone number of the remote router that is dialed.

*Mar  1 01:09:34.876: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x0A
*Mar  1 01:09:34.888:         Bearer Capability i = 0x8890
*Mar  1 01:09:34.895:         Channel ID i = 0x83
*Mar  1 01:09:34.903:         Keypad Facility i = '5552222'
*Mar  1 01:09:35.169: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x8A
*Mar  1 01:09:35.177:         Channel ID i = 0x89
*Mar  1 01:09:35.415: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x8A

!--- Call is connected.

*Mar  1 01:09:35.439: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
*Mar  1 01:09:35.447: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
*Mar  1 01:09:35.463: BR0:1 PPP: Treating connection as a callout

!--- PPP negotiation begins.

*Mar  1 01:09:35.467: BR0:1 PPP: Phase is ESTABLISHING, Active Open
 [0 sess, 0 load]
*Mar  1 01:09:35.479: BR0:1 LCP: O CONFREQ [Closed] id 14 len 34
*Mar  1 01:09:35.483: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.487: BR0:1 LCP:    MagicNumber 0x10BC0680 (0x050610BC0680)
*Mar  1 01:09:35.491: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.495: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130F016D6175692D736F686F2D3031)
*Mar  1 01:09:35.511: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x0A
*Mar  1 01:09:35.566: BR0:1 LCP: I CONFREQ [REQsent] id 6 Len 33
*Mar  1 01:09:35.570: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.574: BR0:1 LCP:    MagicNumber 0x30D37ABB (0x050630D37ABB)
*Mar  1 01:09:35.578: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.582: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130E016D6175692D6E61732D3035)
*Mar  1 01:09:35.590: BR0:1 LCP: O CONFACK [REQsent] id 6 Len 33
*Mar  1 01:09:35.598: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.602: BR0:1 LCP:    MagicNumber 0x30D37ABB (0x050630D37ABB)
*Mar  1 01:09:35.606: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.610: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130E016D6175692D6E61732D3035)
*Mar  1 01:09:35.618: BR0:1 LCP: I CONFACK [ACKsent] id 14 Len 34
*Mar  1 01:09:35.622: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.626: BR0:1 LCP:    MagicNumber 0x10BC0680 (0x050610BC0680)
*Mar  1 01:09:35.630: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.637: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130F016D6175692D736F686F2D3031)
*Mar  1 01:09:35.641: BR0:1 LCP: State is Open
*Mar  1 01:09:35.645: BR0:1 PPP: Phase is AUTHENTICATING, by both
 [0 sess, 1 load]

!--- PPP authentication begins.

*Mar  1 01:09:35.649: BR0:1 CHAP: O CHALLENGE id 6 Len 33 from "maui-soho-01"

!--- This is the username used for outgoing CHAP challenge. The remote router
!--- must have this username configured along with shared secret.

*Mar  1 01:09:35.657: BR0:1 CHAP: I CHALLENGE id 6 Len 32 from "maui-nas-05"

!--- This is the username for incoming CHAP challenge.
!--- This username must be locally configured.

*Mar  1 01:09:35.760: BR0:1 CHAP: O RESPONSE id 6 Len 33 from "maui-soho-01"
*Mar  1 01:09:35.804: BR0:1 CHAP: I SUCCESS id 6 Len 4
*Mar  1 01:09:35.808: BR0:1 CHAP: I RESPONSE id 6 Len 32 from "maui-nas-05"
*Mar  1 01:09:35.820: BR0:1 CHAP: O SUCCESS id 6 Len 4

!--- CHAP authentication is successful.

*Mar  1 01:09:35.828: BR0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
*Mar  1 01:09:35.844: Di1 DDR: Authenticated host maui-nas-05 with no matching
 dialer map
*Mar  1 01:09:35.848: Di1 PPP: Phase is UP [0 sess, 1 load]
*Mar  1 01:09:35.856: Di1 IPCP: O CONFREQ [Closed] id 6 Len 10
*Mar  1 01:09:35.860: Di1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 01:09:35.872: Di1 CDPCP: O CONFREQ [Closed] id 6 Len 4
*Mar  1 01:09:35.876: BR0:1 MLP: maui-nas-05, multilink up, first link
*Mar  1 01:09:35.884: BR0:1 IPCP: MLP bundle interface is built,
 process packets now 
*Mar  1 01:09:35.887: BR0:1 IPCP: Redirect packet to Di1
*Mar  1 01:09:35.891: Di1 IPCP: I CONFREQ [REQsent] id 6 Len 10
*Mar  1 01:09:35.895: Di1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 01:09:35.903: Di1 IPCP: O CONFACK [REQsent] id 6 Len 10
*Mar  1 01:09:35.907: Di1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 01:09:35.911: BR0:1 CDPCP: MLP bundle interface is built,
 process packets now 
*Mar  1 01:09:35.915: BR0:1 CDPCP: Redirect packet to Di1
*Mar  1 01:09:35.919: Di1 CDPCP: I CONFREQ [REQsent] id 6 Len 4
*Mar  1 01:09:35.927: Di1 CDPCP: O CONFACK [REQsent] id 6 Len 4
*Mar  1 01:09:35.931: Di1 IPCP: I CONFACK [ACKsent] id 6 Len 10
*Mar  1 01:09:35.935: Di1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 01:09:35.939: Di1 IPCP: State is Open

!--- IPCP state is open and route will be installed.

*Mar  1 01:09:35.951: Di1 CDPCP: I CONFACK [ACKsent] id 6 Len 4
*Mar  1 01:09:35.955: Di1 CDPCP: State is Open
*Mar  1 01:09:35.959: Di1 DDR: dialer protocol up
*Mar  1 01:09:35.971: Di1 IPCP: Install route to 172.20.10.1

!--- Route to remote side is installed.

*Mar  1 01:09:36.840: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
*Mar  1 01:09:36.844: Di1 LCP: Not allowed on a Dialer Profile
*Mar  1 01:09:36.848: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
 changed state to up
*Mar  1 01:09:41.411: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552222
 maui-nas-05

!--- Connection is up.

*Mar  1 01:09:44.931: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on
 Dialer1 from LOADING to FULL, Loading Done

!--- OSPF database exchange is complete.


相关信息


Document ID: 5721