拨号和接入 : 异步连接

在接入服务器上配置 WINS、DNS 与 DHCP

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

某些拨入客户端需要WINDOWS互联网名称服务(WINS),和/或域名命名系统(DNS)服务器信息,以正确连接到网络。将 IP 地址传送到接入服务器上的拨入客户端也有几种不同的机制。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

使用的组件

此配置是使用下面的设备开发并测试的:

  • 带有两个 T1 PRI 回路的 Cisco AS5200

  • DNS 服务器

  • WINS 服务器

  • 用于向客户端分配 IP 地址的 DHCP 服务器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

相关产品

这些DNS、DHCP和WINS配置命令可以在任何支持呼入PPP呼叫的所有路由器上使用。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景理论

用于向客户端分配 IP 地址的部分可能选项包括:

  • 从接入服务器上的 IP 池分配地址。

  • 使用外部动态主机控制协议 (DHCP) 服务器。

  • 使用 Remote Authentication Dial-in User Service (RADIUS) 或 Terminal Access Controller Access Control System (TACACS+)。

本文描述了把WINS和DNS服务器信息通过接入服务器传输到拨入客户端的程序。接入服务器也可以将外部DHCP服务器返回的IP地址传送到拨入客户端。

有关详细信息,请参阅本文档的相关信息部分中的文档。

配置

本部分提供有关如何配置本文档所述功能的信息。

网络图

本文档使用此图中所示的网络设置:

/image/gif/paws/6303/winsdhcp.gif

配置

这台AS5200接入服务器用两个主速率接口(PRI)配置,以允许呼入的异步呼叫和ISDN用户通过。为 ISDN 用户创建动态 Dialer Maps。如果没有配置TACACS+或RADIUS,每个用户配置的用户名和密码就必须要求拨号接入。DHCP 服务器将所有 IP 地址传递给客户端。在点到点协议IP控制协议(IPCP)协商期间,接入服务器将DNS和Windows服务器的IP地址传递到客户端。

AS5200 接入服务器
version 11.1
!
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service udp-small-servers
no service tcp-small-servers
!
hostname as5200
!
enable password letmein
!
username Jason password foo
username Laura password bar
username Russ password fake
username Syed password pseudo
username Tito password knockknock
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
interface Loopback0
 ip address 172.16.209.65 255.255.255.192
!
interface Loopback1
 ip address 172.16.209.129 255.255.255.192
!
interface Ethernet0
 ip address 172.16.162.4 255.255.255.0

!
interface Serial0
 no ip address 
!
interface Serial1
 no ip address
!
interface Serial0:23
 no ip address
 isdn incoming-voice modem
 dialer rotary-group 1
 encapsulation ppp
 no fair-queue
!
interface Serial1:23
 no ip address
 encapsulation ppp
 dialer rotary-group 1
 isdn incoming-voice modem
 no fair-queue
!
interface Group-Async1
 ip unnumbered Ethernet0
 encapsulation ppp
 async mode interactive
 peer default ip address dhcp

! -- Async dialup users will be assigned ip addresses from 
! -- the dhcp server. The dhcp server is specified with the
! -- ip dhcp-server command shown below.
! -- Refer to the section Command Summary for more information.

 ip helper-address 172.16.162.10

! -- The ip helper address command enables BOOTP broadcast 
! -- forwarding for a set of clients. The helper address specifies
! -- the address of the DHCP server configured below.
! -- Refer to the section Command Summary for more information.

 ppp authentication chap
 group-range 1 48
!
interface Dialer1
 ip unnumbered Ethernet0
 encapsulation ppp
 peer default ip address dhcp

! -- ISDN dialup users will be assigned ip addresses from the dhcp server.
! -- The dhcp server specified with the ip dhcp-server command shown 
! -- below. Refer to the section Command Summary for more information.

 ip helper-address 172.16.162.10

! -- The ip helper address command enables BOOTP broadcast  
! -- forwarding for a set of clients. The helper address specifies
! -- the address of the DHCP server configured below. 
! -- Refer to the section Command Summary for more information.

 dialer in-band
 dialer idle-timeout 300
 dialer-group 1
 no fair-queue
 ppp multilink
 ppp authentication chap
!
router eigrp 222
 redistribute connected
 network 172.16.0.0
!
dialer-list 1 protocol ip permit
!
async-bootp dns-server 172.16.224.100 172.16.154.101

! -- Specifies the primary and secondary DNS servers.
! -- The first IP address belongs to the primary DNS server.
! -- If you only have one DNS server you do not need to specify 
! -- a secondary DNS server.
! -- Refer to the section Command Summary for more information.

async-bootp nbns-server 172.16.224.10 172.16.4.2 

! -- Specifies the primary and secondary WINS  servers.
! -- The first IP address belongs to the primary WINS server.
! -- If you only have one WINS server you do not need to specify 
! -- a secondary WINS server.
! -- Refer to the section Command Summary for more information.

ip dhcp-server 172.16.162.10

! -- Specifies the dhcp server ip address. This command is required
! -- if the IP address for dialin clients is obtained from the server.
! -- Note: The dhcp server need not be on the same subnet as the 
! -- Ethernet interface. 
! -- It can be more than one hop away as long has it is reachable.

!
line con 0
 login 
line 1 48
modem InOut
transport input telnet
 autoselect during-login
 autoselect ppp
 flowcontrol hardware
line aux 0
line vty 0 4
 password secret
 login 
!
end

命令汇总

下面介绍接入服务器上 DHCP、DNS 和 WINS 的相关命令:

  • ip helper-address address - BOOTP 数据包中携带 DHCP 协议信息。ip helper address 命令可启用一组客户端的 BOOTP 广播转发。帮助地址应该指定DHCP服务器上的地址,并且应该在最接近客户端的接口上配置(在这种情况下是异步组和拨号程序接口)。如果您有多个服务器,则可为每个服务器配置一个帮助程序地址。帮助程序地址在 RFC 1531 中进行定义。leavingcisco.com 不能在 DHCP 池中配置多个域名。

  • peer default ip address dhcp - 在要返回的DHCP机制与连接此接口的远端对等体之间指定一个地址。这意味着该接口连接的客户端将分配从DHCP服务器检索的IP地址。您还应该使用ip dhcp server命令,从将获得客户端IP地址的地方指定DHCP服务器的IP地址。

  • async-bootp dns-server address - 配置DNS服务器的地址,当处理实施RFC1877的PPP客户端时,NAS使用该服务器进行回应。 leavingcisco.com DNS 服务器 IP 地址将在 IPCP 协商过程中传递给拨入客户端。

  • async-bootp nbns-server address - 指定 Windows 名称服务 (WINS) 服务器的 IP 地址。WINS 服务器 IP 地址将在 IPCP 协商过程中传递给拨入客户端。

验证

为了验证客户端已经从接入服务器上正确接收到适当参数,您需要从该客户端进行测试。

例如,可从客户端对一个 DNS 可解析地址(如 www.cisco.com)执行 ping。如果 DNS 服务器能够解析该地址,则说明配置正常运行。若要测试 WINS 服务器分配,请使用 Windows Networking 来浏览网络。

建立ISDN连接之后,使用show dialer map 命令,查看动态拨号映射是否建立。否则,您将无法实现路由。您应该发现分配给对等体的地址(该地址是从DHCP服务器获得的)。这样会验证 DHCP 地址分配是否成功。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

本文档假定 ISDN 第 1 层、第 2 层和第 3 层都正常运行。如果您具有 ISDN 较低层的问题,请参阅文档使用 show isdn status 命令进行 BRI 故障排除以获得详细信息。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug ppp authentication -看见客户端可以是否通过认证。如果使用在Cisco IOS�软件版本11.2之前的一个版本,请使用debug ppp chap命令。

  • debug ppp negotiation - 用于查看客户端是否正在传递 PPP 协商;这是您检查地址协商的时候。IPCP 协商将显示出正在传递给客户端的 DNS 和 WINS 服务器信息

  • debug ppp error - 显示和PPP连接协商与操作相关的协议错误以及统计错误。

在 PPP 协商的 IPCP 阶段,可查看 DNS 和 WINS 服务器分配。下面是示例输出。

调试输出示例

debug ppp negotiation命令输出(异步拨入呼叫)显示客户端的IPCP协商。在本示例中,仅指定了主 DNS 服务器。WINS 服务器未传递给客户端。

Sep 26 12:50:47.227: As97 CHAP: O CHALLENGE id 1 len 32 
from "maui-nas-02"
Sep 26 12:50:47.355: As97 CHAP: I RESPONSE id 1 len 31 
from "async_user"
Sep 26 12:50:47.355: As97 AUTH: Started process 0 pid 56
Sep 26 12:50:47.355: As97 CHAP: O SUCCESS id 1 len 4
Sep 26 12:50:47.359: As97 PPP: Phase is UP [0 sess, 0 load]

! -- IPCP negotiation begins

Sep 26 12:50:47.359: As97 IPCP: O CONFREQ [Closed] id 1 len 10
Sep 26 12:50:47.359: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:47.467: As97 IPCP: I CONFREQ [REQsent] id 1 len 40
Sep 26 12:50:47.467: As97 IPCP:    CompressType VJ 15 slots 
CompressSlotID 
(0x0206002D0F01)
Sep 26 12:50:47.467: As97 IPCP:    Address 0.0.0.0 
(0x030600000000)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:47.467: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:47.467: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2

! -- The IP address for the client is assigned.

Sep 26 12:50:47.467: As97 IPCP: O CONFREJ [REQsent] id 1 len 28
Sep 26 12:50:47.467: As97 IPCP:    CompressType VJ 15 slots 
CompressSlotID 
(0x0206002D0F01)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:47.483: As97 CCP: I CONFREQ [Not negotiated] 
id 1 len 15
Sep 26 12:50:47.483: As97 CCP:    MS-PPC supported bits 
0x00000001 
(0x120600000001)
Sep 26 12:50:47.483: As97 CCP:    Stacker history 1 check mode 
EXTENDED 
(0x1105000104)
Sep 26 12:50:47.483: As97 LCP: O PROTREJ [Open] id 4 len 21 
protocol CCP
Sep 26 12:50:47.483: As97 LCP:  (0x80FD0101000F12060000000111050001)
Sep 26 12:50:47.483: As97 LCP:  (0x04)
Sep 26 12:50:47.499: As97 IPCP: I CONFACK [REQsent] id 1 len 10
Sep 26 12:50:47.499: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:49.359: As97 IPCP: TIMEout: State ACKrcvd
Sep 26 12:50:49.359: As97 IPCP: O CONFREQ [ACKrcvd] id 2 len 10
Sep 26 12:50:49.359: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:49.467: As97 IPCP: I CONFACK [REQsent] id 2 len 10
Sep 26 12:50:49.467: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:50.459: As97 IPCP: I CONFREQ [ACKrcvd] id 2 len 34
Sep 26 12:50:50.459: As97 IPCP:    Address 0.0.0.0 (0x030600000000)
Sep 26 12:50:50.459: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.459: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:50.459: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:50.459: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:50.459: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.463: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.463: As97 IPCP: O CONFREJ [ACKrcvd] id 2 len 22
Sep 26 12:50:50.463: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:50.463: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:50.463: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:50.571: As97 IPCP: I CONFREQ [ACKrcvd] id 3 len 16
Sep 26 12:50:50.571: As97 IPCP:    Address 0.0.0.0 
(0x030600000000)
Sep 26 12:50:50.571: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.571: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.571: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.571: As97 IPCP: O CONFNAK [ACKrcvd] id 3 len 10
Sep 26 12:50:50.571: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.683: As97 IPCP: I CONFREQ [ACKrcvd] id 4 len 16
Sep 26 12:50:50.683: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.683: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.683: As97 AAA/AUTHOR/IPCP: Start.  
Her address 172.22.60.2, we want 172.22.60.2
Sep 26 12:50:50.683: As97 AAA/AUTHOR/IPCP: Reject 172.22.60.2, 
using 172.22.60.2
Sep 26 12:50:50.687: As97 AAA/AUTHOR/IPCP: Done.  
Her address 172.22.60.2, we want 172.22.60.2
Sep 26 12:50:50.687: As97 IPCP: O CONFACK [ACKrcvd] id 4 len 16
Sep 26 12:50:50.687: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.687: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)

! -- The IP address of the client and Primary DNS server's 
! -- IP address are negotiated.

Sep 26 12:50:50.687: As97 IPCP: State is Open

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 6303