IP : 开放最短路径优先 (OSPF)

通过多接入网络连接的OSPF路由器

2015 年 7 月 13 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档说明连接在多路访问网络中的两台 Open Shortest Path First (OSPF) 路由器。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用此图所示的网络设置。

/image/gif/paws/47863/ospfdb4a.gif

配置

本文档使用此处所示的配置。

路由器 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Ethernet2/0/2
 ip address 5.0.0.1 255.0.0.0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

路由器 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Ethernet0/0/2
 ip address 5.0.0.2 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

检查 OSPF 数据库

查看show ip ospf database 命令的输出,以了解此网络环境中的OSPF数据库是什么样子的

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router  Age   Seq#         Checksum  Link count 
1.1.1.1   1.1.1.1     107   0x80000018   0x7966        2 
2.2.2.2   2.2.2.2     106   0x80000015   0x6770        2 

                Net Link States (Area 0) 

Link ID   ADV Router  Age   Seq#         Checksum 
5.0.0.2   2.2.2.2     102   0x80000004   0x7E9D 
  

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 147 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, the Link State Id is always the 
  !--- same as the Advertising Router. 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created 
  !--- this LSA.
 
  LS Seq Number: 80000018 
  Checksum: 0x7966 
  Length: 48 
   Number of Links: 2 

    Link connected to: a Transit Network
    
!--- This router (1.1.1.1) has a link connected to 
    !--- a transit network that has a designated router (DR)
    !--- and backup designated router (BDR) listed here.  

     (Link ID) Designated Router address: 5.0.0.2
	 
!--- The DR's interface IP address is 5.0.0.2.
 
     (Link Data) Router Interface address: 5.0.0.1
	 
!--- This router's (1.1.1.1) interface address 
     !--- connected to the DR is 5.0.0.1. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
       
!--- The OSPF cost of the link is 10.
 

    Link connected to: a Stub Network 
    
!--- This represents the subnet of the Ethernet segment
    !--- 4.0.0.0/8. 

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
       
!--- The cost of the link is 10. 


r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 162 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000015 
  Checksum: 0x6770 
  Length: 48 
   Number of Links: 2 

    Link connected to: a Transit Network 
     (Link ID) Designated Router address: 5.0.0.2
     
!--- The DR's interface IP address is 5.0.0.2.
 
     (Link Data) Router Interface address: 5.0.0.2
     
!--- Since these values are equal, router
     !--- (2.2.2.2) is the DR. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 
  

r2.2.2.2#show ip ospf database network 5.0.0.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Net Link States (Area 0) 

  Routing Bit Set on this LSA 
  LS age: 182 
  Options: (No TOS-capability, DC) 
  LS Type: Network Links 
  Link State ID: 5.0.0.2 (address of Designated Router)
  
!--- This is the IP address of the DR 
  !--- (not the router ID). 

  Advertising Router: 2.2.2.2
  
!--- This is the router ID of the router that 
  !--- created this LSA.

  LS Seq Number: 80000004 
  Checksum: 0x7E9D 
  Length: 32 
  Network Mask: /8
  
!--- Binary and the DR's interface address with the 
  !--- mask to get to network 5.0.0.0/8. 

        Attached Router: 2.2.2.2
	
!--- The DR's router ID, along with a list of routers 
    !--- adjacent on the transit network. 

        Attached Router: 1.1.1.1 

计算最短路径

本部分从路由器 1.1.1.1 的角度来计算最短路径树。

路由器 1.1.1.1 在其自身的 LSA 中进行查找,并确定是否有通向 DR 接口地址为 5.0.0.2 的中转网络。然后查找链路状态 ID 为 5.0.0.2 的网络 LSA。它会在网络 LSA 中找到所连接的路由器(路由器 1.1.1.1 和 2.2.2.2)的列表。这意味着所有这些路由器都可以通过此中转网络来访问。路由器 1.1.1.1 可以验证其自身 ID 是否在该列表中。然后,它可以计算经过这些连接的路由器中任何路由器的路由。

路由器 1.1.1.1 会查找路由器 2.2.2.2 的 LSA,以验证它是否包含连接至同一中转网络 (5.0.0.2) 的链路。现在,路由器 1.1.1.1 可以安装路由器 2.2.2.2 的 LSA 中的任何末节网络。

由于网络 6.0.0.0/8 在其 LSA 中作为一个末节网络列出,因此,路由器 1.1.1.1 会将网络 6.0.0.0/8 的路由安装在其路由表中。

r1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/20] via 5.0.0.2, 00:03:35, Ethernet2/0/2 

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/20] via 5.0.0.1, 00:03:18, Ethernet0/0/2 

无论该网络是广播网络还是非广播网络,OSPF 链路状态数据库的外观均相同。主要区别在于邻居发现机制。在广播网络中,邻居是通过组播 hello 数据包发现的。在非广播网络中,将对邻居进行静态配置,并发送单播 hello 数据包以在邻居之间建立邻接。

非广播多路访问网络上的下一跳

若要探讨非广播多路访问 (NBMA) 网络中的下一跳问题,请参见此示例。中转网络上有三个路由器(路由器 non_DR_a、non_DR_b 和 DR)。它是 NBMA 媒体(例如,帧中继、异步传输模式 (ATM) 或 X.25)上的星型拓扑。

/image/gif/paws/47863/ospfdb4b.gif

当路由器 non_DR_a 计算经过路由器 non_DR_b 的路由时,它会使路由器 non_DR_b 成为下一跳。但是,路由器 non_DR_a 没有通往路由器 non_DR_b 的虚电路 (VC),这意味着这两个路由器无法相互执行 ping 操作。OSPF 会将路由安装到含有无法访问的下一跳的路由表中。

此问题的解决方法是添加另一个 frame-relay map 语句,以使所有邻居都可以通过通往路由器 DR 的 VC 进行访问。例如:

interface Serial0 
 frame-relay map ip 1.1.1.1 700 broadcast
 
!--- This is a map for the DR. 

 frame-relay map ip 1.1.1.2 700 broadcast
 
!--- This is a map on the same VC data-link connection 
 !--- identifier (DLCI) for a non-DR router. 

在将此行为与中间系统到中间系统 (ISIS) 协议的行为进行比较时,除非下一跳是邻居,否则路由器不会安装经过下一跳的 ISIS 路由。这意味着只有路由器完全网格化时,ISIS 才能在多点接口上运行。

即使下一跳不是邻居且无法通过第 2 层进行访问,OSPF 也会安装路由。不过,您可以通过配置多个 map 语句来解决此问题。

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 47863