网络管理 : Cisco Configuration Professional

使用 Cisco Configuration Professional 的基本路由器配置

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 27 日) | 反馈


目录


简介

本文档介绍了如何使用 Cisco Configuration Professional (Cisco CP) 设置路由器的基本配置。路由器的基本配置包括 IP 地址、默认路由、静态和动态路由、静态和动态 NATing、主机名、标语、加密口令、用户帐户和其它选项的配置。通过 Cisco CP,您可以使用简单易用的基于 Web 的管理界面在一些网络环境(包括小型家庭办公室 (SOHO)、分支机构 (BO)、地区办事处以及中心站点或企业总部)中配置路由器。

有关 Cisco Configuration Professional 的详细信息,请参阅 Cisco Configuration Professional 快速入门指南

先决条件

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco 2811路由器用Cisco IOS�软件版本12.4(9)

  • Cisco CP 2.5 版

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

安装 Cisco Configuration Professional

要安装 CCP,请执行以下步骤:

  1. Cisco 软件中心仅限注册用户)下载 Cisco CP V2.5 并将其安装到本地 PC。

    最新版本的 Cisco CP 可在 CCP 网站找到。

  2. 从本地 PC 通过“开始”>“程序”>“Cisco Configuration Professional”启动 Cisco CP 并选择具有要配置路由器的 Community

    basic-router-config-ccp-42.gif

    basic-router-config-ccp-43.gif

  3. 要发现希望配置的设备,请突出显示路由器并单击 Discover 按钮。

    basic-router-config-ccp-44.gif

注意: 有关与 CCPv2.5 兼容的 Cisco 路由器型号和 IOS 版本的信息,请参阅兼容的 Cisco IOS 版本部分。

注意: 有关运行 CCPv2.5 的 PC 要求的信息,请参阅系统要求部分

运行 Cisco CP 的路由器配置

要在 Cisco 路由器上运行 Cisco CP,请执行以下配置步骤:

  1. 使用 Telnet、SSH 或控制台连接路由器。

    使用以下命令进入全局配置模式:

    Router(config)#enable
    Router(config)#
  2. 如果启用了 HTTP 和 HTTPS 并将其配置为使用非标准端口号,则可跳过此步骤并直接使用已配置的端口号。

    使用以下 Cisco IOS 软件命令启用路由器 HTTP 或 HTTPS 服务器:

    Router(config)# ip http server
    Router(config)# ip http secure-server
    Router(config)# ip http authentication local
    
  3. 创建一个权限级别为 15 的用户:

    Router(config)# username <username> privilege 15 password 0 <password>
    
    

    注意: 使用要配置的用户名和口令替换 <username><password>。请勿对用户和启用口令使用相同的口令。

  4. 为本地登录和权限级别 15 配置 SSH 和 Telnet。

    Router(config)# line vty 0 4
    Router(config-line)# privilege level 15
    Router(config-line)# login local
    Router(config-line)# transport input telnet
    Router(config-line)# transport input telnet ssh
    Router(config-line)# exit
    
  5. (可选)启用本地登录以支持日志监控功能:

    Router(config)# logging buffered 51200 warning
    

要求

本文档假设 Cisco 路由器运行完全正常,并已配置为允许使用 Cisco CP 进行配置更改。

有关如何开始使用 Cisco CP 的完整信息,请参阅 Cisco Configuration Professional 入门

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

在本部分中,您将了解有关网络中路由器基本设置的配置信息。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

/image/gif/paws/111999/basic-router-config-ccp-01.gif

注意: 此配置中使用的 IP 编址方案在 Internet 上不可合法路由。这些地址是在实验室环境中使用的 RFC 1918 地址。leavingcisco.com

接口配置

要配置 Cisco 路由器的接口,请执行以下步骤:

  1. 单击 Home 访问 Cisco CP 主页。

    Cisco CP 主页提供路由器硬件和软件、功能可用性和配置概要等信息。

    /image/gif/paws/111999/basic-router-config-ccp-02.gif

  2. 选择 Configure > Interface Management > Interfaces and Connections > Create Connection 以配置接口的广域网连接。

    例如,对于 FastEthernet 0/1,请选择 Ethernet 选项,然后单击 Create New Connection

    注意: 对于其他类型的接口,如以太网,请选择各自的接口类型,然后单击 Create New Connection 继续。

    /image/gif/paws/111999/basic-router-config-ccp-03-1.gif

    basic-router-config-ccp-03-2.gif

  3. 一旦显示此界面,请单击 Next 继续:

    /image/gif/paws/111999/basic-router-config-ccp-04.gif

  4. 从 Available Interfaces 选项中选择 FastEthernet 0/1(必需),然后单击 Next

    /image/gif/paws/111999/basic-router-config-ccp-05.gif

  5. 为该接口指定静态 IP 地址及相应的子网掩码,然后单击 Next

    /image/gif/paws/111999/basic-router-config-ccp-06.gif

  6. 使用 ISP 提供的下一跳 IP 地址(根据网络图为 172.16.1.2)等可选参数配置默认路由,然后单击 Next

    /image/gif/paws/111999/basic-router-config-ccp-07.gif

    随即会出现此窗口,其中显示了由用户配置的配置概要。单击 完成

    注意: 可以通过选中 Test the connectivity after configuring 旁边的复选框来检查配置的连通性。这是一个可选的功能(可用)。

    /image/gif/paws/111999/basic-router-config-ccp-08.gif

    随即会出现此窗口,其中显示了路由器的命令传送状态。另外,如果因命令不兼容或功能不受支持而导致命令传送失败,则该窗口会显示错误。

    /image/gif/paws/111999/basic-router-config-ccp-09.gif

  7. 选择 Configure > Interface Management > Interfaces and Connections > Edit Interfaces/Connections 以添加/编辑/删除各种接口。

    /image/gif/paws/111999/basic-router-config-ccp-10-1.gif

    basic-router-config-ccp-10-2.gif

    如果要编辑或更改接口配置,请突出显示要对其进行更改的接口,然后单击 Edit。您可以在此更改现有的静态 IP 地址。

    basic-router-config-ccp-11.gif

NAT 配置

动态 NAT 配置

要在 Cisco 路由器中配置动态 NAT,请执行以下步骤:

  1. 选择 Configure > Router > NAT > Basic NAT,然后单击 Launch the selected task 以配置基本 NATing。

    /image/gif/paws/111999/basic-router-config-ccp-12.gif

  2. 单击 Next

    /image/gif/paws/111999/basic-router-config-ccp-13.gif

  3. 选择连接到 Internet 或 ISP 的接口,然后选择要共享 Internet 访问的 IP 地址范围。选择这些信息后,请单击 Next(如图所示):

    /image/gif/paws/111999/basic-router-config-ccp-14.gif

  4. 随即会出现此窗口,其中显示了由用户配置的配置概要。单击 完成

    /image/gif/paws/111999/basic-router-config-ccp-15.gif

  5. “Edit NAT Configuration”窗口显示转换后的 IP 地址过载 (PATing) 的已配置动态 NAT 配置。如果要使用地址池配置动态 NATing,请单击 Address Pool

    /image/gif/paws/111999/basic-router-config-ccp-16.gif

  6. 单击 Add

    /image/gif/paws/111999/basic-router-config-ccp-17.gif

    此处提供了池名称和带网络掩码的 IP 地址范围等信息。有时,IP 地址池中的多数地址均已分配,因此该池几乎耗尽。如果出现这种情况,可以将 PAT 与单个 IP 地址一起使用,以便满足对 IP 地址的其他需求。如果希望路由器在地址池快要耗尽时使用 PAT,请选中 Port Address Translation (PAT)。单击 Ok

    basic-router-config-ccp-18.gif

  7. 单击 Add

    /image/gif/paws/111999/basic-router-config-ccp-19.gif

  8. 单击 Edit

    /image/gif/paws/111999/basic-router-config-ccp-20.gif

  9. 选择 Type 字段中的 Address Pool,提供 pool 作为 Address Pool 的名称,然后单击 OK

    /image/gif/paws/111999/basic-router-config-ccp-21.gif

  10. 此窗口说明如何使用地址池配置动态 NATing。单击 Designate NAT Interfaces

    /image/gif/paws/111999/basic-router-config-ccp-22.gif

    请使用此窗口指定要在 NAT 事务中使用的内部和外部接口。由于转换是从内部到外部或从外部到内部执行的,因此在 NAT 解释转换规则时使用内部和外部标记。

    指定后,这些接口将用在所有 NAT 转换规则中。指定的接口显示在 NAT 主窗口中的“Translation Rules”列表上方。

    basic-router-config-ccp-23.gif

静态 NAT 配置

要在 Cisco 路由器上配置静态 NAT,请执行以下步骤:

  1. 选择 Configure > Router > NAT > Edit NAT Configuration,然后单击 Add 以配置静态 NATing。

    /image/gif/paws/111999/basic-router-config-ccp-24.gif

  2. Direction 中选择从内部到外部或从外部到内部,在 Translate from Interface 下指定要进行转换的内部 IP 地址。在 Translate to Interface 区域中选择 Type:

    • 如果希望将“Translate from Address”转换为“IP Address”字段中定义的 IP 地址,请选择 IP Address

    • 如果希望“-Translate from Address”使用路由器接口的地址,请选择 InterfaceTranslate from Address 将转换为分配给“Interface”字段中指定的接口的 IP 地址。

    如果希望在转换中包含内部设备的端口信息,请选中 Redirect Port。这样,只要为每个设备指定不同的端口,您便可以对多个设备使用相同的公网 IP 地址。您必须为此转换目标地址的每个端口映射创建一个条目。如果这是 TCP 端口号,请单击 TCP;如果这是 UDP 端口号,请单击UDP。在“Original Port”字段中,输入内部设备的端口号。在“Translated Port”字段中,输入路由器将用来执行此转换的端口号。请参阅配置网络地址转换:入门的允许 Internet 访问内部设备部分。

    /image/gif/paws/111999/basic-router-config-ccp-25.gif

    此窗口显示启用了端口重定向功能的静态 NATing 配置:

    basic-router-config-ccp-26.gif

路由配置

静态路由配置

要在 Cisco 路由器中配置静态路由,请完成以下步骤:

  1. 选择 Configure > Router > Static and Dynamic Routing,然后单击 Add 以配置静态路由。

    /image/gif/paws/111999/basic-router-config-ccp-27.gif

  2. 输入带掩码的目标网络地址,然后选择传出接口或下一跳 IP 地址。

    /image/gif/paws/111999/basic-router-config-ccp-28.gif

    此窗口显示了为 10.1.1.0 网络(使用 172.16.1.2 作为下一跳 IP 地址)配置的静态路由:

    /image/gif/paws/111999/basic-router-config-ccp-29.gif

动态路由配置

要在 Cisco 路由器中配置动态路由,请执行以下步骤:

  1. 选择 Configure > Router > Static and Dynamic Routing

  2. 选择 RIP,然后单击Edit

    /image/gif/paws/111999/basic-router-config-ccp-30.gif

  3. 选中 Enable RIP,选择 RIP 版本,然后单击 Add

    /image/gif/paws/111999/basic-router-config-ccp-31.gif

  4. 指定要通告的网络地址。

    /image/gif/paws/111999/basic-router-config-ccp-32.gif

  5. 单击 Ok

    /image/gif/paws/111999/basic-router-config-ccp-33.gif

  6. 要将命令传输到路由器,请单击 Deliver

    /image/gif/paws/111999/basic-router-config-ccp-34.gif

    此窗口显示了动态 RIP 路由配置:

    basic-router-config-ccp-35-1.gif

    basic-router-config-ccp-35-2.gif

其他配置

要在 Cisco 路由器中配置其他基本设置,请执行以下步骤。

  1. 如果要更改路由器的“主机名”、“域名”、“标语”和“启用加密口令”属性,请选择 Configure > Router > Router Options,然后单击 Edit

    /image/gif/paws/111999/basic-router-config-ccp-36.gif

  2. 要在路由器中添加/编辑/删除用户帐户,请选择 Configure > Router Access > User Accounts/View

    /image/gif/paws/111999/basic-router-config-ccp-37-1.gif

    basic-router-config-ccp-37-2.gif

  3. 要将配置保存到路由器及 PC 的 NVRAM 或将当前配置重置为默认(出厂)设置,请选择 Configure > Utilities > Save Running Config to PC

    注意: 要使用 CCP 将存储在计算机上的配置文件恢复到路由器或将配置文件从路由器备份到计算机,请访问配置编辑器,然后单击 I agree。在 Configure 窗口中,选择 Import configuration from PC,然后单击 replace running configuration 按钮。

    /image/gif/paws/111999/basic-router-config-ccp-38.gif

CLI 配置

路由器配置
Router#show run
Building configuration...

Current configuration : 2525 bytes

!

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption

!

hostname Router

!

boot-start-marker
boot-end-marker

!

no logging buffered
enable password cisco

!

no aaa new-model

!

resource policy

!
!
!

ip cef

!
!
!


!--- RSA certificate generated after you enable the 
!--- ip http secure-server command.

crypto pki trustpoint TP-self-signed-2401602417
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2401602417
 revocation-check none
 rsakeypair TP-self-signed-2401602417

crypto pki certificate chain TP-self-signed-2401602417
 certificate self-signed 01
  30820248 308201B1 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 32343031 36303234 3137301E 170D3130 30353139 30393031 
  31315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 34303136 
  30323431 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  8100CD35 A3A6E322 9B6005DA A0FF26C2 8A0DC5AF 27B38F3B DBF2BF58 D8F2655D 
  31115681 EC8BC750 03FE3A25 0F79DC74 3A839496 CB9486F1 A1F5BF43 D92BA7AF 
  3C72A57B D8D37799 50493588 A5A18F7F 27955AB0 AC36B560 3BE9F648 A4F6F41F 
  B9E9C5E6 F9570DEB 5555FDED 9593BD00 5ABB30CD D3B9BDFA F570F987 651652CE 
  3D310203 010001A3 70306E30 0F060355 1D130101 FF040530 030101FF 301B0603 
  551D1104 14301282 10526F75 7465722E 70616D6D 692E636F 6D301F06 03551D23 
  04183016 80146A0A C2100122 EFDA58AB C319820D 98256622 52C5301D 0603551D 
  0E041604 146A0AC2 100122EF DA58ABC3 19820D98 25662252 C5300D06 092A8648 
  86F70D01 01040500 03818100 83B0EC8C 6916178F 587E15D6 5485A043 E7BB258D 
  0C9A63F2 DA18793D CACC026E BC0B9B33 F8A27B34 5BD7DD7F FCECA34F 04662AEC 
  07FD7677 A90A8D1C 49042963 C2562FEC 4EFFF17C 360BF88A FEDC7CAA AE308F6C 
  A5756C4A F574F5F3 39CE14AE BAAEC655 D5920DD0 DA76E296 B246E36E 16CFBC5A 
  00974370 170BBDAD C1594013
  	quit



!
! 
!
!
!
!
!
!
!--- Create a user account named ccpccp with all privileges.

username ccpccp privilege 15 password 0 cisco123
archive
 log config
  hidekeys


!
!
!
!
!
!
!--- The LAN interface configured with a private IP address.

interface FastEthernet0/0
 description $ETH-LAN$
 ip address 192.168.1.1 255.255.255.0
 

!--- Designate that traffic that originates from behind 
!--- the interface is subject to Network Address Translation (NAT).

 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto


!
!--- This is the LAN interface configured with a routable (public) IP address.

interface FastEthernet0/1
 description $ETH-WAN$
 ip address 172.16.1.1 255.255.255.0
 
!--- Designate that this interface is the 
!--- destination for traffic that has undergone NAT.
 
ip nat outside
 ip virtual-reassembly
duplex auto
 speed auto


!
!
!--- RIP version 2 routing is enabled. 

router rip
 version 2
 network 192.168.1.0
 no auto-summary

!--- This is where the commands to enable HTTP and HTTPS are configured.

ip http server
ip http authentication local
ip http secure-server


!
!--- This configuration is for dynamic NAT.
!



!--- Define a pool of outside IP addresses for NAT.

ip nat pool pool 10.10.10.1 10.10.10.100 netmask 255.255.255.0

!--- In order to enable NAT of the inside source address,
!--- specify that traffic from hosts that match access list 1
!--- are NATed to the address pool named pool1.

ip nat inside source list 1 pool pool1


!
!--- Access list 1 permits only 122.168.1.0 network to be NATed.

access-list 1 remark CCP_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255


!
!--- This configuration is for static NAT
!--- In order to translate the packets between the real IP address 10.10.10.1 with TCP 
!--- port 80 and the mapped IP address 172.16.1.1 with TCP port 500.
!

ip nat outside source static tcp 10.10.10.1 8080 172.16.1.1 80 extendable

!
!




!
!
!--- The default route is configured and points to 172.16.1.2.

ip route 0.0.0.0 0.0.0.0 172.16.1.2

!
!
!
!

control-plane

!
!
!
!
!
!
!
!
!
!

line con 0
line aux 0

!--- Telnet enabled with password as cisco.

line vty 0 4
 password cisco
 transport input all
line vty 5 15
 password cisco
 transport input all

!
!
!

end

验证

要测试端到端连接,请选择 Configure > Interface & Connections > Edit Interface Connections > Test Connection。如果单击 User-specified 单选按钮,可以指定远程端 IP 地址。

/image/gif/paws/111999/basic-router-config-ccp-39.gif

故障排除

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

注意: 发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

要进行排除故障,请使用以下选项:

  • 选择 Help > About this Router 查看路由器的硬件和软件详细信息。

    /image/gif/paws/111999/basic-router-config-ccp-40.gif

  • Help 选项提供了 Cisco CP 中各种适用于路由器配置的选项的相关信息。

    /image/gif/paws/111999/basic-router-config-ccp-41.gif

如何更改路由器的用户名和口令?

您可以通过 Cisco CP 更改路由器的用户名和口令。要更改用户名和口令,请完成以下步骤:

  1. 创建一个新的临时用户帐户,然后登录到该临时用户帐户。

  2. 更改您的 Cisco CP 中的主要用户帐户(即您要在其上更改用户名和口令的路由器的用户帐户)的用户名和口令。

  3. 从临时帐户注销,然后登录到主要用户帐户。

  4. 更改主要帐户的口令后,请删除临时用户帐户。

我在使用 Internet Explorer 8 访问 Cisco CP 时收到内部错误。如何解决此问题?

问题

使用 Internet Explorer 8 通过 Cisco CP 配置 2800 系列路由器时,您可能会收到此内部错误:

内部错误:[[FaultEvent fault=[RPC Fault faultString="Send failed" faultCode="Client.Error.MessageSend" faultDetail="Channel.Connect.Failed error NetConnection.Call.Failed:HTTP :Status 200:URL :''http://localhost:8600/messagebroker/amf'"] messageId="A08846FF-E7C6-F578-7C38-61C6E94899C7" type="fault" bubbles=false cancelable=true eventPhase=2]

让 Java 降级无法解决问题。

解决方案

此错误可能是由于浏览器兼容性问题造成的。Internet Explorer 8 改变了 IE 应用程序开发的许多基本方面。Cisco 建议将 Internet Explorer 降级到版本 7。您还应卸载并重新安装 Cisco CP。

我在尝试安装 Cisco CP 时收到此错误消息:"“Unable to read the source file.File could be Corrupted.Please re-install Cisco Configuration Professional to resolve the issue.”如何解决此问题?

问题

在下载应用程序设置文件并尝试安装 Cisco CP 时,您可能会收到此错误:

Unable to read the source file. File could be Corrupted.
Please re-install Cisco Configuration Professional to resolve the issue

解决方案

请尝试下述问题解决步骤。

  1. 删除 PC 上的所有 Cisco CP 实例,然后重新进行下载和安装。

  2. 如果上一步不起作用,请尝试下载其他版本的 Cisco CP。

  3. 如果上一步不起作用,请与 Cisco TAC 联系。

    注意: 您必须拥有有效的 Cisco 用户凭据才能与 Cisco TAC 联系。

如何访问 Cisco CP 技术日志?

单击“开始”>“程序”>“Cisco Systems”>“Cisco Configuration Professional”>“收集用于技术支持的数据”。Cisco CP 自动将日志归档到名为 _ccptech.zip 的 zip 文件中。如果该文件未保存到桌面,请对其执行本地文件系统搜索。您能发送这些技术日志到为做进一步的故障排除Ciscotac

注意: 关闭所有 Cisco CP 实例以消除与日志归档相关的所有其他问题。

路由器发现比平常花费更长时间。如何解决此问题?

问题

启动 Cisco CP 并配置社区后,发现路由器的时间比平常更长。以下是描述所用时间的 Cisco CP 日志:

July 10, 2009 8:29:19 AM EDT Discovering device test-router
July 10, 2009 8:29:20 AM EDT Last discovery clean-up elapsed time was 47 milliseconds.
July 10, 2009 8:31:13 AM EDT Discovery job allocation elapsed time was 113859 milliseconds.
July 10, 2009 8:31:13 AM EDT Authentication completed.
July 10, 2009 8:40:28 AM EDT Video feature disabled. Video feature discovery elapsed time=214375 ms
July 10, 2009 8:51:15 AM EDT Security feature ready - elapsed time was 860734 milliseconds.
July 10, 2009 8:51:16 AM EDT Total device test-router discovery elapsed time was 1316047 milliseconds.

所有路由器,不论其型号和平台,都存在此问题。此外,路由器上不存在内存或 CPU 相关问题。

解决方案

验证身份验证模式。如果身份验证不在本地发生,则检查身份验证服务器是否存在问题。纠正身份验证服务器存在的任何问题,即可解决此问题。

我无法查看 Cisco CP 上的 IPS 配置页。如何解决此问题?

问题

如果 Configuration 窗口中的特定功能除空白页外不显示任何内容,则可能存在不兼容问题。

解决方案

请验证以下项目以解决此问题:

  • 验证您的路由器型号是否支持并启用了该特定功能。

  • 验证您的路由器版本是否支持该功能。路由器版本不兼容可以通过版本升级来解决。

  • 验证当前许可是否存在问题。


相关信息


Document ID: 111999