语音和统一通信 : Cisco Unified Border Element

统一边界网元(多CUBE)与Cisco 统一通信管理器(CUCM)配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

可以使用 Cisco Unified Border Element,在通向公共交换电话网 (PSTN) 的企业统一通信会话初始协议 (SIP) 中继之间实现简单且经济有效的连接。设计适应企业和service-provider会话博德控制器(SBC)设备需要, Cisco Unified Border Element (多维数据集)是运行的集成Cisco IOS�软件应用:

  • Cisco 2800 系列集成多业务服务路由器

  • Cisco 3800 系列集成多业务服务路由器

  • Cisco 2600XM 系列多业务平台

  • Cisco 3700 系列路由器

  • Cisco 7200VXR 路由器

  • Cisco 7301 路由器

  • Cisco AS5400XM 和 AS5350XM 接入网关

与传统公共交换电话网 (PSTN) 的时分多路复用 (TDM) 互联相比,统一通信网络之间的直接 IP 互联在支持新兴服务方面具有更大的灵活性。

Cisco Unified Border Element 提供具有以下功能的网络对网络接口点:

  • 信令互通 — H.323、SIP

  • 媒体互通 — 双音多频 [DTMF]、传真、调制解调器和编解码器转码

  • 地址和端口转换 — 保密性和拓扑隐藏

  • 计费和呼叫详细记录 (CDR) 标准化

  • 服务质量 (QoS) 和带宽管理 — 使用 Differentiated Services Code Point [DSCP] 或 Type Of Service (ToS) 的 QoS 标记功能、使用 Resource Reservation Protocol [RSVP] 和编解码器过滤的带宽强制功能

Cisco Unified Border Element 可在许多不同的应用环境中与包括语音网关、IP 电话和呼叫控制服务器在内的许多不同网元进行互操作,这些应用环境既包括使用 Cisco Unified Communications Manager 或 Cisco Unified Communications Manager Express 提供的高级企业语音和/或视频服务,也包括较简单的长话旁路和 IP 语音 (VoIP) 传输应用程序。

Cisco Unified Border Element 可为组织提供已集成到网络层中的所有边界控制器功能,帮助组织完成从企业到服务提供商的体系结构互联,从而实现统一的语音和视频通信。企业和中小型组织可以使用 Cisco Unified Border Element 来完成 SIP PSTN 访问与 SIP 和 H.323 企业统一通信网络之间的互联。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档所提供的信息基于 Cisco Unified Border Element (CUBE)。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

配置

可通过此配置在平台上启用基本的 Cisco Unified Border Element 功能。此功能可以终止传入的 VoIP 呼叫,并可使用出站 VoIP 拨号对等体再次发起该呼叫。呼叫既可以是从 H.323 到 SIP 的,也可以是从 SIP 到 SIP 的。

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
allow-connections h323 to h323

使用相关协议、DTMF 类型和编解码器信息配置传入和传出拨号对等体。

dial-peer voice 1 voip
session target ipv4:10.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:10.13.8.16
dtmf-relay rtp-nte
codec g711ulaw

SIP 用户代理配置

配置 SIP 用户代理 (UA) 以进行注册和身份验证。

SIP 用户代理 (UA)
sip-ua
registrar ipv4:10.1.1.10
or
registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com

与 Cisco Unified Communications Manager 互联

可使用 H.323 或 SIP 统一通信中继将 Cisco Unified Communications Manager 与 Cisco Unified Border Element 互联。

通向 Cisco Unified Border Element 的 H.323 中继

在 Cisco Unified Communications Manager 上,可以使用两种方法来定义通向 Cisco Unified Border Element 的 H.323 中继:

  • 使用网守 — 配置通向 Cisco Unified Border Element 的 H.225 中继(受 GK 控制)

  • 不使用网守 — 将 Cisco Unified Border Element 配置为 H.323 网关

媒体终结点 (MTP) 要求:

  • 如果 Cisco Unified Border Element 发出从 H.323 到 H.323 的呼叫,则只要 Cisco Unified Border Element 的版本为 12.4(6)T 或更高版本,且 Cisco Unified Communications Manager 的版本为 4.1 或更高版本,就不一定要使用 MTP。

  • 硬件或软件 MTP 可以共存于 Cisco Unified Border Element(位于支持 CUCM MTP 的路由器平台上,这些路由器平台包括 Cisco 2800 和 3800 系列 ISR)所在的路由器。

H.323 快速启动要求:

  • 如果 Cisco Unified Border Element 为 Cisco Unified Communications Manager 实现从 H.323 到 SIP 的互通,则多数 SIP 代理服务器会要求快速发出 SIP 呼叫。这意味着,H.323 端必须使用 H.323 快速启动模式。因此,必须将 Cisco Unified Communications Manager 配置为使用入站和出站 H.323 快速启动模式,该模式也要求使用 MTP。

图 1 显示了在 Cisco Unified Communications Manager 上定义为 H.323 网关的 Cisco Unified Border Element 的配置。

图 1.在 Cisco Unified Communications Manager 上作为 H.323 网关的 Cisco Unified Border Element 的配置

/image/gif/paws/99863/cube-config01.gif

cube-config02.gif

图 2 显示了与前面的 Cisco Unified Communications Manager 配置相匹配的 Cisco Unified Border Element 配置。

图 2. Cisco Unified Border Element 上的 H.323 中继配置

cube-config03.gif

通向 Cisco Unified Border Element 的 SIP 中继

定义通向 Cisco Unified Border Element 的统一通信 SIP 中继时,需要使用 Cisco Unified Communications Manager 5.x 版本或更高版本。

MTP 要求:

  • 不使用 MTP 的 SIP 中继 — 如果允许在没有 SDP 的情况下使用延迟的媒体或邀请,即可配置不使用 MTP 的统一通信 SIP 中继。

  • 使用 MTP 的 SIP 中继 — 如果必须使用带 SDP 的早期媒体或邀请(仅限 G.711 呼叫),则应配置统一通信 SIP 中继(使用 MTP)。

图 3 显示了使用通向 Cisco Unified Communications Manager 的统一通信 SIP 中继定义的 Cisco Unified Border Element 配置。

图 3.Cisco Unified Border Element 的配置,其中包含通向 Cisco Unified Communications Manager 的 SIP 中继

/image/gif/paws/99863/cube-config04.gif

图 4 显示了与前面的 Cisco Unified Communications Manager 配置相匹配的 Cisco Unified Border Element 配置。

图 4. Cisco Unified Border Element 上的 SIP 中继配置

/image/gif/paws/99863/cube-config05.gif

MTP 与 Cisco Unified Border Element 共存

如果 Cisco Unified Communications Manager 配置要求使用软件 MTP,则可在供 Cisco Unified Border Element 使用的同一路由器上进行相关配置。

下面是 Cisco Unified Border Element 上的 MTP 配置:

sccp local FastEthernet0/1

sccp ccm 15.5.34.1 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP

!

dspfarm profile 1 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

在 Cisco Unified Border Element 上进行转码

Cisco Unified Border Element能执行在G.711ï ¿  ½之间的转码- law/a法律和G.729多种类似。可以为任何呼叫调用转码操作,不管该呼叫是从 Cisco Unified Communications Manager 发往 PSTN 的,还是从 PSTN 发往 Cisco Unified Communications Manager 的。主要标准在于:Cisco Unified Border Element 上的两个呼叫段是否使用不同的编解码器 - G.711 和 G.729。在 Cisco Unified Border Element 上对转码进行配置时,需要 DSP 在平台上可用。

下面是 Cisco Unified Border Element 上的转码配置:

voice-card 2

dspfarm

dsp services dspfarm

sccp local FastEthernet 0/0

sccp ccm 200.1.1.100 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP123456782012

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

codec g729r8

maximum sessions 5

associate application SCCP

telephony-service

load 7960-7940 P00303020214

max-ephones 48

max-dn 48

ip source-address 200.1.1.100 port 2000

sdspfarm units 1

sdspfarm transcode sessions 50

sdspfarm tag 1 MTP123456782012

create cnf-files version-stamp 7960 Jul 29 2002 13:50:03

在 Cisco Unified Border Element 上使用 Tcl IVR

Cisco Unified Border Element 支持 TCL 脚本,您可以在 VoIP 拨号对等体下配置这些脚本。无需 DSP 即可使用 TCL 功能。有许多可用于 Cisco Unified Border Element 部署的 TCL 应用程序已内置在 Cisco IOS 软件中。Cisco IOS 的身份验证、授权和计帐 (AAA) 功能也可与 TCL 脚本编写功能和 Cisco Unified Border Element 结合使用,以便对呼叫进行身份验证和授权。

aaa new-model

!

aaa authentication login h323 group radius

aaa authorization exec h323 local group radius

aaa accounting exec h323 start-stop group radius

!

application

service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl

paramspace english index 1

paramspace english language en

paramspace english location tftp://15.5.27.11/prompts/en/

param pid-len 4

paramspace english prefix en

param uid-len 6

!

gw-accounting aaa

!

radius-server host 15.5.27.11 auth-port 1645 acct-port 1646

radius-server timeout 10

radius-server key lab

radius-server vsa send accounting

radius-server vsa send authentication

完整配置示例

router#show run
Building configuration...
Current configuration : 1122 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPIPGW-1
!
boot-start-marker
boot-end-marker
!
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
! aaa new-model
!
aaa authentication login h323 group radius
aaa authorization exec h323 local group radius
aaa accounting exec h323 start-stop group radius
!
application
service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl
paramspace english index 1
paramspace english language en
paramspace english location tftp://15.5.27.11/prompts/en/
param pid-len 4
paramspace english prefix en
param uid-len 6
!
gw-accounting aaa
!
radius-server host 15.5.27.11 auth-port 1645 acct-port 1646
radius-server timeout 10
radius-server key lab
radius-server vsa send accounting
radius-server vsa send authentication
!
no ip domain lookup
no ftp-server write-enable
!
voice service voip
allow-connections h323 to sip 

!--- key command

allow-connections sip to h323 

!--- key command

allow-connections sip to sip 

!--- key command

allow-connections h323 to h323 

!--- key command

!
interface FastEthernet0/0
ip address 200.1.1.100 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.1
ip http server
!
control-plane
!
dial-peer voice 1 voip
application debitcard 

!--- TCL Application

session target ipv4:9.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric 

!--- DTMF config for h.245 alphanumeric

codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:9.13.8.16
dtmf-relay rtp-nte 

!--- DTMF config for RFC2833

codec g711ulaw
!
gatekeeper
shutdown
sip-ua
registrar ipv4:200.1.1.10 or registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com
!
line con 0
line aux 0
line vty 0 4
login
!
end

验证

当前没有可用于此配置的验证过程。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • logging — 由于 debug 命令冗长,因此务必确保设置 Cisco Unified Border Element 以进行日志记录(如本示例所示),并尽可能在非高峰时段执行调试。

    logging console informational
    logging buffer 200000 debug
    service sequence-number
    service timestamp debug date msec
  • show — 以下是相关输出:

    show version
    show run
    show voip rtp connection (once the call is up)
    show call active voice brief (once the call is up)
  • debug — 请确保在清除日志之后再调用调试,并在执行该调用之后获取 show logging 命令的输出。

    H.323 到 H.323 方案

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug h225 q931
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout

    H.323 到 SIP 方案

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout
    debug ccsip all

    SIP 到 SIP 方案

    debug ccsip all
    debug voip ccapi inout
  • debug — 除了启用基于前面所述方案的调试命令之外,还应启用以下转码器调试命令:

    debug dspfarm all
    debug sccp messages
  • debug voip rtp session named-events — 如果使用了 RFC2833 (dtmf-relay rtp-nte),还应启用此 debug 命令。


相关信息


Document ID: 99863