交换机 : Cisco Catalyst 3750 系列交换机

Catalyst 3750系列交换机常见问题故障排除

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档描述 Cisco Catalyst 3750 系列交换机存在的常见问题以及解决这些问题的可能方法。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于 Cisco Catalyst 3750 系列交换机。

本文档中的信息都是基于特定实验室环境中的设备编写的。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

连接问题

以太网速度/双工自动协商不匹配

IEEE 802.3ab 自动协商协议用于管理速度(10 Mbps、100 Mbps 和 1000 Mbps,SFP 模块端口除外)和双工(半双工或全双工)方面的交换机设置。某些情况下,此协议可能无法严格遵守这些设置,因此会导致性能下降。

以下情况会导致不匹配发生:

  • 手动设置的端口速度或双工参数与已连接端口上的手动设置速度或双工参数不一致。

  • 端口被设置为自动协商,而相连的端口却被设为全双工且无自动协商。

为了最大限度地提高交换机性能并确保链路连通,在更改双工和速度设置时,请遵照以下准则:

  • 使两个端口自动协调速度和双工。

或者

  • 手工设置连接两端端口的速度和双工参数。

注意: 如果远程设备没有自适应功能,配置两边端口的双工设置使之匹配。即使连接的端口不支持自动协商,速度参数也能够自动调整。

SFP 速度/双工自动协商不匹配

您无法配置 SFP 模块端口上的速度,但是如果该端口连接到不支持自动协商的设备,则可以将速度配置为不协商 (nonegotiate)。但是,当 1000BASE-T SFP 模块位于 SFP 模块端口中时,您可以将速度配置为 10 Mbps、100 Mbps、1000 Mbps 或 auto。

除非 1000BASE-T SFP 模块或 100BASE-FX MMF SFP 模块位于 SFP 模块端口中,否则不能在此类端口上配置双工模式。所有其他 SFP 模块仅在全双工模式下运行。

  • 当 1000BASE-T SFP 模块位于 SFP 模块端口中时,可以将双工模式配置为 auto 或 full。

  • 当 100BASE-FX SFP 模块位于 SFP 模块端口中时,可以将双工模式配置为 half 或 full。

注意: 千兆以太网接口支持半双工模式。但是,不能将这些接口配置为在半双工模式下运行。

启用 IP 路由之后连接中断

人们面临的一个常见问题是:一旦在交换机上启用 IP 路由,即失去连接。用于指定设备的默认网关的命令是造成此问题的一个常见原因。

如果没有在设备上启用 IP 路由,此命令为 ip default-gateway

3750-1#ip default-gateway A.B.C.D


!--- where A.B.C.D is the IP address of the default router

如果已启用 IP 路由,请使用 ip route 命令指定该设备的默认路由器。

3750-1#ip route 0.0.0.0 0.0.0.0 A.B.C.D


!--- where A.B.C.D is the IP address of the default router

将端口分配给单个 VLAN 时因未将其配置为接入端口而导致的间歇性连接问题

将端口分配给某些 VLAN 时,必须对端口应用 switchport mode access 命令,将接口置于永久非中继模式,并确保接口可以通过协商将链路转换成非中继链路。即使邻居接口不发生改变,此接口也将变为非中继接口。

如果没有应用 switchport mode access 命令,端口可能会出现抖动。此命令迫使端口作为非中继链路运行。

要将接口配置为接入模式,请完成以下步骤:

  1. 访问将配置为接入端口的接口:

    Switch(config)#interface fastEthernet 0/25
    Switch(config-if)#switchport mode access
    
    !--- This command forces the interface go into a permanent nontrunking mode
    
    Switch(config-if)#switchport access vlan 3
    
    !--- This command will assign interface fastethernet 0/25 to vlan 3
    
    Switch(config-if)#no shut
    
  2. 当交换机出现端口抖动时,请检查是否对抖动的接口应用了 switchport mode access 命令。检查 show run 命令的输出。

    Switch# show run
    Building configuration...
    
    Current configuration : 3183 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log datetime
    service password-encryption
    !
    
    !--- Output supressed.
    
    !
    interface FastEthernet0/25
     switchport access vlan 3
     switchport mode access
    !
    interface FastEthernet0/26
     switchport access vlan 3
    !
    
    !--- Output supressed.
    
    

    注意: 当接口 FastEthernet0/26 仅配置为属于 VLAN 3 时,会将接口 FastEthernet0/25 配置为接入端口。

    注意: 只有当设备或主机连接到物理接口时,才会出现端口抖动。

Catalyst 3750 交换机收到大量 TCN 数据包

网络中存在大量主机时,交换机可能会收到多个拓扑更改通知 (TCN) 数据包。例如,当一个直接连接的服务器重新通电时,交换机必须通知生成树根关于该拓扑更改。

交换机在需要对拓扑更改发出信号时,就会开始在根端口上发送 TCN 数据包。指定的网桥接收并确认 TCN,还为自己的根端口生成另一个 TCN。此过程将一直持续,直到 TCN 发现根网桥为止。

这里要考虑的重点是,TCN 并不启动 STP 重新计算。这种可能性源自 TCN 通常与不稳定的 STP 环境相关联的事实;TCN 是这种可能性的后果,而不是原因。TCN 只影响老化时间。它不更改拓扑,也不创建环路。

当交换机在端口上收到大量 TCN 时,请验证仅终端设备连接到那些端口上。为避免 TCN,您可以在连接终端设备的每个端口上启用 portfast。打开或关闭为 portfast 配置的端口时,交换机从不生成 TCN。

注意: 在通往集线器或其他网桥的端口上应该明确避免使用 STP Portfast。

有关生成树中拓扑更改的详细信息,请参阅了解生成树协议拓扑更改

如果没有主机或设备连接到端口,则接口 VLAN 将处于打开/关闭状态

创建新的 VLAN 作为第 3 层接口时,如果没有为其分配端口,并且该端口的状态为未连接,则此 VLAN 的状态将显示为打开/关闭。要让此 VLAN 的状态显示为打开/打开,需要至少为此接口 VLAN 分配一个端口,并且需要有一台设备或主机连接到已分配给新接口 VLAN 的端口。

示例

本示例将创建一个新的第 3 层接口 VLAN。将为此新建的 VLAN 分配一个端口,并将一台设备连接到此端口,使得接口 VLAN 的状态为打开/打开。

  1. 在数据库中创建新 VLAN。退出 VLAN 数据库模式时,将应用配置更改。

    Switch# vlan database
    Switch(vlan)# vlan 40
    VLAN 40 added:
        Name: VLAN0040
    Switch(vlan)# exit
    APPLY completed.
    Exiting....
  2. 请确保已在 VLAN 数据库中成功创建了 VLAN。请检查 show vlan 命令的输出。

    Switch# show vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa1/0/2, Fa1/0/3, Fa1/0/4
                                                    Fa1/0/5, Fa1/0/6, Fa1/0/7
                                                    Fa1/0/8, Fa1/0/9, Fa1/0/10
                                                    Fa1/0/11, Fa1/0/13, Fa1/0/14
                                                    Fa1/0/15, Fa1/0/16, Fa1/0/17
                                                    Fa1/0/18, Fa1/0/19, Fa1/0/20
                                                    Fa1/0/21, Fa1/0/22, Fa1/0/23
                                                    Fa1/0/24, Gi1/0/1, Gi1/0/2
    2    VLAN0002                         active    
    10   data                             active    
    21   VLAN0021                         active    
    35   VLAN0035                         active    
    36   VLAN0036                         active    Fa1/0/12
    40   VLAN0040                         active    
    99   VLAN0099                         active    
    100  VLAN0100                         active    
    198  VLAN0198                         active 

    注意: 没有端口分配给 VLAN 40。

  3. 为新建的 VLAN 设置 IP 地址。

    Switch(config)# int vlan 40
    Switch(config-if)# ip address 10.4.4.1 255.255.255.0
    Switch(config-if)# no shut
    Switch(config-if)# exit
    
  4. 配置连接客户端和相应 VLAN 的物理接口。

    Switch(config)# int fa 1/0/2
    Switch(config-if)# switchport mode access
    Switch(config-if)# switchport access vlan 40
    Switch(config-if)# no shut
    
  5. 检查是否已为此 VLAN 分配物理接口

    Switch# show vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa1/0/3, Fa1/0/4, Fa1/0/5
                                                    Fa1/0/6, Fa1/0/7, Fa1/0/8
                                                    Fa1/0/9, Fa1/0/10, Fa1/0/11
                                                    Fa1/0/13, Fa1/0/14, Fa1/0/15
                                                    Fa1/0/16, Fa1/0/17, Fa1/0/18
                                                    Fa1/0/19, Fa1/0/20, Fa1/0/21
                                                    Fa1/0/22, Fa1/0/23, Fa1/0/24
                                                    Gi1/0/1, Gi1/0/2
    2    VLAN0002                         active    
    10   data                             active    
    21   VLAN0021                         active    
    35   VLAN0035                         active    
    36   VLAN0036                         active    Fa1/0/12
    40   VLAN0040                         active    Fa1/0/2
    
  6. 现在,此 VLAN 的状态将显示为打开/关闭,因为没有主机或设备连接到端口 Fa1/0/2

    Switch# show interface vlan 40
    Vlan40 is up, line protocol is down 
    
    !--- Output suppressed.
    
    

    注意: 虽然已有端口分配给此 VLAN,但此 VLAN 的状态仍显示为打开/关闭,因为没有设备或主机在物理上连接到端口 Fa1/0/2

  7. 将主机或设备连接到属于 VLAN 40 的端口 Fa1/0/2。

  8. 检查端口 Fa1/0/2 的状态是否为打开/打开

    Switch# show interface fa1/0/2
    FastEthernet1/0/2 is up, line protocol is up
    
    !--- Output suppressed.
    
    
  9. 由于已有端口分配给新的 VLAN,且端口状态为打开/打开,因此 VLAN 的状态将显示为打开/打开。

    Switch# show interface vlan 40
    Vlan40 is up, line protocol is up
    
    !--- Output suppressed.
    
    

    注意: 只有在已有端口分配给第 3 层 VLAN,且该端口的状态为打开/打开时,此 VLAN 的状态才会显示为打开/打开。

连接到 IP 电话

DHCP 在 IP 电话获取 IP 地址以及进行自我配置时发挥着重要作用。IP 电话和 DHCP 服务器之间的通信可能会由于各种原因而受到阻碍。下面列出了常见的原因和解决方法:

HTTP 访问问题

设备重新启动时,自签名证书丢失

如果交换机没有配置主机名和域名,则会生成临时自签名证书。如果交换机重新启动,所有临时自签名证书将会丢失,并分配一个新的临时自签名证书。

如果交换机已配置主机名和域名,则会生成永久性自签名证书。如果您重新启动交换机,或禁用安全 HTTP 服务器,此证书仍然会保持活动状态,以便您在下次重新启用安全 HTTP 连接时使用。

当您启用安全 HTTP 连接,并且没有配置客户端身份验证 (CA) 信任点时,将自动生成临时或永久性自签名证书。

注意: 对于安全 HTTP 连接,我们强烈建议您配置 CA 信任点。如果没有为运行 HTTPS 服务器的设备配置 CA 信任点,服务器会自己进行验证,并生成所需的 Rivest、Shamir 和 Adelman (RSA) 密钥对。由于自认证(自签名)证书无法提供足够的安全,因此,连接的客户端会生成通知,指出证书为自验证证书,让用户有机会接受或拒绝连接。

未将本地用户名用于 HTTP 访问

连接到 Catalyst 3750 交换机设备管理器时,交换机不会使用在设备上配置的本地用户名,而是仅使用加密口令或启用口令(仅在没有配置加密口令时使用)。

为确保连接安全,您可以在设备上启用 SSL。有关详细信息,请参阅配置安全套接层 HTTP 的交换机

升级 Cisco IOS 软件时,安全 HTTP 访问丢失

在您升级在Cisco Catalyst 3750系列交换机后的Cisco IOS 软件,您能丢失对设备的安全访问。即使禁用访问后又重新启用,也不能恢复该访问。要解决此问题,请完成以下步骤:

  1. 禁用安全 HTTP 服务器。

    no ip http secure-server
    
  2. 删除 CA 信任点或 PKI 信任点配置。

    no crypto ca trustpoint name
    
    

    no crypto pki trustpoint name
    
    
  3. 要重新配置安全 HTTP 服务器,请使用 SSL 配置指南中提及的步骤。

以太网供电问题

电源超额订阅

网络管理员可以使用 Cisco Catalyst 3560 及 3750 系列以太网供电 (PoE) 产品上的 Power Inline Consumption 功能来配置用电设备的实际功率要求。此功能允许管理员覆盖用电设备分类设置。许多大型企业客户都请求使用此功能,版本 12.2(25)SEC 及更高版本均支持此功能。

下面是两种方案。在这两种方案中,可以将功耗命令行界面 (CLI) 用于手动配置 PoE 分配,这比自动算法更有效:

  • 当前,Cisco Catalyst 3750 系列交换机针对 0 类用电设备的功率预算为 15.4W。然而,其中一些用电设备要求最大功率预算低于 15.4W(例如,Siemens IP 电话要求 5W 的功率)。不使用 Power Inline Consumption 功能,客户只能部署 24 台此类设备。使用 power inline consumption 命令来配置交换机端口的功率要求,客户可以部署多达 48 台此类设备。

  • 通常,第 3 类用电设备分配有 15.4W 的功率。一些 IEEE 第 3 类用电设备(8-15W 范围)使用的功率要远低于 15.4W 的最大值。例如,即使在最糟糕的情况下,Avaya 2620SW 使用的功率也仅为 8W。如果使用功耗 CLI 来配置支持此类功率要求最高为 8W 的电话的端口,3750-48PS 可以安全地为 46 部(而不是 24 部)电话供电。

注意: 交换机上的任何配置错误(电源超额订阅)都可能降低其可靠性或损坏交换机。即使电源超额订阅约 20%,交换机也会继续运行,但其可靠性会降低。如果超额订阅达 20% 以上,就会触发电路的短路保护,并关闭交换机。

断电导致端口被禁用

如果连接到 PoE 交换机端口并且由 AC 电源供电的用电设备(如 Cisco IP 电话 7910)断电,该设备可能会进入“因错误而被禁用”状态。要从“因错误而被禁用”状态中恢复,请输入 shutdown 接口配置命令,然后输入 no shutdown 接口命令。

错误链路导致端口被禁用

在 Cisco 用电设备已连接到某端口的情况下,此时如果使用 power inline never 接口配置命令配置此端口,则可能会出现错误链路,端口也将进入“因错误而被禁用”状态。要使端口从“因错误而被禁用”状态中恢复,请使用 power inline 更改 PoE 模式,然后输入 shutdownno shutdown 接口配置命令。请勿将 Cisco 用电设备连接到已使用 power inline never 命令进行配置的端口。3750 设备不支持载波延迟。此外,虽然载波延迟可以作为去除链路抖动的替代方案,但它只是线卡硬件的一项功能,并且采用的是第 3 层 Cisco IOS 机制。因此,Cat3750 不支持它们。

将一台新交换机添加到现有堆叠后,电话无法通电

将新交换机添加到现有堆叠时,可能会发生此问题。将工作站连接到此新交换机时,端口运行良好,并且交换机与工作站之间可以建立连接。当 IP 电话连接到此新交换机时,电话无法通电,端口也无法接通。

如果遇到此问题,请确保新的交换机支持 PoE,以便为 IP 电话供电。如果新交换机不支持 PoE,请更改设置,使交换机支持 PoE。

有关支持 PoE 的 3750 型号的详细信息,请参阅 Cisco Catalyst 3750 问答

堆叠问题

%STACKMGR-6-SWITCH_ADDED_VM

堆叠成员之间的软件兼容性取决于堆叠协议版本号。要查看交换机堆叠的堆叠协议版本,可以发出 show platform stack-manager all 命令。

3750-Stk# show platform stack-manager all
                                               Current
Switch#  Role      Mac Address     Priority     State
--------------------------------------------------------
 1       Slave     0016.4748.dc80     5         Ready
*2       Master    0016.9d59.db00     1         Ready


!--- Output suppressed


                 Stack State Machine View
==============================================================

Switch   Master/   Mac Address          Version    Uptime   Current
Number   Slave                          (maj.min)            State
---------------------------------------------------------------------
1        Slave     0016.4748.dc80          1.11        8724    Ready
2        Master    0016.9d59.db00          1.11        8803    Ready


!--- Output suppressed

具有相同 Cisco IOS 软件版本的交换机拥有相同的堆叠协议版本。此类交换机完全兼容,并且所有功能在整个交换机堆叠中都能正常工作。具有相同 Cisco IOS 软件版本的交换机会作为堆叠主交换机立即加入到交换机堆叠中。

如果存在不兼容性,则完全正常工作的堆叠成员会生成一个系统消息,描述特定堆叠成员上产生不兼容性的原因。堆叠主交换机会向所有堆叠成员发送该消息。

具有不同 Cisco IOS 软件版本的交换机可能会有不同的堆叠协议版本。具有不同主要版本号的交换机不兼容,并且不能存在于同一个交换机堆叠中。

3750-Stk# show switch
                                               Current
Switch#  Role      Mac Address     Priority     State
--------------------------------------------------------
 1       Member    0015.c6f5.6000     1         Version Mismatch
*2       Master    0015.63f6.b700     15        Ready
 3       Member    0015.c6c1.3000     5         Ready

主要版本号相同而次要版本号不同的交换机在充当堆叠主交换机时,将被视为部分兼容的交换机。部分兼容的交换机连接到交换机堆叠后,它们会进入版本不匹配 (VM) 模式,因此不能作为完全正常工作的成员加入到该堆叠中。该软件会检测不匹配的软件,并尝试使用交换机堆叠映像或交换机堆叠闪存中的 tar 文件映像升级(或降级)处于 VM 模式下的交换机。该软件会使用自动升级 (auto-upgrade) 和自动建议 (auto-advise) 功能。

如果堆叠主交换机上运行的软件版本与处于 VM 模式下的交换机兼容,并且所有堆叠成员都可以使用当前映像的 tar 文件,则会进行 auto-upgrade。如果当前映像的 tar 文件不可用,则 auto-advise 功能会建议您使用所需命令下载兼容的映像。如果主交换机和处于 VM 模式下的交换机运行不同的功能集(IP 服务和 IP Base)或不同的加密功能(加密和非加密),则 auto-upgrade 和 auto-advise 功能都将无法正常运行。

有关详细信息,请参阅堆叠中的交换机无法启动新映像(版本不匹配)

%%IDBs can not be removed when switch is active

从堆叠中移除交换机时,将收到以下错误消息:

如果从堆叠中移除交换机且成员值没有更改为默认值 1,则会显示这些错误消息。要解决此问题,请完成以下步骤:

  1. 断开您希望从堆叠中移除的交换机。这包括手动对电缆去堆叠,以便从堆叠中移除交换机。

  2. 使用此命令对交换机重新编号:

    switch current-stack-member-number renumber new-stack-member-number
    
    
  3. 要从交换机堆叠中移除已配置的交换机,与已移除堆叠成员相关联的配置将作为已设置信息保留在运行配置中。要完全删除配置,请使用 no switch stack-member-number provision 全局配置命令。

有关成员编号的详细信息,请参阅堆叠成员编号

配置问题

DHCP 服务在 VLAN 间不可用

当 Cisco Catalyst 3750 充当 DHCP 中继代理时,它可能不会为 DHCP 服务器所在 VLAN 之外的 VLAN 中的客户端提供服务。要解决此问题,请完成以下步骤:

  1. 验证交换机上是否已启用 IP 路由。

  2. 验证 VTP 版本 2 是否在网络中运行。

    3750-Stk#show vtp status
    VTP Version                     : 2
    
    ! ---- Output suppressed
    
    
  3. 在路由接口上配置 DHCP 服务器的 IP 帮助程序地址。

    3750-Stk(config-if)# ip helper-address <IP Address of DHCP Server>
    
    
  4. 在全局配置模式下,打开用于转发请求的 DHCP/BOOTP 端口。

    3750-Stk(config)#ip forward-protocol udp bootpc
    3750-Stk(config)#ip forward-protocol udp bootps
    

不支持的命令

在 Catalyst 3750 系列交换机中,一些 CLI 命令虽然也在 CLI 帮助中会显示,但由于没有经过测试或者由于 Catalyst 3750 交换机硬件的限制,事实上并不受系统支持。

有关 Cisco IOS 软件版本 12.2(35)SE 不支持的命令的列表,请参阅 Cisco IOS 版本 12.2(25)SEE 不支持的命令

有关其他 Cisco IOS 软件版本的信息,请参阅 Catalyst 3750 交换机软件配置指南

组播无法在同一 VLAN 中运行

在 Catalyst 交换机中,一个常见的配置错误就会导致组播流量不流经交换机。有关此问题及可用解决方案的详细信息,请参阅组播无法在 Catalyst 交换机的同一 VLAN 中运行

端口由于端口安全违规转换到 Err-Disable 状态

如果同一 VLAN 中的一个安全接口看到在另一个安全接口上识别或配置的地址,这时就会发生端口安全违规。

SW1-3750#
1d01h: %PM-4-ERR_DISABLE: psecure-violation error detected on Gi2/0/22, 
   putting Gi2/0/22 in err-disable state
1d01h: %PORT_SECURITY-2-PSECURE_VIOLATION: Security violation occurred, 
   caused by MAC address 0009.434b.c48c on port GigabitEthernet2/0/22.
1d01h: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/22, 
   changed state to down
1d01h: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/22, 
   changed state to down SW1-3750#

如果必须从一个安全接口移动到另一个接口,请完成以下步骤:

  1. 使用动态学习提高端口安全,并删除所有静态 MAC 地址列表或粘性学习配置。

    SW1-3750(config-if)#no switchport port-security mac-address sticky
    SW1-3750(config-if)#no switchport port-security mac-address H.H.H
    
    
    !--- H.H.H is the 48 bit MAC addresses configured
    
    
  2. 配置端口安全老化。

    老化时间用于确定在另一端口上显示 MAC 地址之前所需的最短时间间隔。

    SW1-3750(config-if)#switchport port-security aging time 1
    
    SW1-3750(config-if)#switchport port-security aging type inactivity
    

    仅当指定时段内没有来自安全源地址的数据流量时,才能使用老化类型非活动状态表示此端口上的安全地址已老化。

  3. 配置从端口安全违规的 err-disable 状态中恢复。

    SW1-3750(config)#errdisable recovery cause psecure-violation
    

有关详细信息,请参阅配置基于端口的流量控制配置端口安全部分。

FIB-2-FIBDOWN

FIB-2-FIBDOWN : CEF has been disabled due to a low memory condition.
It can be re-enabled by configuring "ip cef [distributed]"

在重新启用 CEF 之前,请确定原因并解决此问题。此错误可能由以下问题造成:

  • 桌面默认模板所允许的非直接连接路由数量超出限制。

    如果使用此模板,则很可能会超出最大数量 2000。

    作为应急方案,请发出 sdm prefer routing 命令,并重新加载交换机。理想情况下,此应急方案可解决问题。有关详细信息,请参阅配置 SDM 模板

  • 交换机识别的 MAC 地址的数量超出硬件中为存储 MAC 地址而分配的空间容量。

    在此情况下,show mac-address-table count 的输出将显示 0 个空闲条目。

    作为应急方案,请更改交换机数据库管理 (SDM) 模板,为单播 MAC 地址区域分配更大的空间,或删除不必要的 VLAN,以减少交换机识别的 MAC 地址的数量。Cisco Bug ID CSCef89559仅限注册用户)记录了此问题。

系统时钟在每次重新加载后重置

Catalyst 3750 交换机或几乎所有的低端交换机(如 2900 XL、3500 XL、2950、3550 和 3560)都没有由电池支持的系统时钟。因此,如果时间与日期是手动设置的,在重新加载后会丢失时间与日期设置。所以,我们建议您使用外部 NTP 服务器来管理此类交换机上的系统时间和日期。有关系统时钟的详细信息,请参阅管理交换机管理系统时间和日期部分。

注意: 只有当您没有交换机能够与之同步的外部源时,Cisco 才建议您使用手动的时间与日期配置。

交换机在重新加载后丢失静态路由配置

交换机在重新加载或断电通电以后,可能会丢失静态路由配置。要验证在重新加载后是否存在路由配置,请检查 show run 命令的输出。

为确保交换机在重新加载后不会丢失静态路由,请完成以下步骤:

  1. 在全局配置模式下使用 ip routing 命令,以便在交换机上启用 IP 路由。

    3750_Switch(config)#ip routing
    
    !--- Enable IP routing for interVLAN routing.
    
    
  2. 添加静态路由。

  3. 发出 write memory 命令。

    3750_Switch#write memory
    
  4. 重新加载交换机。

  5. 在交换机重新加载后,发出 show run 命令以验证静态路由没有丢失。

无法通过安全壳和 Telnet 登录

当您尝试通过安全壳或 Telnet 会话连接到 3750 交换机时,登录尝试失败。两个连接均提示需要口令,但不允许您登录。您无法使用该用户名和口令通过超级终端 HTTP 连接到交换机。

要通过 SSH 或 Telnet 访问交换机,请使用以下配置:

3750_Switch(config)#line vty 0 4
3750_Switch(config-line)#no password <removed>
3750_Switch(config-line)#login local
3750_Switch(config-line)#transport input ssh
3750_Switch(config)#line vty 5 15
3750_Switch(config-line)#no password <removed>
3750_Switch(config-line)#login local
3750_Switch(config-line)#transport input ssh

使用此用户名和口令登录:

username swadmin password 0 <removed>

Catalyst 3750 交换机上的默认路由命令无法正常工作

在您第一次使用 Express Setup 在 3750 交换机上设置默认路由后,默认网关并不能正常工作。

必须启用 ip routing 命令,才能让默认网关设置在 3750 上生效。如果是第一次使用 Express Setup 配置 3750 交换机,请确保启用 ip routing 命令,因为此命令不会默认启用。

使用 CNA 可以启用此命令。

  1. 应用 ip routing 命令。

  2. 设置默认网关。

注意: ip route 命令仅在启用 IP 路由的情况下生效。默认情况下,IP 路由处于禁用状态。

与路由相关的命令没有在运行配置中显示

当您在交换机中配置路由映射时,设备接受相关命令,但这些命令可能不会在运行配置中显示。这是因为,交换机当前使用的是 VLAN SDM 模板,而非路由模板。

路由模板为了单播路由会最大限度地利用系统资源,处于网络中心位置的路由器或汇聚路由器通常需要这种模板,而 VLAN 模板则禁用路由并且支持最大数量的单播 MAC 地址。通常会为第 2 层交换机选择此模板。

有关 SDM 模板及其用法的详细信息,请参阅配置 SDM 模板

升级问题

堆叠在软件升级后无法使用新映像启动

在软件升级以后,堆叠中的 Catalyst 3750 系列交换机可能无法使用新映像启动。这个问题可能是由于您在下载选项中使用了 archive download-sw /leave-old-sw 而造成的。

/leave-old-sw 选项在下载以后保留旧软件版本。当您重新加载时,只有堆叠主交换机被重新加载。出现这个问题,是因为作为堆叠的交换机期待堆叠中的所有型号均具有相同版本的映像。因此,堆叠主交换机被置于禁用状态,而另一台成员交换机则被选择作为主交换机。

要从这种状态中恢复,请在堆叠主交换机上使用 archive copy-sw 命令,将正在运行的映像从一个堆叠成员的闪存复制到一个或多个其他堆叠成员的闪存中。此命令用于将软件映像从现有堆叠成员复制到使用不兼容软件的堆叠成员中。该交换机会自动重新加载,并作为功能完全正常的成员加入堆叠。

与 Cisco Catalyst 3750 交换机中 Cisco IOS 软件升级相关的其他问题,请参阅使用命令行界面升级堆叠配置中的 Catalyst 3750 软件故障排除部分。

Unable to create temp dir "flash: 更新”

当您升级 Cisco IOS 软件时,可能会显示此错误消息:

Unable to create temp dir "flash:update"

此错误消息指示 flash: 文件系统中已存在临时目录“update”,且当前升级过程不能使用该目录。此目录可能因为之前的任何升级尝试遗留在 flash: 文件系统中。

要解决此问题,请完成以下步骤:

  1. 使用 rmdir flash: update 命令可删除此临时目录。

  2. 发出 delete flash: update 命令。

  3. 如果 rmdir flash: update 无效,则发出 delete /force /recursive flash: update 命令。

  4. 继续 Cisco IOS 软件升级过程。

性能问题

CPU 使用率较高问题

在查看 CPU 数据包处理体系结构和对 CPU 使用率较高进行排除故障之前,您必须了解基于硬件的转发交换机和基于 Cisco IOS 软件的路由器使用 CPU 的不同方式。一种常见的误解是,CPU 使用率较高意味着设备上的资源耗尽且可能会发生崩溃。容量问题是 Cisco IOS 路由器上的 CPU 使用率较高的症状之一。但是,容量问题几乎从未是基于硬件的转发交换机 CPU 使用率过高的症状。

排除故障高CPU利用率的第一步将检查您的Catalyst 3750交换机Cisco IOS版本版本注释可能的已知IOS Bug。这样您可以通过故障排除步骤排除 IOS Bug。有关您所使用的 Cisco IOS 软件版本的发行版本注释,请参阅 Cisco Catalyst 3750 系列交换机发行版本注释

有关常见的 CPU 使用率较高问题以及可能的解决方法,请参阅 Catalyst 3750 系列交换机 CPU 使用率较高问题故障排除

高温问题

交换机可能体验在温度的一异常增加。此增加可以由show environment temperature命令确认。

例如:

Switch#show environment all
FAN is OK
TEMPERATURE is FAULTY
Temperature Value: 127 Degree Celsius
Temperature State: RED
Yellow Threshold : 55 Degree Celsius
Red Threshold    : 65 Degree Celsius
POWER is OK
RPS is NOT PRESENT

如果输出显示红色,当温度状态或温度值超出阈值范围,则推荐的操作是防止交换机过度加热。结果,请勿在超出最大推荐的环境温度113� F的区域操作交换机(45� C)。

吞吐量问题

交换机端口的入口和出口流量速率可能由于各种原因而有所不同。以下是一些可能的常见原因:

  • 交换机,特别是接口,配置了 QoS 功能。如果保留为默认设置,标准 QoS 设置可能无法提供最佳性能。如果不熟悉 QoS,Cisco 建议您使用 Cisco Catalyst 3750 交换机中的自动 QoS 功能。如果您希望对 QoS 设置进行手动调整,有关详细信息,请参阅配置标准 QoSCisco Catalyst 3750 QoS 配置示例

  • 速度/双工设置 — 如果网络使用自动协商,则不同供应商之间的协商可能无法按预期正常运作。请验证操作速度/双工值,如果它们并非所需值,则建议在连接两端对这些值进行硬编码。有关自动协商的详细信息,请参阅排除 Cisco Catalyst 交换机的 NIC 兼容性问题

%SIGNATURE-3-NOT_ABLE_TO_PROCESS :%ERROR :

在重新启动期间,使用 file verify auto 命令配置 3750/3560 交换机时,将看到此错误消息。默认情况下,no file verify auto 命令处于禁用状态,但如果启用此命令,就会出错。因此,这两个平台的最新映像已删除此命令。

在尝试重新加载时,将会显示另一条错误消息。

 %SIGNATURE-3-NOT_ABLE_TO_PROCESS: %ERROR: Not able to process Signature in flash:.
%SIGNATURE-3-ABORT_OPER: %ERROR: Aborting reload

这些错误消息特定于 3560 和 3750 交换机。Cisco Bug ID CSCsb65707仅限注册用户)记录了此问题。从配置中删除 file verify auto 命令即可解决此问题。删除此命令后,在重新加载路由器时就不会显示错误消息。

内存问题

内存耗尽

使用 Cisco Catalyst 3750 交换机时,由于内存泄漏或分段问题,您可能会收到 %SYS-2-MALLOCFAIL 消息。此消息表明进程无法找到足够大的连续内存块。如本示例所示,IP 输入进程尝试从处理器内存池中获取 1028 个字节:

%SYS-2-MALLOCFAIL: Memory allocation of 1028 bytes failed from 0x601617A4, 
pool Processor, alignment 0 -Process= "IP Input", ipl= 2, pid= 21

导致这些错误消息的可能原因是:

  • 正常内存利用率

  • 内存泄漏

  • 内存分段

通常,MALLOCFAIL 错误是由安全问题(如网络中运行的蠕虫或病毒)造成的。如果最近没有更改网络(如交换机 IOS 升级),则安全问题极有可能是造成错误的原因。通常,一个配置更改(例如添加另外的线路到您的访问控制列表)能减轻此问题的影响。Cisco 安全建议和通知页包含有关检测最可能的原因和特定解决方法的信息。

如果记录到 %SYS-2-MALLOCFAIL 消息,请执行以下步骤:

  1. 使用 show version 命令验证交换机是否具有足够的 DRAM 来支持 Cisco IOS 软件。

    3750-Stk#show version
    Cisco IOS Software, C3750 Software (C3750-IPBASE-M), Version 12.2(25)SEC2, 
      RELEASE SOFTWARE (fc1)
    Copyright (c) 1986-2005 by Cisco Systems, Inc.
    Compiled Wed 31-Aug-05 08:45 by antonino
    
    ROM: Bootstrap program is C3750 boot loader
    BOOTLDR: C3750 Boot Loader (C3750-HBOOT-M) Version 12.2(25r)SEC, 
       RELEASE SOFTWARE (fc4)
    
     SW1-3750 uptime is 6 hours, 32 minutes
    System returned to ROM by power-on
    System image file is "flash:/c3750-ipbase-mz.122-25.SEC2.bin"
    
    cisco WS-C3750G-24T (PowerPC405) processor (revision L0) with 118784K/12280K 
       bytes of memory.
    
    !--- Output suppressed
    
    

    交换机使用 128MB 的 DRAM 运行(118784K/12280K 字节)。遗憾的是,Catalyst 3750 系列交换机不支持 DRAM 升级。要检查 Cisco IOS 软件的最低内存需求,请剪贴并粘贴命令输出解释程序仅限注册用户)工具中 show version 命令的输出。访问分析输出的“Cisco IOS Image Software Advisor - IOS 映像名称”部分提供的链接。

  2. 一些应用程序的某些功能,如 Cisco Works 的用户跟踪 (UT) 搜索功能,可能导致低内存状况,除非发出 ip cef 命令。

  3. 内存分配失败可能是由于内存泄漏 Bug 或内存分段造成的。在此情况下,请使用命令输出解释程序仅限注册用户)工具分析 show memory 命令的输出。

  4. 要确定是否发生了分段,请发出 show memory summary 命令来比较“Largest”和“Free”字段。

    如果“Largest”字段中的数字要远小于“Free”字段中的数字,则表示发生了分段。这是因为“Largest”字段表示最大连续空闲内存块,正常情况下,它应接近于空闲内存,如本示例所示:

    SW1-3750#show memory summary
               Head     Total(b)  Used(b)   Free(b)   Lowest(b) Largest(b)
    Processor  18AA068  95772568  24384312  71388256  68313048  69338560
          I/O  7400000  12574720  9031656   3543064   3499232   3535816
    
    !--- Output suppressed
    
    

    以下是对字段的简要描述:

    • Total 为分配给处理器或 I/O 存储器的内存总量。此值不包括 Cisco IOS 软件占用的内存量。

    • Used 为发出命令时使用的内存量。

    • Free 为发出命令时可用的空闲内存量。

    • Lowest 为自上次重新加载以来的最低可用内存量。

    • Largest 为发出命令时的最大空闲连续内存量。正常情况下,此值接近于空闲内存。如果与空闲内存相比,该值较小,则表示发生了分段。

  5. 要确定是否已发生内存泄漏,可按固定的时间间隔多次捕获 show memory summary 命令的输出。时间间隔取决于显示内存分配失败所需的时间。如果交换机在四天之后开始显示错误,则每天捕获一到两次足以确定错误模式。

    如果空闲内存持续减小,说明可能已发生内存泄漏。

    如果进程占用了内存,但并不将内存返还给系统,此时就会发生内存泄漏。要确定导致问题的进程,请发出 show processes memory 命令,并执行以下步骤:

    1. 要确定不将内存返还给系统的进程,请按固定的时间间隔多次捕获 show processes memory 命令的输出。

    2. 用于此捕获的两个计数器为“Freed”和“Holding”。如果某个进程的“Holding”计数器变大,但“Freed”计数器并未变大,则该进程可能是造成内存泄漏的原因。

    3. 确定进程后,请参阅 Bug 工具包仅限注册用户)搜索任何内存泄漏问题。此问题与影响交换机上当前安装的 Cisco IOS 软件的进程有关。

有关如何解决内存问题的详细信息,请参阅内存问题故障排除

Cisco Network Assistant报告交换机是不可得到的

当访问交换机的网页或通过telnet时, Cisco Network Assistant报告交换机是不可得到的。

作为应急方案,请重新启动交换机为了解决问题。此种问题典型地关联与内存泄漏。为了识别保持内存的进程,请控制到交换机并且分析输出show processes memory sorted命令在时间间隔的3次每5分钟。

在 CEF IPC 后台进程中出现意外内存消耗

堆叠 Catalyst 3750 交换机时,交换机中的 IP 路由被禁用,且堆叠主交换机发生更改,这时 Cisco Express Forwarding (CEF) IPC 后台进程中会发生缓慢而持续的内存泄漏。Cisco Bug ID CSCsc59027仅限注册用户)记录了此问题。

要解决此问题,可以启用 IP 路由,或将交换机软件升级到不受此 Bug 影响的 Cisco IOS 版本。

%Error opening flash: // (Device or resource busy)

升级到 Cisco IOS 软件版本 12.2(25)SED 后,您可能会遇到闪存或 NVRAM 问题,并收到以下错误消息:

%Error opening flash:/ (Device or resource busy)

在这些情况下观察到的症状包括:

  • 如果使用 switch renumber 命令对交换机重新编号,则可能发生意外重新加载。

  • 文件系统无法正常运行,并且显示以下错误消息之一:

    Switch#dir
    Directory of flash:/
    %Error opening flash:/ (Device or resource busy)

    或者

    Switch#copy flash:config.text flash:config.also.text
    Destination filename [config.also.text]? 
    i28f128j3_16x_write_bytes: command sequence error
    flashfs[1]: writing to flash handle 0x2411CD8, device 0, offset 0x520000, 
       length 0x208: Operation Failed
    flashfs[1]: sector ptr: {0x29, 0xA3}
    %Error opening flash:config.also.text (I/O error)

    或者

    Switch(config)#boot system flash:
         /c3750-ipservices-mz.122-25.SEC/c3750-ipservices-mz.122-25.SEC.bin
    i28f128j3_16x_erase_sector: timeout after 593 polling loops, 
         and 0x393AC7D usecs
    bs_open[2]: Unable to erase boot_block 0
    vb:: I/O error

Cisco Bug ID CSCsc41813仅限注册用户)记录了此问题。要解决此问题,可以将交换机软件升级到不受此 Bug 影响的 Cisco IOS 版本。

Debug Exception (Could be NULL pointer dereference)

重新加载运行 Cisco IOS 系统软件的 Catalyst 3750 系列交换机时,日志中记录了 Debug Exception (Could be NULL pointer dereference) 错误消息。

导致此错误消息的可能原因包括:

  • CEF 后台进程出现内存泄漏。有关如何解决此问题的信息,请参阅 CEF IPC 后台进程中的意外内存消耗

  • 用电设备检测。

    如果检测到用电设备或该设备的类别为过载电流类,将会发生此问题。Cisco Bug ID CSCsa72400仅限注册用户)记录了此问题。

    要解决此问题,请勿将 IEEE 802.3af 非标准类用电设备(或者损坏的电缆或环回电缆)连接到交换机,因为交换机可能会错误地检测此类设备。您还可以将交换机软件升级到不受此 Bug 影响的 Cisco IOS 版本。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 77805