IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

在 Cisco 路由器上配置 IP 的 IS-IS

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文目的是在Cisco路由器上展示IP中间系统到中间系统(IS-IS)的基本配置。除配置以外,还介绍了如何监控各种 IS-IS 信息,例如指定中间系统 (DIS) 选择信息和 IS-IS 数据库信息。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息根据Cisco IOS �软件版本12.1(5)T9。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

IS-IS 示例配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

要在 Cisco 路由器上启用 IP 的 IS-IS 并使其与其他启用 IS-IS 的路由器交换路由信息,您必须执行以下两项任务:

  • 启用 IS-IS 进程并指定区域

  • 在接口上启用 Ip 路由的 IS-IS

其他配置任务可选择执行,但上述两项任务必须执行。有关可选配置任务的详细信息,请参阅配置集成的 IS-IS

网络图

本文档使用以下网络设置:

/image/gif/paws/13795/is-is-ip-config.jpg

配置

本文档使用以下配置:

以下示例配置使用这些参数配置上述拓扑中的所有路由器:

  • 区域 49.0001

  • 级别 1 (L1) 和级别 2 (L2) 路由器(除非另外指定,否则这是默认配置)

  • 无可选参数

  • 仅运行 IP 的 IS-IS

  • 环回接口(环回由 IS-IS 通告,而不是由 IS-IS 启用)

路由器 1
!
interface Loopback0
ip address 172.16.1.1 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0
ip address 172.16.12.1 255.255.255.0
ip router isis 


!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
router isis
passive-interface Loopback0
net 49.0001.1720.1600.1001.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

路由器 2
!
interface Loopback0
ip address 172.16.2.2 255.255.255.255

!--- Creates loopback interface and assigns 
!--- IP address to interface Loopback0.

!
Interface Ethernet0
ip address 172.16.12.2 255.255.255.0
ip router isis

!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
Interface Serial0
ip address 172.16.23.1 255.255.255.252
ip router isis

!--- Assigns IP address to interface Serial0 
!--- and enables IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1720.1600.2002.00
!

!--- Enables the IS-IS process on the router,
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router. 

路由器 3
!
interface Loopback0
ip address 172.16.3.3 255.255.255.255 

!--- Creates loopback interface 
!--- and assigns IP address to 
!--- interface Loopback0.

!
Interface Serial0
ip address 172.16.23.2 255.255.255.252
ip router Isis

!--- Assigns IP address to 
!--- interface Serial0 and enables 
!--- IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1234.1600.2231.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

监控 IS-IS

有许多show命令,可用于监控Cisco路由器上的IS-IS状态。本文档基于上述路由器配置介绍了一些更基本的命令。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

监控 IS-IS 邻接

使用 show clns neighbor 命令显示某个特定路由器的邻接。这是此命令在路由器 1 (R1) 和路由器 2 (R2) 上的输出:

R1# show clns neighbor
System Id   Interface  SNPA            State  Holdtime  Type Protocol
R2          Et0        0000.0c47.b947  Up     24        L1L2 ISIS
    
R2# show clns neighbor
System Id  Interface  SNPA             State  Holdtime  Type Protocol
R1         Et0        0000.0c09.9fea   Up     24        L1L2 ISIS
R3         Se0        *HDLC*           Up     28        L1L2 ISIS

在上述示例中,R1可以识别在其E0接口上的R2,以及邻接类型L1L2。由于R1和R2用默认配置配置,它们发送和接收L1和L2的hello。

R2在其E0接口上认识R1,并在S0接口上认识路由器3 (R3) 。邻接类型具有与上述内容相同的说明。

因为R1和R2是在同一个以太网接口,所以DIS用于第一层和第二层。在路由器1上使用show clns interface < int >命令,您可以验证它,如下所示:

R1# show clns interface ethernet 0
Ethernet0 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  Routing Protocol: ISIS
    Circuit Type: level-1-2
    Interface number 0x0, local circuit ID 0x1
    Level-1 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-1 adjacencies: 1
    Level-2 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-2 adjacencies: 1
    Next ISIS LAN Level-1 Hello in 5 seconds
    Next ISIS LAN Level-2 Hello in 1 seconds

在上述输出中,R2 为 DIS。它是生成伪节点链路状态信息包的R2 (DIS) (LSP) 并可表示为非零LSP-ID - R2.01

由于Metric/Priority对于第一层/第二层的两个路由器是相同的,所以DIS是在LAN分段上的最高子网连接点(SNPA)地址。SNPA 地址是指数据链路地址,在本例中,它是指 MAC 地址。数据链路地址的其他实例为 X.25 地址和帧中继 DLCI。

注意为两个级别选择DIS,并且不存在备份DIS,如同带有备份指定路由(DR)的开放式最短路径优先(OSPF)。

上述输出的一些其他兴趣点包括:

  • 电路类型:L1L2

  • L1 和 L2 的量度和优先级均为默认值:10 和 64

  • L1 和 L2 邻接:1(在以太网接口上从 R1 的角度来看 - 它仅为 R2)

  • L1 和 L2 的 IS-IS LAN hello

  • 最大传输单元 (MTU):1497.这是因为开放系统互联 (OSI) IS-IS头封装在一个3字节的802.2头里。

监控 IS-IS 数据库

show isis database (detail) 命令显示 IS-IS 数据库的内容。在 R2 上发出此命令时,这是此命令的输出。因为IS-IS是一条链路状态协议,链路状态数据库应该与同一个区域的任何路由器相同。

R2# show isis database
ISIS Level-1 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x0000008B   0x6843        55              0/0/0
R2.00-00    * 0x00000083   0x276E        77              0/0/0
R2.01-00    * 0x00000004   0x34E1        57              0/0/0
R3.00-00      0x00000086   0xF30E        84              0/0/0
ISIS Level-2 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x00000092   0x34B2        41              0/0/0
R2.00-00    * 0x0000008A   0x7A59        115             0/0/0
R2.01-00    * 0x00000004   0xC3DA        50              0/0/0
R3.00-00      0x0000008F   0x0766        112             0/0/0

对于上述输出,要注意以下几点。首先,关于 LSP-ID:

LSP-ID R1.00-00 可分为三个部分:R1/00/00

  • R1 = 系统 ID

  • 00 = 伪节点的非零值。请注意,R2.01-00 即为伪节点 LSP。

  • 00 = 分段号。在本例中,仅存在 00 分段号,这表示所有数据均适合此 LSP 分段,且无需创建更多分段。如果没有适合到第一个LSP的信息,IS-IS将创建更多LSP分段,例如01、02等。

*表示由此路由器生成的LSP打开了,此路由器发出了show命令。并且,因为此路由器是L1和L2路由器,所以它包含一个L1和L2数据库。

您还可以查看特定 LSP,并使用 detail 关键字显示详细信息。相应示例如下:

R2# show isis database R2.00-00 detail
ISIS Level-1 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x00000093   0x077E        71            0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2 
  Metric: 10         IP 172.16.12.0 255.255.255.0
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
ISIS Level-2 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x0000009A   0x5A69        103           0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IP 172.16.1.1 255.255.255.255
  Metric: 10         IP 172.16.3.3 255.255.255.255
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.12.0 255.255.255.0

上述输出显示此路由器的回环地址用“0”这个值来通告。这是因为回环在路由器IS-IS过程中用passive-interface命令通告,并且回环接口本身不支持IS-IS。其它IP前缀有值为10,它是运行IS-IS的接口的默认值。

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 13795