拨号和接入 : 异步连接

通过 AUX 端口背对背连接路由器

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

此示例配置向您说明如何在不使用调制解调器或其他数据通信设备 (DCE) 的情况下,直接连接两个路由器。有关如何在辅助 (AUX) 或控制台端口上配置调制解调器的更多信息,请参阅调制解调器与路由器连接指南接入拨号技术支持

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

在此配置中,两个 Cisco 路由器借助于无调制解调器电缆(全反电缆)通过异步 AUX 端口进行背对背连接。这两个路由器的 AUX 端口借助于全反电缆直接进行连接,链路中运行点对点协议 (PPP)。AUX 端口是数据终端设备 (DTE)。您将需要一条无调制解调器电缆(全反电缆),用于将 DTE 连接到 DTE 设备。

扁平全反(无调制解调器)电缆(部件号 CAB-500RJ=)通常随每个 Cisco 路由器一起提供,以便进行 RJ-45 控制台连接。如果 AUX 端口为 DB-25,请使用带有无调制解调器电缆(全反电缆)且标有“终端”的 RJ-45-to-DB-25 适配器。

注意: 由于 EIA/TIA-232(以前称为 RS-232)的限制,需确保电缆长度小于 50 英尺。

有关布线的更多信息,请参阅 RJ-45 控制台和 AUX 端口的布线指南以及 RJ-45 电缆。

具有 DB-25 AUX 端口的路由器

对于带有 DB-25 AUX 端口的路由器(例如:Cisco 4500、7200 及 7500),您需要 DB-25-to-DB-25 无调制解调器电缆。该电缆在大多数电子产品零售商场均有售。

注意: 由于存在错误信号对,因此您不能使用两端带有 RJ-45-to-DB-25 适配器(部件号 CAB-25AS-MMOD)的反转 RJ-45-to-RJ-45 扁平电缆。

验证您的 DB-25-to-DB-25 无调制解调器电缆是否具有表 1 中所示的引脚连接。

表 1 - DB-25-to-DB-25 无调制解调器电缆引脚连接

DB-25 DB-25
Rxd 2 3 TXD
TxD 3 2 Rxd
CTS 4 5 RTS
RTS 5 4 CTS
DTR 6 20 CD
DSR 8
CD 20 6 DTR
8 DSR
GND 7 7 GND

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/10365/auxback.gif

配置

本文档使用以下配置:

  • 路由器 1

  • 路由器 2

注意: 此连接配置有位于 AUX 端口的 IP 地址,用于永久性(“固定”)连接。

路由器 1
version 11.1
 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router1
 !
 interface Ethernet0
  no ip address
  shutdown
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX port.

  ip address 192.168.10.1 255.255.255.0

 !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

 !--- Set PPP as the encapsulation.

  async default routing 

 !--- This allows routing protocols on the link. 

  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Async1

 !--- The default route points to the Async1 (AUX port) interface.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

  !--- This allows all protocols to use the line.

  rxspeed 38400

  !--- Set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

  !--- Set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

路由器 2
version 11.1

 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router2
 !
 interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX Port.

  ip address 192.168.10.2 255.255.255.0

  !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

  !--- Set PPP as encapsulation.

  async default routing 
  
!--- This allows routing protocols on the link.
 
  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Ethernet0
 
!--- This default route points to interface Ethernet0.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

 !--- This allows all protocols to use the line.

  rxspeed 38400

 !--- set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

 !--- set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

验证

当前没有可用于此配置的验证过程。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除步骤

在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

完成这些步骤:

  1. 使用 show line 命令确定 AUX 端口的异步接口。

    虽然大多数路由器将 AUX 端口作为 interface async 1,但接入服务器却将 AUX 端口接口置于 tty 线路之后。例如,如果您的路由器有 16 条异步/调制解调器线路,则 AUX 端口是第 17 条线路。在这种情况下,必须在 interface async 17 上配置 AUX 端口。根据 show line 输出配置 AUX 端口。以下示例用来验证 AUX 端口配置是否位于路由器的 interface Async 1 上:

    Router1#show line
     Tty Typ     Tx/Rx    A Modem Roty AccO AccI Uses  Noise  Overruns
    *  0 CTY              -    -     -    -    -    0      0       0/0
    A  1 AUX  38400/38400 - inout    -    -    -    0      0       0/0
       2 VTY              -    -     -    -    -    0      0       0/0
       3 VTY              -    -     -    -    -    0      0       0/0
       4 VTY              -    -     -    -    -    0      0       0/0
       5 VTY              -    -     -    -    -    0      0       0/0
       6 VTY              -    -     -    -    -    0      0       0/0
  2. 发出 show line aux 0 命令。

  3. 验证所有信号是否均已启用(例如:清除发送 (CTS)、请求发送 (RTS)、数据终端就绪 (DTR) 和载波检测 (CD))。

    如果这些信号旁未出现任何信息,则表示它们处于启用状态。如果这些信号旁边显示“No”(如 No-CTS),则表示它们处于关闭状态。如果它们处于关闭状态,请验证两端的配置。验证您是否已经对异步接口和 AUX 端口的线路进行了配置(如上所述)。

    注意: 如果 show line 命令输出表明 DSR 未启用 (noDSR),您必须验证 DB-25-to-DB-25 无调制解调器电缆每一端的引脚 6 和引脚 8 是否已经物理连接到另一端的引脚 20。有关正确引脚布局的信息,请参阅表 1

    Router1#show line aux 0
     Tty Typ    Tx/Rx     A Modem Roty AccO AccI Uses  Noise  Overruns
    A  1 AUX 38400/38400  - inout    -    -    -    0      0       0/0
    
    Line 1, Location: "", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 38400/38400, no parity, 2 stopbits, 8 databits
    Status: Ready, Active, Async Interface Active
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
      Modem Callout, Modem RI is CD, Line is permanent async interface
    Modem state: Ready
    Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                    ^^x    none   -     -       none         
    Timeouts:  Idle EXEC  Idle Session  Modem Answer  Session  Dispatch
               00:10:00      never                       none   not set
    Modem type is unknown.
    Session limit is not set.
    Time since activation: 00:00:30
    Editing is enabled.
    History is enabled, history size is 10.
    Full user help is disabled
    Allowed transports are pad v120 telnet.  Preferred is telnet.
    No output characters are padded
    No special data dispatching characters
    Line is running PPP for address 192.168.10.2.
    0 output packets queued, 1 input packets.
     Async Escape map is 00000000000000000101000000000000
    Modem hardware state: CTS* DSR*  DTR RTS 
    
  4. 如果配置显示正确,请替换在路由器之间的全反电缆。

  5. 请在异步接口上使用 shutdownno shutdown 命令重置连接。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

使用这些 debug 命令以验证链路是否正确启动。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug ppp negotiation — 在链路控制协议 (LCP)、身份验证和网络控制协议 (NCP) 的协商过程中,显示 PPP 数据流和交换信息。成功的PPP协商将首先开放LCP状态,然后进行验证,最后进行NCP协商。如果已发出 CONFREQ,但没有接收到 CONFACK,请检查布线是否正确以及配置线路是否正确(针对其发出 interface async x 命令)。

  • debug ppp authentication — 显示 PPP 身份验证协议消息(如果已配置身份验证),并且包括质询握手身份验证协议 (CHAP) 分组交换以及口令身份验证协议 (PAP) 交换。在此配置中,未配置身份验证。所以,不必采用此 debug 命令。

  • debug ppp error -显示与PPP连接协商和操作相关的协议错误和错误统计数据。


相关信息


Document ID: 10365