IP : 边界网关协议(BGP)

删除 BGP 专用 AS 编号示例配置

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档显示了从传出 eBGP 更新中删除专用自治系统 (AS) 编号的示例配置。AS 编号分为两类:专用编号和公用编号。与专用和公用 IP 地址类似,您不能将专用 AS 编号泄露给 internet。公用 AS 编号范围是 1 至 64511,而专用 AS 编号范围是 64512 至 65535。您可使用专用 AS 编号将较大的 AS 分为通过 eBGP 连接的多个小 AS。此外,如果连接至单个 ISP,则 ISP 可分配专用 AS 编号以保存公用 AS 编号。但是,在您将更新发送至全局 BGP 网格 (Internet) 之前,您必须删除这些专用 AS 编号。

注意: 如果连接至多个 ISP,则不推荐分配专用 AS 编号。如果客户网络连接至单个 ISP(单链路或双链路),则可使用专用 AS 编号。

有关专用 AS 编号的详细信息,请参阅删除 BGP 中的专用自治系统编号

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息适用于以下软件和硬件版本:

  • Cisco IOS 软件版本12.2(27)

  • Cisco 2501 和 Cisco 2503 路由器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用的网络设置:路由器 3 使用专用 AS 编号 65000,路由器 1 和路由器 2 分别使用公用 AS 编号 AS 1 和 AS 5。

路由器 2 位于具有路由器 1(运行 AS 1)和路由器 3(运行 AS 65000)作为客户端的服务提供商云中。

/image/gif/paws/13758/36-1.gif

发送和接收更新

此过程说明了路由器 3 通告某个网络(本例中为 10.0.0.0/24)时发生的事件顺序。

  1. 路由器 3 将 AS 路径属性为 65000 的网络 10.0.0.0/24 通告至路由器 2。

  2. 路由器 2 接收来自路由器 3 的更新,并为网络 10.0.0.0 /24 在其路由表中创建一个条目,下一跳为 172.16.0.1(路由器 3 上的串行接口 S0)。

  3. 当使用 neighbor 192.168.0.2 remove-private-AS 命令进行配置时,路由器 2(服务提供商设备)会删除专用 AS 编号并构建一个新的更新数据包,将其自己的 AS 编号作为 10.0.0.0/24 网络的 AS 路径属性,并发送相同内容至 AS1 中的路由器 1。

  4. 路由器 1 接收来自网络 10.0.0.0/24 的 eBGP 更新,并在其路由表中创建一个条目,下一跳为 192.168.0.1(路由器 2 上的串行接口 S1)。如路由器 1 上所示,此网络的 AS 路径属性为 AS 5(路由器 2)。因此,将阻止专用 AS 编号进入 Internet 的 BGP 表。

配置

本文档使用以下配置:

路由器 3
Current configuration :
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
!
interface Serial0
 ip address 172.16.0.1 255.255.255.0
!
router bgp 65000
 network 10.0.0.0 mask 255.255.255.0
 neighbor 172.16.0.2 remote-as 5

!--- Configures Router 2 as an eBGP neighbor in public AS 5. 

!
end

路由器 2
Current configuration :
!
!
interface Ethernet0
 ip address 172.30.1.1 255.255.0.0
!
interface Serial0
 ip address 172.16.0.2 255.255.255.0
!
interface Serial1
 ip address 192.168.0.1 255.255.255.0
!
router bgp 5
 network 172.30.0.0
 network 192.168.0.0
 neighbor 172.16.0.1 remote-as 65000

!--- Configures Router 3 as an eBGP neighbor in private AS 65000.

 neighbor 192.168.0.2 remote-as 1

!--- Configures Router 1 as an eBGP neighbor in public AS 1. 

 neighbor 192.168.0.2 remove-private-AS

!--- Removes the private AS numbers from outgoing eBGP updates.

!
!
end

路由器 1
Current configuration :
!
version 12.2
!
!
interface Serial0
 ip address 192.168.0.2 255.255.255.0
 !
router bgp 1
 neighbor 192.168.0.1 remote-as 5

!--- Configures Router 2 as an eBGP neighbor in public AS 5.

!
end

自治系统 DOT 格式

本示例介绍如何将大于 65535 的 AS 编号转换为 4 字节自治系统(ASDOT 格式)。

在 ASDOT 配置之前

Router#show run | beg router 
router bgp 131280
no synchronization 
bgp log-neighbor-changes 
no auto-summary 

ASDOT 配置

Router(config-router)#bgp asnotation dot 
Router(config-router)#end 

配置之后

Router#show run | beg router bgp 
router bgp 2.208  <== 
no synchronization 
bgp asnotation dot 
bgp log-neighbor-changes 
no auto-summary ! 

验证

本部分提供的信息可用于确认您的配置是否工作正常。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

在路由器 1 上使用 debug ip bgp updates 命令获得的调试消息显示,从路由器 2 (192.68.0.1) 接收的网络 10.0.0.0/24 更新具有 AS 路径属性 5,这就是路由器 2 的 AS 编号。路由器 2 和路由器 1 上的 show ip bgp 命令说明相同的内容。

Router1#
1w1d: %BGP-5-ADJCHANGE: neighbor 192.168.0.1 Up
1w1d: BGP(0): 192.168.0.1 computing updates, afi 0, 
       neighbor version 0, table version 1, starting at 0.0.0.0
1w1d: BGP(0): 192.168.0.1 update run completed, afi 0, 
       ran for 0ms, neighbor version 0, start version 1, throttled to 1
1w1d: BGP: 192.168.0.1 initial update completed
1w1d: BGP(0): 192.168.0.1 rcvd UPDATE w/ attr: nexthop 
       192.168.0.1, origin i, path 5
1w1d: BGP(0): 192.168.0.1 rcvd 10.0.0.0/24
1w1d: BGP(0): Revise route installing 10.0.0.0/24 -> 192.168.0.1 
      to main IP table
1w1d: BGP(0): 192.168.0.1 computing updates, afi 0, neighbor 
      version 1, table version 2, starting at 0.0.0.0
1w1d: BGP(0): 192.168.0.1 update run completed, afi 0, ran for 0ms,
      neighbor version 1, start version 2, throttled to 2

Router2#show ip bgp
BGP table version is 3, local router ID is 192.168.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
    Network         Next Hop      Metric  LocPrf Weight   Path
 *> 10.0.0.0/24     172.16.0.2         0              0   65000 i
 *> 172.30.0.0      0.0.0.0            0         32768    i
 

Router1#show ip bgp
BGP table version is 19, local router ID is 192.168.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
    Network          Next Hop      Metric  LocPrf  Weight  Path
 *> 10.0.0.0/24      192.168.0.1                        0  5 i
 *> 172.30.0.0       192.168.0.1        0               0  5 i

路由器 2 的 BGP 表显示网络 10.0.0.0 源自 AS 65000。路由器 1 的 BGP 表显示相同网络源自 AS 5。这是由路由器 2 上的 neighbor 192.168.0.2 remove-private-as 命令导致的,该命令会删除专用 AS 编号并阻止其到达 Internet。因此,AS 1(路由器 1)具有一致的 AS 5 视图,作为网络 10.0.0.0/24 的源。

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 13758