语音 : H.323

如何针对 Polycom 视频设备配置 IP 视频

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文讨论了带Cisco路由器的Polycom ViewStation128 (视频会议设备)的基本的网络安装和配置情况,用于IP视频应用。它也包括在整个LAN和WAN媒体中添加QoS和排除实时视频质量的故障。

Polycom ViewStation 连接到用于显示捕获的视频和音频的 TV;它也有到LAN的连接,在IP上传输压缩视频数据包。与所有其他网关一样,Polycom 是 H323 终点。Video over IP 使用以下协议:

  • H.225 用于呼叫控制信号的消息传递

  • H.245 用于打开和关闭媒体流通道

  • H.263 和 H.261 用于具有图片格式的视频编解码器

  • G.723 用于 5.3kpbs 或 6.3kpbs 模式的音频编解码器

用于Polycom ViewStation128的软件应该是最近的,并且能够在LAN上从Polycom网站下载。在本文档发布时,可用的最新固件是 7.0.1。http://www.polycom.com/home/leavingcisco.com

ViewStation可以在128k、256k 、384k、512k、576k或768k等速率发送经过压缩的视频和音频呼叫。此压缩率不包括添加的IP和LAN/WAN 头,因此在QoS中预留带宽时,切记应将该开销计算在内。例如,音频 (64kbps)+ 视频 (704kbps)+IP(25% 的开销)=960kbps。

视频应用程序的最佳延迟与语音类似:125-150msec 的往返时间可获得最佳结果。增加的时延是可以忍受的,但您远程登录时,Polycom将其报告为错误。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

下面的设置在实验室测试了用Cisco IOSï ¿ Â在Cisco 7200路由器的½软件版本12.1(5)T和12.2(1a)。Polycom ViewStation 128 的固件版本为 7.0.1。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

网络图

本文档使用下图所示的网络设置。Polycom 以 10Mbps 的速度采用半双工模式进行硬编码。本例的2900XL包括硬性编码为auto/auto的所有端口,因此无需在Cisco 7200 FE (快速以太网接口)上进行更改。它应设置为100/Full。如果在某些情况下,Polycoms直接附到路由器或Catalyst交换机上,则必须相应地配置与双工/速度匹配的端口。

/image/gif/paws/6172/polycom_video_over_ip1.gif

Polycom ViewStation 配置和设置

为 ViewStation 配置 H.323 呼叫

System Info > Admin Setup 下,执行以下步骤:

  1. 在 LAN/H.323 和 LAN/Intranet 下,配置 Polycom 的 IP 地址和默认网关。

  2. 如有需要,请在LAN/H.323和H323下配置ViewStation和任何E164 ID的H323名称。

  3. (可选)在LAN/H.323和H323中,QoS可为UDP或TCP端口特别指定。对于视频流量而言,固定的TCP端口范围是3230-3231,固定的UDP端口是3230-3235。还可以在此处针对数据包将 IP 优先级设置为至关重要。

  4. 在 General Setup 下,配置标准选项,如系统名称、自动应答、自动拨号、语言。

从 ViewStation 进行 H.323 呼叫

此处的所有呼叫都使用远程 IP 地址发出;如果使用关守发出视频呼叫,您也可以使用E.164编号。在主屏幕之下,为远程polycom键入IP地址,然后选择压缩速度;这应该与在远程站点上设置为默认值的速度匹配。

针对视频配置 QoS 的路由器

在WAN上为VideoOverIP 使用的最有效的一个QoS方法是低延迟队列(LLQ)。策略映射可以基于多个不同的参数,相关内容在下面讨论。必要的带宽可以是专用的,而其他IP应用程序的视频可以使用LLQ进行优先排列。另外,ATM 链接应为 VBR-NRT 或 CBR 才能获得较高的视频质量。

7206VXR 的配置

Cisco 7206VXR
!
class-map match-all video
  match access-group 101

!--- Class map used to associate access-list 101 to the LLQ class video.

!
policy-map video-police

!--- Definition of the policy map for the LLQ Configuration
 
  class video
    priority 900

!--- This is the priority class/queue assigned for video traffic.
!--- It reserves 900 Kbps for video traffic
  
  class class-default
   fair-queue 64

!-- All other non-video traffic uses fair-queuing policing.
 
!
interface FastEthernet0/0
 description Polycom-192.168.3.90
 ip address 192.168.3.100 255.255.255.0
 duplex half
 no cdp enable

!--- This is the LAN interface that connects to the Polycom ViewStation
!--- No QoS (LLQ) was applied here.
 

!
interface ATM6/0
 no ip address
 load-interval 30
 no atm ilmi-keepalive
!
interface ATM6/0.1 point-to-point
 ip address 10.1.105.1 255.255.255.0
 pvc 1/138

!--- atm pvc defined 

  class-vc VBR-NRT
  encapsulation aal5snap

!--- Layer 2 encapsulation type for atm packets

  service-policy out video-police

!--- Applies LLQ (defined above) to the subinterface for 
!--- layer 3 (Video over IP)traffic shaping and priotization

!
vc-class atm VBR-NRT

!--- atm traffic shaping class defined

  vbr-nrt 1500 1400 100

!--- Maximum bandwidth at 1500Kbps and nominal at 1400Kbps with 100Kbps burst

!
access-list 101 permit tcp any any range 3230 3231
access-list 101 permit udp any any range 3230 3235

!--- These access-lists are used by the LLQ class-map.
!--- These access-lists are based on the fixed UDP (3230-3235) 
!--- and TCP (3230-3231) ports for the ViewStation VideoOverIP


或者,可以使用以下访问列表配置。

  • 基于 ViewStation 单元的源/目标 IP 地址:

    access-list 101 permit ip host 192.168.3.90 host 192.168.1.90

    access-list 101 permit ip host 192.168.1.90 host 192.168.3.90

  • 基于 IP precedence 5:

    access-list 101 permit ip any any precedence 5

验证

当前没有可用于此配置的验证过程。

故障排除

建立呼叫后,Polycom 会跟踪所有视频数据包。您可以通过 Telnet 连接到 Polycom 并监视此特写。Polycom 报告 H323 数据包中的延迟,以及丢失的视频或音频数据包。有可能很难在视频屏幕上发现Polycom 调试,但它们可以阅读,并且能显示问题。

某些最普通的视频问题(例如冻结)源自以太网双工和/或速度不匹配。如果以太网计数器显示大量CRC/帧/延迟信息包,视频质量将显著降低,因此第一个检查点是确定所有LAN接口都运行无误。

本部分提供的信息可用于对配置进行故障排除。

您可以根据初始信息显示在 Polycom 上检查配置。存在针对每个操作启用的信息性调试。当您有视频呼叫时,Polycoms将自动报告计算出的信息包延迟:任何丢失的数据包,以及因丢失的数据包而重新排列的数据包。

MS-7206VXR-12A#telnet 192.168.3.90

!--- Action: Telnetting to the Polycom ViewStation unit to capture information 
!--- and debug output. 
!--- When a call is established, the Polycom unit keeps track of video packets. 
!--- The Polycom reports h323 packet latency and lost video and voice packets.


Trying 10.122.3.90 ... Open

Hi, my name is :     Polycom166-regnl
Here is what I know about myself:
Serial Number:       011B12
Brand:               Polycom
Software Version:    Release 7.0.1 - 16 Jun 2001
Model:               VS
Network Interface:   ISDN_UNKNOWN
MP Enabled:          No
H323 Enabled:        Yes
IP Address:          192.168.3.90
Time In Last Call:   0:08:41
Total Time In Calls: 44:20:06
Total Calls:         171
Switch Type:         Nortel DMS-100
Country Code:        1
Area Code:           919
ISDN 1 a is:         9913293
ISDN 2 a is:         9913294

在应用QoS之前,如果同时运行视频和数据,那么polycom上的远程登录结果将报告如下:这是网络问题的一个清楚的迹象,也应该反应在视频质量上。

RTP: Video Packet Lost
RTP: Reseting last_seq_num from 23397 to 23398
RTP: Send FastVideoPicture_MSG
RTP: last eBit 6 plus new sBit 0 not equal 8! (instance 0)
...VideoFastUpdatePictureHandler() time 469850
RTP: Max. video packets stored = 4
RTP: Minimum/MaximumThreshold = 4 0/256, 4 0/256
UI:UI msg from VidDec: S VD1 ReceivedFreezeRelease 0
Received a Picture Fast Update request from the other side
Audio Packet(s) lost - last_seq_num = 15147, new_seq_num = 15149
Transfer 1 duplicate packets
Received a Picture Fast Update request from the other side
RTP: Max. video packets stored = 1
RTP: Minimum/MaximumThreshold = 4 0/256, 4 255/256

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

在Cisco IOS路由器LLQ中获得的以下输出应用于ATM接口,在视频呼叫期间,发送溢出的ping制造拥塞。存在带宽争用时,LLQ 动态指定视频数据流的优先级。

MS-7206VXR-12A#show queue atm 6/0.1

  Interface ATM6/0.1 VC 1/138 
  Queuing strategy: weighted fair
  Total output drops per VC: 22863
  Output queue: 66/512/64/22863 (size/max total/threshold/drops)
     Conversations  3/4/64 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 0 kilobits/sec

  (depth/weight/total drops/no-buffer drops/interleaves) 1/4626/0/0/0
  Conversation 1, linktype: ip, length: 54
  source: 10.122.3.100, destination: 10.1.105.2, id: 0x002B, ttl: 255,
  TOS: 192 prot: 6, source port 23, destination port 11032

  (depth/weight/total drops/no-buffer drops/interleaves) 1/5397/0/0/0
  Conversation 51, linktype: ip, length: 308
  source: 10.122.3.90, destination: 10.122.1.90, id: 0x51AB, ttl: 59,
  TOS: 160 prot: 17, source port 49206, destination port 3232

以下输出通告没有信息包丢弃在视频组。

MS-7206VXR-12A#show policy-map int atm 6/0.1
 ATM6/0.1: VC 1/138 -

  Service-policy output: video-police

    Class-map: video (match-all)
      0 packets, 0 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: access-group 101
      Weighted Fair Queueing
        Strict Priority
        Output Queue: Conversation 72 
       Bandwidth 900 (kbps) Burst 22500 (Bytes)
        (pkts matched/bytes matched) 0/0
        (total drops/bytes drops) 0/0

    Class-map: class-default (match-any)
      290307 packets, 252480609 bytes
      30 second offered rate 2951000 bps, drop rate 2341000 bps
      Match: any 
      Weighted Fair Queuing
        Flow Based Fair Queuing
        Maximum Number of Hashed Queues 64 
        (total queued/total drops/no-buffer drops) 67/35584/0

相关信息


Document ID: 6172