IP : IP 可被路由的协议

Catalyst 3550系列交换机的策略路由配置示例

2016 年 10 月 25 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 10 月 6 日) | 反馈


目录


简介

本文档提供 Catalyst 3550 系列交换机上策略路由的示例配置。Catalyst 3550 系列交换机具有基于硬件的转发,所以在三重内容寻址存储器 (TCAM) 中对转发信息进行编程。为了使 TCAM 支持基于策略的路由 (PBR),应该通过更改交换机数据库管理 (SDM) 模板来设置其格式。必须修改 SDM 模板,以便它支持 144 位第 3 层 TCAM。有关 SDM 的详细信息,请参阅了解并配置 Catalyst 3550 系列交换机上的交换数据库管理器

注意: Catalyst 3550 限制可以使用的 route-map 命令。

先决条件

要求

尝试此配置之前请确保您了解以下方面:

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IOSï ¿  ½软件版本12.1.19-EA1a

  • Cisco Catalyst 3550

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

启用策略路由前,必须在全局配置模式下配置以下命令之一,然后必须写入此配置并重新加载交换机:

  • sdm prefer extended-match

  • sdm prefer access extended-match

  • sdm prefer routing extended-match

CAT3550(config)# access-list 10 permit 20.20.20.0 0.0.0.255
CAT3550(config)# route-map pbr permit 10
CAT3550(config-route-map)# match ip address 10
CAT3550(config-route-map)# set ip next-hop 12.12.12.12

CAT3550(config)# int vlan 3
CAT3550(config-if)# ip policy route-map pbr
CAT3550(config-if)#
06:12:31: %L3TCAM-3-SIZE_CONFLICT: PBR requires enabling extended routing

CAT3550# show run int vlan 3
Building configuration...

Current configuration : 60 bytes
!
interface Vlan3
ip address 55.55.55.1 255.255.255.0

!--- Command not taken - you need to enable SDM.

end

CAT3550# conf t
Enter configuration commands, one per line. End with CNTL/Z.
CAT3550(config)# sdm prefer extended-match
Changes to the running SDM preferences have been stored, but cannot take effect 
until the next reload.
Use 'show sdm prefer' to see what SDM preference is currently active.
CAT3550(config)# end

CAT3550# write
06:14:11: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
[OK] 

ltd-1-2# reload
Proceed with reload? [confirm]

您应该了解不支持的命令 — 如果以下配置存在,请参阅不支持的路由映射命令

!
access-list 10 permit 20.20.20.0 0.0.0.255
route-map pbr permit 10
match ip address 10
set ip default next-hop 12.12.12.12
!

如果尝试在接口上配置策略路由映射,则会生成错误消息:

CAT3550(config)# int vlan 3
CAT3550(config-if)# ip policy route-map pbr
CAT3550(config-if)# end
CAT3550#
00:02:29: %PBR-3-UNSUPPORTED_RMAP: Route-map pbr not supported for Policy-Based Routing

网络图

本文档使用以下网络设置:

/image/gif/paws/47900/cat3550pbr-1.gif

配置

本文档使用以下配置:

此配置从 20.20.20.X(访问列表 10)获取数据流源并将它发送到 30.30.30.2 — 配置覆盖设置为 10.10.10.2 的默认网关。

CAT3550 (Cisco Catalyst 3550)
CAT3550# show running-config 
Building configuration...
.
.
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan2
 ip address 20.20.20.1 255.255.255.0
 ip policy route-map pbr
!
interface Vlan3
 ip address 30.30.30.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.10.10.2
ip classless
ip http server
!
!
access-list 10 permit 20.20.20.0 0.0.0.255
route-map pbr permit 10
 match ip address 10
 set ip next-hop 30.30.30.2
!
.
!
end

使用 set ip next-hop 命令时,在输出中不显示匹配的数据流,这是交换机的预期行为。这是因为交换机仅基于硬件运行,show 命令仅提供在软件中处理的信息。set ip next-hop 始终基于硬件运行,因为交换机从不检查路由表和进程。它接收数据包,并且如果进入 route-map 语句,则数据包直接发送到指定的下一跳,无需检查路由表。

set ip default next-hop 命令首先检查整个路由表以查看是否有指向目标的其他路由。如果没有找到路由,则使用默认下一跳。

验证

当前没有可用于此配置的验证过程。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug ip policy — 显示“策略路由”或“策略拒绝”的数据包。debug ip policy 命令输出的示例如下:

  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.607: IP: route map pbr, item 10, permit
  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
  *Dec 5 13:33:23.607: IP: Vlan2 to Vlan3 30.30.30.1
  *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.707: IP: route map pbr, item 10, permit
  *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
  *Dec 5 13:33:23.707: IP: Vlan2 to Vlan3 30.30.30.1
  *Dec 5 13:33:23.847: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.847: IP: route map pbr, item 10, permit

相关信息


Document ID: 47900