IP : IP 可被路由的协议

具有多个跟踪选项功能策略路由的配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档提供了具有多路跟踪选项功能的基于策略的路由的示例配置。此功能在Cisco IOS 软件版本12.3(4)T介绍。有关详细信息,请参阅对多路跟踪选项的 PBR 支持。

此功能扩展了目标跟踪功能,以在将数据流转发到下一跳之前验证下一跳的 IP 地址。验证方法可以是 Internet 控制消息协议 (ICMP) ping、用户数据报协议 (UDP) ping 或者超文本传输协议 (HTTP) GET 请求。ICMP 是用于 Internet 的最常见验证方法。多路跟踪选项功能最适合将多个以太网连接作为下一跳的路由器。通常,以太网接口连接到数字用户线 (DSL) 或电缆调制解调器。当前,没有任何方法可以检测 ISP 宽带网络中的故障上游 — 以太网接口仍处于打开状态并且任何形式的静态路由都指向该接口。此功能的好处是允许您备份两个以太网接口,通过发送 ICMP ping 验证可访问性来选择可用接口,然后将数据流路由出该接口。

先决条件

要求

在尝试进行此配置之前,请确保满足以下要求:

  • 如果尚未将企业基本 IOS 功能集加载到您的路由器,请执行此操作。如果已为此功能集付费,则可以从下载软件区下载它(仅限注册客户)。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

此部分存在信息配置在本文描述的功能中。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用此网络设置。在此方案中,R1 连接到两个不同的 ISP(ISP-1 和 ISP-2)。R1 跟踪两个 ISP 路由器的可访问性。

/image/gif/paws/48003/pbrtracking_01.gif

配置

本文档使用以下配置:

R1
R1# show running-config 
Building configuration...

Current configuration : 1203 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
clock timezone EST 0
no aaa new-model
ip subnet-zero
no ip domain lookup
!
!
!
!
track 123 rtr 1 reachability

!--- Track Router 1's reachability.

!         
track 124 rtr 2 reachability

!--- Track Router 2's reachability.

!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet2/0
 ip address 10.10.10.1 255.255.255.0
 ip policy route-map alpha

!--- Enable policy routing on the outgoing interface.

!
ip classless
no ip http server
!
!
!
!
route-map alpha permit 10

!--- Define a route-map to set the next hop depending on 
!--- the state of the tracked routers.

 set ip next-hop verify-availability 192.168.0.10 10 track 123
 set ip next-hop verify-availability 192.168.1.20 20 track 124
!
!
control-plane
!
rtr 1

!--- Define and start Router 1.

 type echo protocol ipIcmpEcho 192.168.0.10
rtr schedule 1 life forever start-time now
rtr 2

!--- Define and start Router 2.


 type echo protocol ipIcmpEcho 192.168.1.20
rtr schedule 2 life forever start-time now
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 login
 transport preferred all
 transport input all
 transport output all
!
!
end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show track — 显示跟踪信息。

  • show track brief — 显示有限的跟踪信息。

R1# show track           
Track 123
  Response Time Reporter 1 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 8
  Tracked by:
    ROUTE-MAP  0
Track 124
  Response Time Reporter 2 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 12
  Tracked by:
    ROUTE-MAP  0

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

show track brief 命令输出中,您可以看到两个 ISP 均可访问。如果关闭连接到 ISP-1 的接口,则跟踪时它显示为关闭。

R1# conf t
R1(config)# int ethernet 0/0
R1(config-if)# shutdown
R1(config-if)# end
R1#

*Jan 21 06:06:50.167: %SYS-5-CONFIG_I: Configured from console by console
*Jan 21 06:06:50.807: %LINK-5-CHANGED: Interface Ethernet0/0, changed state to administratively down
*Jan 21 06:06:51.827: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Down
124     rtr       2                    reachability     Up
R1# 

注意: PBR 要求进行跟踪,以确定接口或路由是否处于活动状态。要查看路由跟踪的状态,还可以使用 show route-map 命令

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 48003