IP : IP 版本 6 (IPv6)

通过IPv4网络的IPv6隧道

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档提供的配置示例通过事先存在的 IPv4 网络建立 IPv6 Routing Information Protocol (RIP) 和 IPv6 边界网关协议 (BGP) 网络和数据流隧道。利用该技术可通过现有的 IPv4 主干网连接 IPv6 站点。

叠加隧道将 IPv6 数据包封装在 IPv4 数据包中,以便在 IPv4 基础架构中进行传输。这类似于如何通过 IP 网络创建通用路由封装 (GRE) 隧道传输互联网分组交换 (IPX) 数据流。在隧道前端,IPv6 数据包封装到 IPv4 数据包中并发送至远程隧道目标。在该目标中将会删除 IPv4 数据包报头,并将原始 IPv6 数据包进一步转发至 IPv6 云。

以下是建立 IPv6 数据流隧道的五种方法:

  • 手动 IPv6 隧道

  • 自动 IPv4 兼容隧道

  • GRE

  • 自动 6to4 隧道

  • 站内自动隧道编址协议 (ISATAP) 隧道

这些隧道技术的主要区别在于确定隧道源和目标的方法。本文档中介绍了手动和自动 IPv4 兼容隧道类型。有关其他隧道技术及其特性的信息,请参阅实现 IPv6 隧道

注意:叠加隧道使接口的最大传输单元 (MTU) 减少了 20 个八位组。这里假设基本的 IPv4 数据包报头不包含可选字段。使用叠加隧道的网络很难进行故障排除。因此,不应将连接隔离 IPv6 网络的隧道视为最终的 IPv6 网络体系结构。应将叠加隧道的使用视为面向同时支持 IPv4 和 IPv6 协议栈或仅支持 IPv6 协议栈网络的过渡技术。

先决条件

要求

Cisco 建议您在尝试此配置前了解 IPv6 相关知识。有关 IPv6 的相关信息,请参阅实现 IPv6 编址和基本连通性

使用的组件

本文档中的信息根据Cisco 36xx系列路由器该运行Cisco IOS 软件版本12.3(13)。

注意: 任何支持 Cisco IOS 软件版本 12.2(2)T 或 12.0(21)ST 以及更高版本的硬件平台均支持 IPv6。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/25156/ipv6tunnel.gif

配置(手工 IPv6 模式)

IPv6 手动配置隧道的配置无需加以说明。它需要隧道 IPv4 源和隧道 IPv4 目标的明确规范。使用此技术的唯一缺点是隧道数量增加之后的管理量。

本文档对手动 IPv6 模式使用以下配置:

R1-IPv6(Cisco 3640 路由器)
R1-ipv6#show run
Building configuration...
 
Current configuration : 916 bytes
!
version 12.3
hostname R1-ipv6
!
boot system flash 
logging buffered 4096 debugging
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 ipv6 address 2000:1:1:1:1:1:1:1112/112
 ipv6 rip 6bone enable
!
!
ip classless
!
ipv6 router rip 6bone 
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
!
end

R2-IPv6-IPv4(Cisco 3640 路由器)
R2-ipv6-ipv4#show run
Building configuration...
 
Current configuration : 1079 bytes
!
version 12.3
!
hostname R2-ipv6-ipv4
!
ip subnet-zero
!
!
ipv6 unicast-routing
!
!
interface Tunnel0
 no ip address
 ipv6 address 3000::1/112
 ipv6 rip 6bone enable
 tunnel source Serial0/0
tunnel destination 192.34.1.4
tunnel mode ipv6ip

!--- Configures Manual tunnel.


!--- In some cases, user would require a Data License  
!--- in order to issue "tunnel mode ipv6ip"


!
!
interface Serial0/0
 ip address 192.23.1.2 255.255.255.0
 clockrate 64000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
!
ip classless
!
ipv6 router rip 6bone
!
!
line con 0
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!
!
end

R3-IPv4(Cisco 2621 路由器)
R3-ipv4#show run
Building configuration...
 
Current configuration : 865 bytes
!
version 12.3
!
hostname R3-ipv4
!
!
memory-size iomem 15
ip subnet-zero
!
!
interface Serial0/0
 ip address 192.23.1.3 255.255.255.0
!
interface Serial0/1
 ip address 192.34.1.3 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
 network 192.34.1.0 0.0.0.255 area 0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
!
!
end

R4-IPv4-IPv6(Cisco 3640 路由器)
R4-ipv4-ipv6#show run
Building configuration...
 
Current configuration : 1413 bytes
!
version 12.3
!
hostname R4-ipv4-ipv6
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 no ip address
 ipv6 address 3000::2/112
 ipv6 rip 6bone enable
 tunnel source Serial1/5
tunnel destination 192.23.1.2
tunnel mode ipv6ip

!--- Configures Manual tunnel.


!
!
interface Serial1/5
 ip address 192.34.1.4 255.255.255.0
 clockrate 64000
!
!
interface Ethernet3/0
 no ip address
 half-duplex
 ipv6 address 4000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.34.1.0 0.0.0.255 area 0
!
ip classless
!
ipv6 router rip 6bone
!         
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

R5-IPv6(Cisco 7500 路由器)
R5-ipv6#show run
Building configuration...
 
Current configuration : 1001 bytes
!
version 12.3
!
hostname R5-ipv6
!
ip subnet-zero
ip cef distributed
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Ethernet1/2
 no ip address
 ipv6 address 4000:1:1:1:1:1:1:1112/112
 ipv6 rip 6bone enable
!
!
ip classless
!
ipv6 router rip 6bone
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

配置(自动 IPv4 兼容模式)

R1、R3 和 R5 的配置与手动 IPv6 模式示例的配置相同。仅 R2R4 配置有所变化。配置 IPv4 兼容隧道时,请勿明确指定隧道目标 IPv4 地址。隧道目标由 IPv6 路由的 IPv6 下一跳地址自动计算得出。要在此类隧道上提供路由,需要具有明确邻居地址定义(例如 BGP 或静态)的路由协议。在这种情况下,您需要将 IPv4 兼容的 IPv6 地址作为 BGP 邻居 IPv6 地址或静态路由下一跳地址使用。

以下示例将 R2 和 R4 上的串行接口作为 IPv4 兼容的 IPv6 地址使用。相同的串行是隧道源。例如,R2 S0/0 上的 IPv4 地址 192.23.1.2 转换为:IPv6 符号中的 192.23.1.2。此地址作为 BGP 对等 IPv6 地址和 BGP 下一跳使用。最终,IPv6 BGP 路由重分配至 IPv6 RIP,因此,网络的远程端将收到信息。

目前不推荐使用该隧道技术。Cisco 建议您使用 IPv6 ISATAP 隧道技术。有关该技术的详细信息,请参阅 ISATAP 隧道

注意: 在自动 IPv6 模式下无需配置隧道目标。

R2-IPv6-IPv4(Cisco 3640 路由器)
R2-ipv6-ipv4#show run
Building configuration...
Current configuration : 1394 bytes
!
version 12.3
!
hostname R2-ipv6-ipv4
!
!
ip subnet-zero
!
!
!
ipv6 unicast-routing
!
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 rip 6bone enable
 tunnel source Serial0/0
tunnel mode ipv6ip auto-tunnel

!--- Configures Automatic IPv4 compatible tunnel.


!
!
interface Serial0/0
 ip address 192.23.1.2 255.255.255.0
 clockrate 64000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor ::192.34.1.4 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor ::192.34.1.4 activate
 neighbor ::192.34.1.4 next-hop-self
 network 2000:1:1:1:1:1:1:0/112
bgp redistribute-internal

!--- The show run command along with the 
!--- redistribute bgp command allows BGP to redistribute the
!--- IPv6 routes learned through the tunnel from the other site.


 exit-address-family
!         
ip classless
!
ipv6 router rip 6bone
redistribute bgp 100 metric 2
!
!
line con 0
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!
!
end

R4-IPv4-IPv6(Cisco 3640 路由器)
R4-ipv4-ipv6#show run
Building configuration...
 
Current configuration : 1697 bytes
!
version 12.3
!
hostname R4-ipv4-ipv6
!
ip subnet-zero
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 rip 6bone enable
 tunnel source Serial1/5
tunnel mode ipv6ip auto-tunnel

!--- Configures Automatic IPv4 compatible tunnel.


!
!
interface Serial1/5
 ip address 192.34.1.4 255.255.255.0
 clockrate 64000
!
!
interface Ethernet3/0
 no ip address
 half-duplex
 ipv6 address 4000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.34.1.0 0.0.0.255 area 0
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor ::192.23.1.2 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor ::192.23.1.2 activate
 neighbor ::192.23.1.2 next-hop-self
 network 4000:1:1:1:1:1:1:0/112
bgp redistribute-internal

!--- The show run command along with the 
!--- redistribute bgp command allows BGP to redistribute the
!--- IPv6 routes learned through the tunnel from the other site.


 exit-address-family
!
ip classless
!
ipv6 router rip 6bone
redistribute bgp 100 metric 2
!
!
!         
line con 0
line aux 0
line vty 0 4
 login
!
!
end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

  • ping - 确定远程主机处于活动状态还是非活动状态以及与主机通信中的往返延迟。

  • show ipv6 route - 验证 IPv6 上是否存在路由。

  • show bgp ipv6 - 验证 BGP 是否正在运行。

  • show bgp ipv6 summary - 显示有关 IPv6 上运行的 BGP 的概要信息。

  • show ipv6 int tunnel 0 —验证通道是UP在IPv6,并且验证在接口配置的MTU。

手动 IPv6 模式的验证命令输出

从 R1 ping R5 上的 IPv6 地址,验证隧道是否通过 IPv4 网络传输 IPv6。

R1-ipv6#ping ipv6 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms 
R1-ipv6#ping 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms 
R1-ipv6#

从 R5 ping R1 上的 IPv6 地址。

R5-ipv6#ping  2000:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 
R5-ipv6#ping ipv6 2000:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 
R5-ipv6#

自动 IPv6 模式的验证命令输出

ping 远程 IPv6 网络以验证隧道的连通性。

R1-ipv6#ping 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/69/72 ms 
R1-ipv6# 
R5-ipv6#ping ipv6 2000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/70/72 ms 
R5-ipv6#

如果 ping 发生故障,查看 IPv6 路由表,检验该路由是否存在。同样也查看另一侧的路由表。末端路由器(例如R5和R1)的路由应被当作RIP路由被了解。此路由从 BGP 重分配至 R2 和 R4 上的 RIP。在 R2 和 R4 上,隧道将会终止并配置 BGP 对等。

R5-ipv6#show ipv6 route 
IPv6 Routing Table - 6 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
R   ::/96 [120/2] 
     via FE80::230:80FF:FEF3:4731, Ethernet1/2
R   2000:1:1:1:1:1:1:0/112 [120/3]
     via FE80::230:80FF:FEF3:4731, Ethernet1/2
L   4000:1:1:1:1:1:1:1112/128 [0/0] 
     via ::, Ethernet1/2
C   4000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet1/2
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R5-ipv6#

如果远程IPv6网络不在终端路由器上,请检查隧道是在路由器的哪个位置终止的。

R4-ipv4-ipv6#show ipv6 route 
IPv6 Routing Table - 7 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   ::192.34.1.4/128 [0/0] 
     via ::, Tunnel0
C   ::/96 [0/0] 
     via ::, Tunnel0
B   2000:1:1:1:1:1:1:0/112 [200/0]
     via ::192.23.1.2, Null
L   4000:1:1:1:1:1:1:1111/128 [0/0] 
     via ::, Ethernet3/0
C   4000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet3/0
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R4-ipv4-ipv6#

由于您正在二个不同的IPv6网络之间使用IPv6 BGP共享信息,请验证BGP处于UP和运行状态。

R4-ipv4-ipv6#show bgp ipv6 
BGP table version is 3, local router ID is 192.34.1.4 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure 
Origin codes: i - IGP, e - EGP, ? - incomplete 
   Network          Next Hop            Metric LocPrf Weight Path 
*>i2000:1:1:1:1:1:1:0/112 
                    ::192.23.1.2                  100      0 i 
*> 4000:1:1:1:1:1:1:0/112 
                    ::                                 32768 i 
R4-ipv4-ipv6#show bgp ipv6 summary 
BGP router identifier 192.34.1.4, local AS number 100 
BGP table version is 3, main routing table version 3 
2 network entries and 2 paths using 394 bytes of memory 
2 BGP path attribute entries using 120 bytes of memory 
0 BGP route-map cache entries using 0 bytes of memory 
0 BGP filter-list cache entries using 0 bytes of memory 
BGP activity 2/8 prefixes, 2/0 paths, scan interval 60 secs 
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
::192.23.1.2    4   100      24      24        3    0    0 00:19:00        1 
R4-ipv4-ipv6# 
R4-ipv4-ipv6#show ipv6 int tunnel 0 
Tunnel0 is up, line protocol is up 
  IPv6 is enabled, link-local address is FE80::C022:104 
  Global unicast address(es): 
    ::192.34.1.4, subnet is ::/96 
  Joined group address(es): 
    FF02::1 
    FF02::2 
    FF02::9 
    FF02::1:FF22:104 
  MTU is 1480 bytes 
  ICMP error messages limited to one every 100 milliseconds 
  ICMP redirects are enabled 
  ND DAD is not supported 
  ND reachable time is 30000 milliseconds 
  Hosts use stateless autoconfig for addresses. 
R4-ipv4-ipv6#

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • show ipv6 route - 验证 IPv6 上是否存在路由。

  • show ip ospf neighbor - 显示路由器 ID、优先级和邻居路由器的状态。此外,该命令还显示在声明邻居已断开之前,路由器等待接收来自邻居的 Open Shortest Path First (OSPF) hello 数据包的剩余时间。除此以外,该命令还显示该邻居直接连接的接口和 OSPF 邻居形成邻接关系的接口的 IP 地址。

  • show ipv6 interface brief - 验证隧道接口是否已启用。

  • show interfaces tunnel 0 - 验证路由表中是否有配置的隧道目标。

  • show ipv6 rip - 显示 IPv6 RIP 信息。

  • show ipv6 protocols - 显示 IPv6 路由协议的状态。

如果 ping 到远程 IPv6 网络发生故障,请验证 IPv6 路由是通过 ipv6 rip 获知的。

R1-ipv6#show ipv6 route 
IPv6 Routing Table - 6 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   2000:1:1:1:1:1:1:1112/128 [0/0] 
     via ::, Ethernet0/1
C   2000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet0/1
R   3000::/112 [120/2]
     via FE80::202:B9FF:FECB:D281, Ethernet0/1
R   4000:1:1:1:1:1:1:0/112 [120/3] 
     via FE80::202:B9FF:FECB:D281, Ethernet0/1
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R1-ipv6#

在 R2 上验证是否从 Tunnel0 接口获知 IPv6 RIP 路由。

R2-ipv6-ipv4#show ipv6 route 
IPv6 Routing Table - 7 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   2000:1:1:1:1:1:1:1111/128 [0/0] 
     via ::, FastEthernet0/1
C   2000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, FastEthernet0/1
L   3000::1/128 [0/0] 
     via ::, Tunnel0
C   3000::/112 [0/0] 
     via ::, Tunnel0
R   4000:1:1:1:1:1:1:0/112 [120/2]
     via FE80::230:80FF:FEF3:4701, Tunnel0
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R2-ipv6-ipv4#

如果存在连接问题,请首先验证 IPv4 网络状态是否良好。此外,还需验证 OSPF 邻居邻接以及是否存在到 IPv4 地址(远程隧道接口的隧道源)的路由。然后验证是否可以通过 IPv4 ping 在隧道源之间执行 ping

R2-ipv6-ipv4#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
192.23.1.3        1   FULL/  -        00:00:36    192.23.1.3      Serial0/0 
R2-ipv6-ipv4# 
R3-ipv4#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
1.1.1.1           1   FULL/  -        00:00:30    192.34.1.4      Serial0/1 
192.23.1.2        1   FULL/  -        00:00:35    192.23.1.2      Serial0/0 
R3-ipv4# 
R4-ipv4-ipv6#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
192.23.1.3        1   FULL/  -        00:00:35    192.34.1.3      Serial1/5 
R4-ipv4-ipv6#

在 R2 上验证 IPv6 隧道接口是否已启用,并且可以使用 IPv4 兼容的 IPv6 地址 IPv6 ping 远程隧道源。如果隧道接口关闭,检验路由表中是否有配置的隧道目的地。这是网络IPv4部分的问题因为隧道目的地不在路由表里。

R2-ipv6-ipv4#show ipv6 interface brief 
FastEthernet0/0            [up/up] 
    unassigned 
Serial0/0                  [up/up] 
    unassigned 
FastEthernet0/1            [up/up] 
    2000:1:1:1:1:1:1:1111 
Tunnel0                    [up/up] 
    3000::1 
R2-ipv6-ipv4# 
R2-ipv6-ipv4#show interfaces tunnel 0 
Tunnel0 is up, line protocol is up 
  Hardware is Tunnel 
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation TUNNEL, loopback not set 
  Keepalive not set 
  Tunnel source 192.23.1.2 (Serial0/0), destination 192.34.1.4 
  Tunnel protocol/transport IPv6/IP, key disabled, sequencing disabled 
  Tunnel TTL 255 
  Checksumming of packets disabled 
  Last input 00:00:09, output 00:00:19, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: fifo 
  Output queue :0/0 (size/max) 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     3119 packets input, 361832 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     3117 packets output, 361560 bytes, 0 underruns 
     0 output errors, 0 collisions, 0 interface resets 
     0 output buffer failures, 0 output buffers swapped out 
R2-ipv6-ipv4#

如果 IPv6 路由仍然存在问题并且 IPv4 网络已经过验证,则需要检查 IPv6 RIP 配置。

R2-ipv6-ipv4#show ipv6 rip 
RIP process "6bone", port 521, multicast-group FF02::9, pid 111 
     Administrative distance is 120.  Routing table is 0 
     Updates every 30 seconds, expire after 180 
     Holddown lasts 180 seconds, garbage collect after 120 
     Split horizon is on; poison reverse is off 
     Default routes are not generated 
     Periodic updates 176, trigger updates 1 
R2-ipv6-ipv4# 
R2-ipv6-ipv4#show ipv6 protocols 
IPv6 Routing Protocol is "connected" 
IPv6 Routing Protocol is "static" 
IPv6 Routing Protocol is "rip 6bone" 
  Interfaces: 
    FastEthernet0/1 
    Tunnel0 
  Redistribution: 
    Redistributing protocol rip 6bone

如果未使用默认设置,请确保计时器相同。在本示例中,所有 IPv6 RIP 路由器均使用默认设置。验证配置,以确保所有 RIP 启用的接口均配置正确。此外,还需验证整个网络中的相同 RIP 进程名称是否一致。如果需要,可以查看 debug ipv6 rip 的输出。进行了所有调试之后,必须小心不让CPU和控制台记录缓冲区超载。

摘要

本文档说明了如何使用隧道使 IPv6 和 IPv4 在同一网络上共存。这在过渡时期可能非常有用。IPv6 配置需要注意的一点就是,配置 IPv6 RIP 之后,就不再使用网络语句。IPv6 RIP 在全局启用,每个接口均参与 RIP 并为 IPv6 RIP 启用。在 IPv6 BGP 示例中,自动隧道部分要求使用 address-family ipv6 命令集,输入 BGP 语句。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 25156