IP : 动态地址分配和解析

动态配置 DHCP 服务器选项

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

您可通过 DHCP 自动将可重复使用的 IP 地址分配给 DHCP 客户端。本文档举例说明了如何配置 DHCP 选项(例如域名系统 (DNS) 和 Windows Internet 名称服务 (WINS) 地址),以响应客户端设备 (CPE) 之后的本地客户端发出的 DHCP 请求。

以前,网络管理员必须手工配置在每个设备的思科IOSï ¿  ½ DHCP服务器启用与此功能。路由器配置完成之后,用于每个位置和进行修改,将需要密集型劳力和高昂的成本并且耗费时间长。

因此,Cisco IOS DHCP 服务器经过增强,可允许自动更新配置信息。网络管理员可以在DHCP池内配置一个或多个中央控制的DHCP服务器,以更新特定DHCP选项。远程服务器可以从集中式服务器请求或导入这些选项参数。

先决条件

要求

Cisco 建议本文档的读者了解以下主题:

  • DHCP

  • 域名系统 (DNS)

  • Windows Internet 名称服务 (WINS)

使用的组件

此配置使用以下软件和硬件版本开发并测试:

  • Cisco IOSï ¿  ½软件版本12.2(27)

  • 用于 PC 和客户端连接且带有 NM-1E 的两台 Cisco 3660 路由器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

注意Cisco IOS 软件版本 12.0(1)T 中引入了 Cisco IOS DHCP 服务器功能。您需要Cisco IOSï ¿  ½软件版本12.0(2)T或以上为了用在Cisco 1700系列路由器上。有关支持 DHCP 服务器功能的路由器的详细信息,请参阅 Cisco IOS DHCP 服务器文档支持的平台部分。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关配置 DNS 和 WINS 的 DHCP 服务器选项的信息。“中央”路由器为这些服务器选项进行配置,并由“远程”路由器导入这些选项。在 DHCPACK 阶段,远程 PC 或客户端从“远程”路由器接收这些导入的选项。

注意: 要查找有关本文档中所使用命令的其他信息,请参阅 DHCP 命令或使用命令查找工具(仅限注册用户)。

网络图

本文档使用此图中所示的网络设置:

/image/gif/paws/22920/dhcp_ser_01.gif

配置

本文档使用以下配置:

中央 (3660)
Central# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 10.0.0.1 10.0.0.5

!--- This range must not be assigned to DHCP clients.

!
ip dhcp pool Central   
   network 10.0.0.0 255.255.255.0

!--- Specify the network number and mask for DHCP clients.
   
   domain-name Central

!--- Specify the domain name for the client.
   
   dns-server 10.0.0.2

!--- Specify the DNS server you want to respond to DHCP clients who


!--- need to correlate the host name to the IP address.
   
   netbios-name-server 10.0.0.2

!--- Specify the Network Basic Input/Output System (NetBIOS)


!--- WINS server (for Microsoft DHCP clients)
 
!
.
.
!
interface FastEthernet0/0 
 ip address 10.0.0.1 255.255.255.0 
 duplex auto 
 speed auto
!
.
.
!
end

注意: 当您将 Cisco 路由器作为 DHCP 服务器使用时,每个 DHCP 池仅允许一个域,即路由器不能向包括两个域名的客户端发送 DHCP 租用。不可在动态池中混合静态映射。如果进行了混合,将会显示 % This command may not be used with network, origin, vrf, or relay pools 这一错误消息。

远程 (3660)
Remote# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 192.168.1.1

!--- This ip address must not be assigned to DHCP clients.

!
ip dhcp pool Client   
   import all

!--- Import DHCP option parameters into the database.
   
   network 192.168.1.0 255.255.255.248

!--- Specify the network number and mask for DHCP clients.

   default-router 192.168.1.1

!--- Specify the default gateway for DHCP clients.
	
!
.
.
!
interface FastEthernet0/0 
 ip address dhcp 
 duplex auto 
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
end

service config 命令与 boot hostboot network 命令一起使用。输入 service config 命令启用路由器,以便从 boot hostboot network 命令指定的文件自动配置系统。

service config 命令也可在不结合 boot hostboot network 命令的情况下使用。如果不指定主机或网络配置文件名,则路由器将使用默认配置文件。默认网络配置文件为 network-config。默认主机配置文件为 host-config,其中的 host 是路由器主机名。如果 Cisco IOS 软件无法解析其主机名,则默认主机配置文件为 router-config。

请将 boot host 命令与 service config 命令结合使用。如果未使用 service config 命令,则路由器将忽略 boot host 命令并使用 NVRAM 中的配置信息。如果 NVRAM 中的配置信息无效或缺失,则会自动启用 service config 命令。网络服务器将尝试从远程主机加载两个配置文件。第一个是网络配置文件,该配置文件包含适用于网络上所有网络服务器的命令。使用 boot network 命令标识网络配置文件。第二个是主机配置文件,该配置文件包含适用于某个特定网络服务器的命令。使用 boot host 命令标识主机配置文件。

尽管配置了选项 150,但由于客户端寻找 TFTP 服务器的默认属性,并且选项 150 在服务器端(而非在客户端)定义,客户端仍会发出广播。除 TFTP 以外,150 选项还可用于以下应用:

  • 150 Etherboot

  • 150 GRUB 配置路径名

可通过选项代码 ASCII 字符串 tftp-server-name 命令配置 DHCP 选项。如果您没有服务器名称,且服务器仅通过 IP 地址进行配置,请使用选项代码 ip ip address 命令。

验证

本部分提供了可用于确认您的配置是否正常运行的信息。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

Remote#show ip dhcp import
Address Pool Name: Client
Domain Name Server(s): 10.0.0.2
NetBIOS Name Server(s): 10.0.0.2
Domain Name Option: Central
Central#show ip dhcp server statistics
Memory usage         13906
Address pools        1
Database agents      1
Automatic bindings   1
Manual bindings      0
Expired bindings     0
Malformed messages   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         1
DHCPREQUEST          1
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           0

Message              Sent
BOOTREPLY            0
DHCPOFFER            1
DHCPACK              1
DHCPNAK              0
Central#show ip dhcp binding
IP address       Client-ID/Hardware address	 	Lease expiration            Type
10.0.0.6         0063.6973.636f.2d30.                   Apr 25 2005 12:30 AM        Automatic
                 3036.302e.3563.6634.
                 2e61.3961.382d.4574.        
                 30

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

注意: 在发出 debug 命令之前,请参阅有关 debug 命令的重要信息

通过 ipconfig /all 命令从采用 Microsoft Windows 操作系统的 PC 或客户端得到的输出提供了由 DHCP 配置的 TCP/IP 配置值。有关 DHCP 选项的详细信息,请参阅 RFC 2132leavingcisco.com

C:\>ipconfig /all 
  
Windows 2000 IP Configuration 
  
  Host Name . . . . . . . . . . . . : PC 
  Primary DNS Suffix . . . . . . .  : cisco.com 
  Node Type . . . . . . . . . . . . : Hybrid 
  IP Routing Enabled. . . . . . . . : No
  WINS Proxy Enabled. . . . . . . . : No 
  DNS Suffix Search List. . . . . . : cisco.com 
                                       
Ethernet adapter Local Area Connection :
	 
  Connection-specific DNS Suffix . : Central 
  Description . . . . . . . . . .  : 3Com EtherLink XL 10/100 PCI TX NIC(3C905B-TX) 
  Physical Address. . . . . . . .  : 00-10-5A-86-5A-CA 
  DHCP Enabled. . . . . . . . . .  : Yes 
  Autoconfiguration Enabled . . .  : Yes 
  IP Address. . . . . . . . . . .  : 192.168.1.2 
  Subnet Mask . . . . . . . . . .  : 255.255.255.248 
  Default Gateway . . . . . . . .  : 192.168.1.1
  DHCP Server . . . . . . . . . .  : 10.0.0.6 
  DNS Servers . . . . . . . . . .  : 10.0.0.2 
  Primary WINS Server . . . . . .  : 10.0.0.2 
  Lease Obtained. . . .  . . . . . : Tuesday, April 26, 2005 6:04:29 PM 
  Lease Expires . . . . . . . .. . : Wednesday, April 27, 2005 6:04:29 PM

相关信息


Document ID: 22920