IP : 热备份路由协议 (HSRP)

HSRP 负载分摊

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文档举例说明如何配置 Hot Standby Router Protocol (HSRP),以便利用指向给定目标的多条路径。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

背景理论

HSRP 常用于提高网络的弹性,但也会降低网络的效率。在本文档的示例中,有两条路径从主机网络通往服务器网络。出于冗余目的,HSRP 在 R1 和 R2 之间运行,R1 和 R2 中的任何一个路由器都可以成为活动路由器,并拥有 HSRP 虚拟 IP 地址的“所有权”。另一个路由器则成为备用路由器,只有在当前的活动路由器发生故障时,才成为活动路由器。有关活动路由器和备份路由器的详细信息,请参阅如何使用 standby preemptstandby track 命令

主机的默认网关地址被指定为它们的 HSRP 虚拟 IP 地址。当主机需要将数据包发送到服务器网络时,它们将把这些数据包发送到其默认网关,或发送到活动路由器。由于只有一个路由器是活动的,来自主机的数据包在发送到服务器时只会经过两条可用路径中的一条。

注意: 从服务器返回主机的数据包可能会采用两条返回路径,也可能不会,具体取决于您如何配置 R3。并且,从服务器返回主机的数据包不需要通过活动路由器。

要同时使用从主机网络到服务器网络的两条路径,您可以在 R1 和 R2 之间配置多组 HSRP (MHSRP)。实质上,R1 配置了两个 HSRP 组(例如,组 1 和组 2),R2 也配置了相同的 HSRP 组。对于组 1,R1 是活动路由器,R2 是备用路由器。对于组 2,R2 是活动路由器,R1 是备用路由器。然后,您使用 HSRP 组 1 虚拟 IP 地址来配置一半主机的默认网关,用 HSRP 组 2 虚拟 IP 地址来配置另一半主机的默认网关。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/13781/7a.gif

配置

本文档使用以下配置:

R1 MHSRP 配置
Current configuration:

interface Ethernet0
        ip address 171.16.6.5 255.255.255.0

        standby 1 preempt
        standby 1 ip 171.16.6.100
        standby 1 track Serial0
        standby 2 preempt
        standby 2 ip 171.16.6.200
        standby 2 track serial 0
        standby 2 priority 95

R2 MHSRP 配置
Current configuration:

interface Ethernet0
       ip address 171.16.6.6 255.255.255.0
       standby 1 preempt
       standby 1 ip 171.16.6.100
       standby 1 track Serial0
       standby 1 priority 95
       standby 2 preempt
       standby 2 ip 171.16.6.200
       standby 2 track serial 0

请注意以上配置,当两个路由器首先开始运行 HSRP 时,R1 对组 1 的默认优先级为 100,对组 2 的优先级为 95;R2 对组 2 的默认优先级为 100,对组 1 的优先级为 95。因此,对于组 1,R1 是活动路由器;对于组 2,R2 是活动路由器。此示例表明,您可以利用 MHSRP 实现负载共享。但是,您需要使用 HSRP 优先级和抢占来实现负载共享。HSRP 对返回流量没有影响。返回流量采用哪条路径取决于路由器上配置的路由协议。

注意: 如果配置了 standby priority valuestandby preempt 命令,系统会强制明确说明组号码。如果没有说明,则默认值为 0。默认组号码为 0。

重要提示

低端产品中的多个以太网(Lance 和 QUICC)控制器的地址过滤器中只能有一个单播媒体访问控制 (MAC) 地址。这些平台只允许使用单个 HSRP 组,并且当该组变为活动组时,平台会将接口地址更改为 HSRP 虚拟 MAC 地址。因为有这个限制,在平台上通过 HSRP 共享负载就不可能实现。系统引入了 use-bia 命令,用于解决当您在低端产品上运行 HSRP 时发生的问题(如上所述)。例如,如果您在相同的接口上运行 HSRP 和 DECnet,会发生问题,因为 DECnet 和 HSRP 都尝试修改 MAC 地址。通过 use-bia 命令,您可以将 HSRP 配置为使用 DECnet 进程创建的 MAC 地址。但是,您应当注意使用 use-bia 命令的一些缺点,例如:

  • 当路由器变为活动状态时,虚拟 IP 地址会移至其他 MAC 地址。新的活动路由器将发送无故地址解析协议 (ARP) 响应,但不是所有主机实施都能正确处理无故 ARP。

  • use-bia 配置会中断代理 ARP。备用路由器不能实现故障路由器丢失的代理 ARP 数据库的功能。

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 13781