IP : 增强的内部网关路由选择协议 (EIGRP)

EIGRP 常见问题

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文档包含有关 IP 增强型内部网关路由协议 (EIGRP) 的常见问题 (FAQ)。

Q. EIGRP 是否要求 ip default-network 命令传播默认路由?

A. 尽管 EIGRP 能够使用默认的网络方法来传播默认路由,但这不是必需的。EIGRP 会直接重新分配默认路由。

Q. 配置 EIGRP 时是否总是应该使用 eigrp log-neighbor-changes 命令?

A. 是的,使用此命令便于确定 EIGRP 邻居为什么重置。这将减少故障排除时间。

Q. EIGRP 是否支持备用地址?

A. EIGRP 确实支持备用地址。由于 EIGRP 总是从主地址上寻找数据包,思科建议您在带有主地址的特殊子网上配置所有路由器,这些主地址属于同一子集。路由器不会在备用网络上形成 EIGRP 邻居。因此,如果路由器的主 IP 地址没有全部同意,相邻关系会出现问题。

Q. EIGRP 有什么调试能力?

A. 有与协议无关的,也有与协议相关的 debug 命令。还有一套 show 命令,用于显示邻居表状态、拓扑表状态和 EIGRP 数据流统计信息。其中一些命令如下:

Q. 当您发出 show ip eigrp topology 命令时,EIGRP 拓扑条目末尾的词“serno”是什么意思?

A. 例如:

show ip eigrp topology
P 172.22.71.208/29, 2 successors, FD is 46163456
via 172.30.1.42 (46163456/45651456), Serial0.2, serno 7539273
via 172.30.2.49 (46163456/45651456), Serial2.6, serno 7539266

Serno 代表序列号。当 DRDB 排入线程以便发送时,系统会为它们分配一个序列号。如果您在将某一 DRDB 条目排入线程时显示拓扑表,该表将显示与该 DRDB 关联的序列号。

线程是路由器内使用的技术,用于将项目排成队列,以传输给邻居。直到各项目都从接口发出时,才会创建更新。在此之前,会为要发送的项目创建一个带链接的指针列表(例如,线程)。

这些 serno 位于路由器本地,因此不会随着路由更新而传递。

Q. EIGRP 使用百分之几的带宽和处理器资源?

A. EIGRP 版本 1 引入了一个功能,用于防止任何单个 EIGRP 进程在网络收敛期间,在任何链路上使用超过 50% 的配置带宽。每个由EIGRP服务的AS或协议(例如IP、IPX或AppleTalk)都是一个独立的进程。您可以使用 ip bandwidth-percent eigrp 接口配置命令正确配置每个广域网接口上的带宽百分比。有关此功能如何运作的详细信息,请参阅 EIGRP 白皮书

另外,它实施了部分和逐步更新,这意味着:只有在发生拓扑更改时,EIGRP才会发送路由信息。此功能将显著减少带宽的使用。

EIGRP的可行后继者功能,可以减少自治系统(AS)使用的处理器资源数量。它要求只有受到拓扑更改影响的路由器才执行路由重新计算。路由重新计算只发生在受影响的路由上,因此可减少复杂数据结构中的搜索时间。

Q. EIGRP 是否支持聚集和变长子网掩码?

A. 是的,EIGRP 支持聚合和变长子网掩码 (VLSM)。不同于开放最短路径优先 (OSPF),EIGRP 允许在网络的任意一点进行汇总和聚合。EIGRP 支持聚合到任何比特。这允许适当设计的EIGRP网络可以格外良好地扩展,而不使用区域。EIGRP 还支持在主要网络边界上对网络地址进行自动汇总。

Q. EIGRP 是否支持区域?

A. 不支持,单个 EIGRP 进程类似于链路状态协议的一个区域。然而运行程序时,信息可以被过滤并聚集在任何接口边界。为了限制路由信息的传播范围,您可以使用汇总来创建层次结构。

Q. 在同一路由器上能否配置多个 EIGRP 自治系统?

A. 是的,您可以在同一个路由器上配置多个 EIGRP 自治系统。如果某个重分配点上有两个 EIGRP 自治系统互联,通常就需要这么处理。各个路由器接口应当只包含在单个 EIGRP 自治系统内。

思科不建议在路由器的同一组接口上运行多个 EIGRP 自治系统。如果多个 EIGRP 自治系统与多个相互重分配点结合使用,则当重分配点上未正确执行过滤操作时,会导致 EIGRP 拓扑表中存在差异。如果可能,思科建议您在任何一个自治系统中只配置一个 EIGRP 自治系统。您也可以使用其他协议,例如边界网关协议 (BGP),以便连接两个 EIGRP 自治系统。

Q. 如果有两个 EIGRP 进程在运行,并获知了两条等价路径,每个 EIGRP 进程各一条,是否会安装两个路由?

A. 不,仅安装一个路由。路由器将安装通过自治系统 (AS) 编号较低的 EIGRP 进程获知的路由。在低于 12.2(7)T 的 Cisco IOS 软件版本中,从哪个 EIGRP 进程收到的时间戳最新,路由器就会安装带有该时间戳的路径。这一行为变化已记录在 Cisco Bug ID CSCdm47037 中。

Q. EIGRP 陷于活动状态消息是什么意思?

A. 当EIGRP返回"Stuck in Active" (SIA)消息时,则意味着它尚未收到查询的回复。当路由丢失,并且拓扑表中不存在其他可行路由时,EIGRP将发送一次查询。SIA 是由两个连续的事件造成的:

  • SIA 报告的路由已经不存在。

  • EIGRP 邻居尚未答复针对该路由的查询。

当 SIA 发生时,路由器将清除未答复查询的邻居。当这种情况发生时,请确定哪个邻居已经被清除。请注意,此路由器可能相隔很多跳。请参阅 EIGRP DUAL-3-SIA 错误消息意味着什么?

Q. EIGRP 配置部分中的邻居声明起什么作用?

A. neighbor 命令用于在 EIGRP 中定义与哪个相邻路由器交换路由信息。鉴于此命令当前的工作方式,如果为某个接口配置了 neighbor 命令,EIGRP 就会以单播数据包的形式与邻居交换路由信息。EIGRP 将停止处理该接口上的所有入站组播数据包。并且,EIGRP 将停止在该接口上发送组播数据包。

此命令的理想工作方式是:EIGRP 开始以单播数据包的方式向指定的邻居发送 EIGRP 数据包,但不停止在该接口上发送和接收组播数据包。因为该命令并不按照预期的方式工作,所以应当小心使用 neighbor 命令,了解该命令对网络的影响。

Q. EIGRP passive-interface 命令为什么删除了一个接口的所有邻居?

A. passive-interface 命令用于在接口上禁用 EIGRP hello 数据包的传输和接收。与 IGRP 或 RIP 不同,EIGRP 发送 hello 数据包是为了建立和保持相邻关系。没有相邻关系,EIGRP 就无法与邻居交换路由。因此,passive-interface 命令用于防止接口上的路由交换。尽管 EIGRP 在使用 passive-interface 命令配置的接口上不会发送或接收路由更新,它仍然会在其他非被动接口发送的路由更新中包含该接口的地址。请参阅在 EIGRP 中被动接口功能如何工作?

Q. 从运行 EIGRP 的点对多点接口上的一个邻居收到的路由为什么没有传播到同一个点对多点接口上的另一个邻居?

A. 水平分割规则禁止路由器使用其用于到达目标的接口来通告路由。为了禁用水平分割行为,请使用 no ip split-horizon eigrp as-number interface 命令。有关 EIGRP 水平分割,请注意以下重要信息:

  • 默认情况下,水平分割功能是打开的。

  • 如果您更改接口上的 EIGRP 水平分割设置,将重置与通过该接口可以到达的所有 EIGRP 邻居的邻接关系。

  • 只应在星型网络的中心站点禁用水平分割。

  • 在辐射点上禁用纵向隔离,可显著增加了在集线路由器上的EIGRP内存消耗量,以及在辐射路由器上生成的数据流量。

  • EIGRP 水平分割行为不受 ip split-horizon 命令的控制或影响。

有关水平分割与毒性逆转的更多信息,请参阅水平分割与毒性逆转。有关命令的更多信息,请参阅 EIGRP 命令

Q. 配置 EIGRP 时,如何配置带掩码的网络声明?

A. 可选的网络掩码参数最早添加到 Cisco IOS 软件版本 12.0(4)T 的网络声明中。掩码参数可以在所有格式中配置(例如在网络掩码或在万用搜寻字符位中)。例如,您可以使用 network 10.10.10.0 255.255.255.252network 10.10.10.0 0.0.0.3

Q. 我有两个路由:172.16.1.0/24 和 172.16.1.0/28。当我在 EIGRP 中允许 172.16.1.0/24 时,如何才能拒绝 172.16.1.0/28?

A. 为了执行您需要使用前缀列表的此,如显示此处:

router eigrp 100
       network 172.16.0.0
       distribute-list prefix test in
       auto-summary
       no eigrp log-neighbor-changes
       !
       ip prefix-list test seq 5 permit 172.16.1.0/24

该列表只允许 172.16.1.0/24 前缀,因此拒绝 172.16.1.0/28。

注意: 在这种情况下,在 EIGRP 下使用 ACL 和分配列表不起作用。这是因为 ACL 不检查掩码,只检查网络部分。由于网络部分是相同的,当您允许 172.16.1.0/24 时,也就允许了 172.16.1.0/28。

Q. 我有一个运行 Cisco Express Forwarding (CEF) 和 EIGRP 的路由器。如果有多条链路指向一个目标,那由谁执行负载均衡?

A. CEF 的工作方式是,CEF 根据要由 EIGRP 等路由协议填充的路由表来执行数据包的交换。简而言之,CEF 会在计算出路由协议表之后执行负载均衡。请参阅负载均衡如何工作?了解有关负载均衡的更多信息。

Q. 如何验证,如果EIGRP非终止转发(NSF)功能启用?

A. 为了检查EIGRP NSF功能,请发出show ip protocols命令。这是输出示例: :

show ip protocols
  Routing Protocol is "eigrp 101"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Default networks flagged in outgoing updates

  Default networks accepted from incoming updates

  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

  EIGRP maximum hopcount 100

  EIGRP maximum metric variance 1

  Redistributing: eigrp 101

  EIGRP NSF-aware route hold timer is 240s

  Automatic network summarization is in effect

  Maximum path: 4

  Routing for Networks:

  Routing Information Sources:

  Gateway         Distance      Last Update

  Distance: internal 90 external 170

此输出显示路由器是NSF意识的,并且路由保持计时器设置为240秒,是默认值。

Q. 如果一个路由器有两条等价路径,如何才能只使用其中一条路径?

A. 将接口上的带宽值配置为默认值,并增加备份接口上的延迟,使路由器看不到两条等价路径。

Q. EIGRP 和 IGRP 之间的度量计算有何差别?

A. 用 IGRP 度量值乘以 256,就得到 EIGRP 度量值。IGRP 在其度量字段的更新数据包中只使用 24 位,而 EIGRP 在其度量字段的更新数据包中使用 32 位。例如,通向目标网络的 IGRP 度量值为 8586,而 EIGRP 度量值则为 8586 x 256 = 2,198,016。用 10^7 除以最小带宽时使用整数除法,因此结果将与手动计算结果有差别。

Q. EIGRP 末节路由功能是什么?

A. 末节路由功能用于通过汇总和过滤路由来节约带宽。由于末节路由功能,系统只把指定的路由从远程(末节)路由器传播到分布式路由器中。有关末节路由功能的更多信息,请参阅 EIGRP 末节路由。EIGRP残余部分功能在交换机可以配置用eigrp残余部分[receive-only] [leak-map name] [connected] [static] [summary] [redistributed]命令。此功能可以用没有eigrp stub命令删除。当您从交换机时删除eigrp stub命令,运行IP Base镜像的交换机投掷此错误:

EIGRP is restricted to stub configurations only

如果您升级到高级企业镜像,就可以解决此问题。CSCeh58135 中说明了此错误。

Q. 如何从集线器向末节路由器发送默认路由?

A. 使用 ip summary-address eigrp x 0.0.0.0 0.0.0.0 命令,在中心路由器上的出站接口下执行此操作。该命令将抑制所有更具体的路由,只发送汇总路由。0.0.0.0 0.0.0.0 表示抑制所有内容,出站更新中的唯一路由是 0.0.0.0/0。此方法的一个缺点是,EIGRP 向 Null0 安装的 0.0.0.0/0 路由是本地路由表,管理距离为 5。

Q. 什么是另外路由输入EIGRP ?

A. 有三不同种类的在EIGRP的路由:

  • 内部路由—在自治系统(AS)内产生的路由。

  • 汇总路由—例如在路由器汇总的路由(汇总)的内部路径。

  • 外部路由—再分布对EIGRP的路由。

Q. 如何再分布在EIGRP的IPv6默认路由?

A. 对于再分布在EIGRP的一个IPv6默认路由,配置示例显示此处:

ipv6 prefix-list DEFAULT-ONLY-V6 seq 10 permit ::/0
route-map DEFAULT_2EIGRP-V6 permit 10
match ipv6 address prefix-list DEFAULT-ONLY-V6
router eigrp Starz_EIGRP
address-family ipv6 unicast
redistribute static route-map DEFAULT_2EIGRP-V6

Q. EIGRP如何在GRE隧道正常运行直接地与连接的网络比较?

A. 对于 GRE 隧道,EIGRP 将使用相同的管理距离和度量计算。开销计算是基于带宽和延迟的。GRE 隧道的带宽和延迟将从路由器上配置的隧道接口上获取。该隧道也会被当做直连网络处理。如果有两条路径到达网络,一条通过 VLAN 接口,另一条通过隧道接口,EIGRP 会优先选择虚拟访问接口 (VAI) VLAN 接口,这是因为 VLAN 接口的带宽比隧道接口更高。要影响通过隧道接口的路由,请增大隧道接口的带宽参数,或增大 VLAN 接口的延迟参数。

Q. 什么是 offset-list?它有何作用?

A. offset-list 功能是用于在 EIGRP 中修改复合度量值。在 offset-list 命令中配置的值会添加到延迟值中,该延迟值是由路由器为与访问列表匹配的路由计算的。offset-list 是用来影响被通告和/或被选择的特定路径的首选方法。

Q. 如何在 EIGRP 中标记外部路由?

A. 您可以使用 32 位标记值,标记 EIGRP 从另一个路由协议处获知的路由。从 ddts CSCdw22585 开始,内部路由也可以标记。但是,由于内部路由的数据包限制,标记值不能超过 255。

Q. PDM 有哪些主要功能?

A. EIGRP 支持 3 个协议簇:IP、IPv6 和 IPX。每一个协议簇都有自己的 PDM。以下是 PDM 的主要功能:

  • 维护属于该协议簇的 EIGRP 路由器的邻居表和拓扑表

  • 为 DUAL 构建和转换特定于协议的数据包

  • 将 DUAL 连接到特定于协议的路由表

  • 计算度量值,并将此信息传递给 DUAL;DUAL 只处理可行后继路由器 (FS) 的挑选

  • 实施过滤列表和访问列表。

  • 执行到/来自其他路由协议的重分配功能。

Q. EIGRP 中提供了哪些负载均衡选项?

A. offset-list 能够用于修改 EIGRP 通过特定接口获知的路由度量值或可使用 PBR 的路由度量值。

Q. 什么执行%DUAL-5-NBRCHANGE :IPEIGRP(0) 100 :邻居10.254.0.3 (隧道0)发生故障:保持满期的错误消息平均值?

A. 此消息表明路由器听不到从邻居的任何EIGRP数据包在hold-time限制内。由于这是数据包LOS发出,检查Layer2问题。

Q. 有没有包括EIGRPv6的IPv6部署指南?

A. 参考部署在分支机构网络的IPv6欲知更多信息。

Q. 从被压的16:29:14.262毒性:10.X.X.X/24倒转消息,什么毒害被压的平均值?

A. 一拓扑表条目作为以回复更新的一毒性接收的路由器线索(路由器为反向抑制设置)。当路由器构件包含反向抑制的数据包时,路由器意识到不需要发送它。例如,如果路由器收到路由的一查询从邻居,它当前穿线毒害。因此,它传送毒性被压的信息。

Q. 是否是正常EIGRP接收30秒聚合?

A. EIGRP采取更加长聚合在大量CPU使用情况下是正常行为。当您降低保持时间时, EIGRP收敛更加快速。Hello和保持时间的低值分别为1秒和3秒。例如:

Router(Config)# interface Fa0/0 

!--- (Under an interface directly connected to EIGRP peers.)

Router(Config-if)#ip hello-interval eigrp 1
Router(Config-if)#ip hold-time eigrp 3

注意: 确保保持时间在两端更改。

关于EIGRP性能相关问题的更多信息,参考如何解决EIGRP性能问题


相关信息


Document ID: 13681