IP : 网络地址转换 (NAT)

两个ISP连接的IOS NAT负载均衡

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 9 月 26 日) | 反馈


目录


简介

本文描述Cisco IOS 路由器的一配置能连接网络到有网络地址转换(NAT)的互联网通过两ISP连接。Cisco IOS软件的NAT可以在多个网络连接上分配随后的TCP连接和UDP会话,如果等价路由到指定目的地是可用的。

/image/gif/paws/100658/ios-nat-load-balancing-2isp-01.gif

先决条件

要求

本文假设您开始工作LAN和WAN连接,并且没有提供配置或故障排除背景以建立初始连接。本文不描述区分路由的机制;因此,无法选择优先级较高的理想连接和优先级较低的理想连接。

使用的组件

此配置的开发使用了Cisco 1811路由器与Cisco IOS软件版本12.4(15)T3高级IP服务软件。如果使用一个不同的软件版本,一些功能可能不是可用的,或者配置命令室与在本文显示的会有所不同。相似的配置应该是在所有Cisco IOS路由器平台上可用的,虽然接口配置可能在不同平台之间有所不同。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

您需要为特定数据流添加基于策略的路由,以确保该数据流始终使用同一个 ISP 连接。需要此行为的流量的例子包括IPSec VPN客户端、VoIP电话流量和总是使用一个ISP连接选项,更喜欢同样IP地址、更高的速度或者低延时连接的其他流量。.

本部分提供有关如何配置本文档所述功能的信息。

注意: 使用命令查找工具仅限注册用户)查找有关本文档所使用命令的详细信息。

网络图

本文档使用以下网络设置:

/image/gif/paws/100658/ios-nat-load-balancing-2isp-02.gif

此配置示例描述一个路由器,使用DHCP配置的IP连接到ISP,由FastEthernet0,和一个在其他ISP连接上的PPPoE连接显示。连接类型在配置上没有特定的影响,虽然一些连接类型在特定故障情景中会隐藏此配置的使用性,特别在使用连接以太网的WAN服务上的IP连通性,例如,电缆调制解调器或DSL 服务处,一个附加设备终止WAN连接并且提供以太网hand-off给Cisco IOS路由器。在应用静态IP寻址而非DHCP分配地址或PPPoE的情况下,广域网故障发生,以太网端口仍然保持到WAN连接设备的以太网链路,路由器继续尝试在好的和坏的广域网连接间做负载平衡连通性。如果您的部署要求非活动路由从负载平衡删除,请参考该文档提供的配置,两个互联网连接的IOS NAT负载均衡与优化边缘路由,描述新增内容优化边缘路由以监控路由的正确性。

配置

本文档使用以下配置:

interface FastEthernet0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet1
 no ip address
 pppoe enable
 no cdp enable
!
interface FastEthernet2
 no cdp enable
!


!
interface Vlan1
 description LAN Interface
 ip address 192.168.108.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452


!---Define LAN-facing interfaces with "ip nat inside".

!

!
Interface Dialer 0
 description PPPoX dialer
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss


!---Define ISP-facing interfaces with "ip nat outside".

!
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
!
 
!
ip nat inside source route-map fixed-nat interface Dialer0 overload
ip nat inside source route-map dhcp-nat interface FastEthernet0 overload
!

!--- Configure NAT overload (PAT) in order to use route-maps.

 
!
access-list 110 permit ip 192.168.108.0 0.0.0.255 any
!

!--- Define ACLs for traffic that are NATed to 
!--- the ISP connections.


!
route-map fixed-nat permit 10
 match ip address 110
 match interface Dialer0
!
route-map dhcp-nat permit 10
 match ip address 110
 match interface FastEthernet0


!--- Route-maps associate NAT ACLs with NAT outside on 
!--- the ISP-facing interfaces.

验证

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

  • show ip nat translation — 显示 NAT 内部主机与 NAT 外部主机之间的 NAT 活动。此命令为转换为两个 NAT 外部地址的内部主机提供验证。

    Router#show ip nat translation
    Pro Inside global      Inside local       Outside local      Outside global
    tcp 172.16.108.44:54486 192.168.108.3:54486 172.16.104.10:22 172.16.104.10:22
    tcp 172.16.106.42:49620 192.168.108.3:49620 172.16.102.11:80 172.16.102.11:80
    tcp 172.16.108.44:1623 192.168.108.4:1623 172.16.102.11:445  172.16.102.11:445
    Router#
  • show ip route — 验证是否存在多个通往 Internet 的路由。

    Router#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 172.16.108.1 to network 0.0.0.0
    
    C    192.168.108.0/24 is directly connected, Vlan1
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.108.0 is directly connected, FastEthernet4
    C       172.16.106.0 is directly connected, Vlan106
    S*   0.0.0.0/0 [1/0] via 172.16.108.1
                   [1/0] via 172.16.106.1
    Router#

故障排除

使用本部分可排除配置故障。

在您配置有NAT的Cisco IOS路由器后,如果连接不工作,请确认:

  • 在外部和内部接口上正确应用了 NAT。

  • NAT 配置已完成,并且 ACL 反映了必须进行 NAT 处理的流量。

  • 存在多个通往 Internet/WAN 的路由。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 100658