交换机 : Cisco Catalyst 6500 系列交换机

为Polycom会议电话配置Catalyst交换机

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 10 月 20 日) | 反馈


目录


简介

本文提供了 Catalyst 交换机上用于连接到 Polycom IP Conference Station 7935/7936 和 Polycom SoundPoint IP 430 的示例配置。本文不包括嵌入式电源和服务质量 (QoS) 配置。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

使用的组件

本文档中的信息根据Cisco Catalyst 6500系列交换机用Supervisor引擎720和运行Cisco IOSï ¿  ½软件版本12.2(18)SXD6和Cisco Catalyst 6500系列交换机以Supervisor引擎2和运行Cisco CatOS软件版本8.4(4)。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

相关产品

此配置也可用于运行 Cisco IOS 软件的 Cisco Catalyst 交换机,但不包括 Cisco 2900XL 和 3500XL 系列。CatOS 配置可用于任何运行 Catalyst OS 软件的 Cisco Catalyst 交换机。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

本文说明在交换机端口上连接 PC 和 IP 电话 Polycom SoundPoint IP 430 的交换机配置。本文还说明了连接到 Polycom IP Conference Station 7935/7936 交换机端口的交换机配置。

Polycom IP Conference Station 7935/7936 具有通过 RJ-45 电缆接口连接到网络的单路 10/100BaseTx 以太网 LAN 连接,与其他 Cisco Unified IP 电话 7900 系列不同,它没有用于连接到 PC 的 10/100BaseTx 以太网 LAN 连接。

由于 Cisco 7935/7936 IP 会议电话没有提供连接到 PC 的 10/100BaseTx 以太网 LAN 连接,所以无法直接应用语音或辅助 VLAN,这可能会导致问题。Cisco IP Conference Station 7935/7936 提供的单路 10/100BaseTx 以太网 LAN 连接用于将此设备连接到交换机端口。由于此连接只传输语音通信,所以交换机端口应属于单个 VLAN。

Polycom SoundPoint IP 430 具有双路 10/100 Mbps 以太网端口。一个端口连接到交换机,另一个端口连接到 PC。在此连接中,端口传输这两个 VLAN 的通信:

  • 数据 (PC) 通信

  • 语音(IP 电话)通信

在此方案中,您需要中继端口以传输多个 VLAN 的通信。

注意: Polycom IP Conference Station 7935/7936 没有外部电源,因此交换机必须通过其 PoE 端口提供电源,或者需要使用单独的电源插头。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-series-switches/97229-config-cat-switches-polycom.gif

Cisco IOS 配置

本文档使用以下配置:

  • Catalyst 6500

使用本地 Cisco IOS 模式的 Catalyst 6500
Cat6500#show running-config 
 Building configuration...
Current configuration : 5869 bytes
!
version 12.1 
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!

boot system sup-bootflash:s72033-psv-mz.122-18.SXD6.bin


main-cpu
 auto-sync standard
ip subnet-zero
!
!
no ip finger
!
!
!
!
vlan 1
name DataVlan
!
vlan 2
name VoiceVlan
!
interface FastEthernet4/1
 no ip address 
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1
 switchport trunk allowed vlan 1,2
 switchport mode trunk
 spanning-tree portfast

!--- Use PortFast only when you connect a single end station to a
!--- Layer 2 access port. Otherwise, you create a network loop.
!--- Refer to Using Portfast and Other Commands to Fix Workstation Startup
!--- Connectivity Delays for more information on how to enable portfast.

!
interface FastEthernet4/2
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast

!--- Use PortFast only when you connect a single end station to a 
Layer 2 access port. Otherwise, you create a network loop.

!
interface FastEthernet4/3
 no ip address
 shutdown
!

!--- Output suppressed.

!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line vty 0 4 
!
end

CatOS 配置

本例说明在交换机端口上以混合模式连接 PC 和 IP 电话 Polycom SoundPoint IP 430 的交换机配置。本文还说明了连接到 Polycom IP Conference Station 7935/7936 交换机端口的交换机配置。此配置使用与前例相同的图表。

使用混合模式的 Catalyst 6500

!--- Set the VLAN Trunk Protocol (VTP) mode.
!--- In this example, the mode is set to transparent.
!--- Dependent upon your network, set the VTP mode accordingly.
!--- Refer to Understanding and Configuring VLAN Trunk Protocol (VTP) 
!--- for more information on VTP.

Catalyst6500> (enable) set vtp mode transparent
VTP domain modified


!--- Add VLAN 2. VLAN 1 already exists by default.
 
Catalyst6500> (enable) set vlan 2
VLAN 2 configuration successful


!--- Add port 4/2 to VLAN 2.

Catalyst6500> (enable) set vlan 2 4/2
VLAN 2 modified.
VLAN 1 modified.
VLAN  Mod/Ports
---- -----------------------
2     4/2


!--- Enable trunking on port 4/1.

Catalyst6500> (enable) set trunk 4/1 1,2 dot1q on
Vlan(s) 1,2 already allowed on the trunk
Please use the 'clear trunk' command to remove vlans from allowed list.
Port(s)  4/1 trunk mode set to on.
Port(s)  4/1 trunk type set to dot1q.
Catalyst6500> (enable) 


!--- Enable spanning tree portfast on the ports. Refer to 
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays
!--- for more information on how to enable portfast.

Catalyst6500> (enable) set spantree portfast 4/1 enable

Warning: Connecting Layer 2 devices to a fast start port can cause
temporary spanning tree loops. Use with caution.

Spantree port  4/1 fast start enabled.
Catalyst6500> (enable) set spantree portfast 4/2 enable

Warning: Connecting Layer 2 devices to a fast start port can cause
temporary spanning tree loops. Use with caution.

Spantree port  4/2 fast start enabled.
Catalyst6500> (enable)


!--- If you want to ONLY allow VLAN 1 and VLAN 2 on trunk port 4/1, do this.
!--- A trunk port allows all VLANs by default.

Catalyst6500> (enable) show trunk 4/1
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
$ - indicates non-default dot1q-ethertype value
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 4/1      on           dot1q          not-trunking  1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 4/1      1-4094

Port      Vlans allowed and active in management domain 
--------  ---------------------------------------------------------------------
 4/1      1

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 4/1       
Catalyst6500> (enable) clear trunk 4/1 1-4094
Removing Vlan(s) 1-4094 from allowed list.
Port  4/1 allowed vlans modified to none.


!--- Allow only VLAN 1 and VLAN 2 on trunk port 4/1.

Catalyst6500> (enable) set trunk 4/1 1,2 dot1q on
Adding vlans 1,2 to allowed list.
Port(s)  4/1 allowed vlans modified to 1,2.
Port(s)  4/1 trunk mode set to on.
Port(s)  4/1 trunk type set to dot1q.

Catalyst6500> (enable) show trunk 4/1
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
$ - indicates non-default dot1q-ethertype value
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 4/1      on           dot1q          not-trunking  1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 4/1      1,2

Port      Vlans allowed and active in management domain 
--------  ---------------------------------------------------------------------
 4/1      1

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 4/1       

!--- Refer to Configuring Ethernet VLAN Trunks for more
!--- information on how to configure trunk ports. 


!--- Issue the show config <module_number> command 
!--- in order to check the configuration.

Catalyst6500> (enable) show config 4
This command shows non-default configurations only.
Use 'show config <mod> all' to show both default and non-default configurations.
.................................
begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Thu Jun 21 2007, 23:37:51 
!
# default port status is enable
!
!
#module 4 : 16-port 1000BaseX Ethernet
set vlan 2    4/2
clear trunk 4/1  1-9,11-39,41-4094
set trunk 4/1  on dot1q 1,2
set spantree portfast    4/1-2 enable
end
Catalyst6500> (enable) 

验证

当前没有可用于此配置的验证过程。

故障排除

本部分提供了可用于对配置进行故障排除的信息。

由于 Polycom IP 电话造成的生成树环路

将 IP 电话连接到交换机时,将出现 STP 环路,这会造成交换机 CPU 的满负荷使用。即使在连接 IP 电话的交换机端口上启用了 portfast 也会出现 STP 环路。

  1. 检查交换机端口配置。如果连接 IP 电话的端口进入了 err-disabled 状态,并且不存在物理环路,则可以尝试将端口从 err-disabled 状态中恢复。有关详细信息,请参阅 Cisco IOS 平台上的 Errdisable 端口状态恢复

  2. 存在终端用户可能会错误造成物理环路的风险时,为避免端口进入 err-disabled 状态,您可以启用 err-disable 恢复,因而无需手动重置禁用的端口。有关 STP 环路防护的详细信息,请参阅使用环路防护和 BPDU 迟滞检测功能的生成树协议增强功能


相关信息


Document ID: 97229