交换机 : Cisco Catalyst 3750 系列交换机

Catalyst第3层交换机通过VLAN支持Wake-On-LAN的配置示例

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 10 月 7 日) | 反馈


目录


简介

本文档提供了使用 Catalyst 第 3 层交换机提供跨 VLAN Wake-On-LAN (WOL) 支持的配置示例。

先决条件

要求

Cisco 建议您在尝试进行此配置之前了解下列主题:

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 运行Cisco IOSï ¿  ½系统软件版本12.2(25r)SEC的Catalyst 3750系列交换机

  • 运行 Cisco IOS 系统软件版本 12.1(19)EA1a 的 Catalyst 2950 系列交换机

  • 运行 Microsoft Windows 2000 操作系统的 PC

  • Solarwinds 提供的免费 Wake-On-LAN 实用工具leavingcisco.com

    注意: Cisco 不推荐任何 Wake-On-LAN 实用工具。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

Wake-On-LAN

Wake-On-LAN (WOL) 是用于唤醒休眠系统的硬件技术和软件技术的组合。WOL 将经过特殊编码的网络数据包(称为魔术封包)发送到具备响应这些数据包的软硬件条件的系统。这项附加功能使管理员即使在用户关闭系统后也可以对系统进行维护。利用 WOL 功能,管理员可以远程启动所有休眠的计算机,使其能够接收更新。WOL 的原理是当 PC 关闭时,NIC 仍然接收电力,并继续监听网络以监视到达的魔术封包。此魔术封包可以通过多种无连接协议 (UDP|IPX) 发送,但最常用的是 UDP。

如果从远程网络发送 WOL 数据包,必须将路由器配置为允许定向广播。必须进行此配置的原因有以下两个:

  • 由于 PC 处于休眠状态,因此不会有 IP 地址,也不会响应来自路由器的地址解析服务 (ARP)。所以,仅在数据段中传输本地子网 IP 广播数据包,而不使用 ARP。

  • 如果路由器与 PC 之间有第 2 层交换机(这是目前大部分网络的配置),该交换机并不知道 PC 实际连接到哪个端口。仅将第 2 层广播或未知单播帧向外发送到所有交换机端口。所有 IP 广播数据包均送至广播 MAC 地址。

警告 - 定向广播

IP 定向广播普遍用于常见的 smurf 拒绝服务攻击,还可用于一些相关攻击。

IP 定向广播是发送到子网广播地址的数据包,发送设备与子网没有直接连接。定向广播以单播数据包的形式路由通过网络,直到它到达目标子网,并在这里被转换成链路层广播。由于 IP 编址体系结构的本质,仅链中的最后一个路由器,也就是和目标子网直接连接的路由器可以决定性地识别定向广播。定向广播偶尔用于一些正当用途,但在金融服务行业之外的使用较为少见。

在 smurf 攻击中,攻击者从伪造的源地址向定向广播地址发送 ICMP Echo 请求。这会导致目标子网的所有主机向该伪造源发送应答。通过连续发送这种请求数据流,攻击者可以制造更加巨大的应答流。这会彻底压倒具有伪造地址的主机。

如果 Cisco 接口配置了 no ip directed-broadcast 命令,则会丢弃在该接口爆发为链路层广播的其他定向广播。这意味着,必须在连接到目标子网的每个路由器的每个接口配置 no ip directed-broadcast 命令。仅仅在防火墙路由器上进行配置是不够的。no ip directed-broadcast 命令在 Cisco IOS 软件版本 12.0 和更高版本中是默认配置。在早期版本中,需要对转发合法定向广播的每个未知 LAN 接口应用此命令。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans1.gif

下面是此网络设置的详细信息:

  • PC 1、PC 2 和 PC 3 是需要唤醒的客户端 PC。

  • PC 4 是 WOL 服务器以及 DHCP 服务器。

  • PC 4 配置了静态 IP 地址 172.16.3.2/24。

  • 客户端 PC 配置为从 DHCP 服务器获取 IP 地址。

  • DHCP 服务器 (PC 4) 配置了三个用于连接到 VLAN 2、VLAN 3 和 VLAN 4 的客户端的 IP 范围。

  • SW-1 和 SW-2 (Catalyst 2950) 用作第 2 层交换机,L3 (Catalyst 3750) 用作第 3 层交换机。

  • PC 1 和 PC 4 连接到同一个 VLAN (VLAN 3)。

  • PC 2 和 PC 3 分别连接到 VLAN 2 和 VLAN 4。

交换机配置

本文档使用以下交换机配置:

  • 第 3 层交换机 - L3

  • 第 2 层交换机 - SW-1SW-2

L3
Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname L3
L3(config)#ip routing
L3(config)#vtp mode server
Device mode already VTP SERVER.
L3(config)#vtp domain cisco
Changing VTP domain name from NULL to cisco
L3(config)#vlan 2
L3(config-vlan)#vlan 3
L3(config-vlan)#vlan 4
L3(config)#interface gigabitEthernet 2/0/1
L3(config-if)#switchport trunk encapsulation dot1q
L3(config-if)#switchport mode trunk
L3(config-if)#interface gigabitEthernet 2/0/2
L3(config-if)#switchport trunk encapsulation dot1q
L3(config-if)#switchport mode trunk
L3(config-if)#exit
L3(config)#access-list 101 permit udp host 172.16.3.2 any eq 7

!--- This accepts directed broadcasts only from PC 4.

L3(config)#ip forward-protocol udp 7 

!--- Specifies the protocol and port to be forwarded.
!--- Capture the WOL packet with any network sniffer to determine the UDP port
!--- to use in this command. The port number varies with the WOL utility used.

L3(config-if)#interface vlan 2
L3(config-if)#ip address 172.16.2.1 255.255.255.0
L3(config-if)#ip helper-address 172.16.3.2

!--- Enables BOOTP broadcast forwarding to the DHCP server.

L3(config-if)#ip directed-broadcast 101

!--- Enables the translation of a directed broadcast to physical broadcasts.

L3(config-if)#interface vlan 3
L3(config-if)#ip address 172.16.3.1 255.255.255.0
L3(config-if)#ip helper-address 172.16.2.255
L3(config-if)#ip helper-address 172.16.4.255

!-- Enables forwarding of WoL packets to clients.
!-- Works in conjunction with the ip forward-protocol command.
L3(config-if)#interface vlan 4
L3(config-if)#ip address 172.16.4.1 255.255.255.0
L3(config-if)#ip helper-address 172.16.3.2

!--- Enables BOOTP broadcast forwarding to the DHCP server.

L3(config-if)#ip directed-broadcast 101

!--- Enables the translation of a directed broadcast to physical broadcasts.

L3(config)#^Z
L3#wr
Building configuration...
[OK]
L3#

SW-1
Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname SW-1
SW-1(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW-1(config)#vtp domain cisco
Changing VTP domain name from NULL to cisco
SW-1(config)#interface fastEthernet 0/1
SW-1(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/1 but will only
 have effect when the interface is in a non-trunking mode.
SW-1(config-if)#switchport mode access
SW-1(config-if)#switchport access vlan 4
SW-1(config-if)#interface fastEthernet 0/2
SW-1(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/2 but will only
 have effect when the interface is in a non-trunking mode.
SW-1(config-if)#switchport mode access
SW-1(config-if)#switchport access vlan 3
SW-1(config-if)#interface gigabitethernet 0/1
SW-1(config-if)#switchport mode trunk
SW-1(config-if)#^Z
SW-1#wr
Building configuration...
[OK]
SW-1#

SW-2
Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname SW-2
SW-2(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW-2(config)#vtp domain cisco
Changing VTP domain name from NULL to cisco
SW-2(config)#interface fastEthernet 0/1
SW-2(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/1 but will only
 have effect when the interface is in a non-trunking mode.
SW-2(config-if)#switchport mode access
SW-2(config-if)#switchport access vlan 3
SW-2(config-if)#interface fastEthernet 0/2
SW-2(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/2 but will only
 have effect when the interface is in a non-trunking mode.
SW-2(config-if)#switchport mode access
SW-2(config-if)#switchport access vlan 2
SW-2(config)#interface gigabitethernet 0/1
SW-2(config-if)#switchport mode trunk
SW-2(config-if)#^Z
SW-2#wr
Building configuration...
[OK]
SW-2#

客户端 PC 配置

目前的大部分主板都带有内置 NIC 并支持 WOL 功能。某些计算机默认禁用 WOL。您必须进入基本输入输出系统 (BIOS) 选项以启用 WOL。下面是在客户端 PC 上启用 WOL 的步骤:

  1. 在计算机开机自检 (POST) 过程中进入 BIOS 设置屏幕。

    注意: 通常是按 F10Delete 键进入 BIOS 设置。

  2. 在 BIOS 屏幕中浏览到 Advanced 设置,然后选择 Device Options

  3. 在此屏幕中找到并启用与 Wake-On-LAN 相关的设置。

  4. 保存并退出 BIOS 设置。

    注意: 各个计算机制造商在 BIOS 中提供的用于启用 WOL 的具体步骤和选项并不相同。有关 BIOS 设置的详细信息,请参阅每台计算机附带的主板手册。

  5. 检查网卡的高级属性以确保启用 WOL 功能。

    1. 选择开始 > 设置 > 网络和拨号连接,然后右键单击您的本地连接

    2. 单击属性并选择配置

    3. 转到高级选项卡。将 Wake Up Capabilities 属性设置为 Both,将 WOL 速度设置为自动

      http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans2.gif

    4. 单击电源管理选项,并选中允许这台设备使计算机脱离待机状态复选框。

      http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans3.gif

      注意: 在 Microsoft Windows XP 计算机中,还有另外一个选项:只允许管理台结束计算机的备用状态。使用这最后一个选项,将仅在收到 WOL 魔术封包时启动计算机。如果未选中此选项,任何发送到网络适配器的数据流都会启动 PC。

完成下列步骤,使客户端从 DHCP 服务器获取 IP 地址:

  1. 选择开始 > 设置 > 网络和拨号连接,然后右键单击您的本地连接并选择属性

  2. 在常规选项卡下,请单击互联网协议(TCP/IP)然后单击属性

  3. 选择自动地获得IP地址

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans4.gif

服务器 PC 配置

完成下列步骤以配置 WOL 服务器:

  1. 下载并安装 Wake-On-LAN 实用工具。

  2. 为 PC 配置静态 IP 地址 172.16.3.2/24。

  3. 将 PC 配置为 DHCP 服务器。

  4. 使用以下详细信息创建三个范围:

    范围 IP 范围 IP 排除范围
    VLAN 2 172.16.2.1 - 172.16.2.254掩码- 255.255.255.0 172.16.2.1
    VLAN 3 172.16.3.1 - 172.16.3.254掩码- 255.255.255.0 172.16.3.1 和 172.16.3.2
    VLAN 4 172.16.4.1 - 172.16.4.254掩码- 255.255.255.0 172.16.4.1

    有关 DHCP 服务器配置的详细信息,请参阅如何在 Windows Server 2003 的工作组中安装并配置 DHCP 服务器leavingcisco.com

验证

使用本部分可确认配置能否正常运行。

完成这些步骤:

  1. 打开 PC 的电源并将它们连接到各个交换机,如网络图所示。

  2. 登录到每个 PC 并记录 MAC 地址和 IP 地址。

    注意: 打开命令提示符并输入 ipconfig /all 命令以确定 MAC 地址和 IP 地址。

  3. 使用 Ping 命令以检查 PC 之间的连接。

  4. 验证连接成功后,关闭所有客户端 PC(PC 1、PC 2 和 PC 3)。

  5. 在服务器 PC (PC 4) 上启动 WOL 实用工具。

  6. 输入要“唤醒”的 PC 的 MAC 地址和 IP 地址,如下所示:

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans5.gif

    注意: IP 地址可以是客户端 PC 所连接的 VLAN 子网范围内的任何地址(甚至是子网广播地址)。只有客户端 PC 的 MAC 地址需要匹配。

  7. 单击唤醒 PC 图标,将一系列魔术封包发送到目标 PC 以尝试打开设备。

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans6.gif

  8. 当远程设备收到唤醒消息并自行启动时,将显示以下消息:

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans7.gif

    此时客户端 PC 便会启动。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 91672