交换机 : Cisco Catalyst 6500 系列交换机

配置在Catalyst 4500/4000, 5500/5000, 6500/6000和Catalyst固定配置交换机上的管理IP地址

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 10 月 20 日) | 反馈


交互:本文档对您的 Cisco 设备进行自定义分析。


目录


简介

本文描述如何配置在Catalyst运行Catalyst OS的4500/4000, 5500/5000和6500/6000系列交换机的一个管理IP地址(CatOS)和Cisco IOSï ¿  ½软件。本文档还包括仅运行 Cisco IOS 软件的 Catalyst 固定配置交换机及 2900/3500XL、2940、2950、2955、2970、3550 和 3750 系列交换机。如果您想从支持 TCP/IP 的远程管理站管理交换机,则您需要有 IP 地址。由控制台端口上的 VT100 终端管理的交换机不需要 IP 地址。

先决条件

要求

Cisco 建议您了解此部分的信息。

仅运行 CatOS 的 Catalyst 4500/4000、5500/5000、6500/6000 交换机是第 2 层 (L2) 交换机。Catalyst 固定配置交换机 2900/3500XL、2940、2950、2955 和 2970 也是 L2 交换机。有关 L2 交换机的 TCP/IP 协议仅用于管理用途。流经交换机的数据可能有第 3 层 (L3) 地址,例如 IP、互联网分组交换 (IPX)、AppleTalk 等。然而,交换机仅使用数据 MAC 地址来确定数据流的出处和应该接受数据的端口。当交换机转发数据时,L2 交换机忽略 L3 地址。

运行 Cisco IOS 软件的 Catalyst 6500/6000、4500/4000 和 3550/3750 系列交换机是交换机路由器或 L3 交换机,并且可使用任何接口进行管理。您可以用以下任何方式配置管理接口:

  • 作为一个逻辑接口,类似环回接口

  • 作为管理 VLAN 中的一个 L2 接入端口

  • 作为一个带 IP 地址的 L3 接口

    注意: 这与您在任何 Cisco 路由器上配置接口的方式一样。

本文档讨论的 Catalyst 交换机有这些管理接口:

  • 运行 CatOS 的带有 Supervisor 引擎的 Catalyst 5500/5000 及 6500/6000 系列交换机有两个可配置 IP 管理接口:

    • 带内 (sc0) 接口

    • 串行线路互联网协议 (SLIP) (sl0) 接口

  • 运行 CatOS 的带有 Supervisor 引擎的 Catalyst 4500/4000 交换器有三个可配置 IP 管理接口。其他接口称为管理以太网 (me1) 接口。

  • 运行 Cisco IOS 软件的 Catalyst L2 固定配置交换机仅有一个可配置 IP 管理接口,默认状态下是接口 VLAN 1。

  • 一直以来,纯粹的第 2 层交换机仅能打开一个接口 VLAN。这称为管理 VLAN(在 IOS 中)或 sc0 接口(在 CatOS 中)。此接口主要目的是管理(telnet、SNMP 等等)。如果交换机是第 3 层交换机,则您可配置多个 VLAN 并在他们之间路由。L3 交换机能处理多个 IP,所以交换机上没有特定的管理 VLAN。

  • 运行 Cisco IOS 软件的 Catalyst 3550/3750 系列交换机可使用任何接口进行管理。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

Catalyst 4500/4000、5500/5000 和 6500/6000 管理接口

sc0 接口是与交换结构连接的内部管理接口。sc0 接口具有一个正常交换机端口的所有功能,包括:

  • 生成树协议 (STP)

  • Cisco 发现协议 (CDP)

  • 虚拟 LAN (VLAN) 成员

me1 和 sl0 接口是带外管理接口,不与交换结构连接,并且不具有这些功能。

当您配置 c0 或 me1 接口的 IP 地址、子网掩码和广播地址(以及 sc0 接口的 VLAN 成员)时,可以通过 Telnet 或简单网络管理协议 (SNMP) 访问交换机。配置 SLIP (sl0) 接口时,您可以通过控制台端口从工作站打开到交换机的点到点连接。

如果您有 Cisco 设备的 show interface 命令输出,则您可使用 Output Interpreter仅限注册用户)工具来显示潜在问题和解决方法。

sc0 没有直接连接的外部端口。此接口作为交换机内的逻辑接口存在,并且可以通过交换机上的任何物理端口访问。此图提供一张图示:

/image/gif/paws/10594/8a.gif

me1 实际上是 Catalyst 4500/4000 系列交换机 Supervisor 引擎模块上的一个物理以太网端口。此接口仅用于网络管理,不支持网络交换。

/image/gif/paws/10594/8d.gif

sl0 将 RS232 控制台端口用作其物理接口。当处于 SLIP 模式时,sl0 不能用作 VT100 控制台。此图显示对 sl0 的一个 SLIP 连接:

8b.gif

在运行 CatOS 的 Catalyst 4500/4000、5500/5000 和 6500/6000 交换机上配置 sc0 接口

此部分描述如何在带内 sc0 接口上配置 IP 地址。

  1. 将一个终端连接到交换机的控制台端口。

    有关如何连接 Catalyst 交换机的控制台端口的详细信息,请参阅将一个终端连接到 Catalyst 交换机的控制台端口

  2. 在交换机提示符下,发出 show interface 命令,以便查看管理接口的默认状态。

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>        
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    !--- Catalyst 5500/5000 and 6500/6000 series switches 
    !--- do not display the me1 interface in the output.
    
    Switch-A> (enable)
  3. 发出 set interface sc0 172.16.84.17 255.255.255.0 172.16.84.255 命令,以便为 sc0 配置一个 IP 地址。

    交换机返回的消息告诉您更改了哪些参数。

    注意: 当您发出 set interface sc0 命令时,您不能在没有 IP 地址子网掩码的情况下输入广播地址。

    Switch-A> (enable) set interface sc0 172.16.84.17 255.255.255.0 172.16.84.255 
    Interface sc0 IP address, netmask, and broadcast set. 
    Switch-A> (enable)

    发出 show interface 命令,以便查看更改。

    Switch-A> (enable) show interface 
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING> 
            vlan 1 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    Switch-A> (enable)

    如果您在 set interface sc0 172.16.84.17 命令后仅输入了一个 IP 地址,则将会为地址类自动配置默认掩码和默认广播地址。示例如下:

    Switch-A> (enable) set interface sc0 172.16.84.17 
    
    !--- Notice that neither the mask nor the broadcast address is specified.
    
    Interface sc0 IP address and netmask set. 
    Switch-A> (enable) 
    Switch-A> (enable) show interface 
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING>
            vlan 1 inet 172.16.84.17 netmask 255.255.0.0 broadcast 172.16.255.255 
    
    !--- Notice that the switch took the default mask 
    !--- and the broadcast address of class B.
    
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    Switch-A> (enable)

    如果在 set interface sc0 命令后输入 IP 地址和子网掩码,则将会为特定子网自动配置广播地址。

  4. 要更改 sc0 接口上的 VLAN,请发出 set interface sc0 vlan# 命令,该命令将指定 VLAN 编号。

    注意: 默认情况下,sc0 接口属于 VLAN 1。

    如果要将 sc0 成员更改为 VLAN 2,请发出此命令:

    Switch-A> (enable) set interface sc0 2 
    
    
    Interface sc0 vlan set. 
    Switch-A> (enable)

    注意: 发出此命令前,请确保在您的交换机上配置了 VLAN 2。在 Catalyst 交换机上配置 VLAN 不在本文档描述的范围内。有关详细信息,请参阅在 Catalyst 交换机上创建以太网 VLAN

    发出 show interface 命令,以便查看更改。

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING> 
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING>
    vlan 2 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    Switch-A> (enable)
  5. 发出 show ip route 命令。

    注意: 如果您想能通过路由器管理交换机,则您必须配置默认网关。交换机不参与 IP 路由。所以,交换机不了解网络的 L3 拓扑。

    当您发出 show ip route 命令时,注意子网 sc0 的网关将分配到其自己的地址。

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable 
    -------------   --------   ----------- 
    enabled         enabled    enabled 
    
    Destination      Gateway          RouteMask    Flags    Use       Interface 
    ---------------  ---------------  ----------   -----    --------  --------- 
    172.16.84.0   172.16.84.17         0xffffff00   U        395         sc0 
    default          default          0xff000000   UH       0           sl0 
    Switch-A> (enable)
  6. 发出 set ip route 0.0.0.0 172.16.84.1 命令或 set ip route default 172.16.84.1 命令,以便建立默认路由。

    第二个IP地址是直接连接的路由器,它将是您联通网络其他部分的路径。此 IP 地址必须是交换机同一 IP 子网的一部分。您最多能定义三个默认 IP 网关。使用 primary 关键字和 set ip route 命令,以便使网关成为主网关。如果您没有指定一个默认主网关,则配置的第一个网关就是主网关。如果将多个网关指定为主网关,则最后配置的主网关为默认主网关。

    • Switch-A> (enable) set ip route 0.0.0.0 172.16.84.1 
      Route added. 
      Switch-A> (enable)

    • Switch-A> (enable) set ip route default 172.16.84.1
      Route added. 
      Switch-A> (enable)

    发出 show ip route 命令,以便查看更改。

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 172.16.84.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default        172.16.84.1          0x0        UG      0           sc0
    172.16.84.0      172.16.84.17     0xffffff00   U       525         sc0
    default          default          0xff000000   UH      0           sl0
    Switch-A> (enable)
  7. 如果需要从路由表清除路由,请发出 clear ip route all 命令。

    注意: 如果您通过 Telnet 从不同的子网的连接到交换机,则您在清除路由时将失去连接。您不能再连接到交换机,直到某人通过交换机相同子网上的连接控制台或 PC/终端重新输入网关地址。

    Switch-A> (enable) clear ip route all
    All routes deleted.
    Switch-A> (enable)

    如果仅指定该路由,则您可清除单个路由。发出 clear ip route 0.0.0.0 172.16.84.1 命令。

在运行 CatOS 的 Catalyst 4500/4000、5500/5000 和 6500/6000 交换机上配置 SLIP (sl0) 接口

您可以使用 sl0 上的 SLIP 连接,以便通过支持 CP/IP 的设备远程监控或管理交换机,在该设备上除通过控制台端口外没有其他通往交换机的路径。

网络管理器可以在世界任何地方使用远程 PC 拨号交换机,并使用 SLIP 上的 SNMP 或 Telnet 来管理这些交换机。您也可以用 TFTP 通过 sl0 接口上载系统软件。如果没有 SLIP,控制台端口只能用于 VT100 访问 (TTY) 或 Kermit 文件传输。有关如何启用到 Catalyst 交换机的拨号连接的详细信息,请参阅将调制解调器连接到 Catalyst 交换机的控制台端口

此图显示用 sl0 通过一个远程终端来管理交换机的示例。此种管理有时称带外管理。带外是指管理终端将通过不包括交换机连接的网络的路径访问设备。

/image/gif/paws/10594/8c.gif

如果您在一个直接连接的控制台终端设置并激活 sl0 接口,则您将失去您的控制台连接。如果您使用的终端支持 SLIP,请使用交换机建立一个 SLIP 会话。完成时,请撤销 SLIP 连接,以便允许直接控制台连接。如果激活 SLIP,而您的终端不支持 SLIP,则您必须建立对交换机的 Telnet 连接并撤销 sl0 或为交换机重新通电,以便恢复对控制台端口的访问。

注意: 除非您有能运行 SLIP 的终端,并知道如何使用它,否则请只执行从 Telnet 连接到交换机的这些步骤。

  1. 建立一个对交换机的 Telnet 会话。

  2. 在命令指示符下,请发出 set interface sl0 1.1.1.1 1.1.1.2 命令,以便设置交换机和目标 IP 地址的 SLIP 地址。

    示例如下:

    Switch-A> (enable) set interface sl0 1.1.1.1 1.1.1.2
    Interface sl0 slip and destination address set.
    Switch-A> (enable)
  3. 在命令指示符下,请发出 slip attach 命令,以便激活 SLIP 模式。

    示例如下:

    Switch-A> (enable) slip attach
    Console Port now running SLIP.
    Switch-A> (enable)
  4. 在命令提示符下,发出 slip detach 命令,以便撤销 SLIP 模式。

    示例如下:

    Switch-A> (enable) slip detach
    SLIP detached on Console port.
    Switch-A> (enable)

在运行 CatOS 的 Catalyst 4500/4000 上配置管理以太网接口 (me1)

此部分说明如何配置 Catalyst 4500/4000 系列交换机的 me1 上的 IP 地址。me1 接口上收到的数据包从不会到达交换结构,并且除了通过 Supervisor 引擎上的以太网端口,没有其他途径可以访问 me1 接口。

me1 接口的另一个特征是当交换机处于 ROM 监控 (ROMmon) 时,me1 接口是唯一的活动接口。当处于 ROMmon 时,您可以通过 me1 从网络启动或通过 me1 升级 Cisco IOS 软件。但是,您必须是直接在控制台端口上。当您从损坏的或丢失的软件镜像或从升级故障中恢复 Catalyst 4500/4000 系列交换机时,您可以使用此接口。有关详细信息,请参阅从启动失败中恢复运行 CatOS 的 Catalyst 交换机恢复 Catalyst 4000、Catalyst 2948G、Catalyst 2980G 和 Catalyst 4912G 部分。

您用类似于在 sc0 接口上配置 IP 地址的方法,在 me1 接口上配置 IP 地址。唯一的区别是您不能将 me1 接口连接到任何 VLAN 上,因为此接口不能到达交换结构,而 sc0 接口却能到达。

完成这些步骤,以便在 me1 接口上配置一个 IP 地址:

  1. 将终端连接到交换机的控制台端口。

  2. 在交换机提示符下,发出 show interface 命令,以便查看 me1 接口的默认状态。

    示例如下:

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    Switch-A> (enable)
  3. 发出 set interface me1 10.1.1.2 255.255.255.0 10.1.1.255 命令,以便为 me1 配置一个 IP 地址。

    交换机返回的消息告诉您更改了哪些参数。

    注意: 您必须输入网络掩码,以便配置广播地址。

    Switch-A> (enable) set interface me1 10.1.1.2 255.255.255.0 10.1.1.255
    Interface me1 IP address, netmask, and broadcast set.
    Switch-A> (enable)

    发出 show interface 命令,以便查看您所做的更改。

    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63 <UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 10.1.1.2 netmask 255.255.255.0 broadcast 10.1.1.255
    Switch-A> (enable)

    如果您在 set interface me1 10.1.1.2 命令后仅输入了一个 IP 地址,则将为您使用的地址类配置默认掩码和默认广播地址。示例如下:

    Switch-A> (enable) set interface me1 10.1.1.2 
    
    !--- Notice that neither the mask nor the broadcast address is specified.
    
    Interface sc0 IP address and netmask set. 
    Switch-A> (enable)
    
    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63 <UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 10.1.1.2 netmask 255.0.0.0 broadcast 10.255.255.255
    
    !--- Notice that the switch took the 
    !--- default mask and the broadcast address of class A.
    
    Switch-A> (enable)

    注意: 通常,me1 接口要配置到与 sc0 接口不同的子网中,这使两个接口都保持打开状态。两个接口可以配置在相同子网或带有同样的 IP 地址,但是 sc0 接口在这种情况下将关闭。在此实例中,接口 me1 总是首选接口。例如,您已经配置了一个 IP 地址为 172.16.84.17 255.255.255.0 的 sc0 接口,并且您试图在同一个子网 (172.16.84.18 255.255.255.0) 中配置 me1 接口,您将看到这些消息:

    Switch-A> (enable) set interface me1 172.16.84.18 255.255.255.0 172.16.80.255
    This command places me1 and sc0 into the same ip subnet. 
    The sc0 interface will be automatically configured down if necessary to resolve 
    the conflict.
    Do you want to continue (y/n) [n]?y
    Interface me1 IP address, netmask, and broadcast set.
    Interface sc0 administratively down due to conflict.
    Console> (enable)
    
    !--- Check the configuration.
    
    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=62 <DOWN,BROADCAST,RUNNING>
            vlan 1 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 172.16.84.18 netmask 255.255.255.0 broadcast 172.16.84.255
    Switch-A> (enable) 
  4. 如果您在第 3 步注意到 me1 的状态是关闭而不是打开,请发出此命令,以便将它手动设置为“打开”:

    Switch-A> (enable) set interface me1 up
    Interface me1 administratively up.
    Switch-A> (enable)
  5. 发出 show ip route 命令。

    注意: 如果想要能通过路由器管理交换机,则您必须配置默认网关,因为交换机不参加 IP 路由。所以,交换机不了解网络的 L3 拓扑。

    当您发出 show ip route 命令时,注意子网 me1 的网关将分配到其自己的地址。

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable 
    -------------   --------   ----------- 
    enabled         enabled    enabled 
    
    Destination      Gateway          RouteMask    Flags    Use       Interface 
    ---------------  ---------------  ----------   -----    --------  --------- 
    10.1.1.0         10.1.1.2         0xffffff00   U       0           me1
    Switch-A> (enable)
  6. 发出 set ip route 0.0.0.0 10.1.1.3 命令或 set ip route default 10.1.1.3 命令以便建立默认路由。

    第二个IP地址是直接连接的路由器,它将是您联通网络其他部分的路径。此 IP 地址必须是交换机同一 IP 子网的一部分。

    • Switch-A> (enable)set ip route 0.0.0.0 10.1.1.3
      Route added. 
      Switch-A> (enable)

    • Switch-A> (enable) set ip route default 10.1.1.3
      Route added. 
      Switch-A> (enable)

    发出 show ip route 命令,以便查看更改。

    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 10.1.1.3
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          UG      0           me1
    10.1.1.0         10.1.1.2         0xffffff00   U       1           me1
    Switch-A> (enable)
    
    

    注意: 如果 sc0 和 me1 处于不同的子网,则您可以配置多个默认网关。但是,首先定义的网关变为主网关。如果这是您想要的网关,则您必须在命令结束时使用关键字 primary,以便更换默认主网关。例如,172.16.84.1 在这两项都为真的情况下为主网关。

    • 您首先将 sc0 的 IP 地址配置为 172.16.84.17 255.255.255.0,默认网关的 IP 地址为 172.16.84.1。

    • 您将 me1 的 IP 地址配置为 10.1.1.2 255.255.255.0,默认网关的 IP 地址为 10.1.1.3。

    您可以发出这些命令,以便将主网关更换为 10.1.1.3:

    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 172.16.80.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          G       0           me1
    default          172.16.84.1      0x0          UG      11          sc0
    172.16.80.0      172.16.84.17     0xffffff00   U       38          sc0
    10.1.1.0         10.1.1.2         0xffffff00   U       4           me1
    
    !--- Notice that 172.16.84.1 is the primary default gateway.
    
    Switch-A> (enable) 
    
    !--- Change the primary default gateway to 10.1.1.3.
    
    Switch-A> (enable) set ip route default 10.1.1.3 primary
    Primary route changed
    Switch-A> (enable)
    
    !--- This message displays when the primary gateway is changed:
    
    %SYS-5-RTE_DEFGATEFROM:Default Gateway switching from 172.16.80.1
    %SYS-5-RTE_DEFGATETO:Default Gateway switching to 10.1.1.3
    
    !--- Verify the change.
    
    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 10.1.1.3
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          UG      0         me1
    default          172.16.84.1      0x0          G       11        sc0
    172.16.80.0      172.16.84.17     0xffffff00   U       38        sc0
    10.1.1.0         10.1.1.2         0xffffff00   U       4         me1
    
    !--- Notice that now the primary default gateway is 10.1.1.3.
    
    
  7. 如果需要从路由表清除路由,请发出 clear ip route all 命令。

    注意: 如果您通过 Telnet 从不同的子网的连接到交换机,则您在清除路由时将失去连接。您不能再连接到交换机,直到某人通过交换机相同子网上的连接控制台或 PC/终端重新输入网关地址。

    Switch-A> (enable) clear ip route all
    All routes deleted.
    Switch-A> (enable)

    如果仅指定该路由,则您可清除单个路由。发出 clear ip route 0.0.0.0 10.1.1.3 命令。

为运行 Cisco IOS 软件的 Catalyst 4500/4000 系列交换机配置一个管理接口

在运行 Cisco IOS 软件的 Catalyst 4500/4000 Supervisor 引擎 III/IV 上,任何可路由接口都可以用于管理。有三个配置此接口的选项。

注意: 管理引擎III (WS-X4014)或管理引擎IV (WS-X4515)上的以太网管理端口(被标记为10/100 MGT)使用ROMmon模式,只用来恢复丢失或损坏的交换机软件镜像。此端口在交换机正常操作时不可用,因而不能用作管理接口。

选项 1 - 为交换机管理配置一个环回接口。环回接口有许多优点。环回接口是总是打开的虚拟接口。路由到环回接口的数据包将重新路由回 L3 交换机或路由器上,并且在本地进行处理。从环回接口上路由出来、但又不是发往环回接口的 IP 数据包会被丢弃。这意味着环回接口也充当 null 0 接口。环回接口可用作开放最短路径优先 (OSPF) 的路由器 ID 等。此示例使用 loopback 0:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

您还必须配置路由协议,以分发分配给环回地址的子网,或者创建静态路由。

选项 2 - 将接口配置为带有 IP 地址的 L3 路由接口。默认情况下,运行 Cisco IOS 软件的 Catalyst 4500/4000 交换机上的所有接口都是 L2。因此,您需要将连接到网络其他部分的所有接口设置为 L3 路由接口。发出 no switchport 命令,并且配置所需的 IP 地址。示例提供图示说明。默认情况下,所有接口均已启用,因此您不需要发出 no shutdown 命令。此示例使用快速以太网 5/30:

Switch(config)#interface fastethernet 5/30 
Switch(config-if)#no switchport
Switch(config-if)#ip address 11.1.1.1 255.0.0.0

如果发出 show running-config interface fastethernet 5/30 命令,则显示此输出:

Building configuration... 
Current configuration : 80 bytes 
! 
interface FastEthernet5/30
no switchport
ip address 11.1.1.1 255.0.0.0
end

选项 3 - 将 L2 接口配置为特定 VLAN 的一部分。发出 switchport mode access 命令和 switchport access vlan vlan-id 命令,并且使用带有 IP 地址的对应交换虚拟接口 (SVI)。

注意: 您必须了解用于管理交换机的管理 VLAN 与用于传输 L2 数据流的数据 VLAN 之间的区别。管理 VLAN 是您用 global interface vlan vlan-id 命令创建的一个 SVI。请不要将此命令与您用于创建传输第 2 层数据流的数据 VLAN 的命令混淆在一起。在运行 Cisco IOS 软件的 Catalyst 6500/6000 系列交换机上,您可以配置来自 VLAN 数据库的数据 VLAN 或者可以发出 global vlan vlan-id 命令。

完成这些步骤:

  1. 发出以下命令:

    Switch(config)#interface vlan 1 
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    注意: 此示例将 VLAN 1 用作管理 VLAN。默认情况下,VLAN 1 在 VLAN 数据库中。

  2. 如果想要确认接口是否为接入交换机端口,请在所需的物理接口下发出 switchport mode access 命令。

    默认情况下,所有接口都是 L2 接口并且是 VLAN 1 中的接入交换机端口。如果计划将 VLAN 1 用作管理 VLAN,则您不需要在接口下进行配置。但是,如果想要在配置里确认接口的确是接入交换机端口,您需要使用 switchport mode access 命令。

    此示例使用快速以太网 5/32:

    Switch(config)#interface fastethernet 5/32
    Switch(config-if)#switchport mode access
    

    如果发出 show run interface fastethernet 5/32 命令,则现在显示此输出:

    Switch#show run interface fastethernet 5/32
    Building configuration...
    
    Current configuration : 84 bytes
    !
    interface FastEthernet5/32
    switchport mode access
    no snmp trap link-status
    end
  3. 如果想要将管理接口从默认 VLAN 1 更改为另一个 VLAN,请发出 interface vlan vlan-id 命令,以便创建一个新的 SVI。

    然后,您必须发出 switchport access vlan vlan-id 命令,以便将 L2 接口配置为新 VLAN 的一部分。此示例展示以下过程:

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 5/32 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switch access vlan 2
    

    如果发出 show run interface fastethernet 5/32 命令,则现在显示此输出:

    Building configuration... 
    Current configuration : 110 bytes
    !
    interface FastEthernet5/32 
     switchport access vlan 2 
     switchport mode access
    end

    为了使交换机能访问远程网络,您必须满足以下条件之一

    • 为下一跳路由器设置的直接连接到交换机的默认网关

    • 配置的动态路由协议

    如果不路由 IP,请发出 ip default-gateway ip-address 命令,以便配置网关路由器 IP 地址。要配置动态路由,请使用 router routing_protocol 命令。发出 show ip route 命令,以便查看路由表的状态。

为运行 Cisco IOS 软件的 Catalyst 6500/6000 交换机配置一个管理接口

在运行 Cisco IOS 软件的 Catalyst 6500/6000 系列交换机上,所有可路由接口都可用于管理。有三个配置此接口的选项。

选项 1 - 为交换机管理配置一个环回接口。环回接口有许多优点。环回接口是总是打开的虚拟接口。路由到环回接口的数据包将重新路由回 L3 交换机或路由器上,并且在本地进行处理。从环回接口上路由出来、但又不是发往环回接口的 IP 数据包会被丢弃。这意味着环回接口也充当 null 0 接口。环回接口可用作 OSPF 的路由器 ID 等。此示例使用 loopback 0:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

您还必须配置路由协议,以分发分配给环回地址的子网,或者创建静态路由。

选项 2 - 将接口配置为带有 IP 地址的 L3 路由接口。默认情况下,运行 Cisco IOS 软件的 Catalyst 6500/6000 交换机上的所有接口都是 L3。默认情况下,所有接口均已启用,因此您不需要发出 no shutdown 命令。此示例使用快速以太网 5/30:

Switch(config)#interface fastethernet 5/30 
Switch(config-if)#ip address 11.1.1.1 255.0.0.0

如果发出 show running-config interface fastethernet 5/30 命令,则显示此输出:

Building configuration... 
Current configuration : 80 bytes 
! 
interface FastEthernet5/30
no switchport
ip address 11.1.1.1 255.0.0.0 
end

选项 3 - 将 L2 接口配置为特定 VLAN 的一部分。发出 switchport mode access 命令和 switchport access vlan vlan-id 命令,并且使用带有 IP 地址的对应 SVI。

注意: 您必须了解用于管理交换机的管理 VLAN 与用于传输 L2 数据流的数据 VLAN 之间的区别。管理 VLAN 是您用 global interface vlan vlan-id 命令创建的一个 SVI。请不要将此命令与您用于创建传输第 2 层数据流的数据 VLAN 的命令混淆在一起。在运行 Cisco IOS 软件的 Catalyst 6500/6000 系列交换机上,您可以配置来自 VLAN 数据库的数据 VLAN 或者可以发出 global vlan vlan-id 命令。

完成这些步骤:

  1. 发出以下命令:

    Switch(config)#interface vlan 1
    
    !--- Interface VLAN 1 is an SVI.
    
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    注意: 此示例将 VLAN 1 用作管理 VLAN。默认情况下,VLAN 1 在 VLAN 数据库中。

  2. 在所需的物理接口下发出 switchport mode access 命令,以便将默认 VLAN 1 状态下的接口设置为 L2 接口。

    注意: 默认情况下,所有接口都是 L3 接口。

    此示例使用快速以太网 5/32:

    Switch(config)#interface fastethernet 5/32
    Switch(config-if)#switchport mode access
    

    如果发出 show run interface fastethernet 5/32 命令,则现在显示此输出:

    Switch#show run interface fastethernet 5/32
    Building configuration...
    Current configuration : 84 bytes
    !
    interface FastEthernet5/32
     switchport mode access
     no snmp trap link-status
    end
  3. 如果想要将管理接口从默认 VLAN 1 更改为另一个 VLAN,请发出 interface vlan vlan-id 命令,以便创建一个新的 SVI。

    然后,您必须发出 switchport access vlan vlan-id 命令,以便将 L2 接口配置为新 VLAN 的一部分。此示例展示以下过程:

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 5/32 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switch access vlan 2
    

    如果发出 show run interface fastethernet 5/32 命令,则现在显示此输出:

    Building configuration... 
    Current configuration : 110 bytes
    !
    interface FastEthernet5/32 
     switchport access vlan 2 
     switchport mode access
    end

    为了使交换机能访问远程网络,您必须满足以下条件之一

    • 为下一跳路由器设置的直接连接到交换机的默认网关

    • 配置的动态路由协议

    如果不路由 IP,请发出 ip default-gateway ip-address 命令,以便配置网关路由器 IP 地址。要配置动态路由,请使用 router routing_protocol 命令。发出 show ip route 命令,以便查看路由表的状态。

为 Catalyst L2 固定配置交换机配置一个管理接口

Catalyst L2 固定配置交换机运行 Cisco IOS 软件,但是仅为支持 L2 的交换机。这些交换机每次只能有一个活动管理接口。默认管理接口是 VLAN 1。您不能删除在这些交换机上的 VLAN 1。都是,您可以创建另一个用于管理的 VLAN 接口,此部分展示了该示例。

注意: 您必须了解用于管理交换机的管理 VLAN 与用于传输 L2 数据流的 VLAN 之间的区别。管理 VLAN 是您用 global interface vlan vlan-id 命令创建的一个 SVI。请不要将此命令与您用于创建传输第 2 层数据流的数据 VLAN 的命令混淆在一起。在 XL 系列交换机上,您可以使用 vlan database 命令只创建数据 VLAN。在针对 2950 的 Cisco IOS 软件版本 12.1(9)EA1 及以上版本(以及针对 2940、2955 和 2970 的所有软件版本)中,有一个可以配置数据 VLAN 的附加选项。此附加选项是 global vlan vlan-id 命令。

这些示例将快速以太网 0/1 用作接入交换机端口并将其作为管理 VLAN 的成员。要使接口成为 VLAN 1 成员,您不需要进行任何配置,因为默认情况下,所有接口都是 VLAN 1 中的接入交换机端口。

这是第一个示例:

Switch(config)#interface vlan 1
Switch(config-if)#ip address 10.1.1.1 255.0.0.0
Switch(config-if)#end
Switch#

Switch#show run interface vlan 1 
Building configuration...
Current configuration: 
! 
interface VLAN1 
 ip address 10.1.1.1 255.0.0.0 
 no ip directed-broadcast 
 no ip route-cache 
end

Switch#show run interface fastethernet 0/1
Building configuration...
 
Current configuration:
!
interface FastEthernet0/1

!--- All interfaces are access switch ports in VLAN 1 by default.

end
 
Switch#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
VLAN1                      10.1.1.1        YES manual up                    up  
    
FastEthernet0/1            unassigned      YES unset  up                    up

切记您不能删除 VLAN 1 管理接口。如果想要将管理接口从默认 VLAN 1 更改为另一个 VLAN,请发出 interface vlan vlan-id 命令,以便创建一个新的 SVI。然后,您必须发出 switchport access vlan vlan-id 命令,以便将 L2 接口配置为新 VLAN 的一部分。此示例展示以下过程:

注意: 如果管理接口不是 VLAN 1 成员,并且您在交换机上配置以下任一这些命令,则在重新加载以后管理接口可以处于关闭状态:

  • ip ftp source-interface vlan vlan-id

  • ip tftp source-interface vlan vlan-id

  • ip telnet source-interface vlan vlan-id

    使管理接口成为 VLAN 1 的成员。或者,请从配置中删除这些命令或将交换机软件升级到最新镜像,以便解决此问题。

注意: 在 XL 系列交换机上,您可以使用新 SVI 下的可选 management 命令,以便自动关闭 VLAN 1,并将 IP 地址传输到新 VLAN。

Switch(config)#interface vlan 2
Switch(config-if)#ip address 20.1.1.1 255.0.0.0
Switch(config-if)#no shut

!--- Configure an interface to access the new management VLAN.

Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport access vlan 2
Switch(config-if)#end

Switch#

如果发出 show run interface fastethernet 0/1 命令,则现在显示此输出:

Switch#show run interface fastethernet 0/1
Building configuration...
Current configuration : 85 bytes
!
interface FastEthernet 0/1
 switchport access vlan 2
 switchport mode access
end
Switch#

为了使交换机能访问远程网络,您必须拥有为直接与交换机连接的下一跳路由器配置的默认网关。发出 ip default-gateway ip-address 命令,以便配置网关路由器 IP 地址。

为 3550 和 3750 系列交换机配置管理接口

在运行 Cisco IOS 软件的 Catalyst 3550 和 3750 系列交换机上,所有可路由接口都可用于管理。有三个配置此接口的选项。

选项 1 - 为交换机管理配置一个环回接口。环回接口有许多优点。环回接口是总是打开的虚拟接口。路由到环回接口的数据包将重新路由回 L3 交换机或路由器上,并且在本地进行处理。从环回接口上路由出来、但又不是发往环回接口的 IP 数据包会被丢弃。这意味着环回接口也充当 null 0 接口。环回接口可用作 OSPF 的路由器 ID 等。此示例使用 loopback 0:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

您还必须配置路由协议,以分发分配给环回地址的子网,或者创建静态路由。

选项 2 - 将接口配置为带有 IP 地址的 L3 路由接口。默认情况下,运行 Cisco IOS 软件的 Catalyst 3550 或 3750 交换机上的所有接口都是 L2。要将 L2 接口变成 L3 接口,请发出 no switchport 命令,然后配置一个 IP 地址。默认情况下,所有接口均已启用,因此您不需要发出 no shutdown 命令。此示例在 Catalyst 3750 上使用快速以太网 2/0/1:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fastethernet 2/0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 11.1.1.1 255.0.0.0
Switch(config-if)#end
Switch#

如果发出 show running-config interface fastethernet 2/0/1 命令,则显示此输出:

Switch#show running-config interface fastethernet 2/0/1
Building configuration...
Current configuration : 81 bytes
!
interface FastEthernet2/0/1
 no switchport
 ip address 11.1.1.1 255.0.0.0
end
Switch#

选项 3 - 将 L2 接口配置为特定 VLAN 的一部分。发出 switchport mode access 命令和 switchport access vlan vlan-id 命令,并且使用带有 IP 地址的对应 SVI。

完成这些步骤:

  1. 发出以下命令:

    Switch(config)#interface vlan 1
    
    !--- Interface VLAN 1 is an SVI.
    
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    注意: 此示例将 VLAN 1 用作管理 VLAN。默认情况下,VLAN 1 在 VLAN 数据库中。

  2. 如果想要确认接口是否为接入交换机端口,请在所需的物理接口下发出 switchport mode access 命令。

    默认情况下,所有接口都是 L2 接口并且是 VLAN 1 中的接入交换机端口。如果计划将 VLAN 1 用作管理 VLAN,则您不需要在接口下进行配置。但是,如果想要在配置里确认接口的确是接入交换机端口,您需要使用 switchport mode access 命令。

    此示例使用快速以太网 2/0/1:

    Switch(config)#interface fastethernet 2/0/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#end
    

    如果发出 show run interface fastethernet 2/0/1 命令,则现在显示此输出:

    Switch#show run interface fastethernet 2/0/1
    Building configuration...
    Current configuration : 59 bytes
    !
    interface FastEthernet2/0/1
     switchport mode access
    end
    Switch#
  3. 如果想要将管理接口从默认 VLAN 1 更改为另一个 VLAN,请发出 interface vlan vlan-id 命令,以便创建一个新的 SVI。

    然后,您必须发出 switchport access vlan vlan-id 命令,以便将 L2 接口配置为新 VLAN 的一部分。此示例展示以下过程:

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 2/0/1
    Switch(config-if)#switchport access vlan 2
    Switch(config-if)#end
    Switch#

    如果发出 show run interface fastethernet 2/0/1 命令,则现在显示此输出:

    Switch#show run interface fastethernet 2/0/1
    Building configuration...
    Current configuration : 85 bytes
    !
    interface FastEthernet2/0/1
     switchport access vlan 2
     switchport mode access
    end
    Switch#

    为了使交换机能访问远程网络,您必须满足以下条件之一

    • 为下一跳路由器设置的直接连接到交换机的默认网关

    • 配置的动态路由协议

    如果不路由 IP,请发出 ip default-gateway ip-address 命令,以便配置网关路由器 IP 地址。

    如果计划配置动态路由,请记住默认情况下 IP 路由已禁用。您必须发出 global ip routing 命令,以便启用 IP 路由。路由信息协议 (RIP) 是您使用标准的多层软件镜像 (SMI) 时支持的唯一动态路由协议。增强型多层软件镜像 (EMI) 需要获得内部网关路由协议 (IGRP)、增强型 IGRP (EIGRP)、OSPF 和边界网关协议 (BGP) 的支持。要配置动态路由,请使用 router routing_protocol 命令。发出 show ip route 命令,以便查看路由表的状态。


相关信息


Document ID: 10594