IP : 网络地址转换 (NAT)

NAT池和Subnet zero

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文讨论网络地址转换(NAT)池与所有其他IP地址一样受子网零规则支配。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

背景理论

当您配置NAT池,使池内地址成为零子网的一部分时,NAT转换会发生故障。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找有关本文档中所使用的命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/13777/7a.gif

在本例中配置示例,内部设备有NAT路由器的默认路由。外部设备有静态路由对内部设备翻译的地址。NAT路由器有此NAT配置:

ip nat pool test 171.68.1.1 171.68.1.10 netmask  255.255.240.0
ip nat inside source list 7 pool test 

interface s 0
ip address 171.16.4.6 255.255.255.0
ip nat inside

interface s 1
ip address 171.16.6.6 255.255.255.0
ip nat outside

access-list 7 permit host 171.16.4.4

注意在NAT池测验的地址是零子网地址。.因为转换不发生,从内部设备的ping到外部设备发生故障。如果运行debug ip nat命令在NAT路由器,显示这些消息:

NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5

注意: “(a)”在debug输出中意味着转换失败,在发生后的路由。

注意: 为了避免此问题,请配置ip subnet-zero命令在NAT路由器。默认情况下命令在Cisco IOS 软件版本12.0启用。默认情况下在初期的Cisco IOS软件版本中,它没有启用。如果NAT没有适当地配置,当使用与PAT,则NAT转换可以出故障。这些是NAT转换故障代码:

 A = Inside to outside fails after routing
 B = Outside to inside fails before routing
 C = Outside to inside fails after routing 
 D = Helpered fails 
 L = Internally generated packet fails 
 E = Inside to outside fails after routing

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 13777