长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

配置 Cisco 1700/2600/3600 ADSL WIC,以通过 CHAP 与 PAP 实现 PPPoA

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 11 月 12 日) | 反馈


目录


简介

Cisco 1700、2600 和 3600 系列路由器支持非对称数字用户线 (ADSL) WAN 接口卡 (WIC)。全部三平台根本配置同样,但是有差异在硬件方面和在为每一个要求的思科IOSï ¿  ½软件版本。在本文中, Cisco 1700/2600/3600指的是Cisco ADSL WIC。

本文显示在Cisco 6400通用接入集中器(UAC)终止的Cisco ADSL WIC连接Cisco 6130 DSL访问复用器(DSLAM)。每一个配置使用PPP over ATM (PPPoA)。ATM接口配置有AALMUX PPP封装。

一配置显示使用质询握手验证协议(CHAP)的PPPoA。使用得密码认证协议的第二配置显示PPP over ATM。

先决条件

要求

在尝试此配置前,请保证您符合这些要求:

  • Cisco 6400 UAC-NRP IOS软件版本12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS软件版本12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS软件版本12.1(5)DA

使用的组件

本文档中的信息基于以下软件和硬件版本:

要支持在Cisco2600/3600的ADSL WIC,需要这些硬件产品:

  • 2600:机箱WIC槽, NM-2W

  • 3600:NM-1FE1R2W, NM-1FE2W, NM-2FE2W, NM-2W

注意: 对于Cisco3600, WIC NM-1E1R2W、NM-1E2W或者NM-2E2W不支持ADSL。

要支持ADSL WIC,这些是要求的最低Cisco IOS软件版本:

  • Cisco IOS软件版本12.1(5)yb (仅加强版本)在Cisco2600/3600

  • 在Cisco 1700上的的Cisco IOS软件版本IOS 12.1(3)XJ或更高版本(仅加强版本或ADSL功能集)。ADSL功能集由镜像名称中的"y7"确定;例如, c1700-sy7-mz.121-3.XJ.bin。

注意: 当您为Cisco 1700下载镜像时,确定您选择1700镜像名称。不要下载1720或1750镜像;功能不会支持ADSL WIC。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/12961/wicadsl_pppoa_chap_12961a.gif

配置

本文档使用如下所示的配置。

  • 使用CHAP的PPPoA

  • 使用PAP的PPPoA

当您使用interface virtual-template命令使用CHAP的PPPoA时,请配置仅PPP CHAP sent-username username password密码。不支持ppp authentication chap callin命令。在本例中使用CHAP PPPoA的,使用interface dialer命令,不受影响。

Cisco ADSL WIC
Current configuration: 
! 
version 12.1 
!
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
interface FastEthernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 ! 
 hold-queue 224 in 
! 
interface Dialer0 
 ip address 172.18.0.1 255.255.0.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap callin 
 ppp chap hostname username

 ppp chap password password

! 
ip classless
ip route 0.0.0.0.0.0.0.0 dialer0 
! 
dialer-list 1 protocol ip permit 
!
end

访问6400个NRP1
username username password password


 !--- The username and password values must match


 !--- the username and password values of the remote device.
!
interface ATM0/0/0.200 point-to-point
 no ip directed-broadcast
 no ip route-cache 
 pvc 1/301 
  encapsulation aal5mux ppp Virtual-Template11
 !
 interface Virtual-Template11 
  ip address 172.18.0.2 255.255.0.0 
  no ip directed-broadcast 
  ppp authentication chap
! 
ip route 10.0.0.1 255.255.255.255 172.18.0.1

当您使用interface virtual-template命令使用PAP的PPPoA时,请配置只ppp pap sent-username username password password命令。不支持ppp authentication pap callin命令。在本例中使用PAP PPPoA的,使用interface dialer命令,不受影响。

Cisco ADSL WIC
version 12.1 
!
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
interface FastEthernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 ! 
 hold-queue 224 in 
! 
interface Dialer0 
 ip address 172.18.0.1 255.255.0.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp authentication pap callin
ppp pap sent-username username password password

 ! 
ip classless
ip route 0.0.0.0.0.0.0.0 dialer0 
no ip http server 
! 
dialer-list 1 protocol ip permit 

访问6400个NRP1
username <username> password <password>

 !--- The username and password values must match


 !--- the username and password values of the remote device. 
!
interface ATM0/0/0.200 point-to-point
 no ip directed-broadcast
 no ip route-cache 
 pvc 1/301 
  encapsulation aal5mux ppp Virtual-Template11
 !
 interface Virtual-Template11 
  ip address 172.18.0.2 255.255.0.0 
  no ip directed-broadcast 
  ppp authentication pap
! 
ip route 10.0.0.1 255.255.255.255 172.18.0.1

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 12961