长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

配置 Cisco 1700/2600/3600 ADSL WIC 以支持 PPPoE 客户端,并在 Cisco 6400 UAC 上终止

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 11 月 12 日) | 反馈


目录


简介

Cisco 1700、2600 和 3600 系列路由器支持非对称数字用户线 (ADSL) WAN 接口卡 (WIC)。全部三平台根本配置同样,但是有差异在硬件方面和在为每一个要求的思科IOSï ¿  ½软件版本。在本文中, Cisco 1700/2600/3600指的是Cisco ADSL WIC。

该示例配置显示如何支持Point-to-Point Protocol over Ethernet (PPPoE)客户端,当其连接到一个Cisco ADSL WIC的以太网接口上时。

Cisco ADSL WIC配置了 RFC 1483 桥接并终止在一个配置使用一个多点ATM子接口,支持PPPoECisco 6400通用接入集中器(UAC)上。leavingcisco.com

PPPoE功能允许您在简单桥接以太网连接的客户端上启动PPP会话。会话运输在ATM链路通过压缩的以太网桥接帧。会话可以终止在本地交换运营商中心局或互联网服务提供商入网点。

PPPoE是客户端初始化的连接。在客户端前置设备(CPE)侧,有以太网接口卡的(NIC) PC和PPPoE客户端代码设立。该PC和其他PC被连接到ADSL WIC以太网分段。

ADSL WIC ATM interface连接到一个Cisco 6130 DSL访问复用器(DSLAM)并且终止在Cisco 6400 UAC

先决条件

要求

在您尝试此配置前,请保证您使用这些事先需要的软件版本之一:

  • Cisco 6400 UAC-NRP IOS软件版本12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS软件版本12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS软件版本12.1(5)DA

使用的组件

本文档中的信息基于以下软件和硬件版本。

要支持在Cisco2600或3600的ADSL WIC,这些硬件组件要求:

  • 2600:机箱WIC槽, NM-2W

  • 3600:NM-1FE1R2W, NM-1FE2W, NM-2FE2W, NM-2W

注意: 对于Cisco3600, WIC NM-1E1R2W、NM-1E2W或者NM-2E2W不支持ADSL。

这些是要求的最低Cisco IOS软件版本支持ADSL WIC :

  • Cisco IOS软件版本12.1(5)YB (仅加强版本)在Cisco2600或3600

  • 在Cisco 1700上的的Cisco IOS软件版本IOS 12.1(3)XJ或更高版本(仅加强版本或ADSL功能集)。ADSL功能集由镜像名称中的"y7"确定;例如, c1700-sy7-mz.121-3.XJ.bin。

注意: 当您为Cisco 1700下载镜像时,确定您选择1700镜像名称。不要下载1720或1750镜像;功能不支持ADSL WIC。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果是在真实网络,请保证您了解所有命令潜在影响,在您使用使用它前。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/12963/wicadsl_pppoe_1_12963a.gif

配置

本文档使用如下所示的配置。

注意: 在Cisco 6400 NRP配置中,您设置最大传输单元(MTU)。关于更改MTU大小的更多信息,参考在PPPoE拨入连通性的故障排除MTU大小

Cisco ADSL WIC
Current configuration:
!
version 12.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
! 
ip subnet-zero
no ip routing
! 
interface FastEthernet0
no ip address
no ip directed-broadcast
bridge-group 1
!
interface ATM0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 3/100 
encapsulation aal5snap
!
bundle-enable
bridge-group 1
hold-queue 224 in
!
ip classless
no ip http server
! 
bridge 1 protocol ieee
!

line con 0
end

Cisco 6400 NRP
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NRP1
! 
username username password password


!--- The username and password must match client username and password.

! 
redundancy
main-cpu
auto-sync standard
no secondary console enable
ip subnet-zero
ip cef
! 
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
pppoe limit per-mac 101
pppoe limit per-vc 102
! 
interface ATM0/0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
!
interface ATM0/0/0.1 multipoint
 no ip directed-broadcast
pvc 3/100
encapsulation aal5snap
protocol pppoe
! 
interface Ethernet0/0/1
ip address 10.0.0.1  255.0.0.0
no ip directed-broadcast
!
interface Ethernet0/0/0
no ip address
no ip directed-broadcast
shutdown
!
interface FastEthernet0/0/0
no ip address
no ip directed-broadcast
half-duplex
!
interface Virtual-Template1

!--- Do not use a static IP assignment within


!--- a virtual template; routing problems can occur.

ip mtu 1492
ip unnumbered Ethernet0/0/1

!--- Always use the ip unnumbered command


!--- when configuring a virtual template.

no ip directed-broadcast
ip mroute-cache
peer default ip address pool pool name

ppp authentication chap
!
ip local pool pool name 10.0.0.2 10.0.0.12  
ip classless
no ip http server
! 
line con 0 
!
end

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 12963