长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

配置 Cisco 1700/2600/3600 ADSL WIC,以实现 NAT、DHCP 服务器、Easy IP,并使用 PPPoA (aal5mux ppp)

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 11 月 12 日) | 反馈


目录


简介

Cisco 1700、2600 和 3600 系列路由器支持非对称数字用户线 (ADSL) WAN 接口卡 (WIC)。所有三个平台的基本配置是相同的。然而,有差异现在硬件里和在要求的思科IOSï ¿  ½软件版本为每一个。在本文中, Cisco 1700/2600/3600指的是Cisco ADSL WIC。

本文显示一个 Cisco ADSL WIC 连接到一个 Cisco 6130 DSL 访问复用器(DSLAM) 并终止在一个Cisco 6400 通用接入集中器(UAC)上。Cisco ADSL WIC 路由器已经配置了 PPP over ATM(PPPoA)和网络地址转换(NAT),并且IP地址协商已经开启。Cisco ADSL WIC 同时为它的本地以太网客户端起到服务器的作用。

先决条件

要求

在尝试此配置前,请保证您符合这些要求。在您尝试此配置前,请保证您使用这些事先需要的软件版本之一:

  • Cisco 6400 UAC-NRP IOS软件版本12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS软件版本12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS软件版本12.1(5)DA

使用的组件

本文档中的信息基于以下软件和硬件版本。

要支持在Cisco2600/3600的ADSL WIC,需要这些硬件产品:

  • 2600:机箱WIC槽, NM-2W

  • 3600:NM-1FE1R2W, NM-1FE2W, NM-2FE2W, NM-2W

注意: 对于Cisco3600, WIC NM-1E1R2W、NM-1E2W或者NM-2E2W不支持ADSL。

要支持ADSL WIC,至少这些Cisco IOS软件版本要求:

  • Cisco IOS软件版本12.1(5)yb (仅加强版本)在Cisco2600/3600

  • 在Cisco 1700上的的Cisco IOS软件版本IOS 12.1(3)XJ或更高版本(仅加强版本或ADSL功能集)。ADSL功能集由镜像名称中的"y7"确定;例如, c1700-sy7-mz.121-3.XJ.bin。

注意: 当您下载Cisco 1700的时镜像,请保证您选择镜像名称1700。不要下载1720或1750镜像;功能不支持ADSL WIC。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

关于文件规则的更多信息,请使用Cisco技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文在图表中使用表示的此网络设置。

/image/gif/paws/12962/wicadsl_pppoa_nat_dhcp_12962a.gif

配置

本文档使用以下配置。

Cisco ADSL WIC
! version 12.1 
service timestamps debug datetime msec 
service timestamps datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
ip dhcp excluded-address 10.0.0.1 
!
ip dhcp pool pool name
 
 network 10.0.0.0 255.0.0.0
   default-router 10.0.0.1 
! 
interface FastEthernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 ip nat inside 
 no ip mroute-cache
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 !
 hold-queue 224 in 
! 
interface Dialer0 
 ip address negotiated 
 no ip directed-broadcast 
 ip nat outside 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp pap sent-username username password password

! 
ip nat inside source list 1 interface Dialer0 overload
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
dialer-list 1 protocol ip permit
! 
end

Cisco Access 6400 NRP1
! interface ATM0/0/0.200 point-to-point 

!--- The username and password values must match
!--- the username and password values of the remote device.

 no ip directed-broadcast
 no ip route-cache
 pvc 1/301
  encapsulation aal5mux ppp Virtual-Template11 
!
interface Virtual-Template11 
 ip unnumbered Ethernet0/0/0 
 no ip directed-broadcast 
 peer default ip address pool pool name

 ppp authentication pap 
!
ip local pool pool name 172.17.0.1 172.17.0.10

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 12962