路由器 : 思科 800 系列路由器

配置 Cisco 827 路由器,以通过 PPPoA 实现 NAT、DHCP 服务器以及 Easy IP (aal5mux ppp)

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 11 月 11 日) | 反馈


目录


简介

此示例配置演示一个连接到 Cisco 6130 数字用户线接入复用器 (DSLAM) 的 Cisco 827 数字用户线 (DSL) 路由器,该路由器在 Cisco 6400 通用接入集中器 (UAC) 上终止。Cisco 827配置了PPP over ATM (PPPoA),而且还启用了网络地址转换(NAT)和IP地址协商。Cisco 827 还可用作其本地以太网客户端的服务器。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • Cisco 827-4V客户端前置设备(CPE) IOSï ¿  ½软件版本12.1(1)XB

  • Cisco 6400 UAC-NRP IOS软件版本12.0(7)DC

  • Cisco 6400 UAC-NSP IOS软件版本12.0(4)DB

  • Cisco 6130 DSLAM-NI2 IOS软件版本12.1(1)DA

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/12888/827pppoa_nat_dhcp.gif

配置

本文档使用如下所示的配置。

Cisco 827
! 
version 12.1 
service timestamps debug datetime msec 
service timestamps datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
ip dhcp excluded-address 10.0.0.1 
!
ip dhcp pool pool name
   network 10.0.0.0 255.0.0.0
   default-router 10.0.0.1 
! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 ip nat inside 
 no ip mroute-cache
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 !
 hold-queue 224 in 
! 
interface Dialer0 
 ip address negotiated 
 no ip directed-broadcast 
 ip nat outside 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp pap sent-username username password password
! 
ip nat inside source list 101 interface Dialer0 overload
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
no ip http server 
! 
access-list 101 permit ip 10.0.0.0 0.255.255.255 any 
dialer-list 1 protocol ip permit
! 
voice-port 1 
 timing hookflash-in 0
!
voice-port 2
 timing hookflash-in 0 
! 
voice-port 3
 timing hookflash-in 0 
!
voice-port 4 
 timing hookflash-in 0 
! 
end

Cisco Access 6400 NRP1
username username password password

!--- The username and password values must  
!--- match the username and password values 
!--- of the remote device.
  
!
interface ATM0/0/0.200 point-to-point 
 no ip directed-broadcast
 no ip route-cache
 pvc 1/301
  encapsulation aal5mux ppp Virtual-Template11 
!
interface Virtual-Template11 
 ip unnumbered Ethernet0/0/0 
 no ip directed-broadcast 
 peer default ip address pool pool name
 ppp authentication pap 
!
ip local pool pool name 172.17.0.1 172.17.0.10

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 12888