IP : 开放最短路径优先 (OSPF)

OSPF 如何将默认路由注入到次末节区域中

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

本文显示开放式最短路径优先(OSPF)如何注入一个默认路由到非末节区域。NSSA的区域边界路由器(ABR),默认情况下, 不产生默认路由到NSSA。您必须使用area <x> nssa default-information originate 命令。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用此图所示的网络设置。

/image/gif/paws/47870/ospfdb11a.gif

配置

本文档使用此处所示的配置。

路由器 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 area 1 nssa

end

路由器 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 nssa default-information originate

end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

在次末节区域检查OSPF数据库

要看到OSPF数据库如何查找,请使用show ip ospf database命令

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

           Router Link States (Area 0) 

Link ID    ADV Router     Age     Seq#          Checksum   Link count 
2.2.2.2    2.2.2.2        600     0x80000001    0x9583          1 

           Summary Net Link States (Area 0) 

Link ID    ADV Router      Age     Seq#          Checksum 
5.0.0.0     2.2.2.2        600     0x80000001    0x8E61 

           Router Link States (Area 1) 

Link ID    ADV Router     Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1        864     0x8000005E     0xD350         2 
2.2.2.2    2.2.2.2        584     0x8000001E     0xF667         2 

           Summary Net Link States (Area 1) 

Link ID    ADV Router     Age     Seq#          Checksum 
6.0.0.0    2.2.2.2        585     0x80000004    0xA87C 

           Type-7 AS External Link States (Area 1) 

Link ID    ADV Router     Age     Seq#          Checksum   Tag 
0.0.0.0    2.2.2.2        601     0x80000001    0xD0D8      0 

NSSAABR生成一个type 7和一个LSA带有Link ID 0.0.0.0这是它的OSPF配置中area 1 nssa default-information-originate命令的结果。

r2.2.2.2#show ip ospf database nssa-external 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-7 AS External Link States (Area 1) 

  LS age: 650 
  Options: (No TOS-capability, No Type 7/5 translation, DC) 
  LS Type: AS External Link 
  Link State ID: 0.0.0.0 (External Network Number ) 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xD0D8 
  Length: 36 
  Network Mask: /0 
        Metric Type: 2 (Larger than any link state path) 
        TOS: 0 
        Metric: 1 
        Forward Address: 0.0.0.0 
        External Route Tag: 0 

ABR生成0.0.0.0 type 7 LSA,即使它没有默认路由。

r2.2.2.2#show ip route 0.0.0.0 
% Network not in table 

r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:00:18, Serial2/1/0 
O*N2 0.0.0.0/0 [110/1] via 5.0.0.2, 00:00:18, Serial2/1/0 

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 47870