长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

配置 Cisco 827 路由器,以支持 PPPoE 客户端,并在 Cisco 6400 UAC 上终止

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 11 月 11 日) | 反馈


目录


简介

此配置示例显示如何支持Point-to-Point Protocol over Ethernet (PPPoE)客户端,当其已连接到Cisco 827数字用户线路DSL路由器的以太网接口时。

Cisco 827配置有RFC1483桥接并且终止在一台Cisco 6400通用接入集中器(UAC)上,该集中器被配置为使用多点 ATM 子接口支持PPPoE

PPPoE功能允许您在简单桥接以太网连接的客户端上启动PPP会话。会话在异步传输模式(ATM)链路传输通过被封装的以太网桥接帧。会话可以终止在本地交换运营商中心局或互联网服务提供商入网点。

PPPoE是客户端初始化的连接。在客户端前置设备(CPE)侧,有以太网接口卡的(NIC) PC和PPPoE客户端代码设立。PC和其他PC已连接到827以太网分段。

827 ATM接口已连接到Cisco6130数字用户线路访问多路复用器(DSLAM)并终止在一个Cisco 6400 UAC上。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

本文档中的信息基于以下软件版本。

  • Cisco 827-4V CPE Cisco IOSï ¿  ½软件版本12.1(1)XB

  • Cisco 6400 UAC-NRP IOS软件版本12.0(7)DC

  • Cisco 6400 UAC-NSP IOS软件版本12.0(4)DB

  • Cisco 6130 DSLAM-NI2 IOS软件版本12.1(1)DA

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/12889/827pppoe.gif

配置

本文档使用如下所示的配置。

注意: 在Cisco 6400 NRP配置中,您设置最大传输单元(MTU)。关于更改MTU大小的更多信息,请参阅在PPPoE拨入连通性的故障排除MTU大小

  • Cisco 827

  • Cisco 6400 NRP

Cisco 827
Current configuration:
!
version 12.1
no service pad
service timestamps debug datetime msec              
service timestamps log datetime msec
no service password-encryption
!
hostname R1
! 
ip subnet-zero
no ip routing
! 
interface Ethernet0
no ip address
no ip directed-broadcast
bridge-group 1
!
interface ATM0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 3/100 
encapsulation aal5snap
!
bundle-enable
bridge-group 1
hold-queue 224 in
!
ip classless
no ip http server
! 
bridge 1 protocol ieee
!
voice-port 1
timing hookflash-in 0
!
voice-port 2
timing hookflash-in 0
!
voice-port 3
timing hookflash-in 0
!
voice-port 4
timing hookflash-in 0
!
!
line con 0
end

Cisco 6400 NRP
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NRP1
! 
username <username> password <password>

!--- Username/password must match 
!--- client username/password.

! 
redundancy
main-cpu
auto-sync standard
no secondary console enable
ip subnet-zero
ip cef
! 
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
pppoe limit per-mac 101
pppoe limit per-vc 102
! 
interface ATM0/0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
!
interface ATM0/0/0.1 multipoint
 no ip directed-broadcast
pvc 3/100
encapsulation aal5snap
protocol pppoe
! 
interface Ethernet0/0/1
ip address 10.0.0.1  255.0.0.0
no ip directed-broadcast
!
interface Ethernet0/0/0
no ip address
no ip directed-broadcast
shutdown
!
interface FastEthernet0/0/0
no ip address
no ip directed-broadcast
half-duplex
!
interface Virtual-Template1

!--- Do not use a static IP assignment within a 
!--- virtual template; routing problems can occur.

ip mtu 1492
ip unnumbered Ethernet0/0/1

!--- Always use the ip unnumbered command when 
!--- configuring a virtual template.
 
no ip directed-broadcast
ip mroute-cache
peer default ip address pool <pool name> 
ppp authentication chap
!
ip local pool <pool name> 10.0.0.2 10.0.0.12  
ip classless
no ip http server
! 
line con 0 
!
end

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 12889