长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

配置 Cisco 1700/2600/3600 ADSL WIC 以使用 IRB 与通过 RFC1483 桥接进行的 NAT

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

Cisco 1700、2600 和 3600 系列路由器支持非对称数字用户线 (ADSL) WAN 接口卡 (WIC)。全部三平台根本配置同样,但是有差异在硬件方面和在为每一个要求的思科IOS�软件版本。在本文档中,Cisco 1700/2600/3600 将称作“Cisco ADSL WIC”。

该示例配置显示了一个Cisco ADSL WIC连接到一个Cisco 6130数字用户线路访问多路复用器(DSLAM),终止在一个Cisco 6400通用接入集中器(UAC)

Cisco ADSL WIC 配置了RFC1483桥接和集成路由和桥接(IRB),运行网络地址转换(NAT)

Cisco 6400 ATM接口配置了路由的网桥封装(RBE)

对Cisco 6400,在Cisco 6400节点路由处理器(NRP)的ATM RBE功能寻址在跨接的从末端桥接LAN的RFC1483以太网流量的IP。

在配置为route-bridged 模式的ATM接口上收到的桥接IP包通过IP报头被路由。界面利用stub LAN结构的特性常用为DSL存取和在IRB上获得更完善的性能和灵活性。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • Cisco 6400 UAC-NRP IOS软件版本12.1(3)DC1

  • Cisco 6400 UAC-Node交换机处理器(NSP) IOS软件版本12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS软件版本12.1(5)DA

  • 在Cisco 2600机箱WIC插槽和NM-2W的ADSL WIC

  • 在Cisco3600的ADSL WIC - NM-1FE1R2W、NM-1FE2W、NM-2FE2W和NM-2W

注意: 对于Cisco3600,下列不支持ADSL WIC :

  • NM-1E1R2W

  • NM-1E2W

  • NM-2E2W

要支持ADSL WIC,以下最低Cisco IOS软件版本要求:

  • Cisco IOS软件版本12.1(5)yb (仅加强版本)在Cisco2600/3600上。

  • Cisco IOS软件版本12.1(3)XJ或以上(仅加强版本或ADSL功能集)在Cisco 1700。ADSL功能集由镜像名称中的"y7"确定;例如, c1700-sy7-mz.121-3.XJ.bin。

    当您为Cisco 1700下载镜像时,确定您选择1700镜像名称。不要下载1720或1750镜像;功能不会支持ADSL WIC。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/12969/wicadsl_rfc_irb_nat_1.gif

配置

本文档使用如下所示的配置。

Cisco ADSL WIC
Current configuration: 
! 
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1
!
ip subnet-zero 
!
bridge irb 
! 
interface FastEthernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 ip nat inside 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 4/100 
  encapsulation aal5snap 
 ! 
 bundle-enable 
 bridge-group 1 
 hold-queue 224 in 
! 
interface BVI1 
 ip address 172.16.0.1 255.255.0.0 
 no ip directed-broadcast 
 ip Nat outside 
! 
ip Nat inside source list 1 interface BVI1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 <next hop IP address>

!--- The next hop IP address is also called the default
!--- gateway and is provided by your ISP. For this example,
!--- one valid default gateway could be the loopback 
!--- interface of the Cisco 6400 NRP, 172.16.0.2.

no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
bridge 1 protocol ieee 
 bridge 1 route ip 
! 
end 

Cisco 6400 NRP -示例1
Current configuration: 
! 
version 12.0 
no service pad 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 

! 
redundancy 
 main-cpu 
 no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback1 
 ip address 172.16.0.2 255.255.0.0 
 no ip directed-broadcast 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no ATM ilmi-keepalive 
! 
interface ATM0/0/0.4 point-to-point

!--The interface ATM0/0/0.4 point-to-point uses IP 
!--unnumbered Loopback1 for its IP address requirements.
 
 ip unnumbered Loopback1 
 no ip directed-broadcast 
 no ip route-cache 
 ATM route-bridged ip 
 PVC 4/100 
  encapsulation aal5snap 
 ! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 
ip route 172.16.0.1 255.255.255.255 ATM0/0/0.4 
end 

Cisco 6400 NRP -示例2
Current configuration: 
! 
version 12.0 
no service pad 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 

! 
redundancy 
 main-CPU 
 no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no ATM ilmi-keepalive 
! 
interface ATM0/0/0.4 point-to-point 
 ip address 172.16.0.2 255.255.0.0 
 no ip directed-broadcast 
 no ip route-cache 
 ATM route-bridged ip 
 PVC 4/100 
  encapsulation aal5snap 
 ! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 
ip route 172.16.0.1 255.255.255.255 ATM0/0/0.4
end

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 12969