长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

Cisco DSL路由器配置与故障排除指南- 静态IP地址的Cisco DSL路由器PPPoA

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

您的 Internet 服务提供商 (ISP) 已向您的 Cisco 数字用户线 (DSL) 路由器分配一个动态公共 IP 地址。

提示:如果不熟悉如何配置Cisco设备,并且希望按照逐步的操作进行配置,参考PPPoA的逐步配置与静态IP地址的

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

要执行的任务

  • 设计一个您的专用LAN的编址方案。

  • 在Cisco DSL路由器以太网接口上配置的一个IP地址和子网掩码。

  • 配置ATM接口(异步数字用户线路(ADSL)接口)有ATM永久虚拟电路(PVC)和封装的Cisco DSL路由器。

  • 创建并且配置Cisco DSL路由器的拨号接口点对点协议的在ATM (PPPoA)与静态IP地址。

  • 对NAT :配置在Cisco DSL路由器的NAT允许共享拨号接口的静态公网IP地址。

    • 可选:NAT池,如果您的ISP提供了额外的IP地址。

    • 可选:静态NAT,如果互联网用户需要对内部服务器的访问。

  • 在每个主机PC上配置IP地址、子网掩码、默认网关和域名系统(DNS)服务器。

    或者,如果想要Cisco DSL路由器分配您的PC客户端的动态IP地址,请配置每个PC通过DHCP自动地得到IP地址和DNS服务器。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

配置

提示:如果不熟悉如何配置Cisco设备,并且希望按照逐步的操作进行配置,参考PPPoA的逐步配置与静态IP地址的

有静态IP地址的Cisco DSL路由器

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 pvc <vpi/vci>
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

!
interface dialer1
 ip address <ip address> subnet mask <subnet mask> 
 no ip directed-broadcast

!--- For NAT:

 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username> 
 ppp chap password <password> 
 ppp pap sent-username <username> password <password> 
!

!--- For NAT:

ip nat inside source list 1 interface dialer1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

验证

当前没有可用于此配置的验证过程。

故障排除

如果ADSL服务不工作,请参考PPPoA故障排除


相关信息


Document ID: 71110