IP : 开放最短路径优先 (OSPF)

通过点到多点链路连接的OSPF路由器

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档说明通过点对多点链路相连的两个开放最短路径优先 (OSPF) 路由器。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/47862/ospfdb3a.gif

配置

本文档使用以下配置:

路由器 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 ip ospf network point-to-multipoint
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

路由器 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.2 255.0.0.0
 ip ospf network point-to-multipoint
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

  • show ip ospf database -显示Link State Advertisement (LSA)列表并且键入他们到连结状态数据库。此列表仅显示 LSA 报头中的信息。

  • show ip ospf database [router] [link-state-id] -显示在数据库中的一台路由器所有的LSA列表。LSA是由每个路由器生产的。这些基本LSA列出所有路由器链路或接口,以及状态和链路流出的开销。他们应只在产生的区内被泛洪。

检查 OSPF 数据库

为了看到给的OSPF数据库看起来此网络环境,如何查看输出show ip ospf database命令

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#           Checksum   Link count 
1.1.1.1  1.1.1.1       206    0x8000000A     0x158C       3 
2.2.2.2  2.2.2.2       206    0x8000000B     0x791        3 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 224 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, Link State Id is always the same 
  !--- as the Advertising Router (next line).

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created 
  !--- this LSA.

  LS Seq Number: 8000000A 
  Checksum: 0x158C 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point) 
   
 !--- This line shows that this router(1.1.1.1) is a 
	   !--- neighbor with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1 
     
!--- This line shows the interface on this router 
	    !--- (1.1.1.1) that connects the neighbor (2.2.2.2).

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64  
       
!--- The OSPF cost of the link is 64.


    Link connected to: a Stub Network 
    
!--- This router's (1.1.1.1) interface on the 
    !--- point-to-multipoint network. 

     (Link ID) Network/subnet number: 5.0.0.1 
     (Link Data) Network Mask: 255.255.255.255
     
!--- Notice the mask. Only the interface is advertised,
     !--- not the whole subnet. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 0
      
 !--- The OSPF cost for this router to reach its 
       !--- own interface is zero. 


    Link connected to: a Stub Network
	
!--- Represents the subnet of the Ethernet segment 4.0.0.0/8. 

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
	   
!--- The cost of the link is 10.


r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 253 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000000B 
  Checksum: 0x791 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.2 
     (Link Data) Network Mask: 255.255.255.255 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 0 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10

计算最短路径

此部分从Router2.2.2.2的角度计算最短路径树。

Router2.2.2.2在其自己的LSA中查找,发现Router1.1.1.1是邻居。路由器2.2.2.2查看1.1.1.1's路由器LSA验证1.1.1.1看到2.2.2.2作为邻居。如果两个路由器互相看见作为邻居,则他们被认为可及的。

每个路由器也检查其本地邻居表(您能检查它使用show ip ospf neighbor命令)验证其接口和邻居的接口在共同的IP子网。如果他们是,路由器安装在他们的邻居的路由器LSA列出的所有末端网络的路由。

在本例中,Router 2.2.2.2 保存了到4.0.0.0/8的路由在其路由表中,因为Router 1.1.1.1列出4.0.0.0/8在其自己的路由器LSA中作为一个末端网络。路由器1.1.1.1也列出了5.0.0.1/32作为残余部分,是其在点到多点网络的接口。所以,路由器2.2.2.2安装5.0.0.1/32的OSPF路由在其路由表里。

Router 2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:09:26, Serial0/1/0 
O    5.0.0.1/32 [110/64] via 5.0.0.1, 00:09:26, Serial0/1/0
  
Router 1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 5.0.0.2, 00:00:49, Serial2/1/0 
O    5.0.0.2/32 [110/64] via 5.0.0.2, 00:00:49, Serial2/1/0

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 47862