拨号和接入 : 综合业务数字网络 (ISDN),随路信令 (CAS)

使用isdn incoming-voice data和dialer voice-call配置语音数据(DoV)

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文提供了一个使用isdn incoming-voice data 和 dialer voice-call命令配置语音数据(DoV)的配置示例。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • Cisco IOS�软件版本11.3或以上。

  • 您可以使用任一具有ISDN接口的路由器。但是您必须确保电话公司支持DOV,且不出现数据损坏。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

背景理论

话音数据(DOV)使您能够使用ISDN线路在语音呼叫上发送数据。ISDN专线既可支持数据呼叫也可支持语音呼叫。使用ISDN线路互连的两个路由器一般使用数据呼叫(64 kbps或者56 kbps)。语音呼叫由电话或者传真机发出。话音呼叫还可以通过连接至模拟调制解调器的设备发出(例如使用普通旧式电话服务[POTS]专线拨号的PC机)。

在一些情况下,用户感兴趣的可能是使用ISDN线路对两个相连接的路由器进行语音呼叫,当他们在考虑数据呼叫和语音呼叫之间的价格差异时尤为如此。ISDN专线通常对所有呼叫(本地的、长途的以及国际的)提供按呼叫计费。

在有些情况下,语音呼叫的价格比数据呼叫的价格要更为低廉。为了使路由器能在两条ISDN线路之间使用语音呼叫进行通讯,需要进行认真的配置,让路由器了解:主叫应以语音呼叫始发,而被叫的语音呼叫应作为数据呼叫处理。在始发端(主叫),请使用map-class选项将呼叫定义为语音呼叫:

map-class dialer name

dialer voice-call

该映射级定义一个行为,且需应用于需要这个行为的ISDN接口。下面是有关拨号映射或拨号串命令上的映射级行为的例子。

dialer map protocol address class map class name host name [broadcast] phone number

dialer string电话号码类映射

有关这两个命令的完整句法,请参Cisco IOS 软件 文档。

在来话端(被叫方),请在物理接口下添加isdn incoming - voice data命令。请记住,所有呼入的语音呼叫将作为数据呼叫处理。如果您使用的平台支持BRI上的调制解调器呼叫,您将无法配置特殊的接口来支持这两种功能。一个特定的接口可以将语音呼叫作为调制解调器呼叫处理,也可以作为DOV呼叫处理,但不能同时作为两种呼叫处理。

注意: 配置特定接口处理语音呼叫作为调制解调器呼叫或语音呼叫作为DOV呼叫是可能的。但是,这要求您对资源池管理(RPM)进行配置。有关RPM的详情,请参阅 资源库管理 文档。资源迟管理。

请注意DOV有有限可靠性。在两条ISDN专线之间的呼叫将支持端到端数字通路。电话公司用于设定数据与话音呼叫的设备、专线以及其它资源通常都是一样的。但是,它们也可能会有所不同。数字语音的传输比数据传输更具有灵活性。对于ISDN数据呼叫,电话网络可保证在64 kbps或56 kbps的数字通路上进行传输。对于语音呼叫,电话网络可以使用不同的方法对比特流进行路由与变换,而不影响到语音质量,但是,这种发送方式破坏了所有的数据。因此,DOV无法和某些ISDN线路工作。请在配置该功能之前核查您的电话公司是否可以处理DOV呼叫,否则呼叫建立虽可成功,但数据将被破坏。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/14964/briipun.gif

配置

本文档使用如下所示的配置。

路由器 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.10.186.133 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5556700 class DOV

! --- The router will use the map-class DOV when dialing this number
! --- The map-class named DOV is defined below

 dialer load-threshold 5 outbound
 dialer-group 1
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
map-class dialer DOV

! --- map class named DOV is applied to the dialer string under 
! --- the physical interface

 dialer voice-call

! --- Outgoing call is treated as a voice call

!
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

路由器 2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 isdn incoming-voice data

! --- Incoming voice calls will be treated as data calls
! --- An interface cannot accept modem calls and DOV calls without RPM

 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.186.129
ip route 10.10.186.128 255.255.255.240 BRI0
no ip http server

dialer-list 1 protocol ip permit

line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug dialer - 显示关于所有呼叫发生的原因信息。这主要用于判断路由器是否始发出了呼叫。

  • debug isdn q931 -当用户拨入来查看ISDN呼叫发生时,对ISDN的连接进行检查(例如连接是否丢失)。您还可以通过该调试 输出来确定承载 容量(它显示该呼叫是数字的还是话音的)。

  • debug ppp nego - 查看PPP协商详情。

  • debug ppp chap - 检查认证情况。

调试输出

以下debug isdn q931输出显示连接使用DOV的呼叫。maui-soho-01 (客户端)拨号maui-nas-08 (服务器)。注意呼叫的承载容量表明他们是语音呼叫,正如所料。maui-nas-08配置处理呼入语音呼叫,数据呼叫(与调制解调器呼叫相对),并且呼叫连接。

maui-soho-01#ping 10.8.186.134 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.8.186.134, timeout is 2 seconds:
Aug 17 15:48:12.523: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x03

! --- Setup message for outgoing call

Aug 17 15:48:12.531:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.543:         Channel ID i = 0x83
Aug 17 15:48:12.550:         Keypad Facility i = '5556700'
Aug 17 15:48:12.908: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x83

Aug 17 15:48:12.916:         Channel ID i = 0x89

Aug 17 15:48:12.927:         Locking Shift to Codeset 5
Aug 17 15:48:12.931:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098001, '<'
Aug 17 15:48:13.130: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x83

! --- maui-nas-08 has accepted the call and responded with the 
! --- CONNECT message

Aug 17 15:48:13.142:         Locking Shift to Codeset 5
Aug 17 15:48:13.150:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098909, 'Connected', 0x80010B8001, '('
Aug 17 15:48:13.217: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up.
Aug 17 15:48:13.249: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x03
Aug 17 15:48:14.372: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up
Aug 17 15:48:19.185: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5556700

以下debug 从maui - nas - 08(服务器端)获得。请注意承载容量显示该呼叫为语音呼叫。NAS已被配置,对在该接口上将呼入的话音呼叫作为数据呼叫处理。

maui-nas-08#
Aug 17 15:48:12.765: ISDN BR2/0: RX <-  SETUP pd = 8  callref = 0x13

! --- Setup message for incoming call

Aug 17 15:48:12.765:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.765:         Channel ID i = 0x89
Aug 17 15:48:12.765:         Signal i = 0x40 - Alerting on - pattern 0 
Aug 17 15:48:12.765:         Called Party Number i = 0xC1, '5556700', 
Plan:ISDN, Type:Subscriber(local)
Aug 17 15:48:12.765:         Locking Shift to Codeset 5
Aug 17 15:48:12.765:         Codeset 5 IE 0x2A  i = 0x808001038001118001, '<'

Aug 17 15:48:12.769: ISDN BR2/0: Event: Received a DATA call from  
on B1 at 64 Kb/s

! --- The incoming voice call (on int bri 2/0) is treated as a data call
! --- This is configured (in interface config mode) using 
! --- isdn incoming-voice data

Aug 17 15:48:12.769: ISDN BR2/0: TX ->  CALL_PROC pd = 8  callref = 0x93
Aug 17 15:48:12.773:         Channel ID i = 0x89
Aug 17 15:48:12.773: %LINK-3-UPDOWN: Interface BRI2/0:1, changed state to up
Aug 17 15:48:12.773: BR2/0:1 PPP: Treating connection as a callin
Aug 17 15:48:12.773: BR2/0:1 PPP: Phase is ESTABLISHING, Passive Open
Aug 17 15:48:12.773: BR2/0:1 LCP: State is Listen
Aug 17 15:48:13.073: ISDN BR2/0: TX ->  CONNECT pd = 8  callref = 0x93

! --- The call is accepted and nas-08 responds with the CONNECT message

Aug 17 15:48:13.073:         Channel ID i = 0x89
Aug 17 15:48:13.121: ISDN BR2/0: RX <-  CONNECT_ACK pd = 8  callref = 0x13


! ---Output omitted

...

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 14964