长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

Cisco DSL路由器配置与故障排除指南-具有单个静态IP地址的RFC1483路由的逐步配置

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

您的 Internet 服务提供商 (ISP) 已向您的 Cisco DSL 路由器分配一个静态公共 IP 地址。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置过程

重要信息:在您开始前,请结束PC上可能监控您的COM端口的所有程序。设备例如PDA和数字照相机在系统托盘经常安置程序,使您的COM端口不可用于配置您的Cisco DSL路由器。

连接Cisco DSL路由器和您的PC

控制台连接用反转电缆建立Cisco DSL路由器的控制台端口到PC的COM端口的连接。包括在Cisco DSL路由器上的控制台电缆是一个平的浅蓝色电缆。关于反转电缆的管脚引线或者一RJ-45到DB9转换器的管脚引线的更多信息,请参见控制台和Aux端口的线缆指南

  1. 连接Cisco控制台电缆一端的RJ-45接头到Cisco DSL路由器的控制台端口。

  2. 连接控制台电缆另一端的RJ-45接头到RJ-45-DB9转换器。

  3. 连接DB9接头到您PC的打开的COM端口。

开始并且设置超级终端

完成这些步骤:

  1. 启动PC上的超级终端程序。

  2. 设置您的超级终端会话。

    1. 为您的会话分配一个名称并且点击OK

    2. 在Connect To窗口,请点击Cancel

    3. 选择File > Properties

    4. 从属性窗口,请入Connect Using列表并且选择您连接控制台电缆的DB9末端的COM端口。

    5. 从属性窗口单击配置并且填写这些值:

      • 比特 / 秒:9600

      • 数据位:8

      • 奇偶校验:

      • 停止位:1

      • 流量控制:

    6. 单击 Ok

    7. 从Call菜单,单击Disconnect

    8. 从Call菜单,单击Call

    9. 请按Enter直到您在超级终端窗口看到一个路由器提示。

清除在Cisco DSL路由器的现有配置

完成这些步骤:

  1. 在路由器提示窗口输入enable进入特权模式。

    Router>enable
    Router#
    
    !--- The # symbol indicates that you are in privileged mode.
    
    
  2. 清除路由器上的现有配置。

    Router#write erase
    
  3. 重新载入路由器,它会以一个空白启动配置启动。

    Router#reload
    System configuration has been modified. Save? [yes/no]:no
    Proceed with reload? [confirm]yes
    
    !--- The router reload can take a few minutes.
    
    
  4. 在路由器重新载入了后,再进入特权模式。

    Router>enable
    Router#

配置Cisco DSL路由器

完成下面这些步骤。

  1. 配置service timestamp以适当地记录和显示在故障排除部分的debug 输出

    Router#configure terminal
    Router(config)#service timestamps debug datetime msec
    Router(config)#service timestamps log datetime msec
    Router(config)#end
    
  2. 当您配置路由器时,禁用在您的Cisco DSL路由器的logging console为了抑制也许被触发的控制台信息。

    Router#configure terminal
          Router(config)#no logging console
          Router(config)#end
    
  3. 配置ip routingip subnet-zeroip classless以在路由配置选项中提供灵活性。

    Router#configure terminal
    Router(config)#ip routing
    Router(config)#ip subnet-zero
    Router(config)#ip classless
    Router(config)#end
    
  4. 在Cisco DSL路由器以太网接口上配置的一个IP地址和子网掩码。

    对于网络地址转换(NAT) :(可选)请在以太网接口启用NAT Inside。

    Router#configure terminal
    Router(config)#interface ethernet 0
    Router(config-if)#ip address <ip address> <subnet mask>
    
    !--- For NAT:
    
    Router(config-if)#ip nat inside
    Router(config-if)#no shut
    Router(config-if)#end
    
  5. 配置您的Cisco DSL路由器ATM接口以no shut命令为了启动接口。

    Router#configure terminal
    Router(config)#interface atm 0
    Router(config-if)#no shut
    Router(config-if)#end
    
  6. 配置您的有ATM永久虚拟电路(PVC)和封装类型的Cisco DSL路由器ATM子接口。

    Router#configure terminal
    Router(config)#interface atm 0.1 point-to-point
    Router(config-subif)#
    Router(config-if)#ip address <ip address> <subnet mask>
    
    !--- For NAT:
    
    Router(config-if)#ip nat outside
    Router(config-subif)#pvc <vpi/vci>
    Router(config-subif-atm-vc)#encapsulation aal5snap
    Router(config-subif-atm-vc)#end
    
  7. 配置默认路由使用ATM0.1作为出站接口。

    Router#configure terminal
    Router(config)#ip route 0.0.0.0 0.0.0.0 atm0.1
    Router(config)#end
    
  8. 对NAT :配置全局NAT on命令Cisco DSL路由器允许共享拨号接口的静态公网IP地址。

    Router#configure terminal
    Router(config)#ip nat inside source list 1 interface atm0.1 overload
    Router(config)#access-list 1 permit <ip network address of ethernet0> 
     <wildcard mask>
    Router(config)#end
    

    可选配置

    NAT池,如果您的ISP提供了额外的IP地址。

    Router(config)#ip nat inside source list 1 interface atm0.1 overload 
    Router(config)#ip nat pool <nat pool name> <first ip address> 
     <last ip address> netmask <subnet mask>
    Router(config)#end
    

    静态NAT,如果互联网用户需要对内部服务器的访问。

    Router(config)#ip nat inside source static tcp <inside ip address of server> 
     {80 or 25} <outside well-known ip address of server> {80 or 25} extendable
    Router(config)#end
    
  9. 对动态主机配置协议(DHCP) :(选项)请配置Cisco DSL路由器作为IP地址池的DHCP服务器,为连接到Cisco DSL路由器以太网接口的主机分配IP 地址。DHCP服务器动态地分配IP地址、域名服务器(DNS)和默认网关IP地址到您的主机。

    Router#configure terminal
    Router(config)#ip dhcp excluded-address <ip address of ethernet0>
    Router(config)#ip dhcp pool <dhcp pool name>
    Router(dhcp-config)#network <ip network address of ethernet0> <subnet mask>  
    Router(dhcp-config)#default-router <ip address of ethernet0> 
    Router(dhcp-config)#dns-server <ip address of primary dns server> 
     <ip address of secondary dns server>
    Router(dhcp-config)#end
    
  10. Cisco DSL路由器的启用日志控制台,然后写入对内存的所有更改。

    Router#configure terminal
    Router(config)#logging console
    Router(config)#end
    *Jan 1 00:00:00.100: %SYS-5-CONFIG_I: Configured from console by console
    Router#write memory
    Building configuration... [OK]
    Router#

配置

这是在您完成了本文的配置程序部分后被建立的配置。

有单个静态IP地址的Cisco DSL路由器

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface atm0.1 point-to-point
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat outside
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!

!--- For NAT:

ip nat inside source list 1 interface atm0.1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface atm0.1 overload 

 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

验证

您的Cisco DSL路由器当前对非对称数字用户线路(ADSL)服务是可用的。您能发出show run指令查看配置。

Router#show run
Building configuration...

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

故障排除

如果您的ADSL服务不适当地,运作请参考寻址排错的RFC1483


相关信息


Document ID: 71136