交换机 : Cisco Catalyst 6500 系列交换机

Microsoft网络上Catalyst交换机负载平衡的配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈

简介

本文描述如何配置思科Catalyst交换机为了与Microsoft网络负载平衡呼应(NLB)。

贡献用安布罗斯泰勒,戴尔Miller和Shashank辛哈, Cisco TAC工程师。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco Catalyst 6500系列交换机用Supervisor引擎2T (Sup2T)该运行Cisco IOS软件版本15.1(1)SY1

  • 运行Cisco IOS软件版本15.0(2)SG7的Cisco Catalyst 4948系列交换机

  • Microsoft Windows服务器

注意:参见使用为了启用在其他Cisco平台的这些功能的命令的相应的配置指南。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

背景信息

NLB技术可以用于为了分配在一套的客户端的要求服务器间。为了保证客户端总是体验可接受性能级别, Microsoft Windows NLB提供能力添加另外的服务器,以便您能扩展无状态的应用程序,例如基于Iis的Web服务器,当客户端负载增加。另外,它减少是由服务器造成的发生故障的停机时间。

Microsoft Windows NLB是提供作为所有Windows 2000服务器和Windows 2003年服务器系列操作系统的零件的集群技术。它为所有客户端提供单个虚拟IP地址作为整个集群的目的IP地址。

您能配置NLB在这三个模式之一中工作:

  • 单播模式
  • 组播模式
  • 互联网组管理协议(IGMP)模式

单播模式

这是关于使用的一些笔记在单播模式的NLB :

  • 在单播模式, NLB用普通的NLB MAC地址替换每个服务器实际MAC控制(MAC)地址在集群的。当所有在集群的服务器有同一MAC地址时,转发对该地址的所有数据包被发送对所有集群的成员。NLB创建虚拟MAC地址并且分配它到在NLB集群的每个服务器。NLB根据成员的主机ID分配每个NLB服务器不同的虚拟MAC地址。此地址出现在以太网帧报头中。

  • MAC地址没有用于地址解析服务(ARP)报头,没有以太网报头。交换机在以太网报头中使用 MAC 地址,在 ARP 报头中则不使用。当数据包发送对与目标MAC地址的NLB集群作为集群MAC地址00-bf-ac-10-00-01时,这导致一个问题。交换机查看MAC地址的00-bf-ac-10-00-01内容可寻址内存(CAM)表,并且,因为没有端口注册与NLB集群MAC地址00-bf-ac-10-00-01,帧传送对所有交换机端口。这引入单播泛洪。 为了避免充斥,思科建议您使用专用VLAN NLB,以便泛滥限制条件。

多播模式

这是关于使用的一些笔记在组播模式的NLB :

  • 在组播模式,系统管理员点击在Microsoft NLB配置GUI的组播按钮。此选择提示集群成员响应到他们的虚拟地址的ARPs与使用组播MAC地址,例如0300.5e01.0101。

  • ARP进程不为组播MAC地址完成(这中断RFC 1812)。静态MAC地址要求为了到达集群在本地子网外面。

  • 虚拟IP地址是10.100.1.99,并且组播MAC地址是0300.5e01.0101。输入此命令为了静态填充ARP表:
    arp 10.100.1.99 0300.5e01.0101
  • 因为入站数据包有一单播目的IP地址和组播目的地MAC地址, Cisco设备忽略此条目,并且单播充斥每团星区域数据包。为了避免此泛滥,请插入一个静态MAC地址表条目为了转换团星区域数据包在硬件里:
    mac address-table static 0300.5e01.0101 vlan 200 interface TenGigabitEthernet1/4
    TenGigabitEthernet1/5

注意:当您静态映射对多个端口时的MAC地址,由在Cisco Catalyst 4500系列交换机的软件只支持。并且,使用在Catalyst 4500系列交换机的此配置也许导致高CPU。为了避免此问题,您能离析NLB特定VLAN,添加仅静态ARP条目,并且允许在该VLAN的泛滥。

IGMP模式

这是关于使用的一些笔记在IGMP模式的NLB :

  • 使用在IGMP模式的NLB要求最少量的手动配置。虚拟MAC地址属于互联网分配号码授权中心(IANA)范围并且从0100.5exx.xxxx开始。因为MAC地址当前依照IANA规格, Cisco交换机能动态地编程与使用的MAC地址IGMP探听。这取消需要手工编程对在组播模式要求为了防止充斥到VLAN的端口映射的MAC地址。

  • 一旦交换机收到从一个成员的一成员报告集群的, IGMP探听编程您的虚拟MAC地址。必须为与使用的NLB VLAN也编程Mrouter端口独立于协议的组播(PIM)或IGMP查询者功能。

  • 因为虚拟IP地址使用组播MAC地址,它是本地子网的不可得到的外部。为了寻址此,您必须配置在每个设备的静态ARP条目有在集群VLAN的一个第3层(L3)接口的。完成此在方式和一样同组播模式。例如,如果虚拟IP地址是10.100.1.99,并且组播MAC地址是0100.5e01.0101,请使用此命令为了静态填充ARP表:
    arp 10.100.1.99 0100.5e01.0101

警告

这是要记住的重要提示,当您在IGMP模式时使用NLB :

  • 如被跟踪在Cisco Bug ID CSCsw72680,您不能以某些编码版本使用在NLB VLAN Switch Virtual Interface (SVI)的PIM。查看解决此问题或使用IGMP探听Querier功能的代码版本的Bug详细信息。

  • 如被跟踪在Cisco Bug ID CSCsy62709,数据包为路由到在IGMP模式的NLB服务器的所有流量被复制。查看受影响的代码版本的Bug详细信息。

  • 由于由Cisco Bug ID CSCug49149跟踪的硬件限制, NLB流量不可能在同一6708线路卡的一分布式EtherChannel间发送,当交换机在PFC3B或PFC3C模式时运行。必须缚住Port-Channel,以便所有成员链接在同一转发引擎。

配置

此部分描述如何配置在组播或IGMP模式运行的Cisco Catalyst 6500及4948系列平台的NLB。

网络图

组播模式的配置

此部分描述如何配置在组播模式运行的Cisco Catalyst 6500及4948系列平台的NLB :

6500-1#show running-config
Building configuration...
!
hostname 6500-1
!
boot system flash disk0:s2t54-adventerprisek9-mz.SPA.151-1.SY1
!
interface TenGigabitEthernet1/4
switchport
switchport trunk allowed vlan 1,100,200
switchport mode trunk
!
interface TenGigabitEthernet1/5
switchport
switchport trunk allowed vlan 1,100,200
switchport mode trunk
!
interface Vlan100
ip address 10.100.1.1 255.255.255.0

!
!        
interface Vlan200
ip address 10.200.1.1 255.255.255.0

!
!
arp 10.100.1.88 0300.5e01.0101 ARPA
!
!
mac address-table static 0300.5e01.0101 vlan 200 interface TenGigabitEthernet1/4
TenGigabitEthernet1/5 TenGigabitEthernet5/5

!
end

这是关于此配置的一些重要提示:

  • IP Address值的接口Vlan100配置用户VLAN。

  • IP Address值的接口Vlan200配置NLB集群VLAN。重要的是您配置Microsoft服务器的默认网关对此地址。

  • arp 10.100.1.88 0300.5e01.0101 ARPA在VLAN包括所有L3接口并且是NLB集群服务器的虚拟IP地址。

  • mac address-table static 0300.5e01.0101 VLAN 200接口创建一静态MAC项对在交换机的端口映射组播虚拟MAC地址的。

注意:保证您使用在NLB集群的组播模式。Cisco 建议您不要使用以 01 开头的多播 MAC 地址,因为已经确认这些地址与 IGMP 设置冲突。

4948-1#show running-config
Building configuration...
!
hostname 4948-1
!
boot system bootflash:cat4500-entservices-mz.150-2.SG7
!
interface GigabitEthernet1/1
 switchport access vlan 200
!
interface TenGigabitEthernet1/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
mac address-table static 0300.5e01.0101 vlan 200 interface Gi1/1 Te1/49 Te1/50
!
!
end

注意mac address-table static 0300.5e01.0101 VLAN 200接口创建在交换机的静态条目组播虚拟MAC地址的。 请记住运载交换机之间的NLB流量的所有中继接口必须添加。一旦静态MAC地址定义,充斥限制条件。如果忘记包括接口, NLB集群中断。 

IGMP模式的配置

此部分描述如何配置在IGMP模式运行的Cisco Catalyst 6500及4948系列平台的NLB :

6500-1#show running-config
Building configuration...
!
hostname 6500-1
!
boot system flash disk0:s2t54-adventerprisek9-mz.SPA.151-1.SY1
!
ip igmp snooping querier
!
!
vlan configuration 1,100
 no ip igmp snooping querier
!        
vlan configuration 200
ip igmp snooping querier address 10.200.1.1
!
!
interface TenGigabitEthernet1/4
 switchport
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/5
 switchport
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
!
interface Vlan100
 ip address 10.100.1.1 255.255.255.0

!
!        
interface Vlan200
 ip address 10.200.1.1 255.255.255.0

!
!
arp 10.100.1.99 0100.5e01.0101 ARPA
!
!
end

这是关于此配置的一些重要提示:

  • ip igmp snooping查询器启用探测询问器功能。

  • ip igmp snooping查询器地址10.200.1.1配置NLB的VLAN探测询问器。

  • 用户VLAN是接口Vlan100

  • NLB集群VLAN是接口Vlan200。重要的是您配置Microsoft服务器的默认网关对此地址(IP地址10.200.1.1 255.255.255.0)。

  • arp 10.100.1.99 0100.5e01.0101 ARPA是NLB集群服务器的虚拟IP地址。静态ARP必须在所有在VLAN的L3接口。

4948-1#show running-config
Building configuration...
!
hostname 4948-1
!
boot system bootflash:cat4500-entservices-mz.150-2.SG7
!
interface GigabitEthernet1/1
 switchport access vlan 200
!
interface TenGigabitEthernet1/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
end

注意:因为IGMP探听在此模式,动态地执行此没有需要配置静态条目。并且,此模式的特别配置在下行Layer2 (L2)交换机没有要求。

验证

使用本部分可确认配置能否正常运行。

注意命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

组播模式验证

输入show ip arp命令为了查看ARP缓存:

6500-1#show ip arp
Protocol Address         Age (min) Hardware Addr   Type   Interface
Internet 10.100.1.99            -   0300.5e01.0101  ARPA

输入static命令的show mac address-table为了查看一特定MAC地址表静态和动态条目或者MAC地址表静态和动态条目在特定接口或VLAN :

6500-1#show mac address-table static add 0300.5e01.0101

vlan   mac address    type   learn    age      ports
----+---------------+-------+-----+------+-----------------
200 0300.5e01.0101   static   No       -  Te1/4 Te1/5 Te5/5
4948-1#show mac address-table static add 0300.5e01.0101

Multicast Entries
vlan    mac address     type   ports
------+---------------+-------+--------------------
200    0300.5e01.0101   static Gi1/1,Te1/49,Te1/50

IGMP模式验证

输入show ip arp命令为了查看ARP缓存:

6500-1#show ip arp

Protocol Address       Age (min) Hardware Addr   Type   Interface
Internet 10.100.1.99         -   0100.5e01.0101  ARPA

输入show ip igmp snooping mrouter为了查看由从上行探测询问器接收的查询编程的Mrouter端口:

4948-1#show ip igmp snooping mrouter

Vlan    ports
----    -----
 200   Te1/49(dynamic)

输入show mac address-table multicast IGMP探听为了查看从IGMP探听和成员端口了解的动态已添加MAC地址:

4948-1#show mac address-table multicast igmp-snooping

Multicast Entries
 vlan   mac address     type    ports
------+---------------+------+-------------
 200   0100.5e01.0101  igmp Gi1/1,Te1/49

输入show ip igmp snooping组为了查看加入组播组集群成员的端口列表:

4948-1#show ip igmp snooping groups

Vlan      Group      Version    Port List
-----------------------------------------
200       239.1.1.1   v2         Gi1/1

故障排除

目前没有针对此配置的故障排除信息。


相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


Document ID: 107995