????????? : Cisco Catalyst 6500 系列/7600 系列无线服务模块 (WiSM)

排除初始无线服务模块 (WiSM) 设置故障并对其进行配置

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档讨论用于验证初始 WiSM 设置和故障排除的命令。本文档还包括将 Catalyst 6500 Supervisor 引擎 720 (Sup720) 配置为与引擎上安装的 WiSM 模块进行通信所需的基本步骤。

先决条件

要求

保证您有关于无线局域网控制器和其配置的若干基础知识,以及思科Catalyst 6500交换机的若干基础知识运行Supervisor 720和功能例如EtherChannel链路聚合(滞后)。除以上要求之外,本文档没有任何特定的要求。

使用的组件

本文档中的信息根据在运行本地Cisco IOS 软件版本12.2(18)SXF2的Catalyst 6500 Supervisor引擎720,但是对支持Supervisor 720和WiSM卡的所有IOS版本的apply命令安装的Cisco WiSM模块。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

Cisco WiSM 是 Cisco 无线 LAN 控制器系列的成员。它与 Cisco Aironet 轻量接入点、Cisco WCS 和 Cisco Wireless Location Appliance 配合使用,以提供支持无线数据、语音和视频应用的安全统一的无线解决方案。

Cisco WiSM 可与 Cisco Catalyst 6500 系列交换机和 Cisco Catalyst 6500 Supervisor 引擎 720 完美集成。支持所有 Supervisor 引擎 720 版本。仅运行 Cisco IOS 软件版本 12.2(18)SXF5 的 Cisco 7600 路由器也支持 WiSM。

下表列出了 Cisco Catalyst 6500 上支持 Cisco WiSM 的插槽:

Slot 6503-E 6504-E 6506 6509 6513
1-3 X X X X  
4   X X X  
5-6     X X  
7-8       X  
9       X X
10-13         X

注意: 没有安装的任何其他服务模块, Catalyst 6509交换机机箱可以支持七Cisco WiSMs, Catalyst 6506用Supervisor 720可以支持四Cisco WiSMs,并且其他Catalyst 6500系列交换机机箱可以支持六Cisco WiSMs。如果一个或更多服务模块安装,机箱可以支持至最多四个服务模块(包括的WiSMs)。冗余Supervisor不可能与这些最大配置一起使用。

Cisco WiSM 包含两个 Cisco 4404 控制器,因此 IT 人员必须了解在一个模块中存在二个独立的控制器。第一个控制器被视为 WiSM-A 卡,而第二个控制器被视为 WiSM-B 卡。必须对这两个卡单独考虑接口和 IP 编址。WiSM-A 管理 150 个接入点,而 WiSM-B 管理另外 150 个接入点。这些控制器可以组合在一个移动组中,从而形成群集。

Cisco WiSM 的每个控制器上都有多种类型的接口;其中三个接口为预定义类型,设置时必须存在这些接口并进行配置:

  • 管理接口(预定义和必需项)

  • AP 管理器接口(预定义和必需项)

  • 虚拟接口(预定义和必需项)

  • 操作员定义的接口(用户定义)

  • 服务端口接口(预定义和必需项)

有关每种类型接口的详细信息,请阅读配置 Cisco 无线服务模块和无线控制系统

在 WiSM 上,服务端口用于同步 Supervisor 引擎和 WiSM。

配置 Supervisor 720 与 Cisco WiSM 之间的通信

注意: 如果有包括VLAN在1到1000范围内,并且的一WiSM中继您打算使用only1到10,请输入命令:没有wism模块x控制器y allowed-vlan 11-1000

在插槽中安装 Cisco WiSM 控制器并在 Supervisor 检测到该控制器后,请在 Supervisor 引擎上进行以下配置,以便与 WiSM 进行通信。

  1. 为 Catalyst WiSM 的服务端口创建 DHCP 范围。

    ip dhcp excluded-address 192.168.10.1 192.168.10.2
    
    !
    ip dhcp pool wism-service-port
     
    network 192.168.10.0 255.255.255.0
    
    default-router 192.168.10.1
    
    

    或者,也可以直接创建与 WiSM 的会话(session slot X proc 1 或 2)或通过控制台访问 WiSM,并设置静态 IP 地址 (config Interface Address Service-Port)。

    请确保服务端口 IP 地址不是网络中的可路由 IP 地址,因为该地址仅用于 Sup 720 与 WiSM 之间的通信。

  2. 创建 WiSM 服务端口网关并分配 IP 地址。

    在 Supervisor 720 中创建 VLAN。此 VLAN 局限于本地机箱并用于通过 Supervisor 上的千兆接口和 Cisco WiSM 中的服务端口在 Cisco WiSM 与 Catalyst Supervisor 720 之间进行通信。

    interface Vlan192
    
    Description WiSM Service Port Gateway or Management Interface on CAT6K
    ip address 192.168.10.1 255.255.255.0
    
    

    注意: 应该已经存在一个网络管理 VLAN 接口,用于连接到 Cat6k。

  3. 为 VLAN 分配 WiSM 服务端口。

    配置以下命令以使用 VLAN 192 与服务端口进行通信。

    wism service-vlan 192
    
    

    注意: wism服务WLAN定义的VLAN的接口VLAN x需要在机箱和控制器一样,并且DHCP范围在WiSM连接的同一个机箱需要定义。为了使工作DHCP的分配,您需要有您的在DHCP范围定义的交换机的接口VLAN XX

  4. 在 Cat6k 上创建 WiSM Management/AP-Manager 网关接口。

    以下是一个配置示例:

    interface vlan40
    
    Description WiSM Management/AP-Manager Interface Gateway
    ip address 40.1.1.1
    
    

    注意: 软件版本 12.2(18) SXF5 引入了用于 auto-LAG 端口(在高端的 200 范围内)新的 WiSM 命令。可以使用这些命令来取代步骤 5 和步骤 6。

    在非 VSS 环境中,发出 wism module <module/slot no> controller 1 native-vlan 40 wism module <module/slot no> controller 1 allowed-vlan native vlan id(40), vlan id1, vlan2, 以此类推...

    命令。在 VSS 环境中,发出 wism switch<module/slot no> controller 1 native-vlan 40 wism switch<module/slot no> controller 1 allowed-vlan native vlan id(40), vlan id1, vlan2, 以此类推... 命令。输入此命令后,可能会暂时中断服务(大约两次 ping 的时间)。

    输入以下命令为接口配置 QoS 信任:

     wism module <module/slot no> controller 1 qos-trust dscp
  5. 在 Cat6k 上创建二个端口信道接口并配置 dot1q 中继、信任 dscp 和本地 VLAN,这将允许从管理端口接收未标记的数据包。

    在 Cisco WiSM 中为两个独立控制器创建二个端口信道接口,并分配 VLAN 40 作为本地接口。

    interface Port-channel X
    
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 40
    
    switchport mode trunk
    mls qos trust dscp
    spanning-tree portfast trunk
    

    同样地,在 WiSM 上为另外一个控制器创建另一个端口信道接口。

  6. 配置 WiSM 控制器 1 和 2 接口。

    在开始时,当 Supervisor 检测到 Cisco WiSM 控制器后,将创建八个千兆接口,范围从 Gig<安装该模块的插槽编号>/1 到 Gig<插槽编号>/8。

    将这些千兆接口配置为中继端口,并将 VLAN 40 作为本地 VLAN。在进行 Cisco WiSM 配置时,请确保未标记本地 VLAN。以下为配置示例:

    router(config)# interface range gigabitEthernet
    <slot>/1 – 4 
    or 
    router(config)# interface range gigabitEthernet 
    <slot>/5 – 8
    
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 40
     
    switchport mode trunk
    mls qos trust dscp
    spanning-tree portfast trunk
    channel-group <port-channel no> mode on
    

    注意: 如果在运行 Cisco IOS 软件版本 12.2.33SXI 的交换机上安装 WiSM,则在该交换机上手动定义端口信道并将其应用到千兆接口不起作用。必须使用 auto-LAG。

验证步骤

本部分介绍用于验证 WiSM 设置的命令。

  1. 要验证运行的是哪个本地 (IOS) 版本,请发出 show version 命令。

    Router#show version
    Cisco Internetwork Operating System Software 
    IOS (tm) s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF5, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2006 by cisco Systems, Inc.
    Compiled Sat 08-Jul-06 02:54 by kellythw
    Image text-base: 0x40101040, data-base: 0x42D88000
    
    ROM: System Bootstrap, Version 12.2(14r)S1, RELEASE SOFTWARE (fc1)
    BOOTLDR: s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF5, RELEASE SOFTWARE (fc3)
    
    ... skip ...
    
    cisco WS-C6503-E (R7000) processor (revision 1.1) with 458720K/65536K bytes of memory.
    Processor board ID FOX0920047A
    SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
    Last reset from power-on
    SuperLAT software (copyright 1990 by Meridian Technology Corp).
    X.25 software, Version 3.0.0.
    Bridging software.
    TN3270 Emulation software.
    3 Virtual Ethernet/IEEE 802.3 interfaces
    20 Gigabit Ethernet/IEEE 802.3 interfaces
    1917K bytes of non-volatile configuration memory.
    8192K bytes of packet buffer memory.
    
    65536K bytes of Flash internal SIMM (Sector size 512K).
    Configuration register is 0x2102

    注意: WiSM 要求运行本地 IOS 版本 12.2(18)SXF2 或更高版本的 Supervisor 720。

  2. 要验证 Cat6k 是否具有 Supervisor 720 和 WiSM 卡,请使用 show module 命令。

    Router#show module
    Mod Ports Card Type                              Model              Serial No.
    --- ----- -------------------------------------- ------------------ -----------
      1    2  Supervisor Engine 720 (Active)         WS-SUP720-BASE     SAD0717003H
      3   10  WiSM WLAN Service Module               WS-SVC-WISM-1-K9   SAD09280AZU
    
    
    Mod MAC addresses                       Hw    Fw           Sw           Status
    --- ---------------------------------- ------ ------------ ------------ -------
      1  000c.ce63.eb0c to 000c.ce63.eb0f   2.1   7.7(1)       12.2(18)SXF5 Ok
      3  0030.f274.ae36 to 0030.f274.ae45   0.3   12.2(14r)S5  12.2(18)SXF5 Ok
    
    
    Mod  Sub-Module                  Model              Serial       Hw     Status 
    ---- --------------------------- ------------------ ----------- ------- -------
      1  Policy Feature Card 3       WS-F6K-PFC3A       SAD071902DP  1.1    Ok
      1  MSFC3 Daughterboard         WS-SUP720          SAD071700L3  1.2    Ok
      3  Centralized Forwarding Card FARFEL             SAD0929038U  0.3    Ok
    
    Mod  Online Diag Status 
    ---- -------------------
      1  Pass
      3  Pass

    注意: 来自交换机的 show module 命令的输出显示 WISM 具有 10 个端口。但仅有 8 个端口用于端口信道配置,端口信道 1 和端口信道 2。另外 2 个端口用作服务端口。

  3. 要验证哪个插槽中安装了 WiSM,请发出 show wism status 命令。以下是此命令的输出示例:

    Router#sh wism status
    Service Vlan : 158, Service IP Subnet : 172.16.158.131/255.255.255.128
    WLAN
    Slot Controller Service IP Management IP SW Version Status
    ----+-----------+----------------+----------------+-----------+---------
    3 1 172.16.158.142 140.1.3.10 3.2.116.21 Oper-Up
    3 2 172.16.158.143 140.1.3.11 3.2.116.21 Oper-Up
    

    对于 6503-E,仅插槽 1 到 3 工作。对于 6504 到 6506,仅插槽 1 到 4 工作。对于 6509,仅插槽 1 到 9 工作。而对于 6913,恰恰相反;仅插槽 9 到 13 工作。有关更多详细信息,请参阅 WiSM 故障排除常见问题

  4. 要验证 Cat6k 端的 WiSM 状态,请发出 show wism module X controller Y status 命令,并查找正在使用的 Oper-Up 和 LAG 端口(验证 LAG 端口)。要验证是否存在服务 IP 地址,请验证服务 VLAN 的 DHCP 设置。或者,创建与该模块的会话(session slot x proc 1 或 2)或直接通过控制台访问 WiSM 来查看静态 IP 地址。

    Router#show wism module 3 controller 1 status 
    
    WiSM Controller 1 in Slot 3
    Operational Status of the Controller : Oper-Up
    Service VLAN                         : 250
    Service Port                         : 9
    Service Port Mac Address             : 0014.a9bd.d9a2
    Service IP Address                   : 172.16.158.142
    Management IP Address                : 140.1.3.10
    Software Version                     : 3.2.116.21
    Port Channel Number                  : 285
    Allowed vlan list                    : 5,10,15,25,35,45,55
    Native VLAN ID                       : 5
    WCP Keep Alive Missed                : 0
  5. 要验证是否定义了到 WiSM 和 VLAN 的中继,请发出 show interface trunk 命令。以下是此命令的输出示例:

    Router#show interface trunk
             Port  Mode   Encapsulation Status Native vlan
             Po1   on     802.1q trunking 140
             Po2   on     802.1q trunking 140
  6. 要验证是否采用了正确的负载均衡算法 (config #port-channel load-balance src-dst-ip),请发出 show etherchannel load-balance 命令。以下是该命令的输出示例:

    Router#show etherchannel load balance
    EtherChannel Load-Balancing Configuration:
                       src-dst-ip
    

    要验证 EtherChannel 上的端口是否正确,请发出 show etherchannel load-balance 命令。示例输出如下:

    Router#show etherchannel summary
    Group Port-channel Protocol Ports
    ------+-------------+-----------+-----------------------------------------
    1     Po1(SU)        -      Gi3/1(P) Gi3/2(P) Gi3/3(P) Gi3/4(P)
    2     Po2(SU)        -      Gi3/5(P) Gi3/6(P) Gi3/7(P) Gi3/8(P)
  7. 要检查 WiSM 端的状态,请直接创建与 WiSM 的会话(session slot x proc 1 或 2)或直接通过控制台访问 WiSM,并检查“show interface summary”下(或“Controller”->“Interfaces”->“edit”(management interface) 下)的 LAG 状态。在“Physical Information”下,将显示“The interface is attached to a LAG”。示例如下:

    (WiSM-slot3-1) >show interface
    		  summary
    Interface Name     Port  Vlan Id   IP Address   Type   Ap Mgr
    --------------------------------   ----      -------   -------- ------- 
             ap-manager         LAG  untagged   192.168.3.9   Static   Yes
             management         LAG  untagged   192.168.3.10  Static    No

    注意: 如果交换机运行Cisco IOS软件版本12.2.(18)SXF11, 12.2.(33)SXH或以后和您配置auto-LAG,输出show run命令不显示WiSM的千兆接口。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 91473