交换机 : Cisco Catalyst 6500 系列交换机

从PVST+到MST移植生成树的配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 9 月 26 日) | 反馈


目录


简介

本文档提供了在园区网络中将生成树模式从 PVST+ 迁移到多生成树 (MST) 的配置示例。

先决条件

要求

在配置 MST 之前,请参阅了解多生成树协议 (802.1s)

下表显示了 Catalyst 交换机中对 MST 的支持,以及该支持功能所需的最低软件版本。

Catalyst 平台 支持 RSTP 的 MST
Catalyst 2900 XL 和 3500 XL 离线
Catalyst 2950 和 3550 Cisco IOS 12.1(9)EA1
Catalyst 3560 Cisco IOS 12.1(9)EA1
Catalyst 3750 Cisco IOS 12.1(14)EA1
Catalyst 2955 所有 Cisco IOS 版本
Catalyst 2948G-L3 和 4908G-L3 离线
Catalyst 4000、2948G 和 2980G (Catalyst OS (CatOS)) 7.1
Catalyst 4000 和 4500 (Cisco IOS) 12.1(12c)EW
Catalyst 5000 和 5500 离线
Catalyst 6000 和 6500 (CatOS) 7.1
Catalyst 6000 和 6500 (Cisco IOS) 12.1(11b)EX、12.1(13)E 和 12.2(14)SX
Catalyst 8500 离线

  • Catalyst 3550/3560/3750:Cisco IOS 版本 12.2(25)SEC 中的 MST 实现基于 IEEE 802.1s 标准。早期 Cisco IOS 版本中的 MST 实现为试行标准。

  • Catalyst 6500 (IOS):Cisco IOS 版本 12.2(18)SXF 中的 MST 实现基于 IEEE 802.1s 标准。早期 Cisco IOS 版本中的 MST 实现为试行标准。

使用的组件

本文用Cisco IOS软件版本12.2(25)和CatOS创建8.5(8),但是配置是可适用的对在表里提及的最低的IOS版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

MST 功能即 IEEE 802.1s,它是对 802.1Q 的修正。MST 将 802.1w 快速生成树 (RST) 算法扩展到多生成树。此扩展可在 VLAN 环境中提供快速收敛和负载均衡功能。PVST+ 和快速 PVST+ 运行每个 VLAN 的生成树实例。在 MST 中,您可以将 VLAN 分组为单个实例。它使用与 802.1D STP(使用 BPDU 版本 0)向后兼容的网桥协议数据单元 (BPDU) 版本 3。

MSTP 配置:MSTP 配置包括区域名称、修订版号和 MST VLAN 到实例的分配映射。可以使用 spanning-tree mst configuration 全局配置命令配置区域交换机。

MST 区域:MST 区域由具有同一 MST 配置的互联网桥组成。网络中 MST 区域的数量没有限制。

MST 区域中的生成树实例:实例只是 spanning-tree mst configuration 命令中映射的一组 VLAN。默认情况下,所有 VLAN 都分组为称为内部生成树 (IST) 的 IST0。您可以手动创建编号为 1 到 4094 的实例,并将其标记为 MSTn(n = 1 到 4094),但是区域最多只支持 65 个实例。某些版本只支持 16 个实例。请参阅适用于您的交换机平台的软件配置指南。

IST/CST/CIST:IST 是可以在 MST 网络中发送和接收 BPDU 的唯一实例。MSTn 实例是区域的本地实例。不同区域中的 IST 通过通用生成树 (CST) 互相连接。每个 MST 区域中的 IST 和连接这些 IST 的 CST 的集合称为通用内部生成树 (CIST)。

向后兼容性:MST 与 PVST+、快速 PVST+ 和试行标准 MST (MISTP) 向后兼容。MST 交换机通过通用生成树 (CST) 连接到其他 STP(PVST+ 和快速 PVST+)交换机。其他 STP(PVST+ 和快速 PVST+)交换机将整个 MST 区域视为单个交换机。连接试行标准 MST 交换机与标准 MST 交换机时,您需要在标准 MST 交换机的接口中配置 spanning-tree mst pre-standard

配置

本示例包含两部分。第一部分显示当前 PVST+ 配置。第二部分显示从 PVST+ 迁移到 MST 的配置。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

下图包括以下交换机:

  • 处于分布层中的 Distribution1 和 Distribution2

  • 两台称为 Access1 (IOS) 和 Access2 (CatOS) 的接入层交换机

  • 两台称为 Services1 和 Services2 的服务器聚合交换机

VLAN 10、30 和 100 传输数据流量。VLAN 20、40 和 200 传输语音流量。

/image/gif/paws/72844/MST-1.gif

配置

本文档使用以下配置:

PVST+ 配置

上述交换机在 PVST+ 中配置为按照网络图来传输数据和语音流量。以下是该配置的简要汇总:

  • Distribution1 交换机通过 Distribution1(config)# spanning-tree vlan 10,30,100 root primary 命令配置为数据 VLAN 10、30 和 100 的主根网桥;语音 VLAN 20、40 和 200 的辅助根网桥使用 Distribution1(config)# spanning-tree vlan 20,40,200 root secondary 命令。

  • Distribution2 交换机通过 Distribution2(config)# spanning-tree vlan 20,40,200 root primary 命令配置为语音 VLAN 20、40 和 200 的主根网桥;数据 VLAN 10、30 和 100 的辅助根网桥使用 Distribution2(config)# spanning-tree vlan 10,30,100 root secondary 命令。

  • 在所有交换机上配置 spanning-tree backbonefast 命令,以便在网络中出现间接链路故障的情况下更迅速地收敛 STP。

  • 在接入层交换机上配置 spanning-tree uplinkfast 命令,以便在出现直接上行链路故障的情况下更迅速地收敛 STP。

Distribution1
Distribution1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 24576
spanning-tree vlan 20,40,200 priority 28672
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

您可以看到端口 Fa1/0/24 是使用 spanning-tree vlan 20,40,200 port-priority 64 命令配置的。Distribution2 是为 VLAN 20、40 和 200 配置的根。Distribution2 具有两条指向 Distribution1 的链路:fa1/0/23 和 fa1/0/24。两个端口均为 VLAN 20、40 和 200 的指定端口,因为 Distribution2 是这些 VLAN 的根。两个端口具有同一优先级 128(默认值)。另外,这两条链路还具有相同的 Distribution1 成本:fa1/0/23 和 fa1/0/24。Distribution1 选择两个端口中的最小端口号,以便将该端口设置为转发状态。最小端口号为 Fa1/0/23,但按照网络图,语音 VLAN 20、40 和 200 可以通过 Fa1/0/24 传输。您可以使用以下方法实现此目的:

  1. 降低 Distribution1 中的端口成本:Fa1/0/24。

  2. 降低 Distribution2 中的端口优先级:Fa1/0/24。

在本示例中,降低了端口优先级以便通过 fa1/0/24 转发 VLAN 20、40 和 200。

Distribution2
Distribution2#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

您可以看到 Services1 中的端口 Fa0/5,以及 Services2 中的 Fa0/6 和 Fa0/48 均具有生成树端口成本和端口优先级配置。这里调整了 STP,以便 Services1 和 Services2 的 VLAN 100 和 200 可以通过它们之间的中继链路。如果不应用此配置,Services1 和 2 将无法通过它们之间的中继链路来传递流量,而会选择那条通过 Distribution1 和 Distribution2 的路径。

Services2 发现两条到 VLAN 100 根 (Distribution1) 的等成本路径:一条通过 Services1,另一条通过 Distribution2。STP 将按以下顺序选择最佳路径(根端口):

  1. 路径成本

  2. 转发交换机的网桥 ID

  3. 最低端口优先级

  4. 最小内部端口号

在本示例中,两条路径具有相同的成本,但对于 VLAN 100 来说,Distribution2 (24576) 的优先级低于 Services1 (32768),因此 Services2 选择 Distribution2。在本示例中,Services1 的端口成本:fa0/5 的设置较低以使 Services2 选择 Services1。该路径成本会覆盖转发交换机优先级号。

Services1
Services1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

Services1 选择 Services2 来转发 VLAN 200 也可应用同一概念。在降低 Services2 - fa0/6 中 VLAN 200 的成本之后,Services1 会选择 fa0/47 转发 VLAN 200。这里的要求是通过 fa0/48 转发 VLAN 200。您可以使用以下两种方法来实现此目的:

  1. 降低 Services1 中的端口成本:Fa0/48。

  2. 降低 Services2 中的端口优先级:Fa0/48。

在本示例中,降低了 Services2 中的端口优先级以便通过 fa0/48 转发 VLAN 200。

Services2
Services2#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1
Access1#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2
Access2> (enable)show config all 

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

MST 迁移

同时将企业网络中的所有交换机都转换为 MST 很困难。由于具有向后兼容性,因此您可以分阶段转换它。请在预定维护窗口中实施更改,原因是重新配置生成树会中断数据流。启用 MST 时,也会启用 RSTP。生成树 uplinkfast 和 backbonefast 功能是 PVST+ 功能,由于这些功能是在 RSTP 中生成的,而 MST 依赖于 RSTP,因此在启用 MST 时将禁用这些功能。在迁移中,您可以删除 IOS 中的这些命令。在 CatOS backbonefast 和 uplinkfast 中,系统会自动从配置中清除命令,但 Portfast、bpduguard、bpdufilter、根防护和环路防护等功能的配置也适用于 MST 模式。这些功能在 MST 模式下的用法与在 PVST+ 模式下相同。如果已在 PVST+ 模式下启用了这些功能,则这些功能在迁移到 MST 模式后将保持活动状态。在配置 MST 时,请遵循以下指南和限制:

  • 迁移到 802.1s/w 的第一步是正确识别点对点端口和边缘端口。确保需要进行快速转换的所有交换机对交换机链路都是全双工的。边缘端口可通过 Portfast 功能进行定义。

  • 选择对网络中的所有交换机通用的配置名称和修订版号。Cisco 建议您将尽可能多的交换机置于单个区域中;将网络划分为单独的区域是不利的。

  • 请仔细决定交换网络中需要的实例数目,并牢记实例将转换为逻辑拓扑。避免将任何 VLAN 映射到实例 0 上。决定要将哪些 VLAN 映射到这些实例上,并为每个实例仔细选择根和备份根。

  • 确保中继传输映射到实例的所有 VLAN,或根本不传输此实例的任何 VLAN。

  • MST 可以在每个端口上与运行 PVST+ 的传统网桥交互,因此如果清楚了解交互作用,混合两种类型的网桥就不是什么问题。始终尝试将 CST 和 IST 的根保持在区域内部。如果通过中继与 PVST+ 网桥交互,请确保 MST 网桥是该中继允许的所有 VLAN 的根。请勿使用 PVST 网桥作为 CST 的根。

  • 确保所有 PVST 生成树根网桥的优先级低于(数字上更高)CST 根网桥。

  • 请勿对任何 PVST 网桥中的 VLAN 禁用生成树。

  • 请勿使用接入链路连接交换机,因为接入链路可以对 VLAN 进行分区。

  • 必须在维护窗口中完成涉及大量当前或新的逻辑 VLAN 端口的任何 MST 配置,这是因为整个 MST 数据库会针对任何增量更改(例如向实例添加新的 VLAN 或在实例中移动 VLAN)重新初始化。

在本示例中,园区网络具有一个名为 region1 的 MST 区域以及两个实例:MST1(数据 VLAN 10、30 和 100)和 MST2(语音 VLAN 20、40 和 200)。您可以看到 MST 只运行两个实例,但 PVST+ 运行六个实例。Distribution1 被选择为 CIST 区域根。这意味着 Distribution1 是 IST0 的根。为了按照该图对网络中的流量进行负载均衡,将 Distribution1 配置为 MST1(数据 VLAN 的实例)的根,将 MST2 配置为 MST2(语音 VLAN 的实例)的根。

您首先需要迁移核心,然后逐步开始处理接入交换机。在更改生成树模式之前,请配置交换机上的 MST 配置。然后,将 STP 类型更改为 MST。在本示例中,按以下顺序进行迁移:

  1. Distribution1 和 Distribution2

  2. Services1 和 Services2

  3. Access1

  4. Access2

  1. Distribution1 和 Distribution2 迁移:

    
    !--- Distribution1 configuration:
    
    Distribution1(config)#spanning-tree mst configuration
    Distribution1(config-mst)#name region1
    Distribution1(config-mst)#revision 10
    Distribution1(config-mst)#instance 1 vlan 10, 30, 100
    Distribution1(config-mst)#instance 2 vlan 20, 40, 200
    Distribution1(config-mst)#exit
    Distribution1(config)#spanning-tree mst 0-1 root primary
    Distribution1(config)#spanning-tree mst 2 root secondary
    
    
    !--- Distribution2 configuration:
    
    Distribution2(config)#spanning-tree mst configuration
    Distribution2(config-mst)#name region1
    Distribution2(config-mst)#revision 10
    Distribution2(config-mst)#instance 1 vlan 10, 30, 100
    Distribution2(config-mst)#instance 2 vlan 20, 40, 200
    Distribution2(config-mst)#exit
    Distribution2(config)#spanning-tree mst 2 root primary
    Distribution2(config)#spanning-tree mst 0-1 root secondary
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    
    Distribution1(config)#interface FastEthernet1/0/1
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/3
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/5
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/23
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/24
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    Distribution2(config)#interface FastEthernet1/0/2
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/4
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/6
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/23
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    !--- STP mode conversion.
    
    Distribution1(config)#spanning-tree mode mst
    Distribution2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic.
    
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#spanning-tree mst 2 port-priority 64
    
    
    !--- PVST+ cleanup.
    
    Distribution1(config)#no spanning-tree backbonefast
    Distribution2(config)#no spanning-tree backbonefast
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#no spanning-tree vlan 20,40,200 port-priority 64
    

    注意: 建议您手动设置 MST0 根。在本示例中,由于选择 Distribution1 作为 MST0 根,因此 Distribution1 成为 CIST 根。

    现在,网络采用了混合配置,可以按照下图来表示:

    MST-2.gif

    Distribution1 和 Distribution2 位于 MST region1 中,PVST+ 交换机将 region1 视为单个网桥。图 2 中显示了重新收敛后的数据流。您仍然可以按照图 1 调整 PVST+(生成树 VLAN X 成本)交换机,以便对数据和语音流量进行负载均衡。在根据步骤 2 至 4 迁移所有其他交换机之后,将获得基于图 1 的最终生成树拓扑。

  2. Services1 和 Services2 迁移:

    
    !--- Services1 configuration:
    
    Services1(config)#spanning-tree mst configuration
    Services1(config-mst)#name region1
    Services1(config-mst)#revision 10
    Services1(config-mst)#instance 1 vlan 10, 30, 100
    Services1(config-mst)#instance 2 vlan 20, 40, 200
    Services1(config-mst)#exit
    
    
    !--- Services2 configuration:
    
    Services2(config)#spanning-tree mst configuration
    Services2(config-mst)#name region1
    Services2(config-mst)#revision 10
    Services2(config-mst)#instance 1 vlan 10, 30, 100
    Services2(config-mst)#instance 2 vlan 20, 40, 200
    Services2(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the 
    !--- VLANs that are mapped to an instance.
    
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/47
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/48
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/47
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    
    !--- STP Mode conversion:
    
    Services1(config)#spanning-tree mode mst
    Services2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic:
    
    Services1(config)#interface fastEthernet 0/46
    Services1(config-if)#spanning-tree mst 2 cost 200000
    Services1(config-if)#exit
    Services1(config)#interface fastEthernet 0/47
    Services1(config-if)#spanning-tree mst 2 cost 100000
    Services1(config-if)#exit
    
    Services2(config)#interface FastEthernet 0/6
    Services2(config-if)#spanning-tree mst 1 cost 500000
    Services2(config-if)#exit
    
    
    !--- PVST+ cleanup:
    
    Services1(config)#no spanning-tree uplinkfast
    Services1(config)#no spanning-tree backbonefast
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#no spanning-tree vlan 100 cost 18
    Services1(config-if)#exit
    
    Services2(config)#no spanning-tree uplinkfast
    Services2(config)#no spanning-tree backbonefast
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#no spanning-tree vlan 200 cost 18
    Services2(config-if)#exit
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#no spanning-tree vlan 200 port-priority 64
    Services2(config-if)#exit
    
  3. Access1 迁移:

    
    !--- Access1 configuration:
    
    Access1(config)#spanning-tree mst configuration
    Access1(config-mst)#name region1
    Access1(config-mst)#revision 10
    Access1(config-mst)#instance 1 vlan 10, 30, 100
    Access1(config-mst)#instance 2 vlan 20, 40, 200
    Access1(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    Access1(config)#interface FastEthernet0/1
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Access1(config)#interface FastEthernet0/2
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    !--- STP mode conversion:
    
    Access1(config)#spanning-tree mode mst
    
    
    !--- PVST+ cleanup:
    
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
  4. Access2 迁移:

    
    !--- Access2 configuration:
    
    Access2> (enable) set spantree mst config name region1 revision 10
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 1 vlan 10,30,100
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 2 vlan 20,40,200
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst config commit
    
    
    !--- Ensure that trunks carry all the VLANs that are mapped to an instance:
    
    Access2> (enable)set trunk 3/3  on dot1q 10,20,30,40,100,200
    Access2> (enable)set trunk 3/4  on dot1q 10,20,30,40,100,200
    
    
    STP mode conversion
    
    Access2> (enable) set spantree mode mst
    PVST+ database cleaned up.
    Spantree mode set to MST.
    
    
    !--- Backbonefast and uplinkfast configurations are cleaned up automatically.
    
    

验证

每次更改配置时,建议您验证生成树拓扑。

验证 Distribution1 交换机是否为数据 VLAN 10、30 和 100 的根网桥,并按照图中的路径验证生成树转发路径是否匹配。

 Distribution1# show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.63f6.b700  priority      24576 (24576 sysid 0)
Root          this switch for the CIST
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p


Distribution1#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.63f6.b700  priority      24577 (24576 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p

Distribution1#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.63f6.b700  priority      28674 (28672 sysid 2)
Root          address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
              port    Gi1/0/24        cost          200000    rem hops 4

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 200000    128.1    P2p
Gi1/0/3          Desg FWD 200000    128.3    P2p
Gi1/0/23         Altn BLK 200000    128.23   P2p
Gi1/0/24         Root FWD 200000    128.24   P2p

Distribution2#show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.c6c1.3000  priority      28672 (28672 sysid 0)
Root          address 0015.63f6.b700  priority      24576 (24576 sysid 0)
              port    Fa1/0/23        path cost     0
Regional Root address 0015.63f6.b700  priority      24576 (24576 sysid 0)
                                      internal cost 200000    rem hops 19
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/2          Desg FWD 200000    128.54   P2p
Fa1/0/4          Desg FWD 200000    128.56   P2p
Fa1/0/6          Desg FWD 200000    128.58   P2p
Fa1/0/23         Root FWD 200000    128.75   P2p
Fa1/0/24         Altn BLK 200000    128.76   P2p


!--- CIST root is Distribution1. All the 
!--- switches are in the same region "region1".
!--- Hence in all the switches in the region1 you can see the path cost as 0.


Distribution2#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.c6c1.3000  priority      28673 (28672 sysid 1)
Root          address 0015.63f6.b700  priority      24577 (24576 sysid 1)
              port    Gi2/0/23        cost          200000    rem hops 1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/23         Root FWD 200000    128.75   P2p
Gi2/0/24         Altn BLK 200000    128.76   P2p

Distribution2#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
Root          this switch for MST2

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/6          Desg FWD 200000    128.58   P2p
Gi2/0/23         Desg FWD 200000    128.75   P2p
Gi2/0/24         Desg FWD 200000     64.76   P2p

Access2> (enable) show spantree mst 1
Spanning tree mode          MST
Instance                    1
VLANs Mapped:               10,30,100

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24577  (root priority: 24576, sys ID ext: 1)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/3

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32769  (bridge priority: 32768, sys ID ext: 1)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT    200000   32 P2P
 3/4                     blocking      ALTR    200000   32 P2P

Access2> (enable) show spantree mst 2
Spanning tree mode          MST
Instance                    2
VLANs Mapped:               20,40,200

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24578  (root priority: 24576, sys ID ext: 2)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/4

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32770  (bridge priority: 32768, sys ID ext: 2)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR    200000   32 P2P
 3/4                     forwarding    ROOT    200000   32 P2P

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 72844