无线 : 思科 4400 系列无线局域网控制器

无线 LAN 控制器和轻量接入点基本配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 12 月 20 日) | 反馈


目录


简介

本文档提供了轻量接入点 (AP) 的基本配置示例,该接入点通过 Cisco Catalyst 交换机连接到 Cisco 无线局域网 (WLAN) 控制器 (WLC)。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • 了解轻量 AP 和 Cisco WLC 配置方面的基础知识

  • 了解轻量 AP 协议 (LWAPP) 的基础知识

  • 了解外部 DHCP 服务器和/或域名服务器 (DNS) 配置方面的知识

  • 了解 Cisco 交换机配置方面的基础知识

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco Aironet 1232AG 系列轻量 AP

  • 运行固件 5.2.178.0 的 Cisco 4402 系列 WLC

  • Microsoft Windows Server 2003 Enterprise DHCP 服务器

此配置与任何其他 Cisco WLC 和任何轻量 AP 均可协同工作。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

要使 WLC 能够管理 LAP,LAP 应发现控制器并注册到 WLC。LAP 可使用多种不同的方法发现 WLC。有关 LAP 用于注册到 WLC 的不同方法的详细信息,请参阅轻量 AP (LAP) 注册到无线 LAN 控制器 (WLC)

本文档介绍将 LAP 注册到 WLC 以及配置 LWAPP 无线网络的基本操作所需的配置步骤。

配置

为了将 LAP 注册到 WLC 并配置 LWAPP 无线网络的基本操作,请完成以下这些步骤:

  1. 架设一个 DHCP 服务器,以使 AP 可以获取网络地址。

    注意: 如果 AP 位于不同的子网中,则使用选项 43。

  2. 配置 WLC 的基本操作

  3. 为 WLC 配置交换机

  4. 为 AP 配置交换机

  5. 将轻量 AP 注册到 WLC。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

http://www.cisco.com/c/dam/en/us/support/docs/wireless/4400-series-wireless-lan-controllers/69719-wlc-lwap-config-1.gif

配置 WLC 的基本操作

在控制器以出厂默认值启动时,启动脚本将运行配置向导,该向导提示安装程序进行初始配置设置。此过程介绍如何在命令行界面 (CLI) 中使用配置向导输入初始配置设置。

注意: 请确保了解如何配置外部 DHCP 服务器和/或 DNS。

    完成以下这些步骤以配置 WLC 的基本操作:

  1. 用 DB-9 无调制解调器串行电缆将计算机与 WLC 相连。

  2. 打开一个具有以下设置的终端仿真器会话:

    • 9600 波特

    • 8 个数据位

    • 1 个停止位

    • 无奇偶校验

    • 无硬件流控制

  3. 在提示符下,登录到 CLI。

    默认用户名为 admin,默认口令为 admin。

  4. 如有必要,请输入 reset system,重新启动设备并启动向导。

  5. 在向导的第一个提示符下,输入系统名称。系统名称最多可以包含 32 个可打印的 ASCII 字符。

  6. 输入管理员用户名和口令。用户名和口令最多可以包含 24 个可打印的 ASCII 字符。

  7. 输入服务端口接口 IP 配置协议,none 或 DHCP。

    如果不想使用服务端口,或者要向服务端口分配静态 IP 地址,则输入 none

  8. 如果在步骤 7 中输入了 none,因而对于服务端口需要输入静态 IP 地址,则在后续的两个提示符下输入服务端口接口 IP 地址和子网掩码。

    如果不想使用服务端口,则对于 IP 地址和子网掩码都输入 0.0.0.0

  9. 输入以下这些选项的值:

    • 管理接口 IP 地址

    • 网络屏蔽

    • 默认路由器 ip 地址

    • 可选的 VLAN 标识符

      可以使用有效的 VLAN 标识符,或使用 0 表示无标记。

    注意: 将控制器上的管理接口配置为其所连接的交换机端口上“本地 VLAN”的一部分后,控制器 应对帧做标记。因此,必须将 VLAN 设置为零(在控制器上)。

  10. 输入网络接口(分发系统)物理端口号。

    对于 WLC,前面板千兆以太网端口可以是 1 至 4 端口。

  11. 输入向客户端、管理接口和服务端口接口(如果使用一个)提供 IP 地址的默认 DHCP 服务器的 IP 地址。

  12. 输入 LWAPP 传输模式,LAYER2 或 LAYER3。

    注意: 如果通过向导配置 WLC 4402,并选择 AP 传输模式 LAYER2,则向导不询问 AP 管理器的详细信息。

  13. 输入虚拟网关 IP 地址。

    此地址可以是任何虚构、未指定的 IP 地址(如 1.1.1.1),供第 3 层安全性和移动性管理器使用。

    注意: 通常所使用的虚拟网关 IP 地址为专用地址。

  14. 输入 Cisco WLAN 解决方案移动组/RF 组名。

  15. 输入 WLAN 1 的服务集标识符 (SSID),即网络名称。

    此标识符是轻量 AP 用于与 WLC 相关联的默认 SSID。

  16. 允许或禁止客户端使用静态 IP 地址。

    要允许客户端提供自己的 IP 地址,则输入 yes。要让客户端从 DHCP 服务器请求 IP 地址,则输入 no

  17. 如果需要在 WLC 上配置 RADIUS 服务器,则输入 yes,然后输入以下这些信息:

    • RADIUS 服务器的 IP 地址

    • 通信端口

    • 共享密钥

    如果不需要配置 RADIUS 服务器,或希望以后再配置该服务器,则输入 no

  18. 输入设备对应的国家/地区代码。

    输入 help 可看到受支持的国家/地区的列表。

  19. 启用和禁用对 IEEE 802.11b、IEEE 802.11a 和 IEEE 802.11g 的支持。

  20. 启用或禁用无线电资源管理 (RRM)(自动 RF)。

WLC 4402 — 配置向导
Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
System Name [Cisco_43:eb:22]: c4402
Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (24 characters max): *****
Service Interface IP Address Configuration [none][DHCP]: none
Enable Link Aggregation (LAG) [yes][NO]: No
Management Interface IP Address: 192.168.60.2
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.168.60.1
Management Interface VLAN Identifier (0 = untagged): 60
Management Interface Port Num [1 to 2]: 1
Management Interface DHCP Server IP Address: 192.168.60.25
AP Transport Mode [layer2][LAYER3]: LAYER3
AP Manager Interface IP Address: 192.168.60.3
AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (192.168.50.3): 192.168.60.25
Virtual Gateway IP Address: 1.1.1.1
Mobility/RF Group Name: RFgroupname
Network Name (SSID): SSID
Allow Static IP Addresses [YES][no]: yes
Configure a RADIUS Server now? [YES][no]: no
Enter Country Code (enter 'help' for a list of countries) [US]: US
Enable 802.11b Network [YES][no]: yes
Enable 802.11a Network [YES][no]: yes
Enable 802.11g Network [YES][no]: yes
Enable Auto-RF [YES][no]: yes

注意: WLC 上的管理接口是唯一一个从 WLC 之外始终可 ping 通的接口。因此,如果不能从 WLC 之外 ping 通 AP 管理器接口,则此行为在预计之内。

注意: 必须配置 AP 管理器接口,AP 才能与 WLC 关联。

为 WLC 配置交换机

本示例使用 Catalyst 3750 交换机,它仅使用一个端口。本示例对 AP 管理器和管理接口做标记,并将这些接口放置在 VLAN 60 上。将交换机端口配置为 IEEE 802.1Q 中继,并且在该中继上只允许相应的 VLAN(在本例中为 VLAN 2 至 4 和 60)。对管理和 AP 管理器 VLAN (VLAN 60) 做了标记,但未将其配置为中继的本地 VLAN。因此,当示例在 WLC 上配置这些接口时,会为这些接口分配一个 VLAN 标识符。

以下是 802.1Q 交换机端口配置的示例:

interface GigabitEthernet1/0/1
description Trunk Port to Cisco WLC
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-4,60
switchport mode trunk
no shutdown

注意: 连接 WLC 千兆端口时,请确保仅将其连接到交换机的千兆端口上。如果将 WLC 千兆以太网连接到交换机的快速以太网端口,则它将无法正常工作。

请注意,此配置示例以 802.1Q 中继上仅允许相关 VLAN 的方式配置相邻的交换机端口。所有其他 VLAN 都受到修剪。此类型的配置并非必需,但却是部署的最佳实践。修剪不相关的 VLAN 时,WLC 仅处理相关的帧,这样就优化了性能。

为 AP 配置交换机

这是 Catalyst 3750 中 VLAN 接口配置的一个示例:

interface VLAN5
description AP VLAN
ip address 10.5.5.1 255.255.255.0

当 Cisco WLC 始终连接到 802.1Q 中继时,Cisco 轻量 AP 无法识别 VLAN 标记,因此只应连接到相邻交换机的接入端口。

这是 Catalyst 3750 中交换机端口配置的一个示例:

interface GigabitEthernet1/0/22
description Access Port Connection to Cisco Lightweight AP
switchport access vlan 5
switchport mode access
no shutdown

基础设施现已准备好与 AP 进行连接。LAP 使用不同的 WLC 发现方法,并选择一个 WLC 加入。然后 LAP 注册到控制器。

这是链路到在解释无线局域网控制器leavingcisco.com 初始配置使用CLI和GUI的Cisco支持社区的一个视频:无线局域网控制器初始配置使用CLI和GUI的leavingcisco.com

http://www.cisco.com/c/dam/en/us/support/docs/wireless/4400-series-wireless-lan-controllers/69719-wlc-lwap-config-2.gif

验证

使用本部分可确认配置能否正常运行。

将 LAP 注册到控制器之后,可以在控制器用户界面顶部的 Wireless 下看到这些 LAP:

http://www.cisco.com/c/dam/en/us/support/docs/wireless/4400-series-wireless-lan-controllers/69719-wlc-lwap-config-3.gif

在 CLI 中,可以使用 show ap summary 命令验证 LAP 是否注册到 WLC:

(Cisco Controller) >show ap summary

Number of APs.................................... 1

Global AP User Name.............................. Not Configured
Global AP Dot1x User Name........................ Not Configured

AP Name             Slots  AP Model             Ethernet MAC       Location     Port  Country  Priority
------------------  -----  -------------------  -----------------  ----------------  ----  -------  ------
AP001b.d4e3.a81b     2     AIR-LAP1232AG-A-K9   00:1b:d4:e3:a8:1b  default location  2     IN       1

在 WLC CLI 中,还可以使用 show client summary 命令查看注册到 WLC 的客户端:

(Cisco Controller) >show client summary

Number of Clients................................ 1

MAC Address        AP Name        Status         WLAN  Auth  Protocol  Port
-----------------  -------------  -------------  ----  ----  --------  ----
00:40:96:a1:45:42  ap:64:a3:a0    Associated     4     Yes   802.11a   1

(Cisco Controller) >

这是解释如何执行使用GUI和CLI的无线局域网控制器初始配置的视频演示:无线局域网控制器初始配置使用CLI和GUI的leavingcisco.com

故障排除

使用本部分可排除配置的故障。

命令

使用这些命令可排除配置的故障。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

debug lwapp events enable WLC 命令输出显示轻量 AP 已注册到 WLC:

(Cisco Controller) >debug lwapp events enable
Tue Apr 11 13:38:47 2006: Received LWAPP DISCOVERY REQUEST from AP 
    00:0b:85:64:a3:a0 to ff:ff:ff:ff:ff:ff on port '1'
Tue Apr 11 13:38:47 2006: Successful transmission of LWAPP Discovery-Response 
    to AP 00:0b:85:64:a3:a0 on Port 1
Tue Apr 11 13:38:58 2006: Received LWAPP JOIN REQUEST from AP 
    00:0b:85:64:a3:a0 to 00:0b:85:33:a8:a0 on port '1'
Tue Apr 11 13:38:58 2006: LWAPP Join-Request MTU path from AP 00:0b:85:64:a3:a0
    is 1500, remote debug mode is 0
Tue Apr 11 13:38:58 2006: Successfully added NPU Entry for AP 
    00:0b:85:64:a3:a0 (index 48) Switch IP: 192.168.60.2, Switch Port: 12223, 
    intIfNum 1, vlanId 60 AP IP: 10.5.5.10, AP Port: 19002, next hop MAC: 
    00:0b:85:64:a3:a0
Tue Apr 11 13:38:58 2006: Successfully transmission of LWAPP Join-Reply to AP 
    00:0b:85:64:a3:a0
Tue Apr 11 13:38:58 2006: Register LWAPP event for AP 
    00:0b:85:64:a3:a0 slot 0
Tue Apr 11 13:38:58 2006: Register LWAPP event for AP 00:0b:85:64:a3:a0 slot 1
Tue Apr 11 13:39:00 2006: Received LWAPP CONFIGURE REQUEST from AP 
    00:0b:85:64:a3:a0 to 00:0b:85:33:a8:a0
Tue Apr 11 13:39:00 2006: Updating IP info for AP 00:0b:85:64:a3:a0 -- 
    static 0, 10.5.5.10/255.255.255.0, gtw 192.168.60.1
Tue Apr 11 13:39:00 2006: Updating IP 10.5.5.10 ===> 10.5.5.10 for AP 
    00:0b:85:64:a3:a0
Tue Apr 11 13:39:00 2006: spamVerifyRegDomain RegDomain set for slot 0 code 0 
    regstring -A regDfromCb -A
Tue Apr 11 13:39:00 2006: spamVerifyRegDomain RegDomain set for slot 1 code 0 
    regstring -A regDfromCb -A
Tue Apr 11 13:39:00 2006: spamEncodeDomainSecretPayload:Send domain secret 
    Mobility Group<6f,39,74,cd,7e,a4,81,86,ca,32,8c,06,d3,ff,ec,6d,95,10,99,dd> 
    to AP 00:0b:85:64:a3:a0
Tue Apr 11 13:39:00 2006: Successfully transmission of LWAPP 
    Config-Message to AP 00:0b:85:64:a3:a0
Tue Apr 11 13:39:00 2006: Running spamEncodeCreateVapPayload for SSID 'SSID'
Tue Apr 11 13:39:00 2006: AP 00:0b:85:64:a3:a0 associated. Last AP failure was 
    due to Configuration changes, reason:  operator changed 11g mode
Tue Apr 11 13:39:00 2006: Received LWAPP CHANGE_STATE_EVENT from AP 
    00:0b:85:64:a3:a0
Tue Apr 11 13:39:00 2006: Successfully transmission of LWAPP Change-State-Event 
    Response to AP 00:0b:85:64:a3:a0
Tue Apr 11 13:39:00 2006: Received LWAPP Up event for AP 00:0b:85:64:a3:a0 slot 0!
Tue Apr 11 13:39:00 2006: Received LWAPP CONFIGURE COMMAND RES from AP 
    00:0b:85:64:a3:a0
Tue Apr 11 13:39:00 2006: Received LWAPP CHANGE_STATE_EVENT from AP 
    00:0b:85:64:a3:a0
Tue Apr 11 13:39:00 2006: Successfully transmission of LWAPP Change-State-Event 
    Response to AP 00:0b:85:64:a3:a0
Tue Apr 11 13:39:00 2006: Received LWAPP Up event for AP 
    00:0b:85:64:a3:a0 slot 1!

此输出显示以下这些有用的 WLC debug 命令:

Tue Apr 11 14:30:49 2006: Applied policy for mobile 00:40:96:a1:45:42
Tue Apr 11 14:30:49 2006: STA [00:40:96:a1:45:42, 192.168.1.41] Replacing Fast 
    Path rule type = Airespace AP Client  on AP 00:0B:85:64:A3:A0, slot 0  
    InHandle = 0x00000000, OutHandle = 0x00000000  ACL Id = 255, Jumbo Frames 
				= NO, interface = 1  802.1P = 0, DSCP = 0, T
Tue Apr 11 14:30:49 2006: Successfully plumbed mobile rule for mobile 
    00:40:96:a1:45:42 (ACL ID 255)
Tue Apr 11 14:30:49 2006: Plumbed mobile LWAPP rule on AP 00:0b:85:64:a3:a0 
    for mobile 00:40:96:a1:45:42
Tue Apr 11 14:30:53 2006: DHCP proxy received packet, src: 0.0.0.0, 
    len = 320
Tue Apr 11 14:30:53 2006: dhcpProxy: Received packet: Client 00:40:96:a1:45:42 
    DHCP Op: BOOTREQUEST(1), IP len: 320, switchport: 1, encap: 0xec03
Tue Apr 11 14:30:53 2006: dhcpProxy(): dhcp request, client: 
    00:40:96:a1:45:42: dhcp op: 1, port: 1, encap 0xec03, old mscb 
    port number: 1
Tue Apr 11 14:30:53 2006: dhcp option len, including the magic cookie = 84
Tue Apr 11 14:30:53 2006: dhcp option: received DHCP REQUEST msg
Tue Apr 11 14:30:53 2006: dhcp option: skipping option 61, len 7
Tue Apr 11 14:30:53 2006: dhcp option: requested ip = 192.168.1.41
Tue Apr 11 14:30:53 2006: dhcp option: skipping option 12, len 15
Tue Apr 11 14:30:53 2006: dhcp option: skipping option 81, len 19
Tue Apr 11 14:30:53 2006: dhcp option: vendor class id = MSFT 5.0 (len 8)
Tue Apr 11 14:30:53 2006: dhcp option: skipping option 55, len 11
Tue Apr 11 14:30:53 2006: dhcpParseOptions: options end, len 84, actual 84
Tue Apr 11 14:30:53 2006: mscb->dhcpServer: 192.168.60.2, mscb->dhcpNetmask: 
    255.255.255.0,mscb->dhcpGateway: 192.168.60.1, mscb->dhcpRelay:
    192.168.60.2 VLAN: 60
Tue Apr 11 14:30:53 2006: Local Address: 192.168.60.2, DHCP Server: 
    192.168.60.2, Gateway Addr: 192.168.60.2, VLAN: 60, port: 1
Tue Apr 11 14:30:53 2006: DHCP Message Type received: DHCP REQUEST msg
Tue Apr 11 14:30:53 2006:   op: BOOTREQUEST, htype: Ethernet, hlen: 6, hops: 1
Tue Apr 11 14:30:53 2006:   xid: 3371152053, secs: 0, flags: 0
Tue Apr 11 14:30:53 2006:   chaddr: 00:40:96:a1:45:42
Tue Apr 11 14:30:53 2006:   ciaddr: 0.0.0.0,  yiaddr: 0.0.0.0
Tue Apr 11 14:30:53 2006:   siaddr: 0.0.0.0,  giaddr: 192.168.60.2
Tue Apr 11 14:30:53 2006: Forwarding DHCP packet locally (348 octets) from 
    192.168.60.2 to 192.168.60.2
Tue Apr 11 14:30:53 2006: Received 348 byte dhcp packet from 0x0201a8c0 
    192.168.60.2:68
Tue Apr 11 14:30:53 2006: DHCP packet: 192.168.60.2 -> 192.168.60.2 using 
    scope "InternalScope"
Tue Apr 11 14:30:53 2006: received REQUEST
Tue Apr 11 14:30:53 2006: Checking node 192.168.1.41  Allocated 1144765719, 
    Expires 1144852119 (now: 1144765853) 
Tue Apr 11 14:30:53 2006: adding option 0x35
Tue Apr 11 14:30:53 2006: adding option 0x36
Tue Apr 11 14:30:53 2006: adding option 0x33
Tue Apr 11 14:30:53 2006: adding option 0x03
Tue Apr 11 14:30:53 2006: adding option 0x01
Tue Apr 11 14:30:53 2006: dhcpd: Sending DHCP packet (giaddr:192.168.60.2)to 
192.168.60.2:67  from 192.168.60.2:1067
Tue Apr 11 14:30:53 2006: sendto (548 bytes) returned 548
Tue Apr 11 14:30:53 2006: DHCP proxy received packet, src: 192.168.60.2, 
    len = 548
Tue Apr 11 14:30:53 2006: dhcpProxy: Received packet: Client 00:40:96:a1:45:42
    DHCP Op: BOOTREPLY(2), IP len: 548, switchport: 0, encap: 0x0
Tue Apr 11 14:30:53 2006: dhcp option len, including the magic cookie = 312
Tue Apr 11 14:30:53 2006: dhcp option: received DHCP ACK msg
Tue Apr 11 14:30:53 2006: dhcp option: server id = 192.168.60.2
Tue Apr 11 14:30:53 2006: dhcp option: lease time (seconds) = 86400
Tue Apr 11 14:30:53 2006: dhcp option: gateway = 192.168.60.1
Tue Apr 11 14:30:53 2006: dhcp option: netmask = 255.255.255.0
Tue Apr 11 14:30:53 2006: dhcpParseOptions: options end, len 312, actual 64
Tue Apr 11 14:30:53 2006: DHCP Reply to AP client: 00:40:96:a1:45:42, 
    frame len 412, switchport 1
Tue Apr 11 14:30:53 2006: DHCP Message Type received: DHCP ACK msg
Tue Apr 11 14:30:53 2006:   op: BOOTREPLY, htype: Ethernet, hlen: 6, hops: 0
Tue Apr 11 14:30:53 2006:   xid: 3371152053, secs: 0, flags: 0
Tue Apr 11 14:30:53 2006:   chaddr: 00:40:96:a1:45:42
Tue Apr 11 14:30:53 2006:   ciaddr: 0.0.0.0,  yiaddr: 192.168.1.41
Tue Apr 11 14:30:53 2006:   siaddr: 0.0.0.0,  giaddr: 0.0.0.0
Tue Apr 11 14:30:53 2006:   server id: 1.1.1.1  rcvd server id: 192.168.60.2

还可以使用以下这些额外的 debug 命令排除配置的故障:

  • debug lwapp errors enable — 显示 LWAPP 错误调试的输出

  • debug pm pki enable — 显示 AP 与 WLC 之间传递的证书消息的调试

控制器不保护 AP 管理器 IP 地址

此问题是 bug CSCsg75863 引起的后果。如果用户无意中在使用控制器的 AP 管理器 IP 地址的子网上注入了设备,则将用错误的 MAC 地址刷新默认网关路由器上的地址解析协议 (ARP) 缓存。发生这种情况时,AP 不能再到达控制器,因此将进入其发现阶段以查找控制器。AP 发送发现请求,而控制器以发现回复进行响应,但是 JOIN 请求因网关路由器上的 ARP 条目有误而无法到达控制器的 AP 管理器接口。默认的 4 小时 ARP 刷新间隔之后,如果除去了设备,则 AP 将加入控制器。

此问题的解决方法是在控制器的网关路由器上为以下这些 IP 地址配置静态 ARP 条目:

  • 管理 IP 地址 — 用户从另一个子网可访问图形用户界面 (GUI),并且控制器收到 AP 发现请求。

  • AP 管理器 IP 地址 — AP 加入另一个子网中的控制器。

  • 每个动态接口的 IP 地址 — 来自其他子网的数据包到达控制器的动态接口。

从无线客户端的接口传输的 DHCP 数据包。通过 Telnet 或 SSH 连接到控制器的网关地址,并使用 arp <IP 地址> <hhhh.hhhh.hhhh> 命令添加 ARP 条目。在控制器的默认路由器上对不同的地址使用 ping 命令,以刷新路由器上的 ARP 缓存。为了发现 MAC 地址,请使用此命令:show arp|include <IP 地址>

排除轻量接入点无法加入无线 LAN 控制器的故障

有关轻量接入点 (LAP) 为何无法加入 WLC 的问题以及如何解决这些问题的信息,请参阅排除轻量接入点无法加入无线 LAN 控制器的故障


相关信息


Document ID: 69719