无线/移动 : 无线 VLAN

无线局域网控制器上的 VLAN 配置示例

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文档介绍如何在无线 LAN 控制器 (WLC) 上配置 VLAN。

先决条件

要求

本文档没有任何特定的要求。但是,本文档假设有一个正在工作的 DHCP 服务器为注册到控制器的接入点 (AP) 提供 IP 地址。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 配置 A:

    • 运行Cisco IOS�软件和WLAN控制器的Catalyst交换机

    • Cisco 4404运行软件版本7.0的WLAN控制器

  • 配置 B:

    • 运行 Catalyst OS (CatOS) 软件的 Catalyst 交换机和一个 WLAN 控制器

    • Cisco 4404运行软件版本7.0的WLAN控制器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

WLC 上的动态接口

动态接口(也称为 VLAN 接口)是由用户创建的并且设计为类似于无线 LAN 客户端的 VLAN。一个控制器最多可以支持 512 个动态接口 (VLAN)。每个动态接口都是单独配置的并且允许控制器的任何或所有分布式系统端口上存在单独的通信流。每个动态接口控制 VLAN 以及控制器和所有其他网络设备之间的其他通信,并且每个动态接口都作为与映射到该接口的 WLAN 关联的无线客户端的一个 DHCP 中继。您能分配动态接口到分布式系统端口、WLAN、Layer2管理接口和第3层Ap-manager接口。您能也映射动态接口到备份端口。

您能配置零,一个或者在分布式系统端口的多个动态接口。然而,所有动态接口必须在不同的VLAN或IP子网从在端口配置的其他接口。如果端口无标记,所有动态接口必须在从在端口配置的其他接口的一个不同的IP子网。

与二级子网的一个动态接口不支持配置。

思科推荐使用标记为的VLAN动态接口。

带有 WLAN 控制器的 VLAN 使用此模型:

/image/gif/paws/68100/wlan_controllers_vlans1.gif

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

Catalyst 交换机配置

本部分使用以下配置:

运行 Cisco IOS 软件的 Catalyst 交换机
lab1sup720ip1#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
lab1sup720ip1(config)#interface gigabitethernet 1/6
lab1sup720ip1(config-if)#
lab1sup720ip1(config-if)#switchport
lab1sup720ip1(config-if)#switchport trunk encapsulation dot1q
lab1sup720ip1(config-if)#switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
lab1sup720ip1(config-if)#switchport mode trunk
lab1sup720ip1(config-if)#end
lab1sup720ip1#

运行 CatOS 软件的 Catalyst 交换机
controller-catos> (enable) set trunk 2/1 on dot1q
Port(s)  2/1 trunk mode set to on.
Port(s)  2/1 trunk type set to dot1q.
!
!clearing out/pruning unwanted vlans
!
controller-catos> (enable) clear trunk 2/1 21-24,26-30,31-34,36-39,41-44,46-49,51-54,
56-99,101-999

!--- This command should be on one line.

Removing Vlan(s) 21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999 from allowed list.
Port  2/1 allowed vlans modified to 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094.

WLAN 控制器 VLAN 配置

GUI 配置

在 WLAN 控制器上完成以下步骤。

  1. 从 WLC GUI 中,选择 Controller > InterfacesInterfaces 页列出在 WLC 上配置的所有接口。要创建新的动态接口,请单击 New

    wlan_controllers_vlans2.gif

  2. 输入接口名称和 VLAN 标识符,然后单击 Apply

    wlan_controllers_vlans3.gif

  3. 输入特定于此 VLAN 的参数。部分参数包括 IP 地址、网络掩码、网关和 DHCP 服务器 IP 地址,然后单击 Apply

    下面是一个示例。

    wlan_controllers_vlans4.gif

    注意: 分配给此接口的 IP 地址将充当客户端从 DHCP 服务器获取 IP 地址的 DHCP 中继。例如,当客户端尝试与映射到此动态接口的 WLAN/SSID(请参阅此配置中的步骤 5)关联时,它会执行本地子网广播以标识 DHCP 服务器。控制器将此动态接口的 IP 地址作为为此接口配置的 DHCP 服务器的中继 IP,向 DHCP 服务器(或其自身,如果它是分段的 DHCP 服务器)发送一个请求。DHCP 服务器从已配置的 DHCP 范围为客户端分配 IP 地址。

  4. 验证接口配置。

    单击窗口顶部菜单中的 Controller 选项卡,并从左侧菜单中选择“Interfaces”。

    wlan_controllers_vlans5.gif

  5. 单击在菜单的WLAN选项卡在窗口顶部,并且单击创建新

    wlan_controllers_vlans6.gif

  6. 输入服务集标识(SSID)和配置文件名称并且单击应用

    本示例使用 vlan15 以便于理解。

    wlan_controllers_vlans7.gif

  7. 从窗口底部的“Interface Name”下拉菜单中选择 vlan15,然后单击“Apply”。

    在本例中,SSID vlan15 与接口名称 vlan15 关联。

    wlan_controllers_vlans8.gif

CLI 配置

使用此部分以通过命令行界面 (CLI) 配置 VLAN。

  1. 创建接口和关联的 VLAN 标记。

    命令为 config interface create interface_name vlan_id

    (lab5wlc4404ip15) >config interface create "vlan 15" 15
    

    注意: 如果有在VLAN/WLAN名称的一空间象在本例中的案件,请确保名称在报价单。

  2. 定义 IP 地址和默认网关。

    命令为 config interface interface_name IP_address netmask gateway

    (lab5wlc4404ip15) >config interface address "vlan 15" 192.168.15.10  
    255.255.255.0 192.168.15.1
    
    !--- This command should be on one line.
    
    
  3. 定义 DHCP 服务器。

    命令是config interface dhcp动态接口<interface-name>主要的<primary-server> [secondary] <secondary-server>

    (lab5wlc4404ip15) >config interface dhcp dynamic-interface "vlan 15" primary 1
    2.168.15.15
    
  4. 发出此命令为了映射接口到物理端口:

    配置接口端口operator_defined_interface_name physical_ds_port_number。示例如下:

    (Cisco Controller) >config interface port "vlan 15" 2
    
  5. 验证接口配置。

    命令为 show interface summary

    (Cisco Controller) >show interface summary
    
    Interface Name                   Port Vlan Id  IP Address      Type    Ap Mgr Guest
    -------------------------------- ---- -------- --------------- ------- ------ ----
    ap-manager                       2    untagged 10.77.244.207   Static  Yes    N
    
    management                       2    untagged 10.77.244.206   Static  No     N
    
    service-port                     N/A  N/A      50.0.0.1        Static  No     N
    
    virtual                          N/A  N/A      1.1.1.1         Static  No     N
    
    vlan 15                          2    15       192.168.15.10   Dynamic No     N
  6. 定义 WLAN。

    命令为 config wlan create wlan_id name

    (lab5wlc4404ip15) >config wlan create 2 "vlan 15"
    
  7. 定义 WLAN 的接口。

    命令为 config wlan interface wlan_id interface_name

    (lab5wlc4404ip15) >config wlan interface 2 "vlan 15"
    
  8. 验证 WLAN 和关联的接口。

    命令为 show wlan summary

    (lab5wlc4404ip15) >show wlan summary 
    
    Number of WLANs.................................. 2
    
    WLAN ID�  WLAN Name�������������� Status���� �� Interface Name����������������� 
    -------� �--------------------�   ---------� ���--------------------------------
    1������� �lab5wlc4404ip15������   Enabled����   management��������������������� 
    2������� �vlan 15����������������� Disabled���   vlan 15������������������������� 
    
    (lab5wlc4404ip15) >

点击此链路为了查看描述如何配置在无线局域网控制器的VLAN的Cisco支持社区视频:

在无线局域网控制器的VLANleavingcisco.com

wlan_controllers_vlans9.gif

验证

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

Catalyst 交换机验证

  • 运行 Cisco IOS 软件的 Catalyst 交换机 - show running-config interface interface_type interface_number

    controller-ios#show running-config interface gigabitethernet 2/1
    
     Building configuration...
     
    Current configuration : 190 bytes
    !
    interface GigabitEthernet2/1
     no ip address
     switchport
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
     switchport mode trunk
    end
  • 运行 CatOS 软件的 Catalyst 交换机 - show config mod

    controller-catos> (enable) show config 2
    
    !--- This command shows non-default configurations only.
    !--- Issue the show config mod all command in order to  
    !--- show both default and non-default configurations.
    
    ............................
    begin
    !
    # ***** NON-DEFAULT CONFIGURATION *****
    !
    !
    #time: Sat Jan 7 2006, 08:03:04 
    !
    # default port status is enable
    !
    !
    #module 2 : 2-port 1000BaseX Supervisor
    clear trunk 2/1  2-4,6-14,16-19,21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999
    set trunk 2/1  on dot1q 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094
    end
    Console> (enable)

WLAN 控制器 VLAN 验证

请参阅本文档的 WLAN 控制器 VLAN 配置部分,其中包括验证步骤。

故障排除

使用本部分可排除配置故障。

故障排除步骤

按照以下说明排除配置故障。

  1. 从 WLAN 控制器 ping VLAN 路由接口上配置的默认网关,然后按相反的方向 ping。

    • WLAN 控制器:

      (lab5wlc4404ip15) >ping 192.168.15.1
      
      Send count=3, Receive count=3 from 192.168.15.1
    • VLAN 路由接口:

      lab1sup720ip1#ping 192.168.15.10
      
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 192.168.15.10, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = �/4 ms
      lab1sup720ip1#
  2. 如果 ping 不成功,请在交换机上部署数据包捕获/嗅探器并进行检查以验证 VLAN 标记是否正确。

    注意: 当您从控制器启动到第 3 层网关(该网关位于与您的动态接口相同的子网中)的 ping 操作时,控制器看似从动态接口发起 ping。


相关信息


Document ID: 68100