语音和统一通信 : Cisco Unity Express

Cisco CallManager Express/Cisco Unity Express 配置示例

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文档提供有关 Cisco CallManager Express (CME) 4.0 和 Cisco Unity Express (CUE) 2.2.2 的示例配置,以及在电话网络中对这两个系统进行集成的方法。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • 安装适当的硬件。

  • 下载并且安装适当的思科IOSï ¿  ½软件。

  • 下载 Cisco Unified CallManager Express 软件。

  • 下载 Cisco Unity Express 软件。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 适用 Cisco IOS 软件版本 12.4(9)T 的 Cisco 3725 路由器

  • 适用 Cisco IOS 软件版本 12.1 的 Cisco Catalyst 3550 交换机

  • Cisco IP 7960 电话

  • Cisco Unified CallManager Express 4.0

  • Cisco Unity Express 2.2.2

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档中所述功能的信息。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

/image/gif/paws/62609/tdcmecue-1.gif

定义本地 DHCP 服务器

在优化的 IP 电话网络中,电话和 PC 的 IP 地址必须设置在不同的网段中。使用动态主机控制协议 (DHCP) 可以自动将可重复使用的 IP 地址分配给 DHCP 客户端。Cisco IOS DHCP 服务器功能是一种完整的 DHCP 服务器实施,它从路由器内指定的地址池中将 IP 地址分配给 DHCP 客户端并对其进行管理。Cisco IOS DHCP 服务器如果不能满足来自数据库的 DHCP 请求,则会将请求转发给网络管理员定义的一个或多个辅助 DHCP 服务器。

图 1 显示了 DHCP 客户端从 DHCP 服务器请求 IP 地址时发生的基本步骤。客户端(主机 A)发送 DHCPDISCOVER 广播消息,以查找 Cisco IOS DHCP 服务器。DHCP 服务器在 DHSCPOFFER 单播消息中为客户端提供配置参数,例如 IP 地址、MAC 地址、域名以及 IP 地址租用。

图 1 - 从 DHCP 服务器请求 IP 地址的 DHCP 请求

/image/gif/paws/62609/tdcmecue-2.gif

客户端在 DHCPREQUEST 广播消息中向 DHCP 服务器返回有关所提供 IP 地址的正式请求。DHCP 服务器向客户端返回 DHCPACK 单播消息,确认已将 IP 地址分配给客户端。

对于此配置需创建两个本地 DHCP 服务器,一个用于语音,一个用于数据。创建两个 DHCP 服务器后,您就拥有两个不同的子网,可促进正确地址的分配过程,且互不冲突。

此过程将创建 IP 地址共享池,其中所有 DHCP 客户端都收到相同信息,包括选项 150 TFTP 服务器 IP 地址。选择此方法设置 DHCP 服务的好处在于,只设置一个 DHCP 池。

  1. 输入命令 enable 进入特权 EXEC 模式。

    Router>enable
    
  2. 输入命令 configure terminal 进入全局配置模式。

    Router#configure terminal
    
  3. 输入命令 ip dhcp pool pool-name 为 DHCP 服务器地址池创建名称并进入 DHCP 池配置模式。

    Router(config)#ip dhcp pool Voice
    
  4. 输入命令 network ip-address mask 指定 DHCP 地址池的 IP 地址和可选掩码。

    Router(dhcp-config)#network 172.22.100.0 255.255.255.0
    
  5. 输入命令 option 150 ip ip-address 指定 Cisco Unified IP 电话下载映像配置文件的 TFTP 服务器地址。

    Router(dhcp-config)#option 150 ip 172.22.1.107
    
  6. 输入命令 default-router ip-address 指定 IP 电话发送或接收本地子网以外的 IP 流量时使用的路由器。

    Router(dhcp-config)#default-router 172.22.100.1
    
  7. 输入命令 end 完成配置。

    Router(dhcp-config)#end
    

    注意: 重复相同过程可为这一系列数据地址创建本地 DHCP 服务器。

配置路由器接口

在本例中,平台 3725 包含两个可用于连接到核心交换机的快速以太网接口。但是,您希望只能使用一个接口来传输数据流量和语音流量,并能通过默认网关访问 Internet。要实现此功能,VLAN 间通信是一个好方法。通过 VLAN 间通信,路由器能够将其包含的某个接口划分为多个子接口,以创建不同的逻辑网段或 VLAN。使用此功能,路由器能够在一个 VLAN 上接收数据包,再将其转发到另一个 VLAN。要实现这一点,需要在交换机和路由器之间的单个物理连接上启用交换机间链路 (ISL) 或 802.1Q 中继。在子接口上配置 IP 地址之后,路由器便感知到作为直接连接的网络与每个 VLAN 相关联的网络。

图 2 显示了连接到交换机的路由器,其中快速以太网 0/0 接口连接到交换机上的中继端口。该快速以太网接口针对每个 VLAN 划分为若干逻辑接口(子接口),且分配有一个 IP 地址以便充当每个广播域的网关。

图 2 - 配置 VLAN 间路由

tdcmecue-3.gif

此处显示了使用 802.1Q 帧标记的路由器 3725 所需的配置:

  1. 输入命令 enable 进入特权 EXEC 模式。

    Router>enable
    
  2. 输入命令 configure terminal 进入全局配置模式。

    Router#configuration terminal
    
  3. 输入命令 interface fastethernet port 进入接口配置模式。

    Router(config)#interface fastethernet 0/0.1
    
  4. 输入命令 encapsulation [dot1q/ISL] id-num native 创建本地 VLAN。

    Router(config-if)#encapsulation dot1q 1 native
    
  5. 输入命令 ip address ip-address mask 为接口分配有效地址。

    Router(config-if)#ip address 172.22.1.154 255.255.255.0
    
  6. 输入命令 exit 退出该接口的配置。

    Router(config-if)#exit
    
  7. 输入命令 interface fastethernet port.id-num 创建并进入语音子接口的配置。

    Router(config)#interface fastethernet 0/0.100
    
  8. 输入命令 encapsulation [dot1q/ISL] id-num 启用中继。

    Router(config-if)#encapsulation dot1q 100
    
  9. 输入命令 ip address ip-address mask 为语音子接口分配有效地址。

    Router(config-if)#ip address 172.22.100.1 255.255.255.0
    
  10. 输入命令 interface fastethernet port.id-num 创建并进入数据子接口的配置。

    Router(config)#interface fastethernet 0/0.20
    
  11. 输入命令 encapsulation [dot1q/ISL] id-num 启用中继。

    Router(config-if)#encapsulation dot1q 20
    
  12. 输入命令 ip address ip-address mask 为数据子接口分配有效地址。

    Router(config-if)#ip address 172.22.101.1 255.255.255.0
    
  13. 输入命令 end 完成配置。

    Router(config-if)#end
    

设置网络时间协议 (NTP)

使用网络时间协议 (NTP) 可以将 Cisco Unified CallManager Express 路由器与网络上的单个时钟(称为主时钟)同步。默认情况下在所有接口上都禁用 NTP,但它对 Cisco Unified CallManager Express 而言至关重要。因此,必须保证它处于启用状态。此过程显示了在 Cisco 3725 上启用 NTP 的步骤:

  1. 输入命令 enable 进入特权 EXEC 模式。

    Router>enable
    
  2. 输入命令 configure terminal 进入全局配置模式。

    Router#configure terminal
    
  3. 输入命令 clock timezone zone hours-offset 设置本地时区。

    Router(config)#clock timezone central -8
    
  4. 输入命令 clock summer-time zone recurring 指定夏令时。默认情况下禁用夏令时。

    Router(config)#clock summer-time central recurring
    
  5. 输入命令 ntp server ip-address 将允许此路由器上的时钟与指定的 NTP 服务器同步。在本例中,这是来自 TFTP 服务器的相同地址。

    Router(config)#ntp server 172.22.1.107
    
  6. 输入命令 end 完成配置。

    Router(config)#end
    

在 Catalyst 交换机 3550 上配置 VLAN

可创建不同的虚拟局域网 (VLAN) 以便将各个 VLAN 的流量分开,从而对语音流量和数据流量进行分隔。要实现这一点,请在 Catalyst 交换机上创建两个 VLAN,一个用于语音,一个用于数据。这样也就创建了两个逻辑子网,从而可创建多个广播域并防止网络中形成环路。电话和 PC 在物理上实际是连接在一起的,但在逻辑上却分隔在不同的子网中。在 Catalyst 3550 上创建语音 VLAN 的步骤如下。

图 3 显示了 VLAN 如何使交换机能够在交换环境内拥有多个广播域。创建一个语音 VLAN 及一个数据 VLAN。两个完全独立的子网允许电话和 PC 在各自对应的 VLAN 上进行通信。

图 3 - VLAN 概览

/image/gif/paws/62609/tdcmecue-4.gif

  1. 输入命令 enable 进入特权 EXEC 模式。

    Switch>enable
    
  2. 输入命令 configure terminal 进入全局配置模式。

    Switch#configure terminal
    
  3. 输入命令 vlan vlan-id 在交换机上创建 VLAN。

    Switch(config)#vlan 100
    
  4. 输入命令 name vlan-name 为 VLAN 命名。

    Switch(config)#name Voice
    
  5. 输入命令 end 完成配置。

    Switch(config)#end
    

    注意: 重复相同过程可创建数据 VLAN。

在 Catalyst 交换机 3550 上配置接口

您需要配置连接到路由器的接口,以完成 Cisco 3725 路由器和 Catalyst 3550 交换机之间的中继过程。交换机接口上的配置需要与路由器接口上的配置相同,这样中继才能跨单个链路从不同 VLAN 传输流量。可以为交换机上配置的每个 VLAN 创建一个 VLAN 接口,例如 int vlan 1。在本例中,对管理 VLAN 使用默认接口 VLAN (int vlan 1)。创建接口 VLAN 并进行正确配置后,需要在接口上启用中继。Catalyst 3550 交换机接口的配置如下:

  1. 输入命令 enable 进入特权 EXEC 模式。

    Switch>enable
    
  2. 输入命令 configure terminal 进入全局配置模式。

    Switch#configure terminal
    
  3. 输入命令 interface vlan vlan-id 进入要配置的接口。

    Switch(config)#interface vlan 1
    
  4. 输入命令 ip address ip-address mask 为接口分配有效地址

    Switch(config-if)#ip address 172.22.1.201 255.255.255.0
    
  5. 输入命令 exit 完成该接口的配置。

    Switch(config-if)#exit
    
  6. 输入命令 ip default-gateway ip-address 为外部网络提供访问权限。

    Switch(config)#ip default-gateway 172.22.1.1
    
  7. 输入命令 interface fastethernet port 进入需要启用中继的接口

    Switch(config)#interface fastethernet 0/19
    
  8. 输入命令 switchport trunk encapsulation [dot1q/ISL] 选择对帧进行标记的方法。

    Switch(config-if)#switchport trunk encapsulation dot1q
    
  9. 输入命令 switchport mode trunk 启用中继。

    Switch(config-if)#switchport mode trunk
    
  10. 输入命令 switchport trunk allowed vlan all 以允许中继上所有的 VLAN。

    Switch(config-if)#switchport trunk allowed vlan all
    
  11. 输入命令 duplex [full/half] 启用双工模式,且与该路由器上的双工相同。

    Switch(config-if)#duplex full
    
  12. 输入命令 speed number 设置数据速度。

    Switch(config-if)#speed 100
    
  13. 输入命令 end 完成配置。

    Switch(config-if)#end
    

配置要连接到 Cisco 7960 IP 电话的端口

Cisco 7960 IP 电话支持与 PC 或其他设备进行连接。因此,将 Catalyst 3550 系列交换机连接到 Cisco 7960 IP 电话的接口可以同时传输语音流量和数据流量。需将接口设置为中继,这样才能在单个链路上传输来自语音 VLAN 和数据 VLAN 的流量,并使其能够扩展至整个网络。启用中继模式后,必须对用于不同 VLAN 的两个交换机端口进行配置,以指定流量的划分方式。配置语音 VLAN 以传输语音流量,并配置本地 VLAN 以允许其余流量通过此 VLAN 进行传输且不作标记。执行此过程对端口进行配置,以便在不同 VLAN 上传输语音流量和数据流量。

图 4 显示了在交换机和电话之间创建的中继。该中继反映了 802.1q 类型的封装以及允许在网络间扩展的不同 VLAN。

图 4 - 中继

/image/gif/paws/62609/tdcmecue-5.gif

  1. 输入命令 enable 进入特权 EXEC 模式。

    Switch>enable
    
  2. 输入命令 configure terminal 进入全局配置模式。

    Switch#configure terminal
    
  3. 输入命令 interface fastethernet port 进入用于连接电话的端口。

    Switch(config)#interface fastethernet0/21
    
  4. 输入命令 switchport mode trunk 将端口配置为 VLAN 中继。

    Switch(config-if)#switchport mode trunk
    
  5. 输入命令 switchport trunk encapsulation dot1q 将端口配置为支持 802.1q 封装。

    Switch(config-if)#switchport trunk encapsulation dot1q
    
  6. 输入命令 switchport voice vlan vlan-id 指示 Cisco IP 电话通过指定 VLAN 转发所有语音流量。

    Switch(config-if)#switchport voice vlan 100
    
  7. 输入命令 switchport trunk native vlan vlan-id 指示 Cisco IP 电话通过指定 VLAN 转发所有数据流量。

    Switch(config-if)#switchport trunk native vlan 20
    
  8. 输入命令 end 完成配置。

    Switch(config-if)#end
    

配置 Cisco Unified CallManager Express 参数

配置过程的下一步将修改可扩展标记语言 (XML) 电话配置文件,使 IP 电话能够自动查找默认值以便在 IP 电话联机或重新启动时可以配置这些默认值。为安全起见,请将自动注册选项关闭以设置为非自动注册,以防任何电话未经允许进行连接。此过程为 Cisco Unified CallManager Express 系统所需要的电话参数设置值。按照此过程可生成配置文件。因此,电话可以下载参数值并进行自我重置。

  1. 输入命令 enable 进入特权 EXEC 模式。

    Router>enable
    
  2. 输入命令 configure terminal 进入配置模式。

    Router#configure terminal
    
  3. 输入命令 tftp-server flash: filename 允许 Cisco CallManager Express 路由器按路由器所服务的 IP 电话提供对指定文件的 TFTP 访问权限。

    Router(config)#tftp-server flash:P00307020300.bin
    
  4. 输入命令 telephony-service 进入电话配置模式。

    Router(config)#telephony-service
    
  5. 输入命令 max-ephones max-num-phones 设置此平台所支持的最大 IP 电话数。

    Router(config-telephony)#max-ephones 144
    
  6. 输入命令 max-dn max-directory-numbers 设置此平台中可存在的最大分机数。

    Router(config-telephony)#max-dn 500
    
  7. 输入命令 no auto-reg-ephone 防止任意电话连接到此系统。

    Router(config-telephony)#no auto-reg-ephone
    
  8. 输入命令 load phone-type firmware-file 标识 IP 电话在系统中注册时使用的固件文件。

    Router(config-telephony)#load 7960 P0030700300
    
  9. 输入命令 ip source-address ip-address 标识 Cisco CallManager Express 路由器进行 IP 电话注册时使用的 IP 地址和端口号。默认端口为 2000。

    Router(config-telephony)#ip source-address 172.22.1.107
    
  10. 输入命令 create cnf-files 生成 XML 配置文件。

    Router(config-telephony)#create cnf-files
    
  11. 输入命令 transfer-system full-consultant 指定呼叫转接方法。默认方法如下。

    Router(config-telephony)#transfer-system full-consultant
    
  12. 输入命令 secondary-dialtone 9 创建拨 9 以进行外部呼叫时发出的另外一种拨号音。

    Router(config-telephony)#secondary-dialtone 9
    
  13. 输入命令 end 完成配置。

    Router(config-telephony)#end
    

设置 IP 电话

Cisco Unified CallManager Express 参数已设置完毕,现在 IP 电话能够注册并开始运作。但是,在开始拨打电话和接收呼叫之前,需要在 Cisco CallManager Express 系统中注册您所需要的特定 IP 电话。在此过程中,您将设置各个 ephone-dn,然后将每个 ephone-dn 关联至一个或多个 ephone 上的一个或多个按键。每个 ephone-dn 都是一条虚拟线路或者分机,可在其上建立呼叫连接。每个物理电话都必须在 Cisco CallManager Express 路由器中配置为一个 ephone,以便在 LAN 环境下获得支持。使用 ephone-dn 命令和 dual-line 关键词可在双线模式下创建 ephone。其目的是要拥有一个语音端口和两个信道,以处理两个独立的呼叫。此模式启用了呼叫转接、呼叫等待和会议选项。此过程将在双线模式下注册 ephone 和 ephone-dn:

  1. 输入命令 enable 进入 EXEC 模式。

    Router>enable
    
  2. 输入命令 configure terminal 进入配置模式。

    Router#configure terminal
    
  3. 输入命令 ephone-dn dn-tag dual-line 创建有两个信道的分机。

    Router(config)#ephone-dn 11 dual-line
    
  4. 输入命令 number number 配置有效分机号码。

    Router(config-ephone-dn)#number 1001
    
  5. 输入命令 name name 将姓名关联至此 ephone-dn。

    Router(config-ephone-dn)#name John Smith
    
  6. 输入命令 exit 退出 ephone-dn 配置。

    Router(config-ephone-dn)#exit
    
  7. 输入命令 ephone phone-tag 进入物理电话配置。

    Router(config)#ephone 1
    
  8. 输入命令 mac-address [mac-address] 指定要配置的电话。

    Router(config-ephone)#mac-address 0030.94C2.D6E7
    
  9. 输入命令 type phone-type 指定电话类型。

    Router(config-ephone)#type 7960
    
  10. 输入命令 button button-number (separator) dn-tag 将按键号和线路特性与分机相关联。在本例中,使用 :(冒号)分隔符,这表示正常振铃。

    Router(config-ephone)#button 1:11
    
  11. 输入命令 end 完成配置。

    Router(config-ephone)#end
    

设置 Cisco CallManager Express 上的拨号计划

拨号计划模式创建了一个数字序列,可指定全局前缀,用于将缩写的分机号码扩展为完全限定的 E.164 号码。通过此配置,Cisco CallManager Express 系统可将缩写分机号码前缀的数字模式映射到完全 E.164 电话号码模式。此过程显示了拨号计划模式的配置:

  1. 输入命令 enable 进入 EXEC 模式。

    Router>enable
    
  2. 输入命令 configure terminal 进入配置模式。

    Router#configure terminal
    
  3. 输入命令 telephony-service 进入电话服务配置模式。

    Router(config)#telephony-service
    
  4. 输入命令 dialplan-pattern tag pattern extension length length 将分机号码与电话进行匹配。

    Router(config-telephony)#dialplan-pattern 1 5123781291 extension length 4
    
  5. 输入命令 end 完成配置。

    Router(config-telephony)#end
    

连接到 PSTN

在此任务期间,请对 FXO 语音端口进行配置,以支持与公共交换电话网 (PSTN) 的连接。对收发来话和去话呼叫所需的硬件(语音端口)和拨号对等体进行配置,以连接到网络外部的电话。

此配置分为三部分。首先,需要配置 FXO 端口,以便将来话呼叫转到接受拨入的分机,例如,转到可转接来话呼叫的接待员。此过程可帮助您配置 FXO 端口:

  1. 输入命令 enable 进入 EXEC 模式。

    Router>enable
    
  2. 输入命令 configure terminal 进入配置模式。

    Router#configure terminal
    
  3. 输入命令 voice-port slot/port 进入语音端口配置模式并指定要配置的端口。该端口为电话线所连接的端口,在本例中为语音端口 1/0。

    Router(config)#voice-port 2/1/0
    
  4. 输入命令 connection plar digits 指定专线自动振铃 (PLAR) 连接并将来话呼叫自动转到数字参数所指定的分机。

    Router(config-voiceport)#connection plar 1001
    
  5. 输入命令 caller-id enable 将允许在所配置的 FXO 端口上接收呼叫方 ID 信息。

    Router(config-voiceport)#caller-id enable
    
  6. 输入命令 exit 退出语音端口配置。

    Router(config-voiceport)#exit
    

其次,需要创建一些拨号对等体,使 Cisco CallManager Express 系统能够将电话号码与特定 FXO 端口相关联,以便能够发出去话呼叫。考虑拨号对等体的不同处理顺序及特定限制时,您需根据需要创建多个拨号对等体(本地呼叫、长途呼叫、国际呼叫等)。有关拨号对等体的详细信息,请参阅了解 Cisco IOS 平台上的拨号对等体和呼叫线路。将语音端口号分配给拨号对等体及目标模式。此过程将配置本地呼叫的拨号对等体:

  1. 输入命令 dial-peer voice tag pots 配置出站 POTS 拨号对等体。

    Router(config)#dial-peer voice 1 pots
    
  2. 输入命令 destination-pattern string 指定用户发出呼叫时必须拨打的号码的模式,包括前缀和目标号码。

    可以使用不同的字符代表号码。但是,此过程将本地呼叫拨号对等体配置为:前缀为 9(发出外部呼叫时需拨打的号码),[](方括号)表示范围,六个“.”(点)匹配输入的任意数字。有关详细信息,请参阅配置拨号计划、拨号对等体和数字操作中的数字剥离和前缀部分。

    Router(config-dial-peer)#destination-pattern 9[2-9]......
    

    注意: 特殊字符 ^ 和 $ 计作明确匹配数字,但 ( ) 内的任何模式都不计作明确匹配数字。

  3. 输入命令 port slot/port 指定向此对等体发出呼叫时需通过的端口。

    Router(config-dial-peer)#port 2/1/0
    
  4. 输入命令 prefix number character-comma 指定提示拨号音以发出外部呼叫的号码。

    Router(config-dial-peer)#prefix 9,
    
  5. 输入命令 end 完成配置。

    Router(config-dial-peer)#end
    

最后,需要创建一个拨号对等体,使模拟电话能够连接到局外交换站 (FXS) 端口。FXS 接口是一个 RJ-11 连接器,允许基本电话设备、键盘及 PBX 的连接,并提供振铃、电压及拨号音。需将 FXS 端口分配给此拨号对等体并为其提供目标或分机,以便能够在路由器上配置 FXS 端口。配置 FXS 端口的过程如下:

  1. 输入命令 configure terminal 进入配置模式。

    Router#configure terminal
    
  2. 输入命令 dial-peer voice tag pots 配置出站 POTS 拨号对等体。

    Router(config)#dial-peer voice 5 pots
    
  3. 输入命令 destination-pattern string 指定用户发出呼叫时必须拨打的号码的模式。在本例中,分配的目标模式需具备与 IP 电话相同的分机长度,以免与其余的拨号对等体相混淆。

    使用拨号对等体可以从模拟电话进行本地呼叫、长途呼叫和国际呼叫。

    Router(config-dial-peer)#destination-pattern 1005
    
  4. 输入命令 port slot/port 指定与 FXS 接口对应的端口,到此对等体的呼叫将通过该端口发出。

    Router(config-dial-peer)#port 2/0/0
    
  5. 输入命令 end 完成配置。

    Router(config-dial-peer)#end
    

激活与 Cisco Unity Express 软件的 IP 连接

现在需要将 Cisco Unity Express 2.2.2 集成到 Cisco CallManager Express 4.0。为此,需创建两个接口,使 Cisco Unity Express Cisco CallManager Express 之间能够进行通信。第一个接口连接到托管 Cisco CallManager Express 的路由器上,之前已在配置路由器接口中设置该接口。第二个接口将 Cisco Unity Express 与 Cisco CallManager Express 的端口及 IP 地址链接到一起。要完成此任务,请执行以下步骤:

  1. 输入命令 enable 进入 EXEC 模式。

    Router>enable
    
  2. 输入命令 configure terminal 进入配置模式。

    Router#configure terminal
    
  3. 输入命令 interface service-engine slot/unit 进入 Cisco Unity Express 接口配置模式。

    Router(config)#interface service-engine 1/0
    
  4. 输入命令 ip unnumbered type number 指定 Cisco IOS 路由器的接口类型及编号。

    Router(config-if)#ip unnumbered fastethernet 0/0.1
    
  5. 输入命令 service-module ip address cue-ip address subnet-mask 指定 Cisco Unity Express 模块接口的 IP 地址。此 IP 必须与托管 Cisco Unity Express 的 Cisco IOS 路由器位于相同的子网内。

    Router(config-if)#service-module ip address 172.22.1.155 255.255.255.0
    
  6. 输入命令 service-module ip default-gateway ip address 指定托管 Cisco Unity Express 的 Cisco IOS 路由器的 IP 地址。

    Router(config-if)#service-module ip default-gateway 172.22.1.154
    

    注意: 仅当服务引擎配置中作为未编号接口引用的接口 (FastEthernet0/0.1) 上当前已启用 proxy-arp,这些步骤才会起作用。默认情况下,proxy-arp 在以太网接口上处于启用状态。发出 Show ip interface FastEthernet0/0.1 可验证接口上 proxy-arp 的操作状态。如果 proxy-arp 已禁用,可在接口配置下发出 ip proxy-arp 将其重新启用

  7. 输入命令 exit 完成接口配置。

    Router(config-if)#exit
    
  8. 输入命令 ip route ip-address mask service-engine slot/number 建立到 Cisco Unity Express 模块的静态路由。

    Router(config)#ip route 172.22.1.155 255.255.255.255 service-engine 1/0
    
  9. 输入命令 exit 完成配置。

    Router(config)#end
    

    注意: 虽然 Cisco Unity Express 模块 CLI 具有启用模式,但 Cisco Unity Express 没有口令功能。对路由器上的启用模式具有访问权限的任何网络管理员都可以访问 Cisco Unity Express CLI。Cisco Unity Express CLI 上没有用户 ID 或口令控制。该访问通过路由器控制。如果需要日志记录,则需要以 AAA/RADIUS 登录访问监控来设置路由器。

为 Cisco CallManager Express 电话配置拨号对等体以呼叫 Cisco Unity Express 语音邮件

需要使用专用的拨号对等体来促进 Cisco CallManager Express 和 Cisco Unity Express 之间的通信。拨号对等体下的目标模式分配了供应用程序(例如 Cisco Unity Express)专用的一组电话号码。需要考虑的一点是,语音邮件号码必须在拨号对等体的目标模式范围内,而且为了将呼叫转到触发使用拨号对等体的语音邮件号码,还必须配置 ephone-dn。对于呼叫会话和从双音多频 (DTMF) 音调到 SIP 通知消息的转换,Cisco Unity Express 拨号对等体必须使用会话初始协议 (SIP)。必须关闭语音活动检测 (VAD),且必须指定编解码器。

  1. 输入命令 enable 进入 EXEC 模式。

    Router>enable
    
  2. 输入命令 configure terminal 进入配置模式。

    Router#configure terminal
    
  3. 输入命令 dial-peer voice tag voip 使用语音封装方法定义拨号对等体。

    Router(config)#dial-peer voice 2 voip
    
  4. 输入命令 destination-pattern string 指定用于拨号对等体的前缀或完全 E.164 号码。

    Router(config-dial-peer)#destination-pattern 2...
    
  5. 输入命令 session protocol sipv2 将 SIP 指定为主机 Cisco CallManager Express 路由器和 Cisco Unity Express 模块之间的呼叫适用的会话协议。

    Router(config-dial-peer)#session protocol sipv2
    
  6. 输入命令 session target ipv4:destination-ip address 指定特定于网络的地址,以便从 IP 拨号对等体上的语音接收呼叫。

    Router(config-dial-peer)#session target ipv4:172.22.1.155
    
  7. 输入命令 dtmf-relay sip-notify 使用 SIP 通知消息转发 DTMF 音调。

    Router(config-dial-peer)#dtmf-relay sip-notify
    
  8. 输入命令 codec codec 指定拨号对等体的语音编解码速率。

    Router(config-dial-peer)#codec g711ulaw
    

    注意: 请始终确保不存在编解码不匹配,因为任何不匹配都可能导致入站和出站呼叫失败。

  9. 输入命令 no vad 对使用特定拨号对等体的呼叫禁用 VAD。

    Router(config-dial-peer)#no vad
    
  10. 输入命令 exit 完成配置。

    Router(config-dial-peer)#end
    

配置语音邮件访问

Cisco CallManager Express 配置必须包括语音邮件号码的创建,该号码需处于之前创建的拨号对等体的目标模式范围内。在按下 Cisco IP 电话上的“留言”按键或者占线或无应答的呼叫被转到语音邮件时,所拨打的电话号码即为语音邮件号码。要配置语音邮件电话号码,请完成以下步骤。此外,必须配置 ephone-dn,以便将无应答或占线的呼叫转到语音邮件号码。

  1. 输入命令 enable 进入 EXEC 模式。

    Router>enable
    
  2. 输入命令 configure terminal 进入配置模式。

    Router#configure terminal
    
  3. 输入命令 telephony-service 进入电话服务配置模式。

    Router(config)#telephony-service
    
  4. 输入命令 voicemail phone-number 定义按下“留言”按键时所拨打的号码。

    Router(config-telephony-service)#voicemail 2000
    
  5. 输入命令 exit 完成配置。

    Router(config-telephony-service)#exit
    
  6. 输入命令 ephone-dn dn-tag 进入 ephone-dn 配置模式,以便修改之前创建的分机。

    Router(config)#ephone-dn 11
    
  7. 输入命令 call-forward busy directory-number 配置呼叫前转,以便将传入占线分机的来话呼叫转到语音邮件。

    Router(config-ephone-dn)#call-forward busy 2000
    
  8. 输入命令 call-forward noan directory number timeout seconds 配置呼叫前转,以便将传入无应答分机的来话呼叫转到语音邮件。

    Router(config-ephone-dn)#call-forward noan 2000 time 10
    
  9. 输入命令 end 完成配置。

    Router(config-ephone-dn)#end
    

    注意: 请在与系统连接的所有 Cisco IP 电话上重复步骤 6-9。

配置 MWI

MWI 机制可打开 Cisco IP 电话上的指示灯,以通知用户有语音邮件消息等待收听。当有人留下语音邮件消息时 MWI 即启动,用户收听语音邮件后 MWI 即关闭。要使 MWI 机制工作,请创建两个 ephone-dn,一个已打开 MWI 功能(例如 ephone-dn 8000),另一个已关闭 MWI 功能(例如 ephone-dn 8001)。

如果分机 (ext. 1001) 收到呼叫时无人应答,IP 电话会将呼叫转到语音邮件,让呼叫方留言。消息记录之后,Cisco Unity Express 向 MWI 处理 ephone-dn (ext. 8000) 发出 MWI 通知呼叫,并附加该分机 (ext. 1001) 作为通知呼叫的主叫方 ID。所拨打的号码为 80001001。分机 (ext. 1001) 上的灯将打开。

分机 (ext. 1001) 的用户收听所有语音邮件后,Cisco Unity Express 向 MWI 处理 ephone-dn (ext. 8001) 发出 MWI 通知呼叫,并附加该分机 (ext. 1001) 作为通知呼叫的主叫方 ID。所拨打的号码为 80011001。用户收听语音邮件后,灯将关闭。配置 MWI ephone-dn 的过程如下:

  1. 输入命令 enable 进入 EXEC 模式。

    Router>enable
    
  2. 输入命令 configure terminal 进入配置模式。

    Router#configure terminal
    
  3. 输入命令 ephone-dn 为 Cisco IP 电话线路创建分机。

    Router(config)#ephone-dn 14
    
  4. 输入命令 number number 将电话或分机与 ephone-dn 相关联。

    Router(config-ephone-dn)#number 8000....
    
  5. 输入命令 mwi [on|off] 配置特定的 ephone-dn,以便从外部语音邮件系统接收 MWI 通知。

    Router(config-ephone-dn)#mwi on
    
  6. 输入命令 end 完成配置。

    Router(config-ephone-dn)#end
    

    注意: 重复相同过程可创建已关闭 MWI 的分机 8001。

配置语音邮件应用程序

从现在起,大多数配置都需要在实际的 NM-Cisco Unity Express 模块上进行,这意味着需要建立一个从路由器到模块的连接。Cisco Unity Express 具有 EXEC 和配置模式,其运行方式类似于 Cisco IOS CLI 命令的 EXEC 和配置模式。发出 service-module service-engine 1/0 session 命令进入 Cisco Unity Express。配置语音邮件的过程如下:

  1. 输入命令 service-module service-engine 1/0 session 连接到模块。

    Router#service-module service-engine 1/0 session
    
  2. 输入命令 enable 进入 EXEC 模式。

    se-172-22-1-155>enable
    
  3. 输入命令 configure terminal 进入配置模式。

    se-172-22-1-155#configure terminal
    
  4. 输入命令 ccn application voicemail 进入语音邮件的应用程序配置。

    se-172-22-1-155(config)#ccn application voicemail
    
  5. 输入命令 description "text" 提供应用程序说明。

    se-172-22-1-155(config-application)#description "Cisco Voicemail"
    
  6. 输入命令 maxsessions number 指定可同时访问此应用程序的用户数目。有关此值的详细信息,请参阅在应用程序和触发器之间共享端口

    se-172-22-1-155(config-application)#maxsessions 4
    
  7. 输入命令 exit 完成应用程序配置。

    se-172-22-1-155(config-application)#exit
    
  8. 输入命令 exit 结束配置模式。

    se-172-22-1-155(config)#exit
    

配置自动总机应用程序

自动总机应用程序允许系统让自动话务员应答呼叫并为呼叫方提供不同的菜单选项以供选择。例如,如果 Cisco Unity Express 系统具有自动总机,呼叫方将听到欢迎问候,然后就可以选择选项以转接到特定部门(例如销售、人力资源等)或特定人员(例如 John Smith、Alex Lewis 等)。此过程提供自动总机配置:

  1. 输入命令 service-module service-engine slot/number session 连接到模块。

    Router#service-module service-engine 1/0 session
    
  2. 输入命令 enable 进入 EXEC 模式。

    se-172-22-1-155#enable
    
  3. 输入命令 configure terminal 进入配置模式。

    se-172-22-1-155#configure terminal
    
  4. 输入命令 ccn application autoattendant 指定要配置的应用程序。

    se-172-22-1-155(config)#ccn applicatio autoattendant
    
  5. 输入命令 description "text" 提供应用程序说明。

    se-172-22-1-155(config-application)#description "Cisco Auto-Attendant"
    
  6. 输入命令 maxsessions number 指定可同时访问此应用程序的呼叫方数目。有关此值的详细信息,请参阅在应用程序和触发器之间共享端口

    se-172-22-1-155(config-application)#maxsessions 4
    
  7. 输入命令 parameter "name" "value" 为应用程序指定参数。

    se-172-22-1-155(config-application)#parameter "operExtn" "1001"
    
  8. 输入命令 exit 完成应用程序配置。

    se-172-22-1-155(config-application)#exit
    
  9. 输入命令 exit 完成配置。

    se-172-22-1-155(config)#exit
    

配置应用程序的 SIP 触发器

配置了语音邮件和自动总机后,必须对系统进行配置,以便在调用特定信号或触发器时启动语音邮件和自动总机应用程序。触发器为电话号码。呼叫方拨打指定的电话号码时,SIP 子系统将启动语音邮件或自动总机。此过程为语音邮件配置 SIP 触发器:

  1. 输入命令 service-module service-engine slot/number session 连接到模块。

    Router#service-module service-engine 1/0 session
    
  2. 输入命令 enable 进入 EXEC 模式。

    se-172-22-1-155>enable
    
  3. 输入命令 configure terminal 进入配置模式。

    se-172-22-1-155#configure terminal
    
  4. 输入命令 ccn trigger sip phonenumber number 指定作为触发器配置模式的电话号码。号码值可以与指向 Cisco Unity Express 的 SIP 拨号对等体的目标模式字段中配置的模式之一相匹配。

    se-172-22-1-155(config)#ccn trigger sip phonenumber 2000
    
  5. 输入命令 application string 指定输入触发器时要启动的应用程序名称。

    se-172-22-1-155(config-trigger)#application voicemail
    
  6. 输入命令 enabled 启用触发器。

    se-172-22-1-155(config-trigger)#enabled
    
  7. 输入命令 maxsessions number 指定应用程序可同时处理的最大呼叫方数目。有关此值的详细信息,请参阅在应用程序和触发器之间共享端口

    se-172-22-1-155(config-trigger)#maxsessions 4
    
  8. 输入命令 exit 完成触发器配置。

    se-172-22-1-155(config-trigger)#exit
    
  9. 输入命令 exit 完成配置。

    se-172-22-1-155(config)#exit
    

    注意: 对自动总机和 promptmgmt 应用程序重复此过程。

配置用户

可创建用户和组以使用此系统。具有分机和访问语音邮件的所有人员都必须是用户。默认情况下,首次访问 Cisco Unity Express 时将创建管理员用户。不能为该管理员分配语音邮箱。但是,管理员可以配置系统,包括语音邮件和自动总机应用程序。此过程将创建用户并分配电话号码:

  1. 输入命令 service-module service-engine slot/number session 连接到模块。

    Router#service-module service-engine 1/0 session
    
  2. 输入命令 enable 进入 EXEC 模式。

    se-172-22-1-155>enable
    
  3. 输入命令 username userid create 创建具有指定用户 ID 的用户。

    se-172-22-1-155#username John create
    
  4. 输入命令 configure terminal 进入配置模式。

    se-172-22-1-155#configure terminal
    
  5. 输入命令 username userid phoneumber number 为此用户指定分机。

    se-172-22-1-155(config)#username John phonenumber 1002
    
  6. 输入命令 exit 完成配置。

    se-172-22-1-155(config)#exit
    

    注意: 重复此过程可根据需要注册多个用户,但不能超出 Cisco Unity Express 系统所支持的限制。请确保为管理员用户分配口令和 pin,使其能够对 Cisco Unity Express 进行配置及更改。有关口令和 pin 的详细信息,请参阅添加和修改用户

配置邮箱

为用户分配语音邮箱以配置 Cisco Unity Express 数据库。在前一部分所创建的用户即为邮箱用户。并非所有的用户或分机都需要语音邮箱,例如管理员用户。请先考虑用户或分机的功能或用途,然后再分配邮箱,以便高效地使用邮箱。

语音邮件不进行压缩,且使用 G.711 编解码器。每一秒的 G.711 音频相当于 64 千位每秒,因此 8 千字节每秒可转换为 480 千字节每分钟。此清单显示了每个 Cisco Unity Express 模块类型的存储能力概要:

  • Cisco Unity Express 高级集成模块 (AIM-CUE) - 14 小时

  • Cisco Unity Express 网络模块 (NM-CUE) - 100 小时

  • Cisco Unity Express 增强型容量 (NM-CUE-EC) - 300 小时

在此配置中,您将创建个人邮箱。个人邮箱将分配给特定的用户,且仅可由此用户访问。呼叫方在此邮箱中留言后,消息等待指示 (MWI) 灯将打开。要配置语音邮箱,请完成以下步骤:

  1. 输入命令 service-module service-engine slot/number session 连接到模块。

    Router#service-module service-engine 1/0 session
    
  2. 输入命令 enable 进入 EXEC 模式。

    se-172-22-1-155>enable
    
  3. 输入命令 configure terminal 进入配置模式。

    se-172-22-1-155#configure terminal
    
  4. 输入命令 voice mailbox owner name 为姓名值创建邮箱。

    se-172-22-1-155(config)#voice mailbox owner John
    
  5. 输入命令 description "text" 提供邮箱说明。

    se-172-22-1-155(config-mailbox)#description "John's Mailbox"
    
  6. 输入命令 enable 激活新建邮箱或重新激活禁用的邮箱。

    se-172-22-1-155(config-mailbox)#enable
    
  7. 输入命令 expiration time days 设置消息在邮箱中存储的天数。默认值为 30 天。

    se-172-22-1-155(config-mailbox)#expiration time 10
    
  8. 输入命令 mailboxsize seconds 指定邮箱的存储大小,单位为秒。

    se-172-22-1-155(config-mailbox)#mailboxsize 300
    
  9. 输入命令 messagesize seconds 指定传入消息的最大大小,单位为秒。

    se-172-22-1-155(config-mailbox)#messagesize 120
    
  10. 输入命令 end 完成邮箱配置。

    se-172-22-1-155(config-mailbox)#end
    
  11. 输入命令 exit 完成配置。

    se-172-22-1-155(config)#exit
    

    注意: 对每个需要语音邮箱的用户重复此过程。

验证

当前没有可用于此配置的验证过程。

故障排除

问题:用户无法通过 Cisco Unity Express 图形用户界面 (GUI) 登录

Cisco Unity Express 用户无法通过 Cisco Unity Express GUI 登录和接收 Cisco Unity Express has lost contact with the Host router.Enter the new CCME Web Administrator username and password 错误消息。

要解决此问题,请完成以下步骤:

  1. 检查 Cisco CallManager Express 配置是否遗漏了本文档中所提及的任何配置命令。

  2. 如果配置正确,则可能是 Cisco CallManager Express 路由器遗漏了默认网关配置。如果管理员在未保存配置的情况下重新加载路由器,则可能发生这种情况。检查 Cisco CallManager Express 与 Cisco Unity Express 的 IP 连接。

  3. 如果管理员决定更改 Cisco CallManager Express web 管理员用户名和口令,但新名称和口令在 Cisco Unity Express 系统中没有进行更新,则也会出现此错误消息。使用 Unity Express GUI 口令恢复中提及的过程以新的 Cisco CallManager Express 用户名和口令更新系统。

  4. 使用 service-module service-engine slot/port reload 命令重新加载 Cisco Unity Express 模块。

    注意: 重新启动 Cisco Unity Express 模块并不需要路由器也重新启动。Cisco Unity Express 模块和路由器可以彼此独立地进行重新启动。但是,如果重新启动路由器,则所有呼叫都无法到达模块,直至路由器和模块之间重新建立 IP 连接。为避免数据丢失或文件损坏,在重启路由器之前请务必先关闭模块。

有关如何对 CallManager Express/Cisco Unity Express 配置问题进行故障排除的详细信息,请参阅 Cisco Unity Express 系统功能故障排除

问题:被叫 IP 电话振铃或占线时,IP 电话无法听到回铃或忙音

网络拓扑如下:

tdcmecue-6.gif

有两个 Skinny 呼叫控制协议 (SCCP) 电话在 Cisco CallManager Express 中进行了注册,即 IP 电话 1 和 IP 电话 2。IP 电话 2 配置为将占线呼叫前转 和无应答呼叫前转 转到 Cisco Unity Express 语音邮件。

请考虑如下情况:Cisco Unity Express 已关闭或正在进行注册,此时 IP 电话 1 向 IP 电话 2 发出呼叫。当 IP 电话 2 振铃时或因尝试转接至语音邮件而占线时,IP 电话 1 无法听到回铃/忙音。当 Cisco Unity Express 打开时,一切按预期方式运作。此问题的原因是,SIP INVITE 到 Cisco Unity Express 的默认重试时间过长。

要解决此问题,请将 SIP 重试邀请配置为一个较低的值,而非默认值 6。可按照本示例输出所示对 SIP-UA 配置下的 SIP 重试邀请计时器进行配置:

configure terminal
 sip-ua
 retry invite 2

!--- For example, SIP retry invite two.

问题:通过 SIP 隧道从 PSTN 到 CUE AA 的呼叫失败

到 CUE 自动总机 (AA) 引导号码的入站 PSTN 呼叫 (SIP) 无法通过 SIP 隧道工作。从 IP 电话 (SCCP) 到 CUE AA 的内部呼叫正常工作。

CUE AA 使用 SIP 协议与 CallManager Express 进行通信。在本例中,来自 PSTN 的呼叫也是 SIP 呼叫。要解决此问题,需要发出以下命令:

CME(config)#voice service voip
CME(conf-voi-serv)#allow-connections sip to sip

注意: 只有 Cisco CallManager Express 4.0 及更高版本支持此功能。

问题:CUE 时钟与配置为 NTP 服务器的 CME 路由器不同步

CUE 上的 NTP 无法与 CallManager Express 同步。CallManager Express 路由器已配置为 NTP 服务器。CUE 时钟未显示准确时间。但是,CallManager Express 显示了正确的时间。

要解决此问题,请发出以下命令:

在 CallManager Express 路由器上:

ntp master

在 CUE 上:

ntp server x.x.x.x


!--- Where x.x.x.x is the ip address of the CME router which is configured as a NTP server.

在 CUE 和 CallManager Express 上进行所提及的配置更改后,请在 CallManager Express 路由器上发出 show ntp status 命令。您应当会看到时钟已同步。

问题:将外部呼叫转接到 CUE 自动总机时听到北美洲回铃音,而不是英国回铃音

CUE 安装了英国英语本地化版本。Cisco CallManager 既安装了美国英语本地化版本,也安装了英国英语本地化版本。

要解决此问题,请在语音网关的相应语音端口下配置 cptone GB 命令。示例输出如下:

aus-3725-03
voice-port 2/0/0
 trunk-group PSTN_ANALOG_IN_OUT_TG
 echo-cancel coverage 32
 no vad
 no comfort-noise
 cptone GB
 connection plar 42700
 description cptone EXAMPLE
 caller-id enable

注意: 回铃音由语音网关生成。

问题:CCME 寻线组不呼叫寻线组中最后一个号码

在已配置 ephone-hunt 命令的情况下,呼叫并未转接至最后一个 dn 之后的 CUE VM 系统,且呼叫方听到忙音。

要解决此问题,请将 max-redirect 增加到所需要的值。

如果 ephone-hunt 命令所配置的跳数大于 max-redirect 命令中指定的值,也可能会发生此问题。

ephone-hunt 和 max-redirect 的示例配置如下:

注意: 示例输出已省略。

设备名称 1
!
!
ephone-hunt 12 sequential

!--- Your ephone hunt group configuration would exist here.

!
!
!
telephony-service
 no auto-reg-ephone
 load 7960-7940 P00307020300
 max-ephones 144
 max-dn 500
 ip source-address 172.22.1.107 port 2000
 max-redirect 15
 service phone videoCapability 1
 dialplan-pattern 1 5123781291 extension-length 4
 voicemail 2000
 max-conferences 8 gain -6
 transfer-system full-consult
 secondary-dialtone 9
 create cnf-files version-stamp Jan 01 2002 00:00:00


相关信息


Document ID: 62609