IP : 开放最短路径优先 (OSPF)

OSPF 如何将默认路由注入到末节区域或完全末节区域

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档说明开放最短路径优先 (OSPF) 如何将默认路由注入末节区域或完全末节区域中。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用此图所示的网络设置。

/image/gif/paws/47869/ospfdb10a.gif

配置

本文档使用此处所示的配置。

路由器 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 area 1 stub

end

路由器 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 stub

end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

  • show ip ospf database -显示Link State Advertisement (LSA)列表并且键入他们到连结状态数据库。此列表仅显示 LSA 报头中的信息。

  • show ip ospf database summary <link-state id> — 显示区域边界路由器(ABR)汇总链路。

  • show ip route - 显示路由表的当前状态。

检查末节区域中的 OSPF 数据库

末节区域的 ABR 会发起链路 ID 为 0.0.0.0 的汇总 LSA。即使没有默认路由,它也将执行此操作。通过 show ip ospf database 命令就可以看到此种情况。

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#           Checksum   Link count 
2.2.2.2    2.2.2.2     19     0x80000001     0x8F8B         1 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age     Seq#           Checksum 
5.0.0.0    2.2.2.2     9       0x80000001     0x8E61 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1     1335    0x80000059     0x56DA         2 
2.2.2.2    2.2.2.2     4       0x80000013     0x7FF3         2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#               Checksum 
0.0.0.0    2.2.2.2     20      0x80000001         0x75C0 
6.0.0.0    2.2.2.2     13      0x80000001         0x2709 


r2.2.2.2#show ip ospf database summary 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Summary Net Link States (Area 1) 

  LS age: 184 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 0.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) injects a default route 
  !--- into the stub area. 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x75C0 
  Length: 28 
  Network Mask: /0 
        TOS: 0  Metric: 1 
  

r2.2.2.2#show ip route 0.0.0.0 
% Network not in table

!--- The ABR (Router 2.2.2.2) does not have a default route
!--- in its routing table.


r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:04:23, Serial2/1/0 
O*IA 0.0.0.0/0 [110/65] via 5.0.0.2, 00:04:23, Serial2/1/0 

检查完全末节区域中的 OSPF 数据库

如果在末节区域示例中将区域 1 从末节区域更改为完全末节区域,ABR 仍会将 0.0.0.0 汇总 LSA 注入区域 1。唯一的区别是其他汇总 LSA 不会发送到完全末节区域。

注意: 仅对 ABR 进行了配置更改。no-summary 语句已添加到其 OSPF 配置:area 1 stub no-summary

此命令输出显示完全末节区域中 OSPF 数据库的状态。

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum     Link count 
2.2.2.2    2.2.2.2     617     0x80000001   0x8F8B           1 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum 
5.0.0.0    2.2.2.2     608     0x80000001   0x8E61 

                Summary ASB Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum 
1.1.1.1    2.2.2.2     243     0x80000003   0x8F5E 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#         Checksum     Link count 
1.1.1.1    1.1.1.1     1934    0x80000059   0x56DA           2 
2.2.2.2    2.2.2.2     247     0x80000015   0x7BF5           2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#               Checksum 
0.0.0.0    2.2.2.2     249     0x80000003         0x71C2  

!--- Notice that this is the only summary LSA 
!--- in the totally stub area. 


r1.1.1.1#show ip route ospf 
O*IA 0.0.0.0/0 [110/65] via 5.0.0.2, 00:04:11, Serial2/1/0 

ABR不产生6.0.0.0/8的一个汇总LSA。结果,路由器1.1.1.1不再有6.0.0.0/8的一个路由。此路由器具有的唯一区域间路由是默认路由。

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 47869