IP : 开放最短路径优先 (OSPF)

OSPF 如何将默认路由注入到正常区域中

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档说明开放最短路径优先 (OSPF) 如何将默认路由注入正常区域中。注入正常区域的默认路由可以由任意 OSPF 路由器产生。默认情况下,OSPF 路由器不会生成 OSPF 域中的默认路由。要使 OSPF 生成默认路由,您必须使用 default-information originate 命令。

有两种方式可向正常区域通告默认路由。第一种方法是将 0.0.0.0 通告到 OSPF 域(只要通告路由器已具有默认路由)。第二种方法是不论通告路由器是否已具有默认路由都会通告 0.0.0.0。通过将关键字 always 添加到 default-information originate 命令,可实现第二种方法。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用此图所示的网络设置。

/image/gif/paws/47868/ospfdb9a.gif

配置

本文档使用此处所示的配置。

路由器 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1

end

路由器 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 default-information originate
 
ip route 0.0.0.0 0.0.0.0 6.0.0.3

end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

检查 OSPF 数据库

此输出通过 show ip ospf database 命令显示此网络环境中的 OSPF 数据库状态。

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age     Seq#          Checksum   Link count 
2.2.2.2    2.2.2.2     600     0x80000001    0x9583          1 

                Summary Net Link States (Area 0) 

Link ID    ADV Router   Age     Seq#          Checksum 
5.0.0.0     2.2.2.2     600     0x80000001    0x8E61 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1     864     0x8000005E     0xD350         2 
2.2.2.2    2.2.2.2     584     0x8000001E     0xF667         2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#          Checksum 
6.0.0.0    2.2.2.2     585     0x80000004    0xA87C 

                Type-5 AS External Link States 

Link ID   ADV Router   Age     Seq#          Checksum    Tag 
0.0.0.0    2.2.2.2     601     0x80000001    0xD0D8       0 

由于路由器 2.2.2.2 具有默认路由,因此它发起链路 ID 为 0.0.0.0 的类型 5 LSA。这是其 OSPF 配置中 default-information originate 命令的结果。

r2.2.2.2#show ip ospf database external 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-5 AS External Link States  

  LS age: 650 
  Options: (No TOS-capability, DC) 
  LS Type: AS External Link 
  Link State ID: 0.0.0.0 (External Network Number ) 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xD0D8 
  Length: 36 
  Network Mask: /0 
        Metric Type: 2 (Larger than any link state path) 
        TOS: 0 
        Metric: 1 
        Forward Address: 0.0.0.0 
        External Route Tag: 0 


r2.2.2.2#show ip route 0.0.0.0 
S* 0.0.0.0/0 [1/0] via 6.0.0.3, 00:28:00, ATM1/0.20  


r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:00:18, Serial2/1/0 
O*E2 0.0.0.0/0 [110/1] via 5.0.0.2, 00:00:18, Serial2/1/0 

您也可以将 always keyword 添加到 default-information originate 命令,以使路由器发起 0.0.0.0 类型 5 LSA(即使路由器的路由表中没有默认路由)。

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 47868