服务质量 (QoS) : QoS 策略

QoS 常见问题

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档解答了与服务质量 (QoS) 有关的最常见问题 (FAQ)。

一般问题

Q. 什么是服务质量(QoS) ?

A. QoS是指网络能够利用各种基础技术为所选网络数据流提供更好的服务,这些技术包括帧中继、异步传输模式(ATM)、以太网和802.1网络,SONET和IP路由的网络。

QoS是一组技术,允许应用请求和接收可预测的服务级别,服务级别是按数据吞吐量(带宽)、时延变化(抖动)和延迟等方面来定义的。特别是,QoS 功能通过以下方法提供更好、更便于预测的网络服务:

  • 支持专用带宽。

  • 改进损失特性。

  • 避免和管理网络拥塞。

  • 对网络流量进行整形。

  • 设置网络中的流量优先级。

互联网工程任务组(IETF)定义了QoS的以下两体系结构:

  • 集成服务 (IntServ)

  • 差分服务 (DiffServ)

IntServ 使用资源预留协议 (RSVP),沿着网络中端到端路径中的设备明确地发出应用程序流量所需的 QoS 信号。如果路径上的每个网络设备能预留必要的带宽,则可以开始传输应用程序。请求注释(RFC) 2205定义了RSVP,并且RFC 1633定义了IntServ。

DiffServ 集中关注聚合的设置 QoS。不是发送应用程序的 QoS 要求信令,而是差分服务在 IP 报头中使用差分服务代码点 (DSCP),显示必需的 QoS 级别。Cisco IOS�软件版本12.1(5)T介绍在Cisco路由器的DiffServ标准。有关更多信息,请参阅下列文档:

Q. 什么是拥塞、延迟和抖动?

A. 当接口承受的流量大于可处理流量时,便会发生拥塞。网络拥塞点是服务质量(QoS)机制的坚强的候选。下面是一个典型拥塞点的示例:

/image/gif/paws/22833/qos_faq1.gif

网络拥塞会导致延迟。网络及其设备引入了各种延迟,如“了解数据包语音网络的延迟”。根据“了解分组语音网络中的抖动”(Cisco IOS平台)中的解释,延迟变化就是抖动。延迟和抖动都需要受到控制并减至最小,以支持实时和交互式流量。

Q. MQC 是什么?

A. MQC代表模块化服务质量(QoS)命令行界面(CLI)。它通过定义通用的命令语法和跨平台 Qos 行为的结果集,简化 Cisco 路由器和交换机上的 Qos 配置。此型号替代掉了原来型号在每个平台上定义每个 QoS 功能的独特语法。

MQC 包含以下三个步骤:

  1. 通过发出 class-map 命令定义一个流量类。

  2. 通过发出 policy-map 命令,使流量级别与一种或多种 QoS 功能匹配,从而创建某种数据流策略。

  3. 附加数据流策略对接口、子接口或者虚拟电路通过发出service-policy命令

注意: 使用 MQC 语法,您可以执行差分服务的数据流调节功能,例如标记和整形。

有关更多信息,请参阅模块化服务质量命令行界面

Q. service-policy is supported only on VIP interfaces with DCEF enabled 消息意味着什么?

A. 在仅通用接口处理器(VIP)在一个Cisco 7500系列,分布式服务质量(QoS)功能自Cisco IOS 12.1(5)T、12.1(5)E和12.0(14)S支持。启用Distributed Cisco Express Forwarding (DCEF)自动地启用分布式QOS。

Non-VIP接口,也称为传统接口处理器(IP),支持路由交换机处理器(RSP)上启用的中央QoS功能。有关更多信息,请参阅下列文档:

Q. 多少类服务质量(QoS)策略支持?

A. 在 12.2 之前的 Cisco IOS 版本中,最多可以定义 256 个类,如果将相同的类重复用于不同策略,在每个策略内最多可以定义 256 个类。如果您有二个策略,两个策略的级别总数都不应超过256。如果策略包括基于类别的加权公平队列(CBWFQ) (意味着在任何类别内包含带宽[或优先]语句),所支持的全部类别数量是64。

在 Cisco IOS12.2(12),12.2(12)T 和 12.2(12)S 版本中,256 全局类别映射的限制被更改,并且可以配置多达 1024 个全局类映射,并在同一策略映射中使用 256 个类映射。

Q. 当服务策略应用时,路由更新和点对点协议(PPP)/高级数据链路控制(HDLC) Keepalive如何处理?

A. Cisco IOS 路由器采用以下两种机制设置控制数据包的优先级:

  • IP 优先级

  • pak_priority

设计了两个机制来确保出局接口被堵塞时,关键控制数据包没有丢失,也没有被路由器和排队系统最后丢下。欲知更多信息,参见“了解路由更新和控制数据包如何在带有 QoS 服务策略的接口排队”。

Q. 接口支持服务质量(QoS)配置与集成路由和桥接(IRB) ?

A. 不能。当接口配置为用于 IRB 时,您无法配置 QoS 功能。

分类和标记

Q. 什么是服务质量(QoS)预分类?

A. QoS 预分类功能使您能够匹配和分类正在进行隧道封装和/或加密的数据包的原始 IP 报头内容。此功能不描述将服务类型(ToS)字节的最初值从原始信息包报头复制到隧道报头的过程。有关更多信息,请参阅下列文档:

Q. 哪些数据包报头字段可以重新标记?可用的值有哪些?

A. 基于类别的标记功能允许设置或标记数据包的第 2 层、第 3 层或者多协议标签交换 (MPLS) 报头。有关更多信息,请参阅下列文档:

Q. 能否根据 URL 设置流量的优先级?

A. 可以。基于网络的应用程序识别(NBAR)使您能够通过匹配应用层上的字段来分类信息包。NBAr引入以前,最精细的分类是采用第4层传输控制协议(TCP)和用户数据包协议(UDP) 端口编号。有关更多信息,请参阅下列文档:

Q. 支持什么平台和Cisco IOS软件版本基于网络的应用程序识别(NBAR) ?

A. 以下版本的 Cisco IOS 软件引入了对 NBAR 的支持:

平台 最低 Cisco IOS 软件版本
7200 12.1(5)T
7100 12.1(5)T
3660 12.1(5)T
3640 12.1(5)T
3620 12.1(5)T
2600 12.1(5)T
1700 12.2(2)T

注意: 需要启用 Cisco 快速转发 (CEF) 才能使用 NBAR。

以下平台提供分布式 NBAR (DNBAR):

平台 最低 Cisco IOS 软件版本
7500 12.2(4)T、12.1(6)E
FlexWan 12.1(6)E

注意: Catalyst 6000多层交换机功能卡(MSFC) VLAN接口、Cisco 12000系列,或Catalyst 5000系列的路由交换模块(RSM)均不支持NBAR。如果您没有看到以上所列的特定平台,请联系您的 Cisco 技术代表。

排队和拥塞管理

Q. 排队有何用途?

A. 排队旨在通过将超额数据包保存在缓冲区直到有带宽可用为止,从而适应网络设备上的临时拥塞。Cisco IOS 路由器技术支持几种排队方法,以满足不同应用程序的各种带宽、抖动和延迟需求。

在多数接口的默认机制是先入先出(FIFO)。有些流量类型具有更高的延迟/抖动需求。因此,应当默认启用以下任何一种排队机制:

  • 加权公平排队 (WFQ)

  • 基于类别的加权公平队列(CBWFQ)

  • 低延迟队列(LLQ),实际上是与优先级队列的CBWFQ (叫作PQCBWFQ)

  • 优先级排队 (PQ)

  • 自定义队列 (CQ)

通常仅在出站接口出现排队。路由器对从接口出站的数据包进行排队。你可以规定入站流量,但通常不能在入站时排队(一个特例是采用分布式Cisco Express Forwarding (dCEF)的Cisco 7500系列路由器上的接收端缓冲)将信息包从入口接口传输到出口接口。有关更多信息,请参阅了解使用率为 99% 的 VIP CPU 和 Rx 端缓冲。在高端分布式平台上(例如 Cisco 7500 和 12000 系列),入站接口可能使用它自己的数据包缓冲区来存储交换到(依照入站接口的交换决定)堵塞出站接口的超额流量。在少数的情况下,通常是入站接口传输到更加缓慢的出站接口时,入站接口用完数据包内存时,它能够体验到被忽略错误的不断增加。过度拥塞可能导致输出队列丢弃。大部分时间,输入队列丢弃都具有另外的根本原因。有关丢弃故障排除的更多信息,请参阅以下文档:

有关更多信息,请参阅下列文档:

Q. 加权公平排队(WFQ)和基于类的加权公平排队(CBWFQ)如何运行?

A. 公平排队寻求在活动对话或 IP 流之间分配接口带宽的公平份额。将数据包分类,编为子队列,通过会话标识号码进行识别,并根据 IP 头的几个字段和数据包的长度使用散列算法。下面是权重的计算方法:

  • W = K / (优先级+1)

对于 Cisco IOS 12.0(4)T 和更低版本,K = 4096;对于 12.0(5)T 和更高版本,K = 32384。

权重越低,优先级和带宽份额越高。除权重外,还要考虑数据包的长度。

CBWFQ 允许您定义一个流量类并为其分配最低带宽保证。这种机制背后的算法是 WFQ,也是其名称的由来。要配置 CBWFQ,可在 map-class 语句中定义特定的类。然后为策略映射中的每个类分配一个策略。此策略映射随后将出站附加到某个接口。有关更多信息,请参阅下列文档:

Q. 如果在基于类的加权公平排队(CBWFQ)的类不使用其带宽,其他类能使用带宽?

A. 可以。虽然通过发出 bandwidth 和 priority 命令提供的带宽保证可以用以下词来描述:“预留”、“带宽保留”,但这两个命令都没有实现真正的预留。这意味着如果一个流量级别不使用配置给它的带宽,任何未使用的带宽将在其他级别中共享。

如果是优先级类,排队系统将强行对此规则实施一种重要例外。如上所述,优先级类的流入负载由数据流监察器测量。在出现拥塞时,优先级类不能使用任何额外的带宽。有关更多信息,请参阅 Qos 服务策略的 bandwidth 和 priority 命令的比较

Q. 子接口支持基于类的加权公平排队(CBWFQ) ?

A. Cisco IOS 逻辑接口本身不支持拥塞状态,并且不支持应用排队方法的服务策略的直接应用程序。相反,您首先需要使用通用流量整形(GTS)或基于等级的整形,将整形应用到子接口。有关更多信息,请参阅将 QoS 功能应用于以太网子接口

Q. 策略映射中的 priority 和 bandwidth 语句有何区别?

A. priority 和 bandwidth 命令的功能不同,而且它们通常支持的应用程序也有所不同。下表总结了这些区别:

功能 bandwidth 命令 priority 命令
最小带宽保证
最大带宽保证
内置监察器
提供低延迟

有关更多信息,请参阅 Qos 服务策略的 bandwidth 和 priority 命令的比较

Q. 队列限制如何计算在FlexWan和多功能接口处理器(VIP) ?

A. 假设在 VIP 或 FlexWan 上拥有足够的 SRAM,队列限制是根据最大延迟为 500ms、数据包平均大小为 250 个字节的情况下计算得到的。下面是一个具有 1 Mbps 带宽的类的示例:

队列限制 = 1000000 / (250 x 8 x 2) = 250

作为可用数据包内存大小分配的队列限制降低,虚拟电路(VC)的数量增加。

在以下示例中,PA-A3安装在一个Cisco 7600系列的FlexWan卡上,并用2 MB永久虚拟电路(PVC)支持多个子接口。服务策略应用于每个 VC。

class-map match-any XETRA-CLASS 
  match access-group 104 
class-map match-any SNA-CLASS 
  match access-group 101 
  match access-group 102 
  match access-group 103 
policy-map POLICY-2048Kbps 
  class XETRA-CLASS 
    bandwidth 320 
  class SNA-CLASS 
    bandwidth 512 

interface ATM6/0/0 
 no ip address 
 no atm sonet ilmi-keepalive 
 no ATM ilmi-keepalive 
! 
interface ATM6/0/0.11 point-to-point 
 mtu 1578 
 bandwidth 2048 
 ip address 22.161.104.101 255.255.255.252 
 pvc ABCD 
  class-vc 2048Kbps-PVC 
  service-policy out POLICY-2048Kbps

异步传输模式(ATM)接口获得整个接口的队列限制。该限制是总可用缓冲、FlexWan 上的物理接口的数量,以及接口允许的最大队列延迟的函数。每个PVC获得基于PVC的平均信元速率(SCR)或最小信元速率(MCR)的接口限制的部分,并且每个级别获得基于带宽分配的PVC限制部分。

show policy-map interface 命令的以下输出示例派生自具有 3687 个全局缓冲区的 FlexWAN。发出 show buffer 命令可查看此值。根据 2Mbps 的 PVC 带宽给每两个 Mbps PVC 分配 50 个数据包 (2047/149760 x 3687 = 50)。每个级别分配部分 50,如以下输出所示:

service-policy output: POLICY-2048Kbps
    class-map: XETRA-CLASS (match-any) 
      687569 packets, 835743045 bytes 
      5 minute offered rate 48000 bps, drop rate 6000 BPS 
      match: access-group 104 
        687569 packets, 835743045 bytes 
        5 minute rate 48000 BPS 
      queue size 0, queue limit 7 
      packets output 687668, packet drops 22 
      tail/random drops 22, no buffer drops 0, other drops 0 
      bandwidth: kbps 320, weight 15 
 
    class-map: SNA-CLASS (match-any) 
      2719163 packets, 469699994 bytes 
      5 minute offered rate 14000 BPS, drop rate 0 BPS 
      match: access-group 101 
        1572388 packets, 229528571 bytes 
        5 minute rate 14000 BPS 
      match: access-group 102 
        1146056 packets, 239926212 bytes 
        5 minute rate 0 BPS 
      match: access-group 103 
        718 packets, 245211 bytes 
        5 minute rate 0 BPS 
      queue size 0, queue limit 12 
      packets output 2719227, packet drops 0 
      tail/random drops 0, no buffer drops 0, other drops 0 
      bandwidth: kbps 512, weight 25 
      queue-limit 100 
 
    class-map: class-default (match-any) 
      6526152 packets, 1302263701 bytes 
      5 minute offered rate 44000 BPS, drop rate 0 BPS 
      match: any 
        6526152 packets, 1302263701 bytes 
        5 minute rate 44000 BPS 
      queue size 0, queue limit 29 
      packets output 6526840, packet drops 259 
      tail/random drops 259, no buffer drops 0, other drops 0

如果您的数据流使用较大的数据包大小,show policy-map interface 命令输出可能报告 no buffer drops 字段的值增大,因为您可能在达到队列限制之前即用尽缓冲区。在这种情况下,请尝试将非优先级类的队列限制手动调低。欲知更多信息,参考了解与IP到ATM CO的传输队列限制

Q. 如何验证队列限制值?

A. 在非分布式平台上,队列限制默认为 64 个数据包。以下示例输出是在 Cisco 3600 系列路由器上捕获的:

november# show policy-map interface s0      
   Serial0
	 
   Service-policy output: policy1 

     Class-map: class1 (match-all) 
       0 packets, 0 bytes 
       5 minute offered rate 0 BPS, drop rate 0 BPS 
       Match: ip precedence 5 
       Weighted Fair Queueing 
         Output Queue: Conversation 265 
         Bandwidth 30 (kbps) Max Threshold 64 (packets) 
         
!--- Max Threshold is the queue-limit. 

         (pkts matched/bytes matched) 0/0 
         (depth/total drops/no-buffer drops) 0/0/0 

      Class-map: class2 (match-all) 
        0 packets, 0 bytes 
        5 minute offered rate 0 BPS, drop rate 0 BPS 
        Match: ip precedence 2 
        Match: ip precedence 3 
        Weighted Fair Queueing 
          Output Queue: Conversation 266 
          Bandwidth 24 (kbps) Max Threshold 64 (packets) 
          (pkts matched/bytes matched) 0/0 
          (depth/total drops/no-buffer drops) 0/0/0 

       Class-map: class-default (match-any) 
         0 packets, 0 bytes 
         5 minute offered rate 0 BPS, drop rate 0 BPS 
         Match: any

Q. 能否在类内部启用公平排队?

A. Cisco 7500系列与分布式服务质量(QoS)支持公平排队每类。其他平台,包括Cisco 7200系列和Cisco 2600/3600系列,支持加权公平排队(WFQ)在等级默认的等级;所有带宽等级使用先入先出(FIFO)。

Q. 哪些命令可用于监控排队?

A. 使用以下命令监控排队:

Q. RSVP可以与基于类的加权公平排队(CBWFQ)一道使用。当接口同时配置了资源预留协议 (RSVP) 和 CBWFQ 时,分别进行 RSVP 和 CBWFQ 操作,如果两个都在独自运行,则两者显示出相同的行为?RSVP 的行为看起来就像 CBWFQ 没有针对带宽可用性、评估和分配进行配置一样。

A. 当在 Cisco IOS 软件 12.1(5) 及以后的版本中使用 RSVP 和 CBWFQ 时,路由器可以这样运行,即 RSVP 流和 CBWFQ 类别共享接口或 PVC 上的可用带宽,不会出现超额预订。

IOS软件 12.2(1)T 及以上版本允许 RSVP 使用其自己的“ip rsvp bandwidth”池,执行接纳控制,而 CBWFQ 执行分类,策略和 RSVP 数据包调度。这里假定数据包由发送方预先标记,而且非 RSVP 数据包的标记有所不同。

拥塞避免加权随机早期检测 (WRED)

Q. 同时能I启用的加权随机早期检测(WRED)和低延迟队列(LLQ),或者基于类的加权公平排队(CBWFQ) ?

A. 可以。排队定义了数据包离开队列的顺序。这意味着,它定义了一种数据包调度机制。它还可以用于提供公平带宽分配和最低带宽保证。相反,请求 注释(RFC)2475把丢失定义为“根据指定规则丢弃信息包的进程”。默认丢弃机制是尾部丢弃,队列已满时,接口将丢弃数据包。备选丢弃机制是随机早期检测(RED)和Cisco的WRED,它在队列满之前随机地开始丢失信息包并且寻求维护一致的平均队列深度。WRED 使用数据包的 IP 优先级值做出有区别的丢弃决策。欲知更多信息,参考加权随机早期检测(WRED)

Q. 监控加权随机早期检测(WRED)和如何能看到它实际上生效?

A. WRED 监控平均队列深度,并在当计算值高于最小阈值时开始丢弃数据包。发出show policy-map interface命令,并监控平均队列深度值,如以下示例所示:

Router# show policy interface s2/1 

  Serial2/1 
  output : p1 
   Class c1 
    Weighted Fair Queueing 
        Output Queue: Conversation 265 
          Bandwidth 20 (%) 
          (pkts matched/bytes matched) 168174/41370804 
          (pkts discards/bytes discards/tail drops) 20438/5027748/0 
          mean queue depth: 39 

     Dscp     Random drop       Tail drop        Minimum   Maximum     Mark 
     (Prec)    pkts/bytes        pkts/bytes      threshold threshold probability 
       0(0)    2362/581052        1996/491016        20        40       1/10 
       1          0/0                0/0             22        40       1/10 
       2          0/0                0/0             24        40       1/10 
       [output omitted]

管制和整形

Q. 监察与整形有何区别?

A. 下图揭示了两者之间的关键区别。流量整形将超额数据包保留在队列中,然后安排超额部分在新增时间进行稍后传输。流量整形的结果是一个平滑的数据包输出速率。相反,流量监察传播突发流量。当流量速率达到所配置的最大速率时,将丢弃(或重新标记)超额流量。结果显示为带有波峰和波谷的锯齿形输出速率。

/image/gif/paws/22833/qos_faq2.gif

有关更多信息,请参阅监察和整形概述

Q. 什么是令牌桶?算法的工作原理是什么?

A. 令牌桶本身没有丢弃或优先级策略。下面是令牌桶工作原理的示例:

  • 令牌以一定速率放到桶中。

  • 每个令牌是源发送一定数量的位的权限。

  • 要发送数据包,数据流调整器必须能够从令牌桶中去除等于数据包大小的令牌数量。

  • 如果桶中没有足够的令牌来发送数据包,数据包要么等待有足够的令牌(在整形的情况下),要么被丢弃或被降级(在警策略情况下)。

  • 桶本身具有指定的容量。如果桶达到了容量,最近到达的令牌被丢弃并且不能容纳将来的数据包。因此在任何时间,信息源能够发送到网络的最大突发传输都是令牌桶大小的组成部分。令牌桶允许突变流量,但会对其进行限制。

Q. 使用信息数据流策略器例如基于类的策略,什么如何承诺突发量(BC)和超额突发(Be)平均值和应该选择这些值?

A. 流量监察器并不像整形器那样,缓冲多余数据包并在稍后进行传输。相反,策略器执行简单发送,或者不发送策略而不需要缓冲。在拥塞期间,由于您不能缓冲,因此您可以执行的最佳操作是通过适当配置扩展突发传输,较为保守地丢弃数据包。因此,重要的是要了解policer使用正常突发和扩展突发值,来保证达到所配置的承诺信息速率(CIR)。

路由器的通用缓冲规则中大致模拟了突发参数。规则建议配置相等于往返时间比特率的缓冲,以便在拥塞时适应所有连接的未清传输控制协议(TCP)窗口。

下表说明 normal burst 值和 extended burst 值的用途及推荐公式:

突发参数 目的 推荐的公式
normal burst
  • 实现一个标准令牌桶。

  • 设置令牌桶的最大值(尽管如果 Be 大于 BC,就可以借用令牌)。

  • 确定令牌桶的容量大小,因为如果桶的容量满了,新到的令牌会被丢弃,不能满足将来数据包的使用。

CIR [BPS] * 
(1 byte)/(8 bits) * 
1.5 seconds

注意: 典型的往返时间为 1.5 秒。

extended burst
  • 实现一个具有扩展突发功能的令牌桶。

  • 通过设置 BC = Be 禁用。

  • 当 BC 等于 Be 时,当可用令牌不足时,数据流调整器不能借用令牌,只能简单丢弃数据包。

2 * normal burst

并不是所有平台使用或支持策略器值的相同范围。请参阅以下文档以了解您的特定平台支持的值:

Q. 承诺接入速率(CAR)或基于类的策略如何决定数据包是否符合或超出承诺信息速率(CIR) ?路由器丢失数据包并报告超出速率,即使一致速率低于配置的 CIR。

A. 流量监察器使用 normal burst 值和 extended burst 值确保达到配置的 CIR。要确保较好的吞吐量,设置足够高的突发值十分重要。如果突发值配置得太低,达到的速率可能低于配置速率。惩罚临时突发能有在吞吐量的一个强不利影响传输控制协议(TCP)流量。通过 CAR,可以发出 show interface rate-limit 命令来监控当前的突发传输,并确定显示的值是否一致地接近极限 (Bc) 和扩展极限 (Be) 值。

rate-limit 256000 7500 7500 conform-action continue exceed-action drop 
rate-limit 512000 7500 7500 conform-action continue exceed-action drop 

router# show interfaces virtual-access 26 rate-limit 
    Virtual-Access26 Cable Customers 
      Input 
        matches: all traffic 
          params:  256000 BPS, 7500 limit, 7500 extended limit 
          conformed 2248 packets, 257557 bytes; action: continue 
          exceeded 35 packets, 22392 bytes; action: drop 
          last packet: 156ms ago, current burst: 0 bytes 
          last cleared 00:02:49 ago, conformed 12000 BPS, exceeded 1000 BPS 
      Output 
        matches: all traffic 
          params:  512000 BPS, 7500 limit, 7500 extended limit 
          conformed 3338 packets, 4115194 bytes; action: continue 
          exceeded 565 packets, 797648 bytes; action: drop 
          last packet: 188ms ago, current burst: 7392 bytes 
          last cleared 00:02:49 ago, conformed 194000 BPS, exceeded 37000 BPS

有关更多信息,请参阅下列文档:

Q. 突发流量和队列限制是否彼此独立?

A. 是,监察器突发流量和队列限制单独存在,彼此独立。可以将监察器视为允许一定数量数据包(或字节)的门,将队列视为在网络传输之前保留承认数据包的大小为队列限制 的桶。理论上讲,您希望桶的大小足够容纳门(监察器)所承认字节/数据包数的突发流量

帧中继服务质量 (QoS)

Q. 承诺信息速率(CIR),承诺突发量(Bc)、超额突发(Be)和最小CIR (MinCIR)的值分别选多少?

A. 通过发出 frame-relay traffic-shaping 命令启用的帧中继流量整形支持若干可配置参数。这些参数包括 frame-relay cir、frame-relay mincir 和 frame-relay BC。欲知选择这些值和了解相关 show 命令的更多信息,请参见以下文件:

Q. Q. 帧中继主接口的优先级排队能否用于 Cisco IOS 12.1?

A. 帧中继接口支持接口排队机制和每虚电路(VC)排队机制。从Cisco IOS 12.0(4)T版本开始,只有当您配置帧中继流量整形(FRTS) 时,接口队列才能支持先入先出(FIFO) 或每接口优先级排队(pipq)。因此,如果升级到 Cisco IOS 12.1,将无法再使用以下配置。

interface Serial0/0 
  frame-relay traffic-shaping 
  bandwidth 256 
  no ip address 
  encapsulation frame-relay IETF 
  priority-group 1
 
 ! 
 interface Serial0/0.1 point-to-point 
  bandwidth 128 
  ip address 136.238.91.214 255.255.255.252 
  no ip mroute-cache 
  traffic-shape rate 128000 7936 7936 1000 
  traffic-shape adaptive 32000 
  frame-relay interface-dlci 200 IETF

如果FRTS不启用,您能在主要接口处应用一个代替排队方法,例如基于类别的加权公平队列(CBWFQ),该接口的操作类似单个带宽管道。另外,自Cisco IOS 12.1.1(T),您能启用帧中继永久虚拟电路(PVC)优先级接口排队(PIPQ)在帧中继主接口。可以定义的高、中、正常或低优先级 PVC,并在主要接口上发送 frame-relay interface-queue priority 命令,如下例所示:

interface Serial3/0 
 description framerelay main interface 
 no ip address 
 encapsulation frame-relay 
 no ip mroute-cache 
 frame-relay traffic-shaping 
 frame-relay interface-queue priority
 
interface Serial3/0.103 point-to-point 
 description frame-relay subinterface 
 ip address 1.1.1.1 255.255.255.252 
 frame-relay interface-dlci 103 
  class frameclass 

map-class frame-relay frameclass 
 frame-relay adaptive-shaping becn 
 frame-relay cir 60800 
 frame-relay BC 7600 
 frame-relay be 22800 
 frame-relay mincir 8000 
 service-policy output queueingpolicy 
 frame-relay interface-queue priority low

Q. 帧中继流量整形(FRTS)与Distributed Cisco Express Forwarding (DCEF)和分布式基于类的加权公平排队(dCBWFQ)一起使用?

A. 从 Cisco IOS 12.1(5)T 开始,Cisco 7500 系列中的 VIP 仅支持分布式版本的 QoS 功能。要启用在帧中继接口的流量整形,请使用分布式流量整形。有关更多信息,请参阅下列文档:

异步传输模式(ATM)上的服务质量 (QoS)

Q. 应该在异步传输模式(ATM)接口的什么地方应用支持基于类的加权公平排队(CBWFQ)和低延迟排队(LLQ)的服务策略?

A. 从 Cisco IOS 12.2 开始,ATM 接口在以下三个级别或逻辑接口支持服务策略:主接口、子接口和永久虚拟电路(PVC)。应用策略就是启用服务质量(QoS)功能。由于排队策略应该逐个虚拟电路(VC)地应用,因为ATM接口逐个监控每个VC的拥塞程度,并为每个VC的超额信息包提供队列。有关更多信息,请参阅下列文档:

Q. 什么字节由对异步传输模式(ATM)业务类别(CoS)排队的IP计数?

A. 服务策略中配置的带宽和优先级分别支持基于类别的加权公平队列(CBWFQ)和低延迟排队(LLQ) ,使用Kbps值统计与show interface命令输出的开销字节相同。具体来讲,第 3 层排队系统对逻辑链路控制/子网访问协议 (LLC/SNAP) 进行计数。它不执行下列计数:

Q. 多少虚拟电路(VC)可以同时支持服务策略?

A. 以下文档在可以支持异步传输模式(ATM) VC的编号提供有用的指南。大约200到300 vbr-nrt永久虚电路(PVC)安全部署:

另外,请考虑以下事项:

  • 使用功能强大的处理器。例如,VIP4-80 提供的性能远远高于 VIP2-50。

  • 可用的数据包内存量。在 NPE-400 上,除了数据包缓冲以外,还设置了 32 MB(在 256MB 的系统中)的容量。对于 NPE-200,最高 16 MB 可以设置在带有 128 MB 的系统上的数据包缓冲区旁边。

  • 带有每VC加权随机早期检测(WRED)功能的配置(最多可同时运行200个 ATM PVC)已经通过大量测试。可以用于每个 VC 队列的 VIP2-50 上的数据包内存数量是有限的。例如,带有 8-MB SRAM 的 VIP2-50 能够把 IP 1085 数据包缓冲区提供给运行 WRED 的每个 VC 排队的 IP 到 ATM 服务等级。如果配置了 100 条 ATM PVC,并且如果所有 VCS 同时出现过度拥塞(正如在使测试环境中模拟的一样,其中会使用非 TCP 流受控源),那么平均每个 PVC 将有大约 10 个数据包的缓冲,这对于 WRED 的成功地运行可能太短。我们强烈建议在设计中采用具有大 SRAM 的 VIP2-50 设备,同时有大量运行每 VC WRED的ATM PVC,可以同时经历拥塞。

  • 配置的活动PVC的数量越多,其平均信元速率(SCR)就越低,因此WRED要求的在PVC上运行的队列就越短。因此,当在大量低速、拥塞的ATM PVC 上激活每VC WRED 时,配置更低的WRED丢弃门限可以将VIP上缓冲短缺的风险减到最低,情况与在IP到ATM服务等级(COS) 阶段1使用IP默认的WRED配置文件一样。VIP 的缓冲短缺不会导致任何故障。一旦在VIP中缺少缓冲,IP到ATM CO的第1阶段特性只是在缓冲短缺期间降低到First-In-First-Out (先进先出 FIFO)尾部丢弃(即如果IP到ATM CO特性不在PVC上激活,将使用相同的丢失策略)。

  • 可以合理支持的同时使用的最大 VCS 数。

Q. 哪个异步传输模式(ATM)硬件支持IP到ATM的服务等级以为特色包括基于类的加权公平排队(CBWFQ)和低延迟队列(LLQ) ?

A. IP到ATM CO是指在每条虚拟电路(VC)上启用的功能集。给出此定义,ATM接口处理器(AIP)、PA-A1或4500 ATM网络处理器不支持IP to ATM CO。根据 PA-A3 及多数网络模块(除 ATM-25 之外)的定义,此 ATM 硬件不支持每 VC 的排队。有关更多信息,请参阅以下文档:

语音和服务质量 (QoS)

Q. Link Fragmentation and Interleaving (LFI) 如何工作?

A. 当网络处理大数据包例如文件传输协议(FTP)转移过渡广域网时,交互式数据流例如Telnet和基于IP的语音是易受加长的等待时间。当 FTP 数据包在较慢的广域网链路排队时,交互式数据流的排队数据包延迟很明显。设计了一种方法将更大的数据包分段,在更大的数据包 (FTP) 分段之间排列更小的(语音)数据包。Cisco IOS 路由器支持多种第 2 层分段机制。有关更多信息,请参阅下列文档:

Q. 可以使用哪些工具监控 IP 语音 (VoIP) 的性能?

A. 使用Cisco的VoIP解决方案, Cisco目前提供监控网络服务质量(QoS)的几种选件。这些解决方案不使用感性语音质量测量(PSQM)或某些新提出的语音质量测量算法,来测量语音质量。Agilent (HP) 和 NetIQ 提供的工具可用于此用途。然而,Cisco 提供的工具通过测量延迟、抖动和数据包丢失,使您体验到理想的语音质量。有关更多信息,请参阅使用 Cisco Service Assurance Agent 和 Internetwork Performance Monitor 管理语音 IP (VoIP) 网络的服务质量

Q. Q. %SW_MGR-3-CM_ERROR_FEATURE_CLASS :Connection Manager Feature Error:Class SSS:(QoS) - install error, ignore.

A. 当无效的配置应用于模板时,显示功能安装错误是预料之中的行为。它表明因冲突而没有应用服务策略。一般来讲,不应为分层策略映射中子策略的 class-default 配置整形,而应在接口的父策略中进行配置。结果,此消息将与回溯消息一起打印出来。

使用基于会话的策略,只能在子接口或 PVC 级别执行 class-default 的整形。不支持在物理接口进行整形。如果在物理接口完成配置,显示此错误消息是预料之中的行为。

对于 LNS,另一个可能的原因是启动会话时可通过 RADIUS 服务器设置服务策略。发出 show tech 命令以查看 RADIUS 服务器配置,并查看会话启动或抖动时通过 RADIUS 服务器安装的所有非法服务策略。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 22833