IP : 增强的内部网关路由选择协议 (EIGRP)

增强的内部网关路由协议

2016 年 9 月 12 日 - 机器翻译
其他版本: | 英语 (2015 年 4 月 27 日) | 反馈


交互:本文档对您的 Cisco 设备进行自定义分析。


目录


简介

增强型内部网关路由协议 (EIGRP) 是适用于许多不同的拓扑和介质的内部网关协议。在设计合理的网络中,EIGRP 具有良好的扩展性,并以最小的网络流量提供极短的收敛时间。

EIGRP 的工作原理

以下是 EIGRP 众多优点中的一部分:

  • 在正常工作期间,网络资源的使用率非常低;仅在稳定网络上传输 hello 数据包

  • 当发生更改时,仅传播路由表更改,而不传播整个路由表;这可减少路由协议自身放在网络上的负载

  • 可以快速收敛网络拓扑中的更改(在某些情况下,几乎可以瞬间收敛)

EIGRP 是增强的距离矢量协议,它依靠扩散更新算法 (DUAL) 计算网络中到目标的最短路径。

协议的主要修订

EIGRP 有两个主要修订版,版本 0 和 1。10.3(11)、11.0(8) 和 11.1(3) 以前的 Cisco IOS 版本运行早期版本的 EIGRP;本文中的一些说明可能不适用于该早期版本。我们强烈建议使用最新版本的 EIGRP,因为它包括许多性能和稳定性增强功能。

基本原理

在计算到目标的最佳路径时,典型的距离矢量协议会保存以下信息:距离(总度量或距离,如跳数)和矢量(下一跳)。例如,在图 1 中,网络中的所有路由器都运行路由信息协议 (RIP)。路由器 Two 通过检查通过每条可用路径的跳数来选择到网络 A 的路径。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp1.gif

由于通过路由器3的路径是三跳,通过路由器1的路径是两跳,路由器2选择通过路由器1的路径,同时丢弃从路由器3获得的信息。如果路由器1和网络A之间的路径断开,路由器2丢失所有与目的地的连接,直至路由表的路由结束为止(3次更新时间,或90秒),并且路由器3重新通告路由(RIP中每30秒发生一次)。路由器2从路由器1切换到路由器3需要90秒~120秒的时间,不包括所有路由的暂挂时间。

EIGRP 不依靠完全的定期更新来进行重新收敛,而是从它每个邻居的通告建立拓扑表(而不是丢弃数据),并且通过在拓扑表中查找一个可能无环路的路由,或通过查询其邻居(如果它不知道任何其他路由)来进行收敛。路由器 Two 保存它从路由器 One 和 Three 收到的信息。它把通过路由器1的路径选为最佳路径(后继路由),把通过路由器3的路径选为无环回路径(可行后继路由)。当通过路由器1的路径不可用时,路由器2检查其拓扑表,并查找可行后继者,立即开始使用通过路由器3的路径。

从此简要说明中,显而易见 EIGRP 必须提供以下内容:

  • 它所用于在给定时间只发送所需更新的系统;这可通过邻居发现和维护实现

  • 一种确定路由器已获知的哪些路径是无环路路径的方法

  • 一个从网络上所有路由器的拓扑表中清除不良路由的进程

  • 一个查询邻居以查找到丢失目标的路径的进程

我们将依次介绍这些要求中的每一个。

邻居发现和维护

为了在整个网络中分配路由信息,EIGRP 使用非周期性的增量路由更新。也就是说,EIGRP 只在这些路径更改时发送有关已更改路径的路由更新。

只发送路由更新的基本问题是:您可能不知道通过相邻路由器的路径什么时候不再可用。您不能使路由超时,而期望从您的邻居那里收到新的路由表。EIGRP 依靠邻居关系在整个网络中可靠地传播路由表更改;当两个路由器在公共网络上看到彼此的 hello 数据包时,它们成为邻居。

EIGRP 在高带宽链路上每隔 5 秒发送一次 hello 数据包;而在低带宽多点链路上则每隔 60 秒发送一次。

  • 5 秒 hello:

    • 广播介质,如以太网、令牌环和 FDDI

    • 点对点串行链路,如 PPP 或 HDLC 租用电路、帧中继点对点子接口和 ATM 点对点子接口

    • 高带宽(大于 T1)多点电路,如 ISDN PRI 和帧中继

  • 60 秒 hello:

    • T1 带宽或更慢的多点电路,如帧中继多点接口、ATM 多点接口、ATM 交换虚拟电路和 ISDN BRI

EIGRP 发送 hello 数据包的速率称为 hello 间隔,您可以使用 ip hello-interval eigrp 命令,根据每个接口对它进行调整。保持时间是路由器在不接收 hello 数据包的情况下认为邻居处于活动状态的时间量。保持时间通常是 hello 间隔的三倍,默认情况下为 15 秒和 180 秒。您可以使用 ip hold-time eigrp 命令调整保持时间。

请注意,如果您更改 hello 间隔,保持时间不会自动调整以适应此更改 - 您必须手动调整保持时间以反映配置的 hello 间隔。

即使 hello 和保持计时器不匹配,两个路由器也可能成为 EIGRP 邻居。保持时间包括在 hello 数据包中,因此即使 hello 间隔和保持计时器不匹配,每个邻居也应保持活动状态。

当没有直接方式确定时什么Hello间隔在路由器,您能从show ip eigrp neighbors输出在相邻路由器的推断它。

如果有输出一show ip eigrp neighbors命令从您的Cisco设备,您能使用Output Interpreter (仅限注册用户)显示潜在问题和修正。要使用命令输出解释程序,必须已启用 JavaScript。

router# show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address       Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2      Et1           13 12:00:53   12   300  0  620
0   10.1.2.2      S0           174 12:00:56   17   200  0  645


rp-2514aa# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2       Et1           12 12:00:55   12   300  0  620
0   10.1.2.2       S0           173 12:00:57   17   200  0  645


rp-2514aa# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2       Et1           11 12:00:56   12   300  0  620
0   10.1.2.2       S0           172 12:00:58   17   200  0  645

命令输出“Hold”列中的值永远不应超过保持时间,并且永远不应低于保持时间与 hello 间隔的差值(当然,丢失 hello 数据包的情况除外)。如果“Hold”列的范围通常在 10 和 15 秒之间,则 hello 间隔为 5 秒,保持时间为 15 秒。如果“Hold”列通常有一个较大的范围(在 120 和 180 秒之间),则 hello 间隔为 60 秒,保持时间为 180 秒。如果数字似乎不适合其中一个默认计时器设置,请在相邻路由器上检查有疑问的接口 - hello 和保持计时器可能已被手动配置。

注意: 

  • EIGRP 不在辅助地址上建立对等关系。所有 EIGRP 流量都源自接口的主地址。

  • 在多通道帧中继网络中配置EIGRP时 (一点对多点等),可在frame-relay map语句中配置广播关键字。没有 broadcast 关键字,不会在两个 EIGRP 路由器之间建立邻接关系。有关详细信息,请参阅帧中继的配置与故障排除

  • 对于 EIGRP 可以支持的邻居数量,没有任何限制。实际支持的邻居数量取决于设备的能力,如:

    • 内存容量

    • 处理能力

    • 交换信息的量,如发送的路由数

    • 拓扑复杂性

    • 网络稳定性

建立拓扑表

即然这些路由器之间在彼此通信,它们通信的内容是什么呢?当然是它们的拓扑表!EIGRP 不同于 RIP 和 IGRP,它不依靠路由器中的路由(或转发)表来保留其运行所需的所有信息。但是,它会建立第二个表(拓扑表),并从该表将路由安装在路由表中。

注意: 自 Cisco IOS 版本 12.0T 和 12.1 起,RIP 保留它自己的数据库,并从该数据库将路由安装到路由表中。

要看到拓扑表的基本格式在路由器运行EIGRP的,请发出show ip eigrp topology命令。拓扑表包含建立到每个可达网络的一组距离和矢量所需的信息,包括:

  • 上游邻居报告的到此目标的路径上的最低带宽

  • 总延迟

  • 路径可靠性

  • 路径负载

  • 最短路径最大传输单元 (MTU)

  • 可行距离

  • 报告距离

  • 路由源(外部路由将被标记)

可行和报告距离在本部分后面讨论。

如果您有来自 Cisco 设备的 show ip eigrp topology 命令的输出,则可以使用命令输出解释程序仅限注册用户)显示潜在问题和解决方法。要使用命令输出解释程序,必须已启用 JavaScript。

EIGRP 度量

EIGRP 使用到目标网络的路径上的最低带宽和总延迟计算路由度量。虽然您可以配置其他度量,但是我们并不建议这样做,因为它可能在网络中导致路由环路。带宽和延迟度量是根据到目标网络的路径中的路由器接口上所配置的值决定的。

例如,在下面的图 2 中,路由器 One 正在计算到网络 A 的最佳路径。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp2.gif

它从该网络的两条通告开始:一条通过路由器 Four,最低带宽为 56,总延迟为 2200;另一条通过路由器 Three,最低带宽为 128,延迟为 1200。路由器 One 选择度量最小的路径。

让我们来计算度量。EIGRP 通过换算带宽和延迟度量来计算总度量。EIGRP 使用以下公式换算带宽:

  • 带宽 = (10000000/bandwidth(i)) * 256

    其中,bandwidth(i) 是到目标网络的路由上所有传出接口的最低带宽(以千位为单位表示)。

EIGRP 使用以下公式换算延迟:

  • 延迟 = delay(i) * 256

    其中,delay(i) 是在到目标网络的路由上的接口上配置的延迟的总和,单位为十微秒。show ip eigrp topology 或 show interface 命令中显示的延迟以微秒为单位,因此在此公式中使用该值前必须将其除以 10。在本文中,我们按接口上的配置和显示使用延迟。

EIGRP使用这些标度值,来确定到网络的总度量值:

  • 量度= ([K1 *带宽+ (K2 *带宽)/(256 -负载) + K3 *延迟] * [K5/(可靠性+ K4)]) * 256

注意: 应在仔细规划后使用这些 K 值。不匹配的 K 值将阻止建立邻居关系,这可能导致您的网络无法收敛。

注意: 如果K5 = 0,公式减少到量度= ([k1 *带宽+ (k2 * bandwidth)/(256 -负载) + k3 *延迟]) * 256。

K 的默认值如下:

  • K1 = 1

  • K2 = 0

  • K3 = 1

  • K4 = 0

  • K5 = 0

对于默认行为,您可以按如下所示简化公式:

metric = bandwidth + delay 

Cisco 路由器不执行浮点运算,因此在每个计算阶段,都需要四舍五入到最接近的整数才能正确计算度量。在本示例中,通过路由器 Four 的总成本为:

在本示例中,通过路由器 Four 的总成本为:

minimum bandwidth = 56k 

total delay = 100 + 100 + 2000 = 2200 

[(10000000/56) + 2200] x 256 = (178571 + 2200) x 256 = 180771 x 256 = 46277376  

通过路由器 Three 的总成本为:

minimum bandwidth = 128k 

total delay = 100 + 100 + 1000 = 1200 

[(10000000/128) + 1200] x 256 = (78125 + 1200) x 256 = 79325 x 256 = 20307200  

因此,为了到达网络 A,路由器 One 选择通过路由器 Three 的路由。

请注意,我们使用的带宽和延迟值是在路由器到达其到目标网络的下一跳所通过的接口上配置的。例如,路由器 Two 使用在其以太网接口上配置的延迟通告网络 A;路由器 Four 添加了在其以太网上配置的延迟,路由器 One 添加了在其串行端口上配置的延迟。

可行距离、报告距离和可行后继路由

可行距离是沿到目标网络的路径的最佳度量,包括到通告该路径的邻居的度量。报告距离是沿到目标网络的路径的总度量,由上游邻居通告。可行后继路由是报告距离小于可行距离(当前最佳路径)的路径。图 3 说明了此过程:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp3.gif

路由器 One 看到它有两个到网络 A 的路由:一个通过路由器 Three,另一个通过路由器 Four。

  • 通过路由器 Four 的路由成本为 46277376,报告距离为 307200。

  • 通过路由器 Three 的路由成本为 20307200,报告距离为 307200。

请注意,在每种情况下,EIGRP 都从通告到网络的路由的路由器计算报告距离。换句话说,从路由器 4的报告距离是从路由器 4到达网络 A 的度量,而从路由器 3的报告距离则是从路由器 3 到达网络 A 的度量。EIGRP选择通过路由器3的路由作为最佳路径,并且使用通过路由器3的度量为可行距离。由于通过路由器4到达此网络的报告距离小于可行距离,因此路由器1 会将通过路由器4的路径视为可行后继路由。

当路由器 1和 3之间的链路断开时,路由器1 会对它所知道的通往网络 A 的每条路径进行检查,并发现它有一个通过路由器 4 的可行后继路由。路由器 One 将使用此路由,并使用通过路由器 Four 的度量作为新的可行距离。网络立即收敛,并且对下游邻居的更新将是路由协议中的唯一流量。

让我们来看一个更复杂的方案,如图 4 所示。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp4.gif

从路由器 One 到网络 A 有两个路由:一个通过路由器2(度量为 46789376),另一个通过路由器 4(度量为 20307200)。路由器 1选择这两个度量中较小一个作为它到网络 A 的路由,此度量将变成可行距离。然后,让我们来看通过路由器 Two 的路径,看它是否有资格作为可行后继路由。路由器 2 的报告距离为 46277376,该距离大于可行距离,因此该路径不是可行后继路由。如果此时要查看路由器 1 的拓扑表(使用 show ip eigrp topology),将只能看到一个针对网络 A 的条目(通过路由器 4)。(实际上路由器 1的拓扑表中有两个条目,但只有一个将成为可行后继路由,因此另一个不会显示在 show ip eigrp topology 的输出中;使用 show ip eigrp topology all-links 可以显示不是可行后继路由的路由)。

让我们假设路由器 One 和路由器 Four 之间的链路断开。路由器 One 看到它丢失了到网络 A 的唯一路由,并查询它的每个邻居(在本例中,只有路由器 Two)以查看它们是否具有到网络 A 的路由。由于路由器 Two 确实具有一个到网络 A 的路由,因此它会对查询做出响应。由于路由器 1不再具有通过路由器4 的更好路由,它会接受此通过路由器 2到网络 A 的路由。

判定一条路径是否无环路

EIGRP 如何使用可行距离、报告距离和可行后继路由的概念来确定路径是否有效且不是环路?在图 4a 中,路由器 Three 检查到网络 A 的路由。由于水平分割已禁用(例如,如果这些是多点帧中继接口),因此路由器 Three 显示三个到网络 A 的路由:通过路由器 4、通过路由器2(路径是 2、1、3、4)和通过路由器 1(路径是 1、2、3、4)。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp21.gif

如果路由器 Three 接受所有这些路由,将导致路由环路。路由器 Three 认为它能通过路由器 Two 到达网络 A,但是通过路由器 Two 的路径经过路由器 Three 才能到达网络 A。如果路由器 Four 和路由器 Three 之间的连接断开,则路由器 Three 认为它能通过其他路径之一到达网络 A,但是由于确定可行后继路由的规则,它将永远不会使用这些路径作为替代。让我们来看这些度量以了解原因:

  • 通过路由器 Four 到网络 A 的总度量:20281600

  • 通过路由器 Two 到网络 A 的总度量:47019776

  • 通过路由器 One 到网络 A 的总度量:47019776

由于通过路由器4的路径具有最佳度量,因此路由器 3将此路由安装在转发表中,并使用 20281600 作为它到网络 A 的可行距离。然后,路由器 3再计算通过路由器 2 和 1到网络 A 的报告距离:通过路由器 Two 的路径的报告距离为 47019776,通过路由器 One 的路径的报告距离为 47019776。由于这两个度量都大于可行距离,因此路由器 Three 不会将其中任何一个路由作为网络 A 的可行后继路由进行安装。

假设路由器 Three 和 Four 之间的链路断开。路由器 3向它的每个邻居查询通向网络 A 的替代路由。路由器 2 收到查询,由于该查询来自其后继路由,因此它会在其拓扑表中搜索其他每个条目以查看是否存在可行后继路由。拓扑表中唯一的其他条目来自路由器 1,其报告距离等于最后获知的通过路由器 3 的最佳度量。由于通过路由器1的报告距离不小于最后获知的可行距离,因此路由器2将此路由标记为不可达,并向它的每个邻居(在本例中,只有路由器1)查询通向网络 A 的路径。

路由器 Three 也向路由器 One 发送针对网络 A 的查询。路由器 1检查其拓扑表,并发现到网络 A 的唯一其他路径是通过路由器 2的路径,其报告距离等于最后获知的通过路由器3的可行距离。再一次,由于通过路由器 2 的报告距离不小于最后获知的可行距离,因此此路由不是可行后继路由。路由器 1将此路由标记为不可达,并向其唯一的其他邻居(路由器2)查询通向网络 A 的路径。

这是第一个级别的查询。路由器 3已查询了它的每个邻居以试图找到通向网络 A 的路由。然后,路由器1和2已将路由标记为不可达,并查询了它们的每个剩余邻居以试图找到通向网络 A 的路径。当路由器 Two 收到路由器 One 的查询时,它会检查其拓扑表,并注意到该目标已被标记为不可达。路由器 Two 向路由器 One 回复网络 A 不可达。当路由器 One 收到路由器 Two 的查询时,它也发送回网络 A 不可达的回复。路由器 One 和 Two 都已得出网络 A 不可达的结论,然后它们回复原始路由器 Three 的查询。网络已收敛,所有路由都返回被动状态。

水平分割与毒性逆转

在前面的示例中,我们假设水平分割不生效以显示 EIGRP 如何使用可行距离和报告距离来确定路由是否可能成为环路。但是,在某些情况下,EIGRP 也使用水平分割来防止路由环路。在研究 EIGRP 如何使用水平分割的详细资料之前,让我们复习一下水平分割的概念及其工作方式。水平分割规则规定:

  • 永远不从通过其获知路由的接口通告该路由。

例如,在图 4a 中,如果路由器1通过一个多点接口(如帧中继)连接到路由器 2和3,并且路由器1从路由器 2获知网络 A,那么它不会从同一接口将到网络 A 的路由通告回路由器 3。路由器 One 假设路由器 Three 将直接从路由器 Two 获知网络 A。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp21.gif

毒性逆转是避免路由环路的另一种方法。其规则规定:

  • 一旦通过某个接口获知路由,便通过该同一接口将其通告回为不可达路由。

假定图 4a 中的路由器已启用毒性逆转。当路由器 1 从路由器 2 获知网络 A 时,它会通过其到路由器 2 和 3 的链路通告网络 A 为不可达网络。如果路由器3显示通过路由器1到网络 A 的任何路径,它将由于不可达通告删除该路径。EIGRP 结合这两个规则来帮助防止路由环路。

在下列情况下,EIGRP 使用水平分割或将路由通告为不可达路由:

  • 两个路由器处于启动模式(第一次交换拓扑表)

  • 通告拓扑表更改

  • 发送查询

让我们来研究其中的每种情况。

启动模式

当两个路由器首次成为邻居时,它们在启动模式期间交换拓扑表。对于路由器在启动模式期间收到的每个表条目,它都将以最大度量(毒化路由)向其新邻居通告回同一条目。

拓扑表更改

在图 5 中,路由器1使用差异值来均衡两个串行链路(路由器 2和 4之间的 56k 链路,和路由器 3和4之间的 128k 链路)之间流向网络 A 的流量(有关差异值的讨论,请参阅负载均衡部分)。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp5.gif

路由器 Two 将通过路由器 Three 的路径视为可行后继路由。如果路由器2和4之间的链路断开,路由器2只需在通过路由器3的路径重新融合即可。由于水平分割规则规定永远不应从通过其获知路由的接口通告路由,因此路由器2 不会正常发送更新。但是,这为路由器 One 留下了一个无效的拓扑表条目。当路由器更改其拓扑表以使路由器通过其到达网络的接口更改时,它会关闭水平分割,并从所有接口毒性逆转旧路由。在本例中,路由器2 将关闭此路由的水平分割,并将网络 A 通告为不可达网络。路由器 One 听到此通告,并将其通过路由器 Two 到网络 A 的路由从其路由表中清除。

查询

只有当路由器收到来自用于查询中目标的后继路由的查询或更新时,查询才会导致水平分割。让我们来看图 6 中的网络。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp6.gif

路由器 Three 从路由器 Four 收到一个关于 10.1.2.0/24(该目标通过路由器 One 到达)的查询。如果三没有此目的地的一后继路由,因为链路抖动或其他临时网络情况,它发送查询对其邻居中的每一个;在本例中,为路由器 One、Two 和 Four。如果,然而,路由器3收到查询或更新(例如一量度的更改)从目的地的10.1.2.0/24路由器1,它不发送查询回到路由器1,因为路由器1是其后继路由对此网络。它只向路由器 Two 和 Four 发送查询。

停滞在活动状态的路由

在某些情况下,查询需要很长时间才能得到回答。因此,实际上发出查询的路由器会放弃并清除其到未做出回答的路由器的连接,从而有效地重新启动邻居会话。这被称为停滞在活动状态 (SIA) 的路由。如果只是查询到达网络另一端的时间和回复返回的时间过长,将发生最基本的 SIA 路由。例如,在图 7 中,路由器 One 正在记录来自路由器 Two 的大量 SIA 路由。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp7.gif

在经过一些调查后,问题范围缩小到路由器2和3之间的卫星链路上的延迟。这种类型的问题有两个可能的解决方案。第一个是增加路由器在发送查询之后、声明路由 SIA 之前的等待时间。可以使用 timers active-time 命令更改此设置。

但是,更好的解决方案是重新设计网络,以减小查询的范围(以便只有极少的查询通过卫星链路)。查询范围在查询范围部分中介绍。但是,查询范围本身不是报告的 SIA 路由的常见原因。通常,网络上的一些路由器由于下列原因之一无法回答查询:

  • 路由器太繁忙以至于无法回答查询(通常由于 CPU 使用率过高)

  • 路由器存在内存问题,因此无法分配内存来处理查询或建立回复数据包

  • 两个路由器之间的电路不好 - 足够的数据包通过以保持邻居关系处于正常状态,但路由器之间的部分查询或回复丢失

  • 单向链路(由于故障,数据包只能向一个方向流动的链路)

SIA 路由故障排除

SIA 路由故障排除通常是一个三步过程:

  1. 查找自始至终被报告为 SIA 的路由。

  2. 查找自始至终无法回答针对这些路由的查询的路由器。

  3. 查找路由器未收到或回答查询的原因。

第一步应该非常容易。如果您记录控制台消息,可快速浏览该日志以了解哪些路由最常被标记为 SIA。第二步稍微困难。用于收集此信息的命令是 show ip eigrp topology active

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

A 10.2.4.0/24, 0 successors, FD is 512640000, Q 
    1 replies, active 00:00:01, query-origin: Local origin 
         via 10.1.2.2 (Infinity/Infinity), Serial1 
    1 replies, active 00:00:01, query-origin: Local origin 
         via 10.1.3.2 (Infinity/Infinity), r, Serial3 
    Remaining replies: 
         via 10.1.1.2, r, Serial0

显示 R 的所有邻居尚未回复(活动计时器显示路由已处于活动状态的时间长度)。请注意,这些邻居可能不会显示在“Remaining replies”部分;它们可能在其他 RDB 之中出现。请特别注意那些具有未处理回复且已处于活动状态一段时间(通常为两到三分钟)的路由。多次运行此命令,您会开始明白哪些邻居不响应查询(或者哪些接口似乎具有大量未回答的查询)。检查此邻居发现它是否一致等待从的回复任何其邻居。重复此过程,直到您发现自始至终不回答查询的路由器。您可以查找有关到此邻居的链路、内存或 CPU 使用率的问题,或此邻居的其他问题。

如果遇到问题似乎出在查询范围上的情况,最好减小查询范围,而不是增加 SIA 计时器。

再分配

本部分研究涉及重分配的不同方案。请注意,下面的示例显示的是配置重分配的最低要求。重分配可能会潜在地导致问题,如不理想的路由、路由环路或缓慢的收敛。要避免这些问题,请参阅重分配路由协议中的“避免由于重分配引起的问题”。

两个 EIGRP 自治系统之间的重分配

在图 8 中,路由器配置如下:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp8.gif

路由器 One

router eigrp 2000 

!--- The "2000" is the autonomous system 

 network 172.16.1.0 0.0.0.255 

路由器 Two

router eigrp 2000 
 redistribute eigrp 1000 route-map to-eigrp2000
 network 172.16.1.0 0.0.0.255 
! 
router eigrp 1000 
 redistribute eigrp 2000 route-map to-eigrp1000
 network 10.1.0.0 0.0.255.255

route-map to-eigrp1000 deny 10
match tag 1000
!
route-map to-eigrp1000 permit 20
set tag 2000
!
route-map to-eigrp2000 deny 10
match tag 2000
!
route-map to-eigrp2000 permit 20
set tag 1000

路由器 Three

router eigrp 1000 
 network 10.1.0.0 0.0.255.255

路由器 Three 通过自治系统 1000 向路由器 Two 通告网络 10.1.2.0/24;路由器 Two 将此路由重分配到自治系统 2000 中并将其通告给路由器 One。

注意: 来自 EIGRP 1000 的路由在被重分配到 EIGRP 2000 之前将被标记为 1000。当来自 EIGRP 2000 的路由重分配回 EIGRP 1000 时,具有 1000 标记的路由将被拒绝以确保拓扑无环路。关于路由协议之间重分配的详细信息,请参阅重分配路由协议

在路由器 One 上,我们看到:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 2 
      External data: 
        Originating router is 10.1.2.1 
        AS number of route is 1000 
        External protocol is EIGRP, external metric is 46251776 
        Administrator tag is 1000 (0x000003E8)

请注意,虽然路由器1和2之间的链路带宽为 1.544 Mb,但是该拓扑表条目中显示的最低带宽为 56k。这意味着 EIGRP 在两个 EIGRP 自治系统之间进行重分配时将保留所有度量。

两个不同自治系统中的 EIGRP 和 IGRP 之间的重分配

在图 9 中,我们已按如下所示更改了配置:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp9.gif

路由器 One

router eigrp 2000 
 network 172.16.1.0

路由器 Two

router eigrp 2000 
 redistribute igrp 1000 route-map to-eigrp2000
 network 172.16.1.0
! 
router igrp 1000 
 redistribute eigrp 2000 route-map to-igrp1000
 network 10.0.0.0 
!

route-map to-igrp1000 deny 10
match tag 1000
!
route-map to-igrp1000 permit 20
set tag 2000
!
route-map to-eigrp2000 deny 10
match tag 2000
!
route-map to-eigrp2000 permit 20
set tag 1000

路由器 Three

router igrp 1000 
 network 10.0.0.0

路由器 One 的配置如下所示:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 1000 
        External protocol is IGRP, external metric is 180671 
        Administrator tag is 1000 (0x000003E8)

当路由被重分配到具有不同自治系统的 EIGRP 中时,将保留 IGRP 度量,但是会通过将 IGRP 度量乘以常数 256 对它们进行换算。在 IGRP 和 EIGRP 之间进行重分配有一个需要注意的警告。如果网络直接连接到进行重分配的路由器,则它会通告度量为 1 的路由器。

例如,网络 10.1.1.0/24 直接与路由器 Two 连接,此网络通过 IGRP 进行路由(router IGRP 下有一条包含该接口的 network 语句)。此网络不通过 EIGRP 进行路由,但 EIGRP 通过从 IGRP 进行重分配获知此直接连接的接口。在路由器 One 上,10.1.1.0/24 的拓扑表条目显示:

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.1.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (2169856/1), Route is External 
                                    
      Vector metric: 
        Minimum bandwidth is 1544 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 0/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 1000 
        External protocol is IGRP, external metric is 0 
        Administrator tag is 1000 (0x000003E8)

请注意,从路由器2 的报告距离为 1(显示为粗体)。

同一个自治系统中的 EIGRP 和 IGRP 之间的重分配

对图 10 中的路由器配置进行了以下更改:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp10.gif

路由器 One

router eigrp 2000 
 network 172.16.1.0 

路由器 Two

router eigrp 2000 
 network 172.16.1.0
! 
router igrp 2000 
 network 10.0.0.0

路由器 Three

router igrp 2000 
 network 10.0.0.0

并且路由器 One 配置如下:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 2000 
        External protocol is IGRP, external metric is 180671 
        Administrator tag is 0 (0x00000000)

当我们在运行 IGRP 和 EIGRP 的两个不同自治系统之间进行重分配时,该配置看起来非常像以前的输出。在这两种情况下,直接连接的 10.1.1.0/24 网络的处理方式相同:

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.1.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (2169856/1), Route is External 
      Vector metric: 
        Minimum bandwidth is 1544 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 2000 
        External protocol is IGRP, external metric is 0 
        Administrator tag is 0 (0x00000000)

因此这个直接与路由器1连接的网络通过度量1 从IGRP重新分配到EIGRP-该度量是我们在l两个不同自治系统之间重新分配时看到的相同值。

在同一个自治系统中进行 EIGRP/IGRP 重分配有两个警告:

  • 内部 EIGRP 路由始终优先于外部 EIGRP 或 IGRP 路由。

  • 外部 EIGRP 路由度量相当于经过换算的 IGRP 度量(管理距离被忽略)。

让我们在图 11 中研究这些警告:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp11.gif

路由器 One 在 IGRP 自治系统 100 中通告 10.1.4.0/24;路由器 Four 将 10.1.4.0/24 通告为 EIGRP 自治系统 100 的外部网络;路由器 Two 在自治系统 100 中同时运行 EIGRP 和 IGRP。

如果我们忽略路由器4 通告的 EIGRP 路由(例如,通过关闭路由器2和 Four 之间的链路),路由器 2将会显示以下内容:

two# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "igrp 100", distance 100, metric 12001 
  Redistributing via igrp 100, eigrp 100 
  Advertised by igrp 100 (self originated) 
                eigrp 100 
  Last update from 10.1.1.2 on Serial1, 00:00:42 ago 
  Routing Descriptor Blocks: 
  * 10.1.1.2, from 10.1.1.2, 00:00:42 ago, via Serial1 
      Route metric is 12001, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 0

请注意,管理距离为 100。当我们添加 EIGRP 路由时,路由器 Two 显示以下内容:

two# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "eigrp 100", distance 170, metric 3072256, type external 
  Redistributing via igrp 100, eigrp 100 
  Last update from 10.1.2.2 on Serial0, 00:53:59 ago 
  Routing Descriptor Blocks: 
  * 10.1.2.2, from 10.1.2.2, 00:53:59 ago, via Serial0 
      Route metric is 3072256, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 1

请注意,在从 IGRP 到 EIGRP 进行换算后,这两个路由的度量相同(请参阅度量部分):

  • 12001 x 256 = 3072256

其中,12001(IGRP 度量)通过路由器 One;3072256(EIGRP 度量)通过路由器 Four。

路由器2将优先选择度量相同(换算后)但管理距离更大的 EIGRP 外部路由。每当在同一个自治系统之内的 EIGRP 和 IGRP 之间发生重分配时,都是这种情况。路由器始终优先选择具有最低成本度量的路径,并忽略管理距离。

到/从其他协议的重分配

EIGRP 和其他协议(例如,RIP 和 OSPF)之间的重分配与所有重分配的工作方式相同。在协议之间进行重分配时,最好始终使用默认度量。在 EIGRP 和其他协议之间重分配时,应该注意以下两个问题:

  • 重分配到 EIGRP 中的路由并不总会被汇总,有关说明,请参阅汇总部分。

  • 外部 EIGRP 路由的管理距离为 170。

指向接口的静态路由的重分配

当您在某个接口上安装静态路由,并使用 router eigrp 配置包括该静态路由的 network 语句时,EIGRP 会重分配该路由,就好像它是直接连接的接口一样。让我们来看图 12 中的网络。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp12.gif

路由器 One 具有通过接口 Serial 0 配置的到网络 172.16.1.0/24 的静态路由:

ip route 172.16.1.0 255.255.255.0 Serial0

并且路由器 One 还有一条针对此静态路由目标的 network 语句:

router eigrp 2000 
 network 10.0.0.0 
 network 172.16.0.0 
 no auto-summary 

路由器1会重分配此路由(即使它不对静态路由进行重分配),因为 EIGRP 认为这是一个直接连接的网络。在路由器 Two 上,这将如下所示:

two# show ip route 
    .... 
        10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
    C       10.1.1.0/24 is directly connected, Serial0
    D       10.1.2.0/24 [90/2169856] via 10.1.1.1, 00:00:47, Serial0
         172.16.0.0/24 is subnetted, 1 subnets 
    D       172.16.1.0 [90/2169856] via 10.1.1.1, 00:00:47, Serial0

请注意,到 172.16.1.0/24 的路由作为内部 EIGRP 路由出现在路由器 Two 上。

汇总

EIGRP 中有两种汇总形式:自动汇总和手动汇总。

Auto-summarization

EIGRP 每次穿过两个不同的主要网络之间的边界时会执行自动汇总。例如,在图 13 中,路由器2只向路由器1 通告 10.0.0.0/8 网络,因为路由器2用来到达路由器1的接口位于不同的主要网络中。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp13.gif

在路由器 One 上,这将如下所示:

one# show ip eigrp topology 10.0.0.0 
IP-EIGRP topology entry for 10.0.0.0/8 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 11023872 
  Routing Descriptor Blocks: 
  172.16.1.1 (Serial0), from 172.16.1.2, Send flag is 0x0 
      Composite metric is (11023872/10511872), Route is Internal 
      Vector metric: 
        Minimum bandwidth is 256 Kbit 
        Total delay is 40000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1

此路由在任何情况下都不会标记为汇总路由;它看起来像内部路由。度量是汇总路由中的最佳度量。请注意,此路由上的最低带宽为 256k,虽然 10.0.0.0 网络中有一些链路的带宽为 56K。

在执行汇总的路由器上,将为汇总地址建立一个到 null0 的路由:

two# show ip route 10.0.0.0 
Routing entry for 10.0.0.0/8, 4 known subnets 
  Attached (2 connections) 
  Variably subnetted with 2 masks 
  Redistributing via eigrp 2000 

C       10.1.3.0/24 is directly connected, Serial2 
D       10.1.2.0/24 [90/10537472] via 10.1.1.2, 00:23:24, Serial1 
D       10.0.0.0/8 is a summary, 00:23:20, Null0 
C       10.1.1.0/24 is directly connected, Serial1

到 10.0.0.0/8 的路由被标记为通过 Null0 的汇总。此汇总路由的拓扑表条目看起来如下所示:

two# show ip eigrp topology 10.0.0.0 
IP-EIGRP topology entry for 10.0.0.0/8 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 10511872 
  Routing Descriptor Blocks: 
  0.0.0.0 (Null0), from 0.0.0.0, Send flag is 0x0 
          (note: the 0.0.0.0 here means this route is originated by this router) 
      Composite metric is (10511872/0), Route is Internal 
      Vector metric: 
        Minimum bandwidth is 256 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 0

要让路由器 Two 通告 10.0.0.0 网络的组件,而不是汇总,请在路由器 Two 上的 EIGRP 进程中配置 no auto-summary

在路由器 Two 上

router eigrp 2000 
 network 172.16.0.0 
 network 10.0.0.0 
 no auto-summary

关闭自动汇总后,路由器1现在可以看到 10.0.0.0 网络的所有组件:

one# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 10.1.3.0/24, 1 successors, FD is 46354176 
         via 20.1.1.1 (46354176/45842176), Serial0 
P 10.1.2.0/24, 1 successors, FD is 11049472 
         via 20.1.1.1 (11049472/10537472), Serial0 
P 10.1.1.0/24, 1 successors, FD is 11023872 
         via 20.1.1.1 (11023872/10511872), Serial0 
P 172.16.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0

在处理外部路由的汇总时有一些警告,后面将在外部路由的自动汇总部分进行介绍。

手动总结

EIGRP 允许使用手动汇总在几乎任何位边界上汇总内部和外部路由。例如,在图 14 中,路由器2将 192.1.1.0/24、192.1.2.0/24 和 192.1.3.0/24 汇总到 CIDR 块 192.1.0.0/22。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp14.gif

路由器 Two 上的配置如下所示:

two# show run 
.... 
! 
interface Serial0 
 ip address 10.1.50.1 255.255.255.0 
 ip summary-address eigrp 2000 192.1.0.0 255.255.252.0 
 no ip mroute-cache 
! 
.... 

two# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status

P 10.1.10.0/24, 1 successors, FD is 45842176 
         via Connected, Loopback0 
P 10.1.50.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 192.1.1.0/24, 1 successors, FD is 10511872 
         via Connected, Serial1 
P 192.1.0.0/22, 1 successors, FD is 10511872 
         via Summary (10511872/0), Null0 
P 192.1.3.0/24, 1 successors, FD is 10639872 
         via 192.1.1.1 (10639872/128256), Serial1 
P 192.1.2.0/24, 1 successors, FD is 10537472 
         via 192.1.1.1 (10537472/281600), Serial1

通过Null0注释ip summary-address eigrp命令下面接口Serial0和汇总路由。在路由器 One 上,我们看到这是内部路由:

  one# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 10.1.10.0/24, 1 successors, FD is 46354176 
         via 10.1.50.1 (46354176/45842176), Serial0 
P 10.1.50.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 192.1.0.0/22, 1 successors, FD is 11023872 
         via 10.1.50.1 (11023872/10511872), Serial0

外部路由的自动汇总

除非存在属于内部路由的同一主要网络的组件,否则 EIGRP 不会自动汇总外部路由。为了进行说明,让我们来看图 15。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp15.gif

路由器 3使用 redistribute connected 命令将到 192.1.2.0/26 和 192.1.2.64/26 的外部路由加入 EIGRP,如以下配置所示。

路由器 Three

interface Ethernet0 
 ip address 192.1.2.1 255.255.255.192 
! 
interface Ethernet1
 ip address 192.1.2.65 255.255.255.192
!
interface Ethernet2
 ip address 10.1.2.1 255.255.255.0
!router eigrp 2000 
 redistribute connected 
 network 10.0.0.0 
 default-metric 10000 1 255 1 1500

对应于路由器 Three 上的此配置,路由器 One 上的路由表显示:

  one# show ip route
.... 
     10.0.0.0/8 is subnetted, 2 subnets 
D       10.1.2.0 [90/11023872] via 10.1.50.2, 00:02:03, Serial0 
C       10.1.50.0 is directly connected, Serial0 
     192.1.2.0/26 is subnetted, 1 subnets 
D EX    192.1.2.0 [170/11049472] via 10.1.50.2, 00:00:53, Serial0 
D EX    192.1.2.64 [170/11049472] via 10.1.50.2, 00:00:53, Serial0

虽然自动汇总一般会导致路由器 Three 将 192.1.2.0/26 和 192.1.2.64/26 路由汇总到一个主要网络目标 (192.1.2.0/24),但它不会执行该操作,因为两个路由都是外部路由。但是,如果将路由器2和 3之间的链路重新配置为 192.1.2.128/26,并在路由器 2和3上为此网络添加 network 语句,那么将在路由器2上生成 192.1.2.0/24 自动汇总。

路由器 Three

 interface Ethernet0 
 ip address 192.1.2.1 255.255.255.192 
! 
interface Ethernet1
 ip address 192.1.2.65 255.255.255.192
!
interface Serial0 
 ip address 192.1.2.130 255.255.255.192 
! 
router eigrp 2000 
 network 192.1.2.0

现在路由器 Two 生成 192.1.2.0/24 的汇总:

two# show ip route 
.... 
D       192.1.2.0/24 is a summary, 00:06:48, Null0
....

并且路由器 One 仅显示汇总路由:

 one# show ip route 
.... 
     10.0.0.0/8 is subnetted, 1 subnets 
C       10.1.1.0 is directly connected, Serial0 
D    192.1.2.0/24 [90/11023872] via 10.1.50.2, 00:00:36, Serial0

查询处理与范围

当路由器处理来自邻居的查询时,以下规则适用:

查询来源 路由状态 操作
邻居(非当前后继路由) 被动 回复当前后继路由信息
后继路由 被动 尝试查找新的后继路由;如果成功,则回复新信息;如果不成功,则将目标标记为不可达,并查询除前一个后继路由以外的所有邻居
任何邻居 查询前没有通过此邻居的路径 回复当前已知的最佳路径
任何邻居 查询前不知道 回复目标不可达
邻居(非当前后继路由) 激活 如果没有到此目标的当前后继路由(通常会是这种情况),则回复目标不可达
如果有好的后继路由,则回复当前路径信息
后继路由 激活 尝试查找新的后继路由;如果成功,则回复新信息;如果不成功,则将目标标记为不可达,并查询除前一个后继路由以外的所有邻居

上表中的操作通过确定当网络在新拓扑上收敛之前收到并回复查询的路由器的数量来影响该网络中查询的范围。要查看这些规则如何影响查询的处理方式,让我们来看图 16 中的网络,该网络正在正常情况下运行。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16.gif

我们可以预计,关于网络 192.168.3.0/24(最右端),将发生以下情况:

  • 路由器 One 有两条到 192.168.3.0/24 的路径:

    • 通过路由器 Two,距离为 46533485,报告距离为 20307200

    • 通过路由器 Three,距离为 20563200,报告距离为 20307200

  • 路由器1选择通过路由器 3的路径,并将通过路由器2 的路径保留为可行后继路由

  • 路由器 Two 和 Three 显示一条通过路由器 Four 到 192.168.3.0/24 的路径

假设 192.168.3.0/24 发生故障。我们可以预计此网络上会发生什么活动?图 16a 到 16h 说明了此过程。

路由器 Five 将 192.168.3.0/24 标记为不可达,并查询路由器 Four:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16a.gif

路由器4在收到来自其后继路由的查询后,将尝试查找到此网络的新可行后继路由。它没找到一,因此指示192.168.3.0/24作为不可达的和查询路由器2和3 :

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16b.gif

随后,路由器2和3发现它们丢失了到 192.168.3.0/24 的唯一可行路由,并将其标记为不可达;它们都向路由器 One 发送查询:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16c.gif

简而言之,假设路由器 One 先收到来自路由器 Three 的查询,并将该路由标记为不可达。然后,路由器 One 收到来自路由器 Two 的查询。虽然也可能是另一个顺序,但它们的最终结果都相同。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16d.gif

路由器 One 对这两个查询都回复不可达;路由器 One 现在对于 192.168.3.0/24 处于被动状态:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16e.gif

路由器 Two 和 Three 回复来自路由器 Four 的查询;路由器 Two 和 Three 现在对于 192.168.3.0/24 处于被动状态:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16f.gif

路由器 Five 在收到来自路由器 Four 的回复后,将从其路由表中删除网络 192.168.3.0/24;路由器 Five 现在对于网络 192.168.3.0/24 处于被动状态。路由器5将更新发送回路由器 4,以便从剩余路由器的拓扑和路由表中删除该路由。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16g.gif

请注意,虽然可能有其他查询路径或处理顺序,但当该链路断开时,网络中的所有路由器会处理针对网络 192.168.3.0/24 的查询。一些路由器可以结束多个查询的处理(本示例中的路由器1)。实际上,如果查询按不同顺序到达路由器,一些路由器将结束三或四个查询的处理。这是 EIGRP 网络中无限查询的很好示例。

汇总点如何影响查询范围

现在让我们来看同一网络中到 10.1.1.0/24 的路径:

  • 路由器2有10.1.1.0/24网络的拓扑表条目,通过路由器1的成本为46251885。

  • 路由器3有10.1.1.0/24网络的拓扑表条目,通过路由器1的成本为20281600。

  • 路由器4有一个针对 10.0.0.0/8 网络(由于路由器2和 3会自动汇总到主要网络边界)的拓扑表条目,通过路由器3,度量为 20307200(通过路由器2的报告距离大于通过路由器 3 的总度量,因此通过路由器2的路径不是可行后继路由)。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17.gif

如果 10.1.1.0/24 断开,路由器1会将其标记为不可达,然后向它的每个邻居(路由器 2 和3)查询通向该网络的新路径:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17a.gif

路由器2在收到来自路由器1的查询后,会将该路由标记为不可达(因为该查询来自其后继路由),然后查询路由器 4和 3:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17b.gif

路由器3在收到来自路由器1的查询时,会将目标标记为不可达,并查询路由器2和4:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17c.gif

路由器 4 在收到来自路由器 2和 3 的查询时,将回复 10.1.1.0/24 不可达(请注意,路由器 4无法了解有问题的子网,因为它只有 10.0.0.0/8 路由):

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17d.gif

路由器 Two 和 Three 相互回复 10.1.1.0/24 不可达:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17e.gif

由于路由器2和 3现在没有未处理的查询,因此它们都向路由器1回复 10.1.1.0/24 不可达:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17f.gif

在本例中,查询受到路由器 Two 和 Three 上的自动汇总的限制。路由器5不参与查询过程,也不参与网络的重新收敛。查询还可能受到手动汇总、自治系统边界和分配列表的限制。

自治系统边界如何影响查询范围

如果路由器在两个 EIGRP 自治系统之间重分配路由,它会在正常处理规则内回复查询,并向另一个自治系统发送新的查询。例如,如果到与路由器3连接的网络的链路断开,路由器 3会将路由标记为不可达,并向路由器 2查询新的路径:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18.gif

路由器 2回复此网络不可达,并且在自治系统 200 中向路由器1发送查询。一旦路由器3收到其原始查询的回复,它将从其表中删除该路由。路由器 Three 现在对于此网络处于被动状态:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18a.gif

路由器 One 回复路由器 Two,路由进入被动状态:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18b.gif

当原始查询未在整个网络中传播时(受到自治系统边界的限制),原始查询将以新查询的形式渗进第二个自治系统。此技术通过限制查询在被回答之前必须通过的路由器数量,来帮助防止网络中的停滞在活动状态 (SIA) 问题,但它无法解决每个路由器必须对查询进行处理的整体问题。实际上,这种通过防止自动汇总路由(外部路由不会汇总,除非该主要网络中有外部组件)限制查询的方法可能会使问题更糟糕。

分配列表如何影响查询范围

EIGRP 中的分配列表不会阻塞查询的传播,而是将所有查询回复都标记为不可达。让我们使用图 19 作为示例。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19.gif

在上图中:

  • 路由器3有一个在其串行接口上应用的分配列表,只允许该路由器通告网络 B。

  • 路由器 One 和 Two 不知道网络 A 通过路由器 Three 可达(路由器 Three 不用作路由器 One 和 Two 之间的中转点)。

  • 路由器3使用路由器1作为到网络A的首选路径,且不使用路由器2作为可行后继者。

当路由器1丢失了与网络 A 的连接时,它会将该路由标记为不可达,并向路由器 3发送查询。由于其串行端口上的分配列表,路由器 Three 不会通告到网络 A 的路径。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19a.gif

路由器 Three 将此路由标记为不可达,然后查询路由器 Two:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19b.gif

路由器 Two 检查其拓扑表并发现它有一个到网络 A 的有效连接。请注意,查询未受路由器 Three 中分配列表的影响:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19c.gif

路由器 Two 回复网络 A 可达;路由器 Three 现在有一个有效路由:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19d.gif

路由器3对路由器1的查询进行回复,但分配表会让路由器3发送网络A不可达的回复,即使路由器3具有到达网络A的有效路由:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19e.gif

调整数据包的步调

部分路由协议在它们收敛(适应网络变化)时会占用低带宽链路上的所有可用带宽。EIGRP 通过调整数据包在网络中的传输速度来避免此拥塞,从而只使用部分可用带宽。EIGRP 的默认配置是最多使用可用带宽的 50%,但可以使用以下命令更改该配置:

router(config-if)# 
ip bandwidth-percent eigrp 2 ? 
  <1-999999>  Maximum bandwidth percentage that EIGRP may use

基本上,每次 EIGRP 在接口上对要传输的数据包排队时,它都使用以下公式确定发送该数据包前的等待时间:

  • (8 * 100 * 以字节为单位的数据包大小) / (以 kbps 为单位的带宽 * 带宽百分比)

例如,如果 EIGRP 在 56k 带宽的串行接口上对数据包排队,并且数据包大小为 512 字节,则 EIGRP 将等待:

  • (8 * 100 * 512 字节) / (56000 比特/秒 * 50% 带宽) (8 *100 * 512) / (56000 * 50) 409600 / 2800000 0.1463 秒

这允许在 EIGRP 发送其数据包之前,此链路上至少可以传输 512 字节的数据包(或数据包组)。步调计时器确定发送数据包的时间,通常以毫秒为单位表示。以上示例中数据包的步调时间是 0.1463 秒。show ip eigrp interface 的输出中有一个显示步调计时器的字段,如下所示:

router# show ip eigrp interface
IP-EIGRP interfaces for process 2	

                    Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0            1        0/0        28       0/15         127           0
Se1            1        0/0        44       0/15         211           0
router#

显示的时间是最大传输单元 (MTU)(可在接口上发送的最大数据包)的步调间隔。

默认路由

有两种方法可将默认路由加入 EIGRP 中:重分配静态路由或汇总到 0.0.0.0/0。如果您希望将流向未知目标的所有流量引向网络核心处的默认路由,请使用第一种方法。此方法对于通告到 Internet 的连接很有效。例如:

ip route 0.0.0.0 0.0.0.0 x.x.x.x (next hop to the internet) 
! 
router eigrp 100 
 redistribute static 
 default-metric 10000 1 255 1 1500

重新分配到EIGRP的静态路由不必一定是网络0.0.0.0。如果使用另一个网络,则必须使用 ip default-network 命令将该网络标记为默认网络。有关详细信息,请参阅配置最后选用网关

只有当您希望提供具有默认路由的远程站点时,汇总到默认路由才有效。因为摘要每个接口配置,您不需要担心使用distribute-list或其他机制防止默认路由被传播往您的网络核心。请注意,到 0.0.0.0/0 的汇总会覆盖从任何其他路由协议获知的默认路由。使用此方法在路由器上配置默认路由的唯一方式是将静态路由配置为 0.0.0.0/0。(开始处在Cisco IOS软件12.0(4)T方面,您能也配置在结尾的管理距离ip summary-address eigrp命令,因此本地摘要不改写0.0.0.0/0路由)。

router eigrp 100 
 network 10.0.0.0 
! 
interface serial 0 
 encapsulation frame-relay 
 no ip address 
! 
interface serial 0.1 point-to-point 
 ip address 10.1.1.1 
 frame-relay interface-dlci 10 
 ip summary-address eigrp 100 0.0.0.0 0.0.0.0

负载平衡

EIGRP 在路由表中最多放置四个等价路由,然后路由器将对这些路由进行负载均衡。负载均衡的类型(按数据包或按目标)取决于在路由器中执行的交换的类型。但是,EIGRP 也可以在非等价链路上进行负载均衡。

注意: 使用 max-paths,可以配置 EIGRP 以使用最多六个等价路由。

假定有四条路径到指定的目标,并且这些路径的度量如下:

  • 路径 1:1100

  • 路径 2:1100

  • 路径 3:2000年

  • 路径 4:4000

默认情况下,路由器将流量同时放在路径 1 和 2 上。使用 EIGRP,您可以使用 variance 命令来指示路由器同时将流量放在路径 3 和 4 上。差异值是一个乘数:流量将被放到度量小于最佳路径度量与差异值相乘得到的结果的任何链路上。要均衡路径 1、2 和 3 上的负载,请使用差异值 2,因为 1100 x 2 = 2200,该值大于通过路径 3 的度量。同样地,要同时添加路径 4,请在 router eigrp 命令下发出 variance 4。有关详细信息,请参阅 IGRP 和 EIGRP 中不等价路径负载均衡 (Variance) 的工作方式

路由器如何在这些路径之间分配流量?它用通过每条路径的度量来除最大度量,四舍五入到最接近的整数,然后使用此数字作为流量份数。

router# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "igrp 100", distance 100, metric 12001 
  Redistributing via igrp 100, eigrp 100 
  Advertised by igrp 100 (self originated) 
                eigrp 100 
  Last update from 10.1.2.2 on Serial1, 00:00:42 ago 
  Routing Descriptor Blocks: 
  * 10.1.2.2, from 10.1.2.2, 00:00:42 ago, via Serial1 
      Route metric is 12001, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 0

对于本示例,流量份数如下:

  • 对于路径 1 和 2:4000/1100 = 3

  • 对于路径 3:4000/2000 = 2

  • 对于路径 4:4000/4000 = 1

路由器在路径 1 上发送前三个数据包,在路径 2 上发送接下来的三个数据包,在路径 3 上发送再接下来的两个数据包,然后在路径 4 上发送下一个数据包。然后路由器通过在路径 1 上发送接下来的三个数据包重新启动,依此类推。

注意: 如果报告距离大于该特定路由的可行距离,那么即使已经配置差异值,EIGRP 也不会通过不等价路径发送流量。有关详细信息,请参阅可行距离、报告距离和可行后继路由部分。

使用度量

当您最初配置 EIGRP 时,如果试图影响 EIGRP 度量,请记住以下两个基本规则:

  • 带宽应始终设置为接口的实际带宽;多点串行链路和其他不匹配的介质速度情况是此规则的例外情况。

  • EIGRP 路由决策中务必要考虑延迟的影响。

由于 EIGRP 使用接口带宽确定发送数据包的速率,因此正确设置这些值非常重要。如果有必要影响 EIGRP 选择的路径,则始终使用延迟来实现此目的。

在带宽较低时,带宽有对总度量的影响更大;在带宽较高时,延迟对总度量的影响更大。

在重分配中使用管理标记

外部管理标记可用于中断 EIGRP 和其他协议之间的重分配路由环路。通过在将路由重分配到 EIGRP 时对路由进行标记,可以阻止从 EIGRP 重分配到外部协议。不能修改从外部路由获知的默认网关的管理距离,因为在 EIGRP 中,管理距离的修改只适用于内部路由。为了提高度量,请使用带 prefix-list 的 route-map;请勿更改管理距离。随后提供配置这些标记的基本示例,但本示例不显示用来中断重分配环路的整个配置。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp20.gif

路由器 Three(它将连接的路由重分配到 EIGRP 中)显示以下内容:

three# show run 

.... 

interface Loopback0 
 ip address 172.19.1.1 255.255.255.0 
! 
interface Ethernet0 
 ip address 172.16.1.1 255.255.255.0 
 loopback 
 no keepalive 
! 
interface Serial0 
 ip address 172.17.1.1 255.255.255.0 

.... 

router eigrp 444 
 redistribute connected route-map foo  
 network 172.17.0.0 
 default-metric 10000 1 255 1 1500 

.... 

access-list 10 permit 172.19.0.0 0.0.255.255 
route-map foo permit 10 
 match ip address 10 
 set tag 1 

.... 

three# show ip eigrp topo 
IP-EIGRP Topology Table for process 444 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 172.17.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
         via Redistributed (2169856/0) 
P 172.16.1.0/24, 1 successors, FD is 281600 
         via Redistributed (281600/0) 
P 172.19.1.0/24, 1 successors, FD is 128256, tag is 1 
         via Redistributed (128256/0)

路由器 Two(它将路由从 EIGRP 重分配到 RIP 中)显示以下内容:

two# show run 

.... 

interface Serial0 
 ip address 172.17.1.2 255.255.255.0 
! 
interface Serial1 
 ip address 172.18.1.3 255.255.255.0 

.... 

router eigrp 444 
 network 172.17.0.0 
! 
router rip 
 redistribute eigrp 444 route-map foo 
 network 10.0.0.0 
 network 172.18.0.0 
 default-metric 1 
! 
no ip classless 
ip route 1.1.1.1 255.255.255.255 Serial0 
route-map foo deny 10 
 match tag 1 
! 
route-map foo permit 20 

.... 

two# show ip eigrp topo 
IP-EIGRP Topology Table for process 444 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 172.17.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 172.16.1.0/24, 1 successors, FD is 2195456 
         via 172.17.1.1 (2195456/281600), Serial0 
P 172.19.1.0/24, 1 successors, FD is 2297856, tag is 1 
         via 172.17.1.1 (2297856/128256), Serial0

请注意 172.19.1.0/24 上的标记 1。

路由器 One(它接收由路由器 2 重分配的 RIP 路由)显示以下内容:

one# show run

.... 

interface Serial0 
 ip address 172.18.1.2 255.255.255.0 
 no fair-queue 
 clockrate 1000000 

router rip 
 network 172.18.0.0 

.... 

one# show ip route 

Gateway of last resort is not set 

R    172.16.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0 
R    172.17.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0 
     172.18.0.0/24 is subnetted, 1 subnets 
C       172.18.1.0 is directly connected, Serial0

请注意,172.19.1.0/24 丢失。

了解 EIGRP 命令输出

show ip eigrp traffic

此命令用于显示关于名为配置的EIGRP的信息和EIGRP自治系统(AS)配置。此命令输出显示交换在相邻的EIGRP路由器之间的信息。此表后面提供了每个输出字段的说明。

show ip eigrp traffic

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp20a.gif

配置说明

  • 发送的Hello/接收显示被发送和接收的Hello数据包数量(发送的-1927/received - 1930)

  • 被发送的更新/接收显示被发送和接收的更新数据包数量(sent-20/received-39)

  • 被发送的查询/接收含义接收查询发送的数据包的编号和(sent-10/received-18)

  • 被发送的回复/接收显示被发送和接收的应答数据包数量(sent-18/received-16)

  • Ack发送/接收确认发送的数据包编号的立场并且接收(sent-66/received-41)

  • SIA查询发送/接收含义接收stuck in active查询发送的数据包的编号和(sent-0/received-0)

  • 发送的SIA回复/接收显示stuck in active应答数据包数量被发送和接收的(sent-0/received-0)

  • Hello进程ID是Hello进程标识符(270)

  • PDM进程ID代表协议从属的模块IOS进程标识符(251)

  • Socket队列显示IP到EIGRP Hello进程socket队列计数器(current-0/max-2000/highest-1/drops-0)

  • Input queue显示EIGRP Hello进程到EIGRP PDM socket队列计数器(current-0/max-2000/highest-1/drops-0)

show ip eigrp topology

此命令只显示可行后继路由。要显示拓扑表中的所有条目,请使用 show ip eigrp topology all-links 命令。此表后面提供了每个输出字段的说明。

show ip eigrp topology

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp22.gif

配置说明

  • A 表示活动。这也可能显示 P,表示被动。

  • 10.2.4.0/24 是目标或掩码。

  • 0 successors 显示可用于此目标的后继路由(或路径)的数量;如果 successors 大写,则表示路由正在转变。

  • FD is 512640000 显示可行距离,这是到达此目标的最佳度量或当路由进入活动状态时已知的最佳度量。

  • tag is 0x0 可以通过 set tag 和 match tag 命令,使用路由映射来设置和/或过滤。

  • Q 表示查询挂起。此字段也可能是:U,表示更新挂起;或 R,表示回复挂起。

  • 1 replies 显示未处理的回复数。

  • active 00:00:01 显示此路由已处于活动状态的时间长度。

  • query origin:Local origin 显示此路由发起查询。此字段也可能是:Multiple origins,表示多个邻居(但不是后继路由)已发送有关此目标的查询;或 Successor origin,表示后继路由发起查询。

  • via 10.1.2.2 显示我们从 IP 地址为 10.1.2.2 的邻居那里获知该路由。此字段也可能是:Connected,如果网络被直接连接到此路由器;Redistributed,如果此路由在此路由器上被重分配到 EIGRP 中;或 Summary,如果这是在此路由器上生成的汇总路由。

  • ((Infinity/Infinity) 显示通过第一个字段中的此邻居到达该路径的度量和通过第二字段中的此邻居的报告距离。

  • r 显示我们已查询此邻居,并且正在等待回复。

  • Q 是此路由的发送标记,表示存在挂起的查询。此字段也可能是:U,表示存在挂起的更新;或 R,表示存在挂起的回复。

  • Serial1 是通过其可到达此邻居的接口。

  • Via 10.1.1.2 显示我们等待其回复的邻居。

  • r 显示我们已向此邻居查询有关路由的信息,但尚未收到回复。

  • Serial0 是通过其可到达此邻居的接口。

  • 通过10.1.2.2 (512640000/128256),Serial1显示我们正在使用此路由(显示出现多个成本相等的路由时,下一个路径/目的地将采取的路由)。

show ip eigrp topology <network>

此命令显示拓扑表中针对此目标的所有条目,而不只是显示可行后继路由。此表后面提供了每个输出字段的说明。

show ip eigrp topology network

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp23.gif

配置说明

  • 状态为被动,这意味着网络处于被动状态,或者换句话说,我们并没有寻找通向此网络的路径。在稳定网络中,路由几乎总是处于被动状态。

  • Query origin flag is 1 如果此路由处于活动状态,该字段将提供关于查询发起方的信息。

    • 0 :此路由处于活动状态,但还没有为其发起查询(我们正在本地搜索可行后继路由)。

    • 1 :此路由器发起针对该路由的查询(或路由处于被动状态)。

    • 2 :针对此查询的多次扩散计算。此路由器已经收到来自多个源的针对此路由的多个查询。

    • 3 :用于获知通向此网络的路径的路由器正在查询另一个路由。

    • 4 :此路由的多个查询源,包括我们用于获知此路由的路由器。与 2 类似,但它也表示存在描述针对此路径的未解决查询的查询源字符串。

  • 2 Successor 表示有两个到此网络的可行路径。

  • FD is 307200 显示到此网络的最佳当前度量。如果路由处于活动状态,则它表示我们以前用来将数据包路由到此网络的路径的度量。

  • Routing Descriptor Blocks 下列每个条目描述一条到网络的路径。

    • 10.1.1.2 (Ethernet1)流到网络和接口(下一跳通过该接口到达)的下一跳。

    • from 10.1.2.2 是此路径信息的源。

    • Send flag is

      • 0x0 :如果有与此条目相关的数据包需要发送,则这表示数据包的类型。

      • 0x1 :此路由器已经收到针对此网络的查询,并需要发送单播回复。

      • 0x2 :此路由处于活动状态,并应发送多播查询。

      • 0x3 :此路由已更改,并应发送多播更新。

  • Composite metric is (307200/281600) 显示到网络的总计算成本。括号中的第一个数字是通过此路径到达网络的总成本,包括到下一跳的成本。括号中的第二个数字是报告距离,或者换句话说,是下一跳路由器使用的成本。

  • Route is Internal 表示此路由在此 EIGRP 自治系统 (AS) 内发起。如果路由被重分配到此 EIGRP AS 中,此字段将指示该路由是外部路由。

  • 向量权值显示EIGRP用于计算网络成本的个别权值。EIGRP 不在整个网络中传播总成本信息;而是传播矢量度量,并且每个路由器分别计算成本和报告距离。

    • Minimum bandwidth is 10000 Kbit 显示到此网络的路径上的最低带宽。

    • Total delay is 2000 microseconds 显示到此网络的路径上的延迟总和。

    • Reliability is 0/255 显示可靠性因子。此数字是动态计算的,但默认情况下并不在度量计算中使用。

    • Load is 1/255 指示链路正在传输的负载量。此数字是动态计算的,但在 EIGRP 计算此路径的使用成本时,默认情况下不使用此数字。

    • Minimum MTU is 1500 此字段不在度量计算中使用。

    • 跳数为2,这不在度量计算中使用,但确实可以限制 EIGRP AS 的最大大小。默认情况下,EIGRP 将接受的最大跳数是 100,但可以使用度量最大跳数将最大值配置为 220。

如果路由是外部路由,则将包括以下信息。此表后面提供了每个输出字段的说明。

外部路由

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp24.gif

配置说明

  • 始发路由器显示,这台路由器将该路由注入到EIGRP AS。

  • External AS 显示此路由来自的自治系统(如果有一个)。

  • External Protocol 显示此路由来自的协议(如果有一个)。

  • external metric 显示外部协议中的内部度量。

  • Administrator Tag 可以通过 set tag 和 match tag 命令,使用路由映射来设置和/或过滤。

show ip eigrp topology [active|待定|zero-successors]

输出格式与 show ip eigrp topology 一样,但它还显示拓扑表的某个部分。

show ip eigrp topology all-links

输出格式与 show ip eigrp topology 一样,但它还显示拓扑表中的所有链路,而不仅是可行后继路由。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 16406