多协议标签交换 (MPLS) : MPLS

使用 OSPF 配置基本的 MPLS

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文档说明如何配置基本的多协议标签交换 (MPLS) 网络。参考的配置示例和TechNotes在MPLS支持页面关于如何配置高级主题的更多信息例如VPN或流量工程(TE)。

先决条件

要求

Cisco 建议您熟悉 MPLS 的基本操作。有关 MPLS 的概述,请参阅多协议标签交换 (MPLS) 概述

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IOSï ¿  ½软件版本12.2(28)

  • Cisco 3600 路由器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

机制

MPLS 网络通常是由支持 MPLS 的路由器(称为标签交换路由器 (LSR))组成的骨干网络。一般情况下,该网络包括一个核心 LSR,以及一个将标签应用于数据包的边缘 LSR。

下面是一个 MPLS 网络的设置机制:

  1. 另外LSRs的路由表计算与内部网关路由协议(IGP)。如果计划部署MPLS TE,一个链路状态协议,例如开放最短路径优先(OSPF)或中间系统对中间系统(IS-IS),要求。

  2. 标签分发协议 (LDP) 通告路由与标签之间的绑定。根据路由表检查这些绑定。如果从 LDP 获知的路由(前缀/掩码和下一跳)与从路由表中 IGP 获知的路由匹配,则会在 LSR 上转发信息库的标签 (LFIB) 中创建一个条目。

LSR 采用以下转发机制:

  1. 当某个边缘 LSR 收到无标签数据包时,将立即检查 Cisco 快速转发表,如果需要,会为数据包附加标签。此 LSR 称为入口 LSR。

  2. 当某个核心 LSR 的入站接口收到有标签的数据包时,LFIB 将提供出站接口和与出站数据包关联的新标签。

  3. 最后一个 LSR 之前的路由器(倒数第二跳)将弹出标签并传输不带标签的数据包。最后一跳称为出口 LSR。

下图说明了这种网络设置:

/image/gif/paws/13736/1b.gif

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找有关本文档中所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/13736/1a.gif

快速配置指南

使用此过程作为快速配置指南。

  1. 照常建立您的网络。MPLS 需要一个标准 IP 连接用于建立转发库。

  2. 确保路由协议(OSPF 或 IS-IS)工作正常。这些命令在下一部分的配置中显示为斜体。

  3. 在一般配置模式下启用 ip cef,如果可用,也可使用 ip cef distributed 以提高性能。此命令在下一部分的配置中显示为粗体。

  4. 在一般配置模式下为每个接口启用 mpls ip(在早期 Cisco IOS 软件版本中为 tag-switching ip),这在下一部分的配置中显示为粗体。在某些 Cisco IOS 软件版本中,即使使用了 mpls ip 命令,show running 输出仍会将命令显示为 tag-switching ip,如下一部分的配置所示。

    注意: LSR 必须有采用 32 位地址掩码的(可用)环回接口,而且必须能够通过 IP 路由表到达这些接口。

配置

本文档使用以下配置:

Pomerol

!
version 12.2

!
hostname Pomerol
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.21 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.6 255.255.255.252
 tag-switching ip
!
interface Serial4/0
 ip address 10.1.1.9 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
! 
ip classless
!
end

Pulligny

!
version 12.2
!
hostname Pulligny
!
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.2 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.10 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pauillac
!
version 12.2
!
hostname Pauillac
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.13 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.17 255.255.255.252
 tag-switching ip
!
interface Serial4/0
 ip address 10.1.1.1 255.255.255.252
 tag-switching ip
!
interface Serial5/0
 ip address 10.1.1.5 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

佩斯卡拉
!
version 12.2
!
hostname Pescara
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.14 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pesaro
!
version 12.2
!
hostname Pesaro
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.22 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

佩鲁贾
!
version 12.2
!
hostname Perugia
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.5 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.18 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

验证

本部分提供的信息可帮助您确认您的配置是否可正常运行。

使用 IS-IS 配置示例配置基本 MPLS 中使用的命令也适用。

为说明此配置示例,请查看 Pomerol LSR 上的某个特定目标,例如 10.10.10.4

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show ip route — 用于在 IP 路由表中检查此目标的 IP 路由:

    Pomerol#show ip route 10.10.10.4
    Routing entry for 10.10.10.4/32
      Known via "ospf 10", distance 110, metric 129, type intra area
      Last update from 10.1.1.5 on Serial3/0, 17:29:23 ago
      Routing Descriptor Blocks:
      * 10.1.1.5, from 10.10.10.4, 17:29:23 ago, via Serial3/0
          Route metric is 129, traffic share count is 1
    
  • show mpls forwarding-table — 用于检查 MPLS 转发表,该表用于标签交换,与用于标准 IP 路由的 IP 路由表等效。它包含数据包的入站和出站标签以及说明。

    Pomerol#show mpls forwarding-table 
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    16     Pop tag     10.1.1.12/30      636        Se3/0      point2point
    17     Pop tag     10.10.10.1/32     0          Se3/0      point2point
    18     21          10.10.10.4/32     0          Se3/0      point2point
    19     Pop tag     10.1.1.0/30       0          Se4/0      point2point
           Pop tag     10.1.1.0/30       0          Se3/0      point2point
    20     Pop tag     10.10.10.6/32     612        Se2/0      point2point
    21     Pop tag     10.1.1.16/30      0          Se3/0      point2point
    22     16          10.10.10.5/32     0          Se3/0      point2point
    23     Pop tag     10.10.10.2/32     0          Se4/0      point2point
  • show mpls forwarding-table detail — 用于查看 MPLS 转发表的详细信息:

    Pomerol#show mpls forwarding-table 10.10.10.4 32 detail
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    18     21          10.10.10.4/32     0          Se3/0      point2point
            MAC/Encaps=4/8, MRU=1500, Tag Stack{21}
            0F008847 00015000
            No output feature configured
        Per-packet load-sharing
  • show mpls ldp bindingsshow tag-switching tdp bindings(根据您使用的 Cisco IOS 软件版本进行选择)— 用于查看与特定目标关联的标签绑定。可以查看本地绑定及远程绑定。

    Pomerol#show tag-switching tdp bindings 10.10.10.4 32
      tib entry: 10.10.10.4/32, rev 14
            local binding:  tag: 18
            remote binding: tsr: 10.10.10.1:0, tag: 21
            remote binding: tsr: 10.10.10.2:0, tag: 23
            remote binding: tsr: 10.10.10.6:612, tag: 20 
    
    

    请注意,将在每个 LSR 为每个转发类建立标签,即使它们未处于首选(最短)路径中也是如此。在这种情况下,发往 10.10.10.4/32 的数据包可经过 10.10.10.1(采用标签 21),也可经过 10.10.10.2(采用标签 23)。LSR 选择第一种解决方案,因为它是最短路径。此决定是根据标准 IP 路由表做出的,在这种情况下该表用 OSPF 构建。

  • show ip cef detail — 用于检查 Cisco 快速转发是否工作正常,以及标记是否交换正确:

    Pomerol#show ip cef 10.10.10.4 detail
    10.10.10.4/32, version 37, cached adjacency to Serial3/0
    0 packets, 0 bytes
      tag information set
        local tag: 18
        fast tag rewrite with Se3/0, point2point, tags imposed: {21}
      via 10.1.1.5, Serial3/0, 0 dependencies
        next hop 10.1.1.5, Serial3/0
        valid cached adjacency
        tag rewrite with Se3/0, point2point, tags imposed: {21}
    

故障排除

有关如何对 MPLS 进行故障排除的信息,请参阅 MPLS 故障排除


相关信息


Document ID: 13736