多协议标签交换 (MPLS) : MPLS

使用 OSPF 的 MPLS 基本流量工程配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文档提供了使用帧中继和开放最短路径优先 (OSPF) 在现有的多协议标签交换 (MPLS) 网络上实现流量工程 (TE) 时所需的示例配置。我们的示例实现两个动态隧道(由入口标签交换路由器 [LSR] 自动设置)和两条使用明确路径的隧道。

TE 是一个通称,是指使用不同的技术优化指定骨干容量和拓扑的利用率。

MPLS TE 提供了一种方法,可将 TE 功能(如用于类似 ATM 的第 2 层协议的功能)整合到第 3 层协议 (IP) 中。MPLS TE 利用对现有协议(中间系统到中间系统 (IS-IS)、资源预留协议 (RSVP)、OSPF)的扩展计算并建立根据网络约束设置的单向隧道。通信流根据其目的地不同,被映射到不同的隧道上。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IOS�软件版本12.0(11)S和12.1(3a)T

  • Cisco 3600 路由器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

功能组件

下表介绍此配置示例的功能组件:

组件 说明
IP 隧道接口 第 2 层:MPLS隧道接口是标签交换路径(LSP)的题头。它配置有一组资源需求,例如带宽和优先级。第 3 层:LSP 隧道接口是指向隧道目标的单向虚拟链路的前端。
具有 TE 扩展的 RSVP RSVP 用于根据计算出的路径使用 PATH 和 RSVP 预留 (RESV) 消息建立和维护 LSP 隧道。RSVP 协议规范已扩展,使 RESV 消息也分发标签信息。
连接状态的内部网关路由协议(IGP) [IS-IS or OSPF with TE extension] 用于对来自链路管理模块的拓扑和资源信息进行泛洪。IS-IS用途新建的类型长度值(TLV);OSPF 使用类型 10 链路状态通告(也称为不透明 LSA)。
MPLS TE 路径计算模块 仅在 LSP 前端运行,用于使用来自链路状态数据库的信息确定路径。
MPLS TE 链路管理模块 在每个 LSP 跳,此模块对 RSVP 信令消息执行链路呼叫准入,并对要由 OSPF 或 IS-IS 泛洪的拓扑和资源信息进行登记。
标签交换转发 基于标签的基本 MPLS 转发机制。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/13731/mplsteisis1.gif

快速配置指南

可以采用下列步骤执行快速配置。有关更多详细信息,请参阅 MPLS 流量工程和增强功能

  1. 采用常见配置设置您的网络。(在这种情况下,我们使用了帧中继。)

    注意: 必须使用 32 位 IP 掩码设置环回接口。此地址将用于按照路由协议设置 MPLS 网络和 TE。此环回地址必须是可通过全局路由表到达的地址。

  2. 为 MPLS 网络设置路由协议。它必须是链路状态协议(IS-IS 或 OSPF)。在路由协议配置模式下,输入以下命令:

    • 对于 IS-IS:

      metric-style [wide | both]
      mpls traffic-eng router-id LoopbackN 
      mpls traffic-eng [level-1 | level-2 |]
      
    • 对于 OSPF:

      mpls traffic-eng area X 
      mpls traffic-eng router-id LoopbackN (must have a 255.255.255.255 mask)
  3. 启用 MPLS TE。在一般配置模式下输入 ip cef(如果 ip cef distributed 可用,也可输入以提高性能)。为每个相关接口启用 MPLS (tag-switching ip)。输入 mpls traffic-engineering tunnel 以启用 MPLS TE,以及零带宽 TE 隧道的 RSVP。

  4. 在非零带宽隧道的每个相关接口通过输入 ip rsvp bandwidth XXX 启用 RSVP。

  5. 设置要用于 TE 的隧道。针对 MPLS TE 隧道可以配置许多选项,但 tunnel mode mpls traffic-eng 命令是必需的。tunnel mpls traffic-eng autoroute announce 命令按照路由协议宣布隧道的存在。

    注意: 不要忘记为隧道接口的 IP 地址使用 ip unnumbered loopbackN

    此配置显示从 Pescara 路由器到 Pesaro 路由器的两个具有不同带宽(和优先级)的动态隧道(Pescara_t1 和 Pescara_t3),以及从 Pesaro 到 Pescara 的两个使用明确路径的隧道(Pesaro_t158 和 Pesaro_t159)。

配置文件

本文档使用如下所示的配置。仅包括配置文件的相关部分。用于启用 MPLS 的命令显示为蓝色文本;特定于 TE(包括 RSVP)的命令显示为粗体文本

Pesaro
Current configuration:

!

version 12.1

!

hostname Pesaro

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.6 255.255.255.255

!

interface Tunnel158

 ip unnumbered Loopback0

 tunnel destination 10.10.10.4

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 2 2

 tunnel mpls traffic-eng bandwidth 158

 tunnel mpls traffic-eng path-option 1 explicit name low

!

interface Tunnel159

 ip unnumbered Loopback0

 tunnel destination 10.10.10.4

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 4 4

 tunnel mpls traffic-eng bandwidth 159

 tunnel mpls traffic-eng path-option 1 explicit name straight

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

 bandwidth 512

 ip address 10.1.1.22 255.255.255.252

 
tag-switching ip


 mpls traffic-eng tunnels 

 frame-relay interface-dlci 603   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

ip explicit-path name low enable

 next-address 10.1.1.21 

 next-address 10.1.1.10 

 next-address 10.1.1.1 

 next-address 10.1.1.14 

!

ip explicit-path name straight enable

 next-address 10.1.1.21 

 next-address 10.1.1.5 

 next-address 10.1.1.14 

!

end

佩斯卡拉
Current configuration:

!

version 12.0

!

hostname Pescara

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.4 255.255.255.255

!

interface Tunnel1

 ip unnumbered Loopback0

 no ip directed-broadcast

 tunnel destination 10.10.10.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 5 5

 tunnel mpls traffic-eng bandwidth 25

 tunnel mpls traffic-eng path-option 2 dynamic

!

interface Tunnel3

 ip unnumbered Loopback0

 no ip directed-broadcast

 tunnel destination 10.10.10.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 6 6

 tunnel mpls traffic-eng bandwidth  69

 tunnel mpls traffic-eng path-option 1 dynamic

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.14 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 401   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

end

Pomerol
Current configuration:



version 12.0

!

hostname Pomerol

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.3 255.255.255.255

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.6 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 301   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.2 point-to-point

 bandwidth 512

 ip address 10.1.1.9 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 302   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.3 point-to-point

 bandwidth 512

 ip address 10.1.1.21 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 306   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Pulligny
Current configuration:

!

version 12.1

!

hostname Pulligny

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.2 255.255.255.255

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.2 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 201   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.2 point-to-point

 bandwidth 512

 ip address 10.1.1.10 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 203   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Pauillac
!

version 12.1

!

hostname pauillac

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.1 255.255.255.255

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

 bandwidth 512

 ip address 10.1.1.1 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 102   

 ip rsvp bandwidth 512 512

!

interface Serial0/0.2 point-to-point

 bandwidth 512

 ip address 10.1.1.5 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 103   

 ip rsvp bandwidth 512 512

!

interface Serial0/0.3 point-to-point

 bandwidth 512

 ip address 10.1.1.13 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 104   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

常规显示命令在使用 IS-IS 配置 MPLS 基本流量工程中举例说明。下面是特定于具有 OSPF 的 MPLS TE 的命令,说明如下:

  • show ip ospf mpls traffic-eng link

  • show ip ospf database opaque-area

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

show 命令输出示例

可以使用 show ip ospf mpls traffic-eng link 命令查看 OSPF 将在某个指定路由器通告哪些内容。RSVP 特性在下面以粗体显示,表示正在通告和使用中的可保留的带宽。您可以查看 Pescara_t1(优先级为 5)和 Pescara_t3(优先级为 6)使用的带宽。

Pesaro# show ip ospf mpls traffic-eng link 

  OSPF Router with ID (10.10.10.61) (Process ID 9)

  Area 9 has 1 MPLS TE links. Area instance is 3.

  Links in hash bucket 48.
    Link is associated with fragment 0. Link instance is 3 
      Link connected to Point-to-Point network
      Link ID : 10.10.10.3 Pomerol
      Interface Address : 10.1.1.22
      Neighbor Address : 10.1.1.21
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 64000
      Number of Priority : 8
      Priority 0 : 64000       Priority 1 : 64000     
      Priority 2 : 64000       Priority 3 : 64000     
      Priority 4 : 64000       Priority 5 : 32000     
      Priority 6 : 24000       Priority 7 : 24000   
      Affinity Bit : 0x0

可以将 show ip ospf database 命令限制为类型 10 LSA,并显示 MPLS TE 进程用于计算动态隧道(在本例中是 Pescara_t1 和 Pescara_t3)的最佳路由(对于 TE)的数据库。以下部分输出显示了此内容:

Pesaro# show ip ospf database opaque-area 

  OSPF Router with ID (10.10.10.61) (Process ID 9)

  Type-10 Opaque Link Area Link States (Area 9)

  LS age: 397
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.1
  LS Seq Number: 80000003
  Checksum: 0x12C9
  Length: 132
  Fragment number : 0

    MPLS TE router ID : 10.10.10.1 Pauillac

    Link connected to Point-to-Point network
      Link ID : 10.10.10.3
      Interface Address : 10.1.1.5
      Neighbor Address : 10.1.1.6
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 48125
      Number of Priority : 8
      Priority 0 : 48125       Priority 1 : 48125     
      Priority 2 : 48125       Priority 3 : 48125     
      Priority 4 : 48125       Priority 5 : 16125     
      Priority 6 : 8125        Priority 7 : 8125      
      Affinity Bit : 0x0

    Number of Links : 1
  LS age: 339
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.2
  LS Seq Number: 80000001
  Checksum: 0x80A7
  Length: 132
  Fragment number : 0

    MPLS TE router ID : 10.10.10.2 Pulligny

    Link connected to Point-to-Point network
      Link ID : 10.10.10.1
      Interface Address : 10.1.1.2
      Neighbor Address : 10.1.1.1
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 64000
      Number of Priority : 8
      Priority 0 : 64000       Priority 1 : 64000     
      Priority 2 : 64000       Priority 3 : 64000     
      Priority 4 : 64000       Priority 5 : 64000     
      Priority 6 : 64000       Priority 7 : 64000     
      Affinity Bit : 0x0

    Number of Links : 1

 LS age: 249
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.3
  LS Seq Number: 80000004
  Checksum: 0x3DDC
  Length: 132
  Fragment number : 0

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 13731