拨号和接入 : 异步连接

如何配置终端/通讯服务器

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 7 月 23 日) | 反馈


目录


简介

终端服务器或称通讯服务器,通常进行多个设备的带外访问。终端服务器是带有多个与其他串行设备(例如,调制解调器,或者路由器或交换机上的控制台端口)连接的低速异步端口的路由器。

借助终端服务器可以通过一个点访问许多设备的控制台端口。使用终端服务器时,不需要为每个设备在辅助端口上配置备份方案(如调制解调器)。也可以在终端服务器的辅助端口上配置单个调制解调器,以在发生网络连接故障时为其他设备提供拨号服务。

本文档说明如何配置终端服务器以通过反向 Telnet 仅访问其他路由器上的控制台端口。反向 Telnet 允许您在从其建立 Telnet 连接的同一设备上(但通过不同的接口)与外部建立 Telnet 连接。有关反向远程登录的详情请参阅在调制解调器上建立反向 Telnet 会话

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

缚住

Cisco 2509 - 2512 系列路由器使用 68 针连接器和分支电缆。该线缆 (CAB-OCTAL-ASYNC) 为每个 68 针插头提供 8 个 RJ-45 反转电缆异步端口。每个 RJ-45 反转电缆异步端口可与一部设备的控制台端口连接。2511 路由器最多允许远程访问 16 个设备。此外,2600 和 3600 系列路由器可采用 NM-16A 或 NM-32A 高密度异步网络模块提供同样功能。有关布线的详细信息,请参阅让我们连接:串行电缆指南控制台和 AUX 端口的布线指南

注意: 从68 Pin连接器的异步端口是数据终端设备(DTE)设备。DTE 到 DTE 需要铜线(无调制解调器)连接;DTE 与数据电路终端设备 (DCE) 需要直通线缆连接。CAB-OCTAL-ASYNC 电缆是反转电缆。因此,可以将每根电缆直接连接到带 RJ-45 接口的设备的控制台端口。但是,如果要连接的设备的控制台端口是 25 针接口 (DCE),则必须使用标有“调制解调器”的 RJ-45 转 25 针适配器(反转“铜线”顺序)才能完成连接。

此表显示了 Cisco 路由器和交换机上的控制台和辅助端口的端口类型:

接口类型 DB25 接口 RJ-45 接口
控制台 DCE DTE
AUX DTE DTE

设计策略

配置终端服务器,以便可以从任何位置访问终端服务器。为了使终端服务器可访问,请分配一个注册的公共 Internet 地址,并将服务器放置在防火墙外部。这样,防火墙问题不会中断您的连接。您可以始终保持与终端服务器的连接以及对所连接设备的访问。如果您担心安全性,可以将访问列表配置为只允许从特定地址访问终端服务器。对于更多强大的安全解决方案,您能例如也配置基于服务器的验证、授权和核算(AAA), RADIUS或者TACACS+。关于AAA的更多信息,参考验证、授权和统计(AAA)

您可以在终端服务器的备用端口配置一个调制解调器,一旦原来的连接(通过 Internet)中断,就可以使用备用的拨号连接。使用这样的调制解调器时,不需要为每个设备配置一个拨号备份。终端服务器通过其异步端口连接到其他设备的控制台端口。有关如何将调制解调器连接到 AUX 端口的详细信息,请参阅调制解调器-路由器连接指南

请使用 ip default gateway 语句,并且指向 Internet 中的下一跳路由器。使用此命令可以通过 Internet 与终端服务器连接,即使未启用路由也是如此。例如,在断电后由于错误重启导致终端服务器处于 ROM 监控器 (ROMMON) 模式时,仍然可以保持连接。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

http://www.cisco.com/c/dam/en/us/support/docs/dial-access/asynchronous-connections/5466-Com-Srv.gif

配置

本文档使用以下配置:

  • Cisco 2511

Cisco 2511
aus-comm-server#show running-config
!
version 12.0

service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname aus-comm-server
!
enable secret  <deleted>
!
username cisco password <deleted>
!
ip subnet-zero
ip domain-list cisco.com
no ip domain-lookup

ip host 3600-3 2014 172.21.1.1

!--- The host 3600-3 is connected to port 14 of the comm server.
!--- Ensure that the IP address is that of an interface on the comm server.

ip host 3600-2 2013 172.21.1.1
ip host 5200-1 2010 172.21.1.1
ip host 2600-1 2008 172.21.1.1
ip host 2509-1 2007 172.21.1.1
ip host 4500-1 2015 172.21.1.1
ip host 3600-1 2012 172.21.1.1
ip host 2511-2 2002 172.21.1.1
ip host 2511-rj 2003 172.21.1.1
ip host 2511-1 2001 172.21.1.1
ip host 5200-2 2011 172.21.1.1
ip host 2520-1 2004 172.21.1.1
ip host 2520-2 2005 172.21.1.1
ip host 2600-2 2009 172.21.1.1
ip host 2513-1 2006 172.21.1.1
ip host pix-1 2016 172.21.1.1
!
!
process-max-time 200
!
interface Loopback1
 ip address 172.21.1.1 255.0.0.0

!--- This address is used in the IP host commands.
!--- Work with loopback interfaces, which are virtual and always available.

 no ip directed-broadcast
!
interface Ethernet0
 ip address 171.55.31.5 255.255.255.192

!---  Use a public IP address to ensure connectivity. 

No ip directed-broadcast
 no ip mroute-cache
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
ip default-gateway 171.55.31.1

!--- This is the default gateway when routing is disabled.
!--- For example, if the router is in boot ROM mode.

ip classless
ip route 0.0.0.0 0.0.0.0 171.55.31.1

!--- Set the default route for the external network.

no ip http server
!
line con 0
 transport input all
 line 1 16
 session-timeout 20

!--- The session times out after 20 minutes of inactivity. 

no exec

!--- Unwanted signals from the attached device do not launch. 
!--- An EXEC session ensures that the line never becomes unavailable 
!--- due to a rogue EXEC process.

 exec-timeout 0 0

!--- This disables exec timeout transport input all.
!--- Allow all protocols to use the line.
!--- Configure lines 1 - 16 with at least transport input Telnet.

line aux 0

!--- Auxiliary port can provide dial backup to the network.
!--- Note: This configuration does not implement modem on AUX port modem InOut. 
!--- Allow auxiliary port to support dialout and dialin connections.

 transport preferred telnet
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 exec-timeout 60 0
 password <deleted> 
login
!
end

注意:如果使用 3600 作为接入服务器,请参阅 Cisco 3600 系列路由器中的异步线路如何编号以了解线路编号详细信息。

命令汇总

ip host - 使用此命令可以在主机缓存中定义静态主机的名称到地址映射。要删除名称到地址映射,请使用此命令的 no 形式。

  • ip host name [tcp-port-number] address1 [address2...address8]

    • name - 此字段指示主机的名称。name 字段不需要与您要连接到的路由器的实际名称匹配。但是,请确保输入您将希望在反向 Telnet 中使用的名称。使用此命令和 name 字段时,不必知道远程设备的实际端口号。

    • tcp-port-number - 此字段表示在将定义的主机名与 EXEC connect 或 telnet 命令一起使用时要连接到的 TCP 端口号。在我们的示例配置中,我们使用的是反向 Telnet,因此端口号必须是 2000 以上的线路编号。

    • address1 - 此字段表示一个关联的 IP 地址。在我们的示例配置中,我们使用的是环回 IP 地址。

transport input - 使用此命令可定义在连接到路由器的特定线路时要使用的协议。

  • transport input {all|lat|mop|nasi|无|填充位|rlogin|telnet|v120}

    • 所有选择所有协议。

    • none - None 禁止在线路上选择任何协议。在这种情况下,端口对于传入连接变得不可用。

    注意: 在我们的配置示例中,异步线路使用 transport input telnet 命令的最低配置。因此您可以在异步线路上建立与设备的 Telnet 连接。

telnet - 使用此 EXEC 命令可登录到支持 Telnet 的主机。

  • telnet host [port] [keyword]

    • host 此字段指示主机名或 IP 地址。主机可以是在 ip host 命令中定义的 name 字段之一。

    • port - 此字段指示一个十进制的 TCP 端口号。主机上的 Telnet 路由器端口(十进制 23)是默认的十进制 TCP 端口号。对于反向 Telnet,端口号必须是 2000 以上的线路编号。在我们的配置中,线路编号的范围在 1 到 16 之间。使用 show line EXEC 命令可以查看可用的线路。

在活动会话之间切换

要在活动会话之间切换,请完成以下步骤:

  1. 使用转义序列 Ctrl-Shift-6,然后按 x 退出当前会话。

  2. 使用 show sessions 命令显示所有开放的连接。

    aus-comm-server#show sessions 
    Conn Host      Address         Byte Idle  Conn Name
       1 2511-1    171.69.163.26   0     0     2511-1
       2 2511-2    171.69.163.26   0     0     2511-2
     * 3 2511-3    171.69.163.26   0     0     2511-3

    注意: 星号 (*) 指示当前终端会话。

  3. 输入任务 (conn) 号码,连接到对应的设备。例如,要连接到 2511-1,只需键入连接号 1 即可。但是,如果按下回车键,则会连接到当前的终端会话,在本例中为路由器 2511-3。

终止活动会话

要终止特定的 Telnet 会话,请完成以下步骤:

  1. 使用转义序列 Ctrl-Shift-6,然后按 x 退出当前 Telnet 会话。

    注意: 确保您能可靠地发出转义序列以暂停 Telnet 会话。某些终端仿真器包无法发送正确的序列,请按 Ctrl-Shift-6,然后按 x。

  2. 发出 show sessions 命令显示所有开放的连接。

  3. 发出 disconnect [connection] 命令断开所需的会话。

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show ip interface brief - 指示您用于 Telnet 会话的接口是否已开启。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除步骤

请按照以下说明排除配置故障。

如果使用 ip host 命令中配置的名称无法连接到您选择的路由器,请检查:

  1. 检查端口地址的配置是否正确。

  2. 验证用于反向 Telnet 的地址(接口)是否已开启。show ip interface brief 命令的输出提供此信息。Cisco 建议您使用环回,因为它们始终处于开启状态。

  3. 确保布线类型正确。例如,您不能使用交叉电缆延伸长度。有关详细信息,请参阅布线部分。

  4. 建立与 IP 地址端口的 Telnet 连接以测试直接连接。您必须从外部设备和终端服务器建立 Telnet 连接。例如,telnet 172.21.1.1 2003

  5. 确保在目标设备的线路下使用 transport input telnet 命令。目标设备是连接到终端服务器的设备。

  6. 使用 PC/哑终端直接连接到目标路由器的控制台。目标路由器是连接到终端服务器的设备。此步骤可帮助您识别是否存在端口问题。

  7. 如果断开连接,请检查超时设置。您可以删除或调整超时设置。

    注意: 如果遇到身份验证失败,请记住,终端服务器执行第一次身份验证(如已配置),而您尝试连接到的设备执行第二次身份验证(如已配置)。请验证是否在终端服务器和连接设备上都正确配置了 AAA。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 5466