Commutateurs : Commutateurs Cisco Nexus, s�rie�7000

Exemple de configuration du commutateur RSPAN de gamme de Nexus 7000

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer une session de l'analyseur de port commutée par distant (RSPAN) sur la gamme d'un Nexus 7000 commutent que surveille le trafic entre les ports Ethernet sur deux Commutateurs différents de gamme de Nexus 7000.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Ayez la connaissance de base de la configuration sur des Commutateurs de gamme de Nexus 7000

  • Ayez la connaissance de base de l'analyseur de port commuté par distant (RSPAN)

Composants utilisés

Les informations dans ce document sont basées sur des périphériques de la gamme NX-OS de Nexus 7000.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Vous pouvez employer le Fonction Switched Port Analyzer (SPAN) afin d'analyser le trafic réseau qui traverse des ports ou des VLAN du commutateur, qui envoient une copie du trafic à une destination port où l'analyseur de réseau se connecte au commutateur.

Afin d'étendre l'ENVERGURE, RSPAN active la télésurveillance des plusieurs commutateurs à travers votre réseau. Le commutateur de gamme de Nexus 7000 est limité dans ce qu'il peut faire avec RSPAN. Un RSPAN VLAN ne peut pas être utilisé comme destination d'ENVERGURE. Par conséquent, le commutateur de Nexus 7000 peut seulement utiliser RSPAN comme transit VLAN ou source VLAN et tirer des données du RSPAN VLAN. Vous ne pouvez placer rien dans le RSPAN VLAN du commutateur de Nexus 7000.

Configurez

Cet exemple de configuration utilise des ports de source sur deux Commutateurs différents de gamme de Nexus 7000 et une destination port sur un commutateur de Nexus 7000 où l'analyseur de réseau s'est connecté. Des Ethernets distincts 1/1 lien sont installés entre les deux périphériques : un lien comme destination d'envergure et l'autre joignent comme accès au RSPAN VLAN.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/switches/nexus-7000-series-switches/113438-rspan-nexus-7000-01.jpg

Cet exemple utilise les ports répertoriés dans cette table :

Périphérique Port de source Destination port
Nexus 1 Ethernets 2/15 et 2/16 Ethernets 1/1
Nexus 2 Ethernets 1/1, 2/26 à 2/28 Ethernets 2/37 2/40

Du commutateur du Nexus 1, le trafic d'ENVERGURE de la source est porté à la destination port et copié sur le RSPAN VLAN. Le trafic est alors expédié au-dessus du lien au commutateur du Nexus 2 sur les Ethernets 1/1 interface. Ensuite, le trafic RSPAN VLAN est envoyé à la destination port où le périphérique, tel qu'un périphérique SwitchProbe ou tout autre sonde de surveillance à distance (RMON) ou périphérique de sécurité, peut recevoir et analyser les paquets.

Configurations

Ce document utilise les configurations suivantes :

Nexus 1
Nexus1#configure terminal


!--- Configure the interface VLAN 15 as RSPAN VLAN.

Nexus1(config)#vlan 15 
Nexus1(config-vlan)#remote-span
Nexus1(config-vlan)#exit



!--- Configure the switchport interface as a SPAN destination.

Nexus1(config)#interface ethernet 1/1
Nexus1(config-if)#switchport monitor
Nexus1(config-if)#no shutdown
Nexus1(config-if)#exit



!--- Configure the SPAN session.

Nexus1(config)#monitor session 1


!---Configure the source port.

Nexus1(config-monitor)#source interface ethernet 2/15-16


!--- Configure the destination port.

Nexus1(config-monitor)#destination interface ethernet 1/1


!--- Enable the SPAN session (by default the session is in shutdown state).

Nexus1(config-monitor)#no shut
Nexus1(config-monitor)#exit

Nexus 2
Nexus2#configure terminal


!--- Configuration of interface VLAN 15 as RSPAN VLAN.

Nexus2(config)#vlan 15 
Nexus2(config-vlan)#remote-span
Nexus2(config-vlan)#exit


!--- Configure the switchport interface to access in RSPAN VLAN.

Nexus2(config)#interface ethernet 1/1
Nexus2(config-if)#switchport mode access
Nexus2(config-if)#switchport access vlan 15
Nexus2(config-if)#no shutdown
Nexus2(config-if)#exit



!--- Configure the switchport interfaces as a SPAN destination.

Nexus2(config)#interface ethernet 2/37-40
Nexus2(config-if)#switchport monitor
Nexus2(config-if)#exit



!--- Configure the SPAN session.

Nexus2(config)#monitor session 1


!--- Configure the source port.

Nexus2(config-monitor)#source interface ethernet 2/26-28
Nexus2(config-monitor)#source vlan 15


!--- Configure the destination port.

Nexus2(config-monitor)#destination interface ethernet 2/37-40


!--- Enable the SPAN session (by default the session is in shutdown state).

Nexus2(config-monitor)#no shut
Nexus2(config-monitor)#exit

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Voici une partie des commandes d'ENVERGURE et RSPAN de vérification :

Nexus 1 :

  • Employez la commande de show monitor afin d'afficher le statut des sessions RSPAN.

    Nexus1# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    1        up           The session is up
  • Employez la commande de show monitor session [session_number de session] afin d'afficher la configuration de session ERSPAN.

    Nexus1# show monitor session 1
       session 1
    ---------------
    type              : local
    state             : up
    source intf       :
        rx            : Eth1/15       Eth1/16
        tx            : Eth1/15       Eth1/16
        both          : Eth1/15       Eth1/16
    source VLANs      :
        rx            :
        tx            :
        both          :
    filter VLANs      : filter not specified
    destination ports : Eth1/1
    
    Legend: f = forwarding enabled, l = learning enabled
  • Utilisez le show monitor session toute la commande afin d'afficher toute la configuration de sessions ERSPAN dans le périphérique.

Nexus 2 :

  • Employez la commande de show monitor afin d'afficher le statut des sessions ERSPAN.

    Nexus2# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    1        up           The session is up
  • Employez la commande de show monitor session [session_number de session] afin d'afficher la configuration de session ERSPAN.

    Nexus2# show monitor session 1
       session 1
    ---------------
    type              : local
    state             : up
    source intf       :
        rx            : Eth1/21       Eth1/22       Eth1/23
        tx            : Eth1/21       Eth1/22       Eth1/23
        both          : Eth1/21       Eth1/22       Eth1/23
    source VLANs      :
        rx            : 15
        tx            : 15
        both          : 15
    filter VLANs      : filter not specified
    destination ports : Eth1/27       Eth1/28       Eth1/29       Eth1/30
    
    Legend: f = forwarding enabled, l = learning enabled

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 113438