IP : Protocole BGP (Border Gateway Protocol)

Configurez l'attribut de mesure AIGP pour le BGP

18 juin 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (21 avril 2016) | Commentaires

Introduction

Ce document décrit comment configurer l'attribut de mesure accumulé de l'Interior Gateway Protocol (AIGP) qui est porté par Protocole BGP (Border Gateway Protocol) dans le Cisco IOS®.

Contribué par Luc De Ghein, ingénieur TAC Cisco.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Informations générales

Cette section fournit un aperçu de l'attribut de mesure AIGP et de quelques importantes considérations en vue de son utilisation.

Aperçu d'attribut de mesure AIGP

Les sociétés pourraient désirer implémenter une conception de réseaux où le réseau est séparé avec de plusieurs protocoles d'Interior Gateway (IGP), chacun avec un Autonomous System BGP. Ceci est utilisé pour des raisons d'évolutivité, où le réseau devient trop grand pour un IGP. Le BGP aide à mesurer quand il porte certaines des artères qui autrement seraient portées par l'IGP. La solution qui utilise AIGP est destinée pour des réseaux avec différents Autonomous System BGP au-dessous d'un contrôle administratif.

Voici un exemple :

Le service de bout en bout est la Commutation multiprotocole par étiquette (MPLS) VPN. Quand il y a un grand nombre de Routeurs de Provider Edge (PE) dans le réseau, l'IGP doit porter trop d'artères. La solution est de faire porter le BGP les interfaces de bouclage des Routeurs de PE. La solution qui est utilisée afin de s'assurer que le chemin commuté par mpls label (LSP) n'est pas de bout en bout interrompu est d'utiliser l'ipv4 + l'étiquette BGP. Ceci signifie que RFC 3107 est utilisé entre les Routeurs de PE et les Routeurs de cadre, qui connecte les différents domaines d'IGP.

La question avec cette solution est que les Routeurs de cadre ou les Routeurs de PE peuvent plus ne prendre une décision au sujet du meilleur chemin, basé sur le de bout en bout métrique le plus court, parce qu'il n'y a plus un IGP qui fonctionne dans tout le réseau entier. La solution à cette question est le nouvel attribut BGP, appelé l'attribut de mesure accumulé d'IGP ou attribut de mesure AIGP. Cet attribut non-transitif BGP porte la mesure accumulée pour les chemins de sorte que les speakers BGP reçoivent la connaissance de la mesure de bout en bout pour ces chemins.

Les speakers BGP doivent ajouter l'artère à la mesure de prochain-saut à la valeur courante dans l'attribut de mesure AIGP avant que l'artère soit expédiée.

Remarque: La comparaison des chemins pour une artère est exécutée juste après la comparaison de la préférence locale. Référez-vous au document Cisco d'algorithme de sélection du meilleur chemin BGP pour plus de détails au sujet de l'algorithme de sélection du meilleur chemin BGP.

Cette solution est semblable à la solution où Multi Exit Discriminator (MED) est placé à la mesure d'IGP. Cependant, dans ce cas, étape 6 (le plus bas MED) décide le meilleur chemin. Cette étape est livré après l'étape 4, où le plus court chemin décide le meilleur chemin. Le meilleur chemin souvent est déjà trouvé avant qu'étape 6 soit atteinte. Avec la solution AIGP, la décision normale BGP est changée de sorte que l'AIGP soit vérifié après qu'étape 3 afin de déterminer si l'artère a été annoncée localement. Si différent pair voisin de systèmes autonomes (AS) avec le speaker BGP, il signifie que la valeur de toujours-comparer-med doit être activée.

L'attribut de mesure AIGP est spécifié dans RFC 7311, qui est l'attribut de mesure accumulé d'IGP pour le BGP. Afin de porter la valeur métrique AIGP dans la communauté de coût, les procédures spécifiées dans l'ébauche-retana-différence-aigp-coût-communauté (utilisation de la Communauté de coût de porter la mesure accumulée d'IGP) sont utilisées.

Remarque: La mesure BGP AIGP attribuée fournit le routage optimal dans les réseaux où différents domaines de routage sont interconnectés par le BGP.

Modifications à l'algorithme de sélection du meilleur chemin BGP

Quand AIGP est utilisé, ces modifications à l'algorithme de sélection du meilleur chemin BGP sont apportées :

  • L'algorithme de sélection du meilleur chemin BGP est modifié afin de comparer l'AIGP juste après qu'étape 3 (localement routes annoncées) et après vérification du prochain saut est valide.

  • Quand le routeur considère un chemin AIGP contre un chemin AIGP, alors la valeur de la mesure AIGP est ajoutée à la mesure vers le prochain-saut.

  • Quand le routeur considère un chemin AIGP contre un chemin de non-AIGP, alors le BGP préfère le chemin avec l'attribut AIGP par défaut.

  • Quand la plus basse mesure d'IGP est comparée au prochain saut BGP, alors le coût AIGP est pris en considération.

  • Si l'artère vers le prochain saut a une mesure AIGP, la mesure est ajoutée à la mesure d'IGP vers le prochain saut. Cette somme est la nouvelle mesure d'IGP (coût intérieur) pour l'artère. Ceci se produit quand une route BGP est récursive à une autre route BGP.

Importantes considérations

Si les IGP dans le réseau sont de différents types (Protocole OSPF (Open Shortest Path First), Protocole IS-IS (Intermediate System-to-Intermediate System), Protocole EIGPR (Enhanced Interior Gateway Routing Protocol)), il est peu probable que la mesure qui résulte de l'utilisation de l'attribut AIGP mène aux résultats cohérents ou raisonnables. Si le même IGP est utilisé dans les différents domaines, alors les mêmes configurations métriques doivent être utilisées afin de garantir à résultats cohérents.

Pour que les Routeurs de cadre ou les Routeurs de PE aient la capacité de décider entre les plusieurs chemins (basés sur la mesure dérivée par AIGP) ils doivent d'abord recevoir des plusieurs chemins. Pour cette raison, vous pourriez être requis d'activer le chemin supplémentaire (Ajouter-chemin) ou d'annoncer la meilleure caractéristique de BGP externe.

Les pairs BGP qui sont activés pour AIGP et ceux qui ne sont pas sont placés dans les groupes distincts de mise à jour. Supplémentaire, les pairs BGP qui sont activés pour AIGP dans la communauté de coût sont placés dans les groupes distincts de mise à jour.

Solution pour les Routeurs existants

S'il y a des Routeurs dans le réseau qui ne sont pas capables d'AIGP (Routeurs existants), alors il y a deux solutions possibles :

  • Un routeur peut traduire l'AIGP à une communauté de coût, le relier à l'artère, et annoncer l'artère au routeur existant.

  • Un routeur peut traduire l'AIGP au MED, le relier à l'artère, et annoncer l'artère au routeur existant.

Configurez

Cette section décrit comment configurer l'attribut de mesure AIGP.

Transmission d'enable de l'attribut AIGP

L'AIGP doit être activé explicitement pour BGP interne (iBGP) et les sessions de BGP externe (eBGP) avec l'aigp voisin d'IP address commandent.

C'est comment vérifier si l'AIGP est activé pour le pair BGP :

P3#show bgp ipv4 unicast neighbors 10.1.9.2 | in AIGP

For address family: IPv4 Unicast

  AIGP is enabled

Lancez l'AIGP

L'AIGP peut être placé à la mesure d'IGP ou à une valeur. En outre, l'AIGP peut être placé pour quelques artères particulières seulement pour un IGP par l'intermédiaire d'un route-map. Quand le créateur de l'AIGP voit un changement de la mesure d'IGP, elle devrait envoyer une nouvelle mise à jour BGP avec les nouvelles valeurs AIGP pour les artères affectées.

La mesure AIGP peut automatiquement être placée à la mesure d'IGP ou à une certaine valeur 32 bits arbitraire :

P1(config-route-map)#set aigp-metric ?
  <0-4294967295>  manual value
  igp-metric      metric value from rib

Cet exemple affiche comment placer l'AIGP métrique à la mesure de l'artère d'IGP :

ip prefix-list loopback seq 5 permit 10.100.1.1/32
!
route-map redistribute-loopback permit 10
match ip address prefix-list loopback
set aigp-metric igp-metric

Molette pour désactiver AIGP à égalité

Si cette molette est activée, alors le BGP n'utilise pas AIGP à égalité à moins que chacun des deux chemins aient l'attribut de mesure AIGP. Ceci signifie que l'attribut AIGP n'est pas évalué pendant le meilleur processus de sélection de chemin entre deux chemins quand un chemin n'a pas l'attribut AIGP.

Voici un exemple :

router bgp 65000
  bgp bestpath aigp ignore

Solution pour les Routeurs existants

Si le routeur que PE2 n'a pas un logiciel qui prend en charge l'attribut de mesure AIGP (il est un routeur existant), alors il y a deux solutions que vous pouvez utiliser.

Traduction de l'AIGP pour coûter la Communauté

Configurez les Routeurs P3 et P4 afin de traduire l'IGP coûtent dans une communauté de coût que le routeur peut annoncer à un routeur existant :

P3#show run | beg router bgp
router bgp 65000
address-family ipv4
  neighbor 10.1.9.2 activate
  neighbor 10.1.9.2 send-community both
  neighbor 10.1.9.2 aigp send cost-community 100 poi igp-cost transitive
P4#show run | beg router bgp
router bgp 65000
address-family ipv4
  neighbor 10.1.10.2 activate
  neighbor 10.1.10.2 send-community both
  neighbor 10.1.10.2 aigp send cost-community 100 poi igp-cost transitive

Vous devez permettre le routeur qui envoie pour envoyer les communautés étendues. Ceci signifie que vous devez spécifier l'envoyer-communauté étendue ou l'envoyer-communauté les deux attributs (l'envoyer-communauté voisine x.x.x.x) pour le pair BGP.

Voici un exemple :

PE2#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 6
Paths: (2 available, best #1, table default)
  Advertised to update-groups:
     6        
  Refresh Epoch 2
  65000 65001
    10.1.9.4 from 10.1.9.4 (10.100.1.4)
      Origin incomplete, localpref 100, valid, external, best
      Extended Community: Cost(transitive):igp:100:6
      mpls labels in/out 17/16
      rx pathid: 0, tx pathid: 0x0
  Refresh Epoch 15
  65000 65001
    10.1.10.6 from 10.1.10.6 (10.100.1.6)
      Origin incomplete, localpref 100, valid, external
      Extended Community: Cost(transitive):igp:100:11
      mpls labels in/out 17/30
      rx pathid: 0, tx pathid: 0

Comme affiché, le routeur PE2 a sélectionné le chemin avec le plus peu coûteux (100:6 contre 100:11) comme meilleur chemin.

Traduction de l'AIGP au MED

Configurez les Routeurs P3 et P4 afin de traduire l'IGP coûtent dans le MED que le routeur peut annoncer à un routeur existant.

Voici la configuration sur le routeur P3 :

router bgp 65000
address-family ipv4
  neighbor 10.1.9.2 activate
  neighbor 10.1.9.2 send-community both
  neighbor 10.1.9.2 aigp send med

Voici la configuration sur le routeur P4 :

router bgp 65000
address-family ipv4
  neighbor 10.1.10.2 activate
  neighbor 10.1.10.2 send-community both
  neighbor 10.1.10.2 aigp send med

Vérifiez

La sortie des mises à jour d'unicast d'ipv4 BGP de débogage affiche aux commandes l'utilisation de l'attribut de mesure AIGP :

PE2#
BGP(0): 10.1.9.4 rcvd UPDATE w/ attr: nexthop 10.1.9.4, origin ?, aigp-metric 22,
merged path 65000 65001, AS_PATH

Quand vous visualisez l'image fournie dans la vue d'ensemble d'attribut de mesure AIGP de ce document, vous pouvez voir que tous les liens dans le réseau EN TANT QUE 6500 ont un coût OSPF de 10, les liens entre les Routeurs P1 et P4 et entre P2 et P3 ayez un coût OSPF de 100, et le lien entre les Routeurs P3 et P1 a un coût de 5.

C'est l'artère pour 10.100.1.1/32, comme vu sur le routeur P3 :

P3#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 9
Paths: (2 available, best #1, table default)
  Additional-path-install
  Path advertised to update-groups:
     5         
  Refresh Epoch 5
  65001
    10.100.1.3 (metric 6) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, metric 0, localpref 100, valid, internal, best
      Originator: 10.100.1.3, Cluster list: 10.100.1.7
      mpls labels in/out 29/16
      rx pathid: 0x0, tx pathid: 0x0
  Path not advertised to any peer
  Refresh Epoch 5
  65001
    10.100.1.5 (metric 21) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, metric 0, localpref 100, valid, internal, backup/repair, all
      Originator: 10.100.1.5, Cluster list: 10.100.1.7
      mpls labels in/out 29/16
      rx pathid: 0x1, tx pathid: 0x1

C'est l'artère pour 10.100.1.1/32, comme vu sur le routeur P4 :

P4#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 9
Paths: (2 available, best #2, table default)
  Additional-path-install
  Path not advertised to any peer
  Refresh Epoch 5
  65001
    10.100.1.3 (metric 16) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, metric 0, localpref 100, valid, internal, backup/repair, all
      Originator: 10.100.1.3, Cluster list: 10.100.1.7
      mpls labels in/out 29/16
      rx pathid: 0x0, tx pathid: 0x1
  Path advertised to update-groups:
     35        
  Refresh Epoch 5
  65001
    10.100.1.5 (metric 11) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, metric 0, localpref 100, valid, internal, best
      Originator: 10.100.1.5, Cluster list: 10.100.1.7
      mpls labels in/out 29/16
      rx pathid: 0x1, tx pathid: 0x0

C'est l'artère pour 10.100.1.1/32, comme vu sur le routeur PE2 :

PE2#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 4
Paths: (2 available, best #2, table default)
  Advertised to update-groups:
     5        
  Refresh Epoch 1
  65000 65001
    10.1.9.4 from 10.1.9.4 (10.100.1.4)
      Origin incomplete, localpref 100, valid, external
      mpls labels in/out 18/17
      rx pathid: 0, tx pathid: 0
  Refresh Epoch 1
  65000 65001
    10.1.10.6 from 10.1.10.6 (10.100.1.6)
      Origin incomplete, localpref 100, valid, external, best
      mpls labels in/out 18/30
      rx pathid: 0, tx pathid: 0x0

Le meilleur chemin sur le routeur P3 est le chemin avec la mesure 6 d'IGP, avec le routeur P1 comme prochain saut. Le meilleur chemin sur le routeur P4 est le chemin avec la mesure 11 d'IGP, avec le routeur P2 comme prochain saut. Les Routeurs P3 et P4 envoient leur meilleur chemin vers le routeur PE2. Le routeur PE2 sélectionne le chemin du routeur P4 en tant que le meilleur, qui a été décidé parce que chacun des deux chemins BGP sur le routeur PE2 sont très semblables et étape 10 était le lien-briseur : le chemin externe le plus ancien gagné. Ceci signifie que le trafic du routeur PE2 au routeur PE1 prend le chemin PE2-P4-P2-PE1. Cependant, le chemin global le plus court, quand vous considérez le coût d'IGP, est PE2-P3-P1-PE1.

Utilisez les informations qui suivent afin de vérifier l'attribut de mesure AIGP sur les Routeurs P3 et P4 vers le routeur PE2 (10.100.1.7) :

Voici la sortie pour le routeur P3 :

router bgp 65000
address-family ipv4
  bgp additional-paths select all
  bgp additional-paths receive
  bgp additional-paths install
  neighbor 10.1.9.2 activate
  neighbor 10.1.9.2 aigp
  neighbor 10.1.9.2 send-label
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 aigp
  neighbor 10.100.1.7 next-hop-self
  neighbor 10.100.1.7 send-label

Voici la sortie pour le routeur P4 :

router bgp 65000
address-family ipv4
  bgp additional-paths select all
  bgp additional-paths receive
  bgp additional-paths install
  neighbor 10.1.10.2 activate
  neighbor 10.1.10.2 aigp
  neighbor 10.1.10.2 send-label
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 aigp
  neighbor 10.100.1.7 next-hop-self
  neighbor 10.100.1.7 send-label

Vous pouvez voir que le routeur P3 a maintenant :

P3#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 30
Paths: (2 available, best #2, table default)
  Additional-path-install
  Path not advertised to any peer
  Refresh Epoch 11
  65001
    10.100.1.5 (metric 21) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, aigp-metric 0, metric 0, localpref 100, valid, internal,
backup/repair, all
      Originator: 10.100.1.5, Cluster list: 10.100.1.7
      mpls labels in/out 28/31
      rx pathid: 0x1, tx pathid: 0x1
  Path advertised to update-groups:
     5         
  Refresh Epoch 11
  65001
    10.100.1.3 (metric 6) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, aigp-metric 0, metric 0, localpref 100, valid, internal, best
      Originator: 10.100.1.3, Cluster list: 10.100.1.7
      mpls labels in/out 28/30
      rx pathid: 0x0, tx pathid: 0x0

Le routeur P4 a maintenant :

P4#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 30
Paths: (2 available, best #1, table default)
  Additional-path-install
  Path advertised to update-groups:
     35        
  Refresh Epoch 11
  65001
    10.100.1.5 (metric 11) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, aigp-metric 0, metric 0, localpref 100, valid, internal, best
      Originator: 10.100.1.5, Cluster list: 10.100.1.7
      mpls labels in/out 16/31
      rx pathid: 0x1, tx pathid: 0x0
  Path not advertised to any peer
  Refresh Epoch 11
  65001
    10.100.1.3 (metric 16) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, aigp-metric 0, metric 0, localpref 100, valid, internal,
backup/repair, all
      Originator: 10.100.1.3, Cluster list: 10.100.1.7
      mpls labels in/out 16/30
      rx pathid: 0x0, tx pathid: 0x1

La mesure d'IGP pour les chemins sur les Routeurs P3 et P4 n'a pas changé, mais le routeur PE2 reçoit maintenant les artères avec l'attribut AIGP des Routeurs P3 et P4.

Le routeur PE2 voit les deux chemins. Chaque chemin a l'attribut AIGP, et le chemin avec le plus bas attribut de mesure AIGP gagne maintenant :

PE2#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 6
Paths: (2 available, best #1, table default)
  Advertised to update-groups:
     5        
  Refresh Epoch 1
  65000 65001
    10.1.9.4 from 10.1.9.4 (10.100.1.4)
      Origin incomplete, aigp-metric 6, localpref 100, valid, external, best
      mpls labels in/out 18/17
      rx pathid: 0, tx pathid: 0x0
  Refresh Epoch 1
  65000 65001
    10.1.10.6 from 10.1.10.6 (10.100.1.6)
      Origin incomplete, aigp-metric 11, localpref 100, valid, external
      mpls labels in/out 18/30
      rx pathid: 0, tx pathid: 0

Si le chemin qui est reçu du routeur P3 est plus long que le chemin qui est reçu du routeur P4 sur le routeur PE2, alors le routeur PE2 sélectionne toujours le chemin du routeur P3 comme meilleur. Vous pouvez augmenter le chemin que le routeur au début P3 annonce par un par l'intermédiaire d'un route-map et de comme-ajouter.

router bgp 65000
address-family ipv4
neighbor 10.1.9.2 route-map as_path out

route-map as_path permit 10
set as-path prepend last-as 1

Le routeur PE2 a maintenant l'artère du routeur P3 avec un frais supplémentaires AUSSI dans QUE le chemin :

PE2#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 7
Paths: (2 available, best #1, table default)
  Advertised to update-groups:
     5        
  Refresh Epoch 1
  65000 65001 65001
    10.1.9.4 from 10.1.9.4 (10.100.1.4)
      Origin incomplete, aigp-metric 6, localpref 100, valid, external, best
      mpls labels in/out 18/nolabel
      rx pathid: 0, tx pathid: 0x0
  Refresh Epoch 1
  65000 65001
    10.1.10.6 from 10.1.10.6 (10.100.1.6)
      Origin incomplete, aigp-metric 11, localpref 100, valid, external
      mpls labels in/out 18/30
      rx pathid: 0, tx pathid: 0

En raison de l'attribut de mesure AIGP, le routeur PE2 sélectionne toujours le chemin du routeur P3 comme meilleur. Le contrôle AIGP est exécuté avant que PENDANT QUE la longueur de chemin est vérifiée.

Si vous enlevez la capacité d'envoyer l'AIGP sur le routeur P4 vers le routeur PE2, alors le routeur PE2 reçoit le chemin sans attribut de mesure AIGP du routeur P4. Cependant, le routeur PE2 a toujours le chemin du routeur P3 avec AIGP. Le routeur PE2 préfère le chemin avec AIGP au-dessus d'un chemin sans AIGP, et il sélectionne le chemin du routeur P3 comme meilleur :

PE2#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 2
Paths: (2 available, best #2, table default)
  Advertised to update-groups:
     6        
  Refresh Epoch 1
  65000 65001
    10.1.10.6 from 10.1.10.6 (10.100.1.6)
      Origin incomplete, localpref 100, valid, external
      mpls labels in/out 17/30
      rx pathid: 0, tx pathid: 0
  Refresh Epoch 1
  65000 65001 65001
    10.1.9.4 from 10.1.9.4 (10.100.1.4)
      Origin incomplete, aigp-metric 6, localpref 100, valid, external, best
      mpls labels in/out 17/nolabel
      rx pathid: 0, tx pathid: 0x0

Remarque: Si vous voulez que le routeur PE2 ignore l'AIGP pendant le meilleur processus de sélection de chemin BGP, alors configurez l'aigp de bestpath BGP ignorent la commande.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Document ID: 119001