IP : Protocole IP Multicast

Configurez les profils de mVPN pour l'IPv6 dans le Cisco IOS

18 juin 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (21 avril 2016) | Commentaires

Contenu

Conversations connexes de la communauté de soutien de Cisco

Introduction

Ce document décrit comment configurer chaque profil de Multicast VPN (mVPN) dans le Cisco IOS® pour l'IPv6 seulement.

Remarque: Les configurations qui sont décrites dans ce document appliquent aux Routeurs de Provider Edge (PE).

Contribué par Luc De Ghein, ingénieur TAC Cisco.

Conditions préalables

Conditions requises

Avant que vous poursuiviez la configuration qui est décrite dans ce document, vérifiez s'il y a soutien d'un profil de mVPN sur la plate-forme spécifique qui exécute le Cisco IOS.

Composants utilisés

Les informations dans ce document sont basées sur toutes les versions de Cisco IOS.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Informations générales

Remarque: Le VRF qui est utilisé dans tout ce document est le VRF un.

Un profil de mVPN est configuré pour le contexte global ou par routage/expédition virtuels (VRF). Seulement la manière plus nouvelle de définir un VRF (vrf definition) peut être utilisée afin d'activer l'IPv6 pour des profils de mVPN. Voici un exemple :

vrf definition one
 rd 1:1
 vpn id 1000:2000
 !
 address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  route-target export 123:456
  route-target import 123:456
 exit-address-family
 !
 address-family ipv6
  mdt default mpls mldp 10.100.1.3
  route-target export 123:456
  route-target import 123:456
 exit-address-family

Le multicast-routing pour l'IPv6 doit être activé pour les profils dans le contexte global. Supplémentaire, la version 6 (PIMv6) de Protocol Independent Multicast doit être activée sur l'interface globale de bouclage. C'est vrai si la commande d'ipv6 multicast-routing est activée, et si l'interface de bouclage a un ipv6 addres ou la commande d'ipv6 enable est configurée sur l'interface de bouclage.

ipv6 multicast-routing

Le routage de Multidiffusion pour l'IPv6 doit être activé sur le VRF pour les profils dans le vrf context.

ipv6 multicast-routing vrf one

Enable d'il est conseillé de se connecter du protocole de distribution d'étiquette multipoint (MLDP) avec cette commande globale pour les profils avec MLDP :

mpls mldp logging notifications

Le PIM pour l'IPv6 est activé par défaut sur les interfaces dans le global ou le vrf context si l'ipv6 multicast-routing ou le vrf respectif d'ipv6 multicast-routing une commande est configuré.

interface Ethernet0/0
 vrf forwarding one
 ip address 10.2.1.1 255.255.255.0
 ip pim sparse-mode
 ipv6 address 2001:DB8:1::1/64

Ceci signifie que la commande d'IPv6 PIM est activée par défaut sur les interfaces. Pour les profils avec le VRF, le Provider Edge 6 virtuel (6VPE) doit être complètement opérationnel pour le trafic unicast. Pour le profil 7, le Provider Edge 6 (6PE) doit être complètement opérationnel pour le trafic unicast.

Remarque: Pour que la Multidiffusion fonctionne, l'unicast doit être complètement opérationnel.

Configurez

Cette section décrit comment configurer les profils de mVPN dans le Cisco IOS.

Remarque: Utilisez l'Outil de recherche de commande (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

VPN ID

Le VPN ID qui est configuré pour le VRF est seulement exigé pour les profils qui utilisent MLDP comme principal arbre de distribution de Multidiffusion de protocole et de par défaut d'arborescence (MDT).

vrf definition one
 rd 1:1
 vpn id 1000:2000

Ipv4 et IPv6 activés pour le mVPN

Pour les profils avec le par défaut MDT et l'Encapsulation de routage générique (GRE), si le mVPN est activé pour l'ipv4 et l'IPv6, puis le même par défaut MDT doit être utilisé pour chacun des deux familles d'adresse (AFs).

Vous ne pouvez pas mélanger différents profils pour l'AFs différent.

Pour les profils avec MDT divisé avec MLDP, si le mVPN est activé pour l'ipv4 et l'IPv6, un MDT divisé différent est signalé pour chaque AF pour le même routeur PE de racine. L'arborescence MLDP aura un identifiant global différent (GID) en valeur opaque. La même interface de l'interface virtuelle de chemin commutée par étiquette (LSPVIF) est utilisée pour des les deux AFs.

Voici un exemple où le profil 14 est utilisé pour l'ipv4 et l'IPv6 d'AFs :

vrf definition one
 rd 1:1
 vpn id 1000:2000
 !
 address-family ipv4
  mdt auto-discovery mldp
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family
 !
 address-family ipv6
  mdt auto-discovery mldp
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

La source 10.100.1.6 et 2001:DB8:2::6 sont derrière le même routeur PE PE2 de source. L'entrée de la base de données des informations de routage de Multidiffusion (MRIB) pour le groupe de multidiffusion d'ipv4 et le groupe de Multidiffusion IPv6 utilise une entrée de la Multidiffusion commutée par étiquette différente (LSM) ou l'entrée MLDP dans la base de données sur le routeur PE d'entrée, ainsi les deux groupes sont expédiés sur différentes arborescences MLDP.

PE2#show mpls mldp database opaque_type gid 
LSM ID : 5   Type: P2MP   Uptime : 02:18:54
  FEC Root           : 10.100.1.2 (we are the root)
  Opaque decoded     : [gid 65536 (0x00010000)]
  Opaque length      : 4 bytes
  Opaque value       : 01 0004 00010000
  Upstream client(s) :
    None
      Expires        : N/A           Path Set ID  : 5
  Replication client(s):
    MDT  (VRF one)
      Uptime         : 02:18:54      Path Set ID  : None
      Interface      : Lspvif1       
    10.100.1.4:0
      Uptime         : 00:32:50      Path Set ID  : None
      Out label (D)  : 20            Interface    : Ethernet2/0*
      Local label (U): None          Next Hop     : 10.1.2.4

LSM ID : 6   Type: P2MP   Uptime : 00:37:06
  FEC Root           : 10.100.1.2 (we are the root)
  Opaque decoded     : [gid 131072 (0x00020000)]
  Opaque length      : 4 bytes
  Opaque value       : 01 0004 00020000
  Upstream client(s) :
    None
      Expires        : N/A           Path Set ID  : 6
  Replication client(s):
    MDT  (VRF one)
      Uptime         : 00:37:06      Path Set ID  : None
      Interface      : Lspvif1       
    10.100.1.4:0
      Uptime         : 00:18:38      Path Set ID  : None
      Out label (D)  : 22            Interface    : Ethernet2/0*
      Local label (U): None          Next Hop     : 10.1.2.4
PE2#show ip mfib vrf one 232.1.1.1                 
Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,
                ET - Data Rate Exceeds Threshold, K - Keepalive
                DDE - Data Driven Event, HW - Hardware Installed
                ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
                MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
                MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
                NS - Negate Signalling, SP - Signal Present,
                A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
                MA - MFIB Accept, A2 - Accept backup,
                RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts:      Total/RPF failed/Other drops
I/O Item Counts:   FS Pkt Count/PS Pkt Count
VRF one
 (10.100.1.6,232.1.1.1) Flags:
   SW Forwarding: 374/0/100/0, Other: 122/0/122
   Ethernet0/0 Flags: A
   Lspvif1, LSM/6 Flags: F
     Pkts: 374/0
PE2#show ipv6 mfib vrf one route FF3E::4000:1      
Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,
                ET - Data Rate Exceeds Threshold, K - Keepalive
                DDE - Data Driven Event, HW - Hardware Installed
                ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
                MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
                MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
                NS - Negate Signalling, SP - Signal Present,
                A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
                MA - MFIB Accept, A2 - Accept backup,
                RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts:      Total/RPF failed/Other drops
I/O Item Counts:   FS Pkt Count/PS Pkt Count
VRF one
 (2001:DB8:2::6,FF3E::4000:1)
   Ethernet0/0 A
   Lspvif1, LSM/5 F

profils de mVPN

Cette section décrit les configurations exigées pour chaque profil.

Profil 0 MDT par défaut - GRE - Signalisation PIM C-mcast

Utilisez cette configuration pour le profil 0 :

interface Loopback0
ipv6 address 2001:DB8:100::2/128
!

vrf definition one
 rd 1:1
!
 address-family ipv6
  mdt default 232.1.1.1
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
!
 address-family ipv4 mdt
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Remarque: Le mdt d'ipv4 d'address-family est exigé pour le par défaut MDT qui est établi pour la Multidiffusion de l'IPv6 PIM/IP. Vous devez avoir l'IPv6 activé sur l'interface de bouclage, ainsi il signifie qu'il doit y a une commande d'ipv6 addres ou d'ipv6 enable configurée sur l'interface de bouclage. Si la Multidiffusion est aussi bien activée pour l'ipv4 dans le VRF, alors l'IPv6 et l'ipv4 utilisent le même par défaut MDT (le même groupe de multidiffusion dans le contexte global) et la même interface de tunnel sur le routeur PE.

Profil 1 MDT par défaut - MLDP MP2MP - Signalisation PIM C-mcast

Utilisez cette configuration pour le profil 1 :

vrf definition one
 rd 1:1
 vpn id 1000:2000
!
 address-family ipv6
  mdt default mpls mldp 10.100.1.3
  route-target export 123:456
  route-target import 123:456
 exit-address-family

ipv6 multicast-routing vrf one

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Profil 2 MDT divisés - MLDP MP2MP - Signalisation PIM C-mcast       

Le profil 2 n'est pas actuellement pris en charge dans le Cisco IOS, et le MLDP ne prend en charge pas MDT divisé avec Multipoint-à-multipoint (MP2MP).

Profil 3 MDT par défaut - GRE - BGP-AD - Signalisation PIM C-mcast

Utilisez cette configuration pour le profil 3 :

interface Loopback0
ipv6 address 2001:DB8:100::2/128
!

vrf definition one
 rd 1:1
!
 address-family ipv6
  mdt auto-discovery pim
  mdt default 232.1.1.1
  route-target export 123:456
  route-target import 123:456
 exit-address-family

interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
!
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Remarque: Puisque la détection de Protocol-automatique de passerelle de cadre (BGP-AD) pour PIM est utilisée, il n'y a plus un besoin d'ipv4 MDT AF, qui était nécessaire pour le profil 0. Vous devez avoir l'IPv6 activé sur l'interface de bouclage, ainsi il signifie qu'il doit y a une commande d'ipv6 addres ou d'ipv6 enable configurée sur l'interface de bouclage. Si la Multidiffusion est aussi bien activée pour l'IPv6 dans le VRF, alors l'IPv6 et l'ipv4 utilisent le même par défaut MDT (le même groupe de multidiffusion dans le contexte global) et la même interface de tunnel sur le routeur PE.

Profil 4 MDT divisés - MLDP MP2MP - BGP-AD - Signalisation PIM C-mcast

Le profil 4 n'est pas actuellement pris en charge dans le Cisco IOS, et MLDP ne prend en charge pas MDT divisé avec MP2MP.

Profil 5 MDT divisés - MLDP P2MP - BGP-AD - Signalisation PIM C-mcast

Le profil 5 n'est pas actuellement pris en charge dans le Cisco IOS, et la signalisation PIM n'est pas prise en charge au-dessus de MDT divisé. 

VRF MLDP du profil 6 - Signalisation d'intrabande

Utilisez cette configuration pour le profil 6 :

vrf definition one
 rd 1:1
 !
 address-family ipv6
  route-target export 123:456
  route-target import 123:456
 exit-address-family
!

interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64

ipv6 multicast-routing vrf one
ipv6 multicast vrf one mpls source Loopback0
ipv6 multicast vrf one mpls mldp

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
!
 address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
 address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Signalisation d'intrabande globale du profil 7 MLDP

Utilisez cette configuration pour le profil 7 :

ipv6 multicast-routing
ipv6 multicast mpls source Loopback0
ipv6 multicast mpls mldp

interface Ethernet0/0
 ip address 10.2.2.2 255.255.255.0
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 2001:DB8:2::6 remote-as 65002
 !
!
 address-family ipv6
  redistribute connected
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-label
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Charge statique globale du profil 8 - P2MP-TE         

Le profil 8 n'est pas actuellement pris en charge dans le Cisco IOS.

Profil 9 MDT par défaut - MLDP - MP2MP - BGP-AD - Signalisation PIM C-mcast

Utilisez cette configuration pour le profil 9 :

vrf definition one
 rd 1:1
 vpn id 1000:2000
!
 address-family ipv6
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  route-target export 123:456
  route-target import 123:456
 exit-address-family

ipv6 multicast-routing vrf one

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Charge statique de VRF du profil 10 - P2MP TE - BGP-AD 

Le profil 10 n'est pas actuellement pris en charge dans le Cisco IOS, et BGP-AD n'est pas pris en charge pour l'ingénierie de trafic point-à-multipoint (P2MP TE).        

Profil 11 MDT par défaut - GRE - BGP-AD - Signalisation BGP C-mcast

Utilisez cette configuration pour le profil 11 :

interface Loopback0
ipv6 address 2001:DB8:100::2/128
!

vrf definition one
 rd 1:1
!
 address-family ipv6
  mdt auto-discovery pim
  mdt default 232.1.1.1
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
!
 address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Remarque: Puisque BGP-AD pour PIM est utilisé, il n'y a plus un besoin d'ipv4 MDT AF, qui était nécessaire pour le profil 0. Vous devez avoir l'IPv6 activé sur l'interface de bouclage, ainsi il signifie qu'il doit y a une commande d'ipv6 addres ou d'ipv6 enable configurée sur l'interface de bouclage. Si la Multidiffusion est aussi bien activée pour l'IPv6 dans le VRF, alors l'IPv6 et l'ipv4 utilisent le même par défaut MDT (le même groupe de multidiffusion dans le contexte global) et la même interface de tunnel sur le routeur PE.

Profil 12 MDT par défaut - MLDP - P2MP - BGP-AD - Signalisation BGP C-mcast

Utilisez cette configuration pour le profil 12 :

vrf definition one
 rd 1:1
 vpn id 1000:2000
 !        
 address-family ipv6
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
 address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
 address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family

Profil 13 MDT par défaut - MLDP - MP2MP - BGP-AD - Signalisation BGP C-mcast

Utilisez cette configuration pour le profil 13 :

vrf definition one
 rd 1:1
 vpn id 1000:2000
!
 address-family ipv6
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

ipv6 multicast-routing vrf one

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

Profil 14 MDT divisés - MLDP P2MP - BGP-AD - Signalisation de C-mât BGP

Utilisez cette configuration pour le profil 14 :

vrf definition one
 rd 1:1
!        
 address-family ipv6
  mdt auto-discovery mldp
mdt strict-rpf interface
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 2001:DB8:2::6 remote-as 65002
 !
!
 address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
 address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
 address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate exit-address-family

Profil 15 MDT divisés - MLDP MP2MP - BGP-AD - Signalisation de C-mât BGP

Le profil 15 n'est pas actuellement pris en charge dans le Cisco IOS, et MLDP ne prend en charge pas MDT divisé avec MP2MP.

Charge statique par défaut du profil 16 MDT - P2MP TE - BGP-AD - Signalisation BGP C-mcast

Le profil 16 n'est pas actuellement pris en charge dans le Cisco IOS.

Profil 17 MDT par défaut - MLDP - P2MP - BGP-AD - Signalisation PIM C-mcast

Utilisez cette configuration pour le profil 17 :

vrf definition one
 rd 1:1
 vpn id 1000:2000
 !        
 address-family ipv6
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
 address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
 address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family

Charge statique par défaut du profil 18 MDT - P2MP TE - BGP-AD - Signalisation PIM C-mcast

Le profil 18 n'est pas actuellement pris en charge dans le Cisco IOS.

Profil 19 MDT par défaut - BGP-AD IR - Signalisation PIM C-mcast    

Le profil 19 et la réplication d'entrée (IR) ne sont pas actuellement pris en charge dans le Cisco IOS.         

Profil 20 MDT par défaut - P2MP-TE - BGP-AD - PIM - Signalisation de C-mcast

Le profil 20 et les Automatique-tunnels TE P2MP ne sont pas actuellement pris en charge dans le Cisco IOS.

Profil 21 MDT par défaut - BGP-AD IR - BGP - Signalisation de C-mcast 

Le profil 21 et IR ne sont pas actuellement pris en charge dans le Cisco IOS.         

Profil 22 MDT par défaut - P2MP-TE - BGP BGP-AD - Signalisation de C-mcast

Le profil 22 et les Automatique-tunnels TE P2MP ne sont pas actuellement pris en charge dans le Cisco IOS.  

Profil 23 MDT divisés - BGP-AD IR - Signalisation PIM C-mcast

Le profil 23 et IR ne sont pas actuellement pris en charge dans le Cisco IOS.      

Profil 24 MDT divisés - P2MP-TE - BGP-AD - Signalisation PIM C-mcast 

Le profil 24 et les Automatique-tunnels TE P2MP ne sont pas actuellement pris en charge dans le Cisco IOS.  

Profil 25 MDT divisés - BGP-AD IR - Signalisation BGP C-mcast 

Le profil 25 et IR ne sont pas actuellement pris en charge dans le Cisco IOS.         

Profil 26 MDT divisés - P2MP TE - BGP-AD - Signalisation BGP C-mcast 

Le profil 26 et les Automatique-tunnels TE P2MP ne sont pas actuellement pris en charge dans le Cisco IOS.

Vérifiez

Il n'y a actuellement aucune procédure de vérification disponible pour ces configurations.

Dépannez

Il n'y a actuellement aucune information de dépannage spécifique disponible pour ces configurations.


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Document ID: 118984