IP : Multidiffusion

Configurez les profils de mVPN dans le Cisco IOS

18 juin 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (21 avril 2016) | Commentaires

Contenu

Conversations connexes de la communauté de soutien de Cisco

Introduction

Ce document décrit comment configurer chaque profil de Multicast VPN (mVPN) dans le Cisco IOS®.

Remarque: Les configurations qui sont décrites dans ce document appliquent aux Routeurs de Provider Edge (PE).

Contribué par Luc De Ghein, ingénieur TAC Cisco.

Conditions préalables

Conditions requises

Avant que vous poursuiviez la configuration qui est décrite dans ce document, vérifiez s'il y a soutien d'un profil de mVPN sur la plate-forme spécifique qui exécute le Cisco IOS.

Composants utilisés

Les informations dans ce document sont basées sur toutes les versions du Cisco IOS.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Configurez

Cette section décrit comment configurer les profils de mVPN dans le Cisco IOS.

Remarque: Utilisez l'Outil de recherche de commande (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

profils de mVPN

Remarque: Non tous les profils sont actuellement pris en charge dans le Cisco IOS.

Remarque: Le routage/expédition virtuels (VRF) qui est utilisé dans tout ce document est le VRF un. Le Rosen MLDP a été renommé pour transférer MDT.

Un profil de mVPN est configuré pour le contexte global ou par VRF. Vous pouvez employer la vieille ou nouvelle méthode afin de définir un VRF quand vous configurez des profils de mVPN dans le Cisco IOS.

Voici un exemple de la vieille méthode :

ip vrf one
rd 1:1
route-target export 1:1
route-target import 1:1

Voici un exemple de la nouvelle méthode :

vrf definition one
rd 1:1
!
address-family ipv4
  route-target export 1:1
  route-target import 1:1
exit-address-family

Pour les profils dans le contexte global, le multicast-routing doit être activé :

ip multicast-routing

Pour les profils dans le vrf context, le multicast-routing doit être activé pour le VRF :

ip multicast-routing vrf one

Vous pouvez activer se connecter du protocole de distribution d'étiquette multipoint (MLDP) avec cette commande globale pour les profils avec MLDP :

mpls mldp logging notifications

Le Protocol Independent Multicast (PIM) doit être activé pour le routeur de Provider Edge (PE) sur le lien de la périphérie de Périphérie-client de fournisseur (PE-CE) pour les les deux les cas (globaux ou vrf context) :

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

FRR pour MLDP

Rapide reroutez (FRR) pour MLDP est disponible dans le Cisco IOS. Le trafic de multidiffusion pour lequel MLDP est le protocole d'avion de contrôle doit utiliser un tunnel primaire de l'ingénierie de trafic (TE) afin d'avoir le trafic protégé par FRR. Le tunnel primaire TE peut être un tunnel du manuel TE ou un automatique-tunnel primaire. Le lien doit être protégé par TE FRR, par un tunnel de sauvegarde manuelle ou un automatique-tunnel de sauvegarde.

Cet exemple utilise un tunnel manuel de sauvegarde primaire et manuelle.

Cette commande globale doit être configurée pour que MLDP utilise des tunnels du Commutation multiprotocole par étiquette (MPLS) TE :

mpls mldp path traffic-eng

Cette configuration est utilisée pour l'interface protégée qui est utilisée par le tunnel primaire d'un-saut :

interface Ethernet3/0
 ip address 10.1.6.6 255.255.255.0
 load-interval 30
 mpls ip
 mpls traffic-eng tunnels
 mpls traffic-eng backup-path Tunnel0
 ip rsvp bandwidth 10000
end

Cette configuration est utilisée pour le tunnel de sauvegarde :

interface Tunnel0
 ip unnumbered Loopback0
 load-interval 30
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.100.1.3
 tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3

Cette configuration est utilisée pour le tunnel primaire d'un-saut :

interface Tunnel1
 ip unnumbered Loopback0
 load-interval 30
 mpls ip
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.100.1.3
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3-direct
 tunnel mpls traffic-eng fast-reroute

Remarque: La configuration d'IP de MPLS est exigée sur le tunnel principal parce que MLDP doit être activé sur le tunnel protégé. La configuration d'autoroute announce est exigée afin de s'assurer que le tunnel TE est utilisé pour expédier le trafic.

MBB pour MLDP

Faites avant caractéristique de la rupture (MBB) est pris en charge dans le Cisco IOS, mais seulement la méthode qui utilise un retard fixe après que le nouveau chemin soit disponible. Il n'y a aucune requête/reconnaît le mécanisme dans le Cisco IOS.

C'est la commande globale qui est utilisée afin de configurer le retard fixe MBB :

P1(config)#mpls mldp make-before-break delay ?
<0-60000> Delay in milliseconds

La valeur par défaut est 0, tellement là n'est aucun MBB par défaut.

Profils

Cette section décrit les configurations exigées pour chaque profil de mVPN.

Profil 0 MDT par défaut - GRE - Signalisation PIM C-mcast

Utilisez cette configuration pour le profil 0 :

vrf definition one
rd 1:1
!
address-family ipv4
  mdt default 232.1.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       
ip multicast-routing
ip multicast-routing vrf one

interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
  neighbor 10.100.1.7 route-reflector-client
exit-address-family
!
address-family ipv4 mdt
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

Remarque: Pour ce profil, PIM doit être activé sur l'interface globale de bouclage. L'arbre de distribution de Multidiffusion d'ipv4 de la famille d'adresse (AF) (MDT) doit être utilisé pour tous les types de PIM signalant au centre (non seulement pour le Fonction Source Specific Multicast (SSM) PIM).

Profil 1 MDT par défaut - MLDP MP2MP - Signalisation PIM C-mcast

Utilisez cette configuration pour le profil 1 :

vrf definition one
rd 1:2
vpn id 1000:2000
!
address-family ipv4
  mdt default mpls mldp 10.100.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one

mpls mldp logging notifications

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.2.9 remote-as 65002
  neighbor 10.2.2.9 activate
exit-address-family

Profil 2 MDT divisés - MLDP MP2MP - Signalisation PIM C-mcast

     

Le profil 2 n'est pas actuellement pris en charge dans le Cisco IOS, et MLDP ne prend en charge pas MDT divisé avec Multipoint-à-multipoint (MP2MP).

Profil 3 MDT par défaut - GRE - BGP-AD - Signalisation PIM C-mcast

Utilisez cette configuration pour le profil 3 :

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery pim
  mdt default 232.1.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family

  

Remarque: Pour ce profil, PIM doit être activé sur l'interface globale de bouclage. Puisque la détection de Protocol-automatique de passerelle de cadre (BGP-AD) pour PIM est utilisée, il n'y a plus un besoin d'ipv4 MDT AF, qui était nécessaire pour le profil 0.

Profil 4 MDT divisés - MLDP MP2MP - BGP-AD - Signalisation PIM C-mcast

Le profil 4 n'est pas actuellement pris en charge dans le Cisco IOS, et MLDP ne prend en charge pas MDT divisé avec MP2MP.

Profil 5 MDT divisés - MLDP P2MP - BGP-AD - Signalisation PIM C-mcast

Le profil 5 n'est pas actuellement pris en charge dans le Cisco IOS, et la signalisation PIM n'est pas prise en charge au-dessus de MDT divisé.

VRF MLDP du profil 6 - Signalisation d'intrabande

Utilisez cette configuration pour le profil 6 :

vrf definition one
rd 1:1
!
address-family ipv4
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
ip multicast-routing vrf one
ip multicast vrf one mpls mldp


!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!


ip pim vrf one mpls source Loopback0

Signalisation d'intrabande globale du profil 7 MLDP

Utilisez cette configuration pour le profil 7 :

ip multicast-routing

ip multicast mpls mldp

interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!

interface Ethernet2/0
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.2.1.8 activate
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

ip pim mpls source Loopback0

Charge statique globale du profil 8 - P2MP-TE

Cette section décrit les configurations exigées pour le profil 8 sur les Routeurs de tête de réseau TE et de fin TE.

Routeur de tête de réseau TE

Utilisez cette configuration pour le profil 8 sur le routeur de tête de réseau TE :

ip multicast-routing
ip multicast mpls traffic-eng

mpls traffic-eng tunnels
mpls traffic-eng destination list name from-PE3
ip 10.100.1.1 path-option 1 dynamic
ip 10.100.1.2 path-option 1 dynamic
ip 10.100.1.4 path-option 1 explicit name to-PE4

interface Tunnel0
ip unnumbered Loopback0
ip pim passive
ip igmp static-group 232.1.1.1 source 10.2.3.10
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name from-PE3
!

interface Ethernet1/0
ip address 10.1.10.3 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000

!
router ospf 1
network 10.1.7.0 0.0.0.255 area 0
network 10.1.10.0 0.0.0.255 area 0
network 10.100.0.0 0.0.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

Remarque: Une liste de destination est exigée pour les Routeurs de fin (P2MP) du tunnel point-à-multipoint TE. Le path-option vers le routeur de fin peut être explicite ou dynamique.

Routeur de fin TE

Utilisez cette configuration pour le profil 8 sur le routeur de fin TE :

ip multicast-routing
ip multicast mpls traffic-eng

mpls traffic-eng tunnels
interface Ethernet0/0
ip address 10.1.1.1 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000
        

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.2.1.8 activate
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

ip mroute 10.2.3.0 255.255.255.0 10.100.1.3

Remarque: Le mroute statique est exigé pour la source vers le routeur de tête de réseau TE dans le contexte global.

Profil 9 MDT par défaut - MLDP - MP2MP - BGP-AD - Signalisation PIM C-mcast

Utilisez cette configuration pour le profil 9 :

vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!

Charge statique de VRF du profil 10 - P2MP TE - BGP-AD

Le profil 10 n'est pas actuellement pris en charge dans le Cisco IOS, et BGP-AD n'est pas pris en charge pour P2MP TE.

Profil 11 MDT par défaut - GRE - BGP-AD - Signalisation BGP C-mcast

Utilisez cette configuration pour le profil 11 :

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery pim
  mdt default 232.1.1.1 
  mdt overlay use-bgp
route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family

Remarque: Pour ce profil, PIM doit être activé sur l'interface globale de bouclage. Puisque BGP-AD pour PIM est utilisé, il n'y a plus un besoin d'ipv4 MDT AF, qui était nécessaire pour le profil 0.

Profil 12 MDT par défaut - MLDP - P2MP - BGP-AD - Signalisation BGP C-mcast

Utilisez cette configuration pour le profil 12 :

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

Profil 13 MDT par défaut - MLDP - MP2MP - BGP-AD - Signalisation BGP C-mcast

Utilisez cette configuration pour le profil 13 :

vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!

Profil 14 MDT divisés - MLDP P2MP - BGP-AD - Signalisation de C-mât BGP

Utilisez cette configuration pour le profil 14 :

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
mdt strict-rpf interface
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

Profil 15 MDT divisés - MLDP MP2MP - BGP-AD - Signalisation de C-mât BGP

Le profil 15 n'est pas actuellement pris en charge dans le Cisco IOS, et MLDP ne prend en charge pas MDT divisé avec MP2MP.

Charge statique par défaut du profil 16 MDT - P2MP TE - BGP-AD - Signalisation BGP C-mcast

Le profil 16 n'est pas actuellement pris en charge dans le Cisco IOS.

Profil 17 MDT par défaut - MLDP - P2MP - BGP-AD - Signalisation PIM C-mcast

Utilisez cette configuration pour le profil 17 :

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

Charge statique par défaut du profil 18 MDT - P2MP TE - BGP-AD - Signalisation PIM C-mcast

Le profil 18 n'est pas actuellement pris en charge dans le Cisco IOS.

Profil 19 MDT par défaut - BGP-AD IR - Signalisation PIM C-mcast

Le profil 19 et la réplication d'entrée (IR) ne sont pas actuellement pris en charge dans le Cisco IOS.

Profil 20 MDT par défaut - P2MP-TE - BGP-AD - PIM - Signalisation de C-mcast

Le profil 20 et les Automatique-tunnels TE P2MP ne sont pas actuellement pris en charge dans le Cisco IOS.

Profil 21 MDT par défaut - BGP-AD IR - BGP - Signalisation de C-mcast

Le profil 21 et IR ne sont pas actuellement pris en charge dans le Cisco IOS.       

Profil 22 MDT par défaut - P2MP-TE - BGP BGP-AD - Signalisation de C-mcast

Le profil 22 et les Automatique-tunnels TE P2MP ne sont pas actuellement pris en charge dans le Cisco IOS.  

   

Profil 23 MDT divisés - BGP-AD IR - Signalisation PIM C-mcast

Le profil 23 et IR ne sont pas actuellement pris en charge dans le Cisco IOS.          

Profil 24 MDT divisés - P2MP-TE - BGP-AD - Signalisation PIM C-mcast

Le profil 24 et les Automatique-tunnels TE P2MP ne sont pas actuellement pris en charge dans le Cisco IOS.

Profil 25 MDT divisés - BGP-AD IR - Signalisation BGP C-mcast

Le profil 25 et IR ne sont pas actuellement pris en charge dans le Cisco IOS.       

Profil 26 MDT divisés - P2MP TE - BGP-AD - Signalisation BGP C-mcast

Le profil 26 et les Automatique-tunnels TE P2MP ne sont pas actuellement pris en charge dans le Cisco IOS.

MVPN Inter-autonome

Les informations dans cette section sont fournies dans la supposition que la configuration correcte est mise en application sur les Routeurs afin de rendre inter-COMME MPLS VPN opérationnel pour l'unicast.

L'option D n'est pas prise en charge pour le mVPN.

Option A

La configuration régulière de mVPN est exigée pour l'option R. Vous pouvez avoir n'importe quel profil dans les Autonomous System, et les profils ne doivent pas s'assortir dans les différents Autonomous System.

PIM

Pour les options B et le C, si les adresses IP d'interface de bouclage sont redistribuées du Protocole BGP (Border Gateway Protocol) dans le Protocole IGP (Interior Gateway Protocol) de l'autre (AS) d'Autonomous System, puis le vecteur PIM n'est pas exigé.

Option B

Seulement le mVPN inter-autonome de système (inter-COMME) est pris en charge avec le profil 0 (avec les tunnels non segmentés).

La configuration régulière de mVPN est exigée pour l'option B. Seulement l'ipv4 MDT AF peut être utilisé ; L'ipv4 MVPN AF n'est pas pris en charge.

L'origine de vecteur PIM avec le moteur de distinction de route (RD) est exigée sur les Routeurs de PE, avec cette configuration supplémentaire :

ip multicast vrf one rpf proxy rd vector

Les routeurs périphériques de système autonome (ASBR) doivent avoir PIM activé sur le lien ASBR-à-ASBR. Les ASBR doivent également avoir l'ipv4 MDT AF configuré pour les voisins d'Internal Border Gateway Protocol (iBGP) et le voisin d'External Border Gateway Protocol ASBR (eBGP).

Cette configuration supplémentaire est exigée sur l'ASBR :

interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding

router bgp 1
bgp log-neighbor-changes
no bgp default route-target filter
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family vpnv4
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family

C d'option

Seulement le mVPN inter-autonome de système (inter-COMME) est pris en charge avec le profil 0 (avec les tunnels non segmentés).

La configuration régulière de mVPN est exigée pour le C d'option. Les préfixes de bouclage de PE de l'autre âne sont annoncés par le BGP dans l'ipv4 AF.

L'origine de vecteur PIM sans RD est exigée sur les Routeurs de PE également, avec cette configuration supplémentaire :

ip multicast rpf proxy vector

Les ASBR doivent avoir PIM activé sur le lien ASBR-à-ASBR. Les ASBR doivent également avoir l'ipv4 MDT AF configuré pour les voisins d'iBGP et le voisin d'eBGP ASBR.

Cette configuration supplémentaire est exigée sur l'ASBR :

interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding

router bgp 1
bgp log-neighbor-changes
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family ipv4
redistribute ospf 1 metric 100 route-map loopbacks-into-BGP
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.3.1.4 send-label
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
neighbor 10.100.1.6 send-label
exit-address-family
!     
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!        

Remarque: L'ipv4 MDT AF entre les Autonomous System peut également être configuré sur les réflecteurs d'artère (RRs) sur une session de multi-alimentation d'eBGP au lieu de sur les ASBR.

MLDP

L'option B n'est pas actuellement prise en charge.

C d'option

Il n'y a aucun soutien de la Classe d'équivalence de transfert récursive (FEC) dans le Cisco IOS. Par conséquent, redistribution des bouclages de PE par l'iBGP dans l'autre COMME n'est pas suffisant, pendant que les Routeurs P (fournisseur) manquent de la connaissance des Routeurs de PE dans l'autre AS.

Il y a support si les bouclages de PE sont redistribués par l'IGP dans l'autre AS. Dans ce cas, les profils avec MDT divisé et le maillage complet P2MP MLDP sont pris en charge. L'ipv4 MDT AF ne peut pas être utilisé ici ; L'ipv4 MVPN AF doit être utilisé. La session de mVPN BGP peut fonctionner entre le siège potentiel d'explosion et le RRs. Entre le RRs, il y a déjà une session de multi-alimentation d'eBGP qui fonctionne pour l'AF VPNv4/6.

Le MLDP BGP-AD doit être activé. Inter-comme le mot clé est prié sur les Routeurs de PE afin de s'assurer que les artères de type 1 BGP-AD n'ont pas le no-export community.

Profils avec le maillage complet P2MP MLDP

Cette section décrit les configurations pour les profils 12 et 17.

Configuration du profil 17

Voici la configuration sur les Routeurs de PE pour le profil 17 :

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
route-target export 1:1
route-target import 1:1
exit-address-family

Voici la configuration sur les ASBR pour le profil 17 :

interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding
end

Remarque: La configuration d'IP de MPLS est exigée sur le lien entre les ASBR afin d'avoir une proximité MLDP entre eux.

Voici la configuration sur le RRs pour le profil 17 :

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!     
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!

Configuration du profil 12

Cette configuration est identique que cela utilisée pour le profil 17, mais il y a la signalisation supplémentaire de C-Multidiffusion par BGP.

Voici la configuration sur les Routeurs de PE pour le profil 12 :

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family

Profils avec MDT divisé par MLDP

Cette section décrit la configuration pour le profil 14.

Configuration du profil 14

Voici la configuration sur les Routeurs de PE pour le profil 14 :

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family

Voici la configuration sur les ASBR pour le profil 14 :

interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding

Remarque: L'IP de MPLS est exigé sur le lien entre les ASBR afin d'avoir une proximité MLDP entre eux.

Voici la configuration sur le RRs pour le profil 14 :

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!     
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!

CsC

Ces informations sont fournies dans la supposition que la configuration correcte est mise en application sur les Routeurs afin d'avoir le transporteur du transporteur (CsC) MPLS VPN opérationnel pour l'unicast.

Seulement le profil 0 est pris en charge pour CsC. Ceci signifie qu'il peut y avoir de CsC hiérarchique avec des VPN Multidiffusion-activés. Le VPN du CsC a le profil 0 de mVPN configuré. Le réseau du transporteur a le profil 0 de mVPN configuré aussi bien. Ceci signifie qu'il y a la configuration régulière de mVPN, sur les Routeurs de CsC-PE du CsC et sur les Routeurs de PE du transporteur, et alors il n'y a aucune configuration supplémentaire requise pour la Multidiffusion.

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Document ID: 118985