Commutateurs : Commutateurs Cisco Nexus, s�rie�9000

Configurez et vérifiez le Maximum Transmission Unit sur des Plateformes de Cisco Nexus

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (11 août 2015) | Commentaires

Introduction

Ce document décrit comment configurer et vérifier le Maximum Transmission Unit (MTU) sur des Commutateurs de Cisco Nexus.

Contribué par la recherche d'Amanda, ingénieur TAC Cisco.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Configurez

Configurations de MTU de la couche 3

MTU sur une configuration commutée de l'interface virtuelle (SVI)

Switch(config)#interface vlan 1
Switch(config-if)#mtu 9216

MTU sur une configuration des ports de la couche 3

Switch(config)#interface ethernet 1/1
Switch(config-if)#no switchport
Switch(config-if)#mtu 9216

Configurations de MTU de la couche 2

Le MTU de la couche 2 peut être placé par la stratégie QoS de réseau ou en configurant le port lui-même sur les Commutateurs qui prennent en charge le MTU de par-port. Le MTU de par-port de supports seulement du Nexus 3048, 3064, 7000, 7700, 9000, et 9300.

Nexus 3100, configuration 3500, 5000, 5500, et 6000

Afin de configurer le MTU élevé sur les 5000, 5500, et 6000 switchess du Nexus 3100, 3500, créer une stratégie de réseau-qos ou modifier une stratégie existante afin de spécifier le MTU élevé. Cette configuration s'applique à tous les ports. Ceci inclut tous les ports de Cisco Fabric Extender (FEX) connectés au commutateur. le MTU de Par-port n'est pas pris en charge.

policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo

Nexus 3048, configuration 3064, 7000, 7700, 9000, et 9300

Afin de configurer le MTU sur une base de par-port, cette configuration est nécessaire :

Switch(config)#interface ethernet 1/1
Switch(config-if)#mtu 9216

Configuration de Nexus 7000

Quand vous configurez le MTU FEX, une stratégie QoS plus étendue est nécessaire dans la version 6.2 et ultérieures :

Switch(conf)#class-map type network-qos match-any c-nq-8e-custom
(config-cmap-nqos)#match cos 0-7

Remarque: Si vous n'êtes pas sûr que le modèle pour l'utiliser, sélectionnent la commande de réseau-qos de type de système de show policy-map afin de voir le modèle actuellement utilisé.

Switch(config)#policy-map type network-qos nq-8e-custom template 8e    
Switch(config-pmap-nqos)#class type network-qos c-nq-8e-custom
Switch(config-pmap-nqos-c)#congestion-control tail-drop
Switch(config-pmap-nqos-c)#mtu 9216

Switch(config)#system qos
Switch(config-sys-qos)#service-policy type network-qos nq-8e-custom

Configuration 2000 de Nexus

Remarque: Le MTU 2000 de Nexus est placé avec la configuration des Trames étendues sur le commutateur de parent. Pour les Commutateurs de parent qui permettent l'éléphant sur une base de par-port, configurez le Port canalisé de matrice FEX (FPC). Si le commutateur de parent exige une stratégie de réseau-qos puis l'éléphant est placé avec la configuration de la stratégie QoS du commutateur de parent. Ces changements sont automatiquement abaissés au FEX des deux cas.

Port canalisé de matrice (FPC) sur la configuration de commutateur de Nexus de parent

interface port-channel136
switchport mode fex-fabric
fex associate 136
vpc 136
mtu 9216

Remarque: Le Nexus 7000 ne te permet pas pour placer le MTU FEX avec le FPC dans la version 6.2 et ultérieures. Vous devez à la place créer une stratégie QoS faite sur commande pendant que la prochaine configuration affiche.

Permettez les Trames étendues dans la configuration du Nexus 7000 FEX

Remarque: Modifiez le modèle actuellement en service. Afin de trouver le modèle en cours en service, sélectionnez la commande de réseau-qos de type de système de show policy-map.

Switch(conf)#class-map type network-qos match-any c-nq-8e-custom 
(config-cmap-nqos)#match cos 0-7

Switch(config)#policy-map type network-qos nq-8e-custom template 8e
Switch(config-pmap-nqos)#class type network-qos c-nq-8e-custom
Switch(config-pmap-nqos-c)#congestion-control tail-drop
Switch(config-pmap-nqos-c)#mtu 9216

Switch(config)#system qos
Switch(config-sys-qos)#service-policy type network-qos nq-8e-custom

Stratégie QoS de réseau sur la configuration de commutateur de Nexus de parent

policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo

Vérifiez

Utilisez cette section pour confirmer que votre configuration fonctionne correctement.

L'Output Interpreter Tool (clients enregistrés seulement) prend en charge certaines commandes show. Utilisez l'Output Interpreter Tool afin de visualiser une analyse de sortie de commande show.

MTU de la couche 3

Vérifiez le MTU de la couche 3 sur toutes les Plateformes de Nexus avec le comme indiqué dans cet exemple de commande de l'eth x/y d'interface d'exposition :

Nexus#show interface ethernet 1/19
Ethernet1/19 is up
Dedicated Interface
Hardware: 100/1000/10000 Ethernet, address: 547f.ee5d.413c (bia 547f.ee5d.40fa)
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

Vérifiez le MTU SVI avec la commande du show interface vlan X comme cette sortie affiche :

Leaf3#show interface vlan 1
Vlan1 is down (Non-routable VDC mode), line protocol is down
Hardware is EtherSVI, address is 547f.eed8.ec7c
Internet Address is 1.1.1.1/23
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

MTU de la couche 2

Cette section décrit comment vérifier le MTU de la couche 2 par plate-forme. Les commandes sont exécutées du commutateur de parent.

Nexus 3100, 3500, 5000, 5500, et 6000

Nexus#show queuing interface ethernet 1/1
Ethernet1/1 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 100
RX Queuing
qos-group 0
q-size: 469760, HW MTU: 9216 (9216 configured)

Nexus 3000, 7000, 7700, 9000

Nexus#show interface ethernet 1/12
Ethernet1/12 is up
admin state is up, Dedicated Interface
Hardware: 1000/10000 Ethernet, address: 7c0e.ceca.f183 (bia 7c0e.ceca.f183)
MTU 9216 bytes, BW 10000000 Kbit, DLY 10 usec

Nexus 2000

Remarque: Quand vous changez le MTU FEX, le FEX augmente son MTU à un montant plus élevé mais prédéterminé qui n'apparie pas la valeur configurée exactement. Le périphérique de parent impose le MTU configuré au Port canalisé de matrice FEX (FPC).

Pour FEX connecté au Nexus 5000, à 6000, et à 7000 :

Nexus#show queuing interface ethernet 136/1/1
if_slot 68, ifidx 0x1f870000
Ethernet136/1/1 queuing information:
Input buffer allocation:
Qos-group: 0
frh: 3
drop-type: drop
cos: 0 1 2 3 4 5 6 7
xon xoff buffer-size
---------+---------+-----------
19200 78080 90880

Queueing:
queue qos-group cos priority bandwidth mtu
--------+------------+--------------------+---------+----------------+--------
3 0 0 1 2 3 4 5 6 WRR 100 9280

Pour FEX connecté au Nexus 9000 :

9396-B#show interface ethernet 104/1/1
Ethernet104/1/1 is up
admin state is up,
Hardware: 100/1000 Ethernet, address: 5475.d0e0.e5c2 (bia 5475.d0e0.e5c2)
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

L'Output Interpreter Tool (clients enregistrés seulement) prend en charge certaines commandes show. Utilisez l'Output Interpreter Tool afin de visualiser une analyse de sortie de commande show.

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

Parfois il est nécessaire de vérifier les changements du logiciel. Afin de faire ceci, vérifiez le gestionnaire de port Ethernet (ethpm) afin de vérifier que les modifications ont été poussées par le logiciel sur n'importe quelle plate-forme :

Switch#show system internal ethpm info interface eth 6/5 | egrep -i mtu
medium(broadcast), snmp trap(on), MTU(4000)

Il est également possible sur les modules M1, m2, F1 et F2 pour vérifier dans le matériel que les modifications ont été abaissées :

module-1#show hardware internal mac port 20 state | i MTU
GD: Port speed Undecided GD MTU 10240 (fixed to max), PL MTU 9238 mode 0

Défauts connus

ID de bogue Cisco CSCuf20035 - (Nexus 7000) les modifications de MTU FEX ne les prennent pas effet sur des files d'attente FEX.


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Document ID: 118994